1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Unklarer Wert waitforcards oscam 7390

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von oli_f1, 15. Januar 2012.

  1. oli_f1
    Offline

    oli_f1 Ist gelegentlich hier

    Registriert:
    6. November 2009
    Beiträge:
    83
    Zustimmungen:
    12
    Punkte für Erfolge:
    8
    Habe meine Box 7390 neu mit Image

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    geflasht. Vorhaer habe ich das Recovery-Image von AVM aufgespeilt, damit alle Daten resetet sind.

    Ich habe deises gemacht, weil ich die Box durch Tests an Watchdog irgendwie geschrottet hatte (cronjobs liefen nicht mehr).

    Siehe auch Frage:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Bin eigentlich nach meiner Meinung ordentlich vorgegagen. Habe mir die OSCAM-Dateien vorher runtergenommen (haben ja funktioniert) und nach dem kompletten Reset wieder aufgespielt. Jetzt hatte ich aber das Problem, dass schienbar der Port-Listener für CCCam nicht mehr wollte. Das OSCAM-Log sah so aus:

    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Sat Jan 14 14:33:19 2012
    -------------------------------------------------------------------------------
    2012/01/14 14:33:19 0 s log_list_thread thread started
    2012/01/14 14:33:19 0 s >> OSCam << cardserver started, version 1.20-unstable_by_EasyBuild_svn, build #6090 (mips-router-linux-uclibc929)
    2012/01/14 14:33:19 0 s version=1.20-unstable_by_EasyBuild_svn, build #6090, system=mips-router-linux, nice=-1
    2012/01/14 14:33:19 0 s client max. idle=120 sec, debug level=0
    2012/01/14 14:33:19 0 s max. logsize=1000 Kb, loghistorysize=4096 bytes
    2012/01/14 14:33:19 0 s client timeout=5000 ms, fallback timeout=2000 ms, cache delay=120 ms
    2012/01/14 14:33:19 0 s services reloaded: 0 services freed, 3 services loaded, rejected 0
    2012/01/14 14:33:19 0 s userdb reloaded: 11 accounts loaded, 0 expired, 2 disabled
    2012/01/14 14:33:19 0 s signal handling initialized (type=sysv)
    2012/01/14 14:33:19 0 s 125 service-id's loaded in 4ms
    2012/01/14 14:33:19 0 s 118 tier-id's loaded
    2012/01/14 14:33:19 0 s 3 provid's loaded
    2012/01/14 14:33:19 0 s 22 lengths for caid guessing loaded
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s monitor: initialized (fd=6, port=xxx)
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s camd33: disabled
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s camd35: disabled
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s cs378x: disabled
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s newcamd: disabled
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s cccam: initialized (fd=7, port=xxxxx, crypted)
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s pandora: disabled
    2012/01/14 14:33:19 0 s Starting listener 0
    2012/01/14 14:33:19 0 s radegast: disabled
    2012/01/14 14:33:19 5C4A80 h HTTP Server listening on port 83
    2012/01/14 14:33:19 0 s http thread started
    2012/01/14 14:33:19 0 s reader check thread started
    2012/01/14 14:33:19 0 s check thread started
    2012/01/14 14:33:19 0 s creating thread for device 002:002
    2012/01/14 14:33:19 5C61B0 r Using 0x82 as endpoint for smartreader hardware detection
    2012/01/14 14:33:19 5C61B0 r Found smartreader device 002:002
    2012/01/14 14:33:19 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/01/14 14:33:19 0 s waiting for local card init
    2012/01/14 14:33:19 5C61B0 r reader hdplus initialized (device=002:002, detect=cd, mhz=357, cardmhz=368)
    2012/01/14 14:33:20 0 hdplus card detected
    2012/01/14 14:33:23 5C61B0 r ATR: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx2
    012/01/14 14:33:23 5C61B0 r Maximum frequency for this card is formally 5 Mhz, clocking it to 4.80 Mhz
    2012/01/14 14:33:24 5C61B0 r detect native nagra card
    2012/01/14 14:33:25 5C61B0 r [nagra-reader] type: NAGRA, caid: 1830, IRD ID: FF FF FF FF
    2012/01/14 14:33:25 5C61B0 r [nagra-reader] ProviderID: 00 00 34 11
    2012/01/14 14:33:25 5C61B0 r [nagra-reader] active to: 2012/03/05 11:59
    2012/01/14 14:33:26 5C61B0 r -----------------------------------------
    2012/01/14 14:33:26 5C61B0 r |id |tier |valid from |valid to |
    2012/01/14 14:33:26 5C61B0 r +----+--------+------------+------------+
    2012/01/14 14:33:26 5C61B0 r |8011|0064 |2009/11/22 |2010/11/23 |
    2012/01/14 14:33:26 5C61B0 r |8011|0065 |1992/01/01 |1993/01/01 |
    2012/01/14 14:33:26 5C61B0 r |8011|0BEA |2010/11/16 |2013/01/05 |
    2012/01/14 14:33:26 5C61B0 r -----------------------------------------
    2012/01/14 14:33:27 5C61B0 r found cardsystem nagra
    2012/01/14 14:33:27 5C61B0 r ROM: D N A S P 1 4 2
    2012/01/14 14:33:27 5C61B0 r REV: R e v G C 6
    2012/01/14 14:33:27 5C61B0 r SER: xx xx xx xx
    2012/01/14 14:33:27 5C61B0 r CAID: 1830
    2012/01/14 14:33:27 5C61B0 r Prv.ID: 00 00 xx xx (sysid)
    2012/01/14 14:33:27 5C61B0 r Prv.ID: 00 00 00 00
    2012/01/14 14:33:27 5C61B0 r Prv.ID: 00 00 xx xx
    2012/01/14 14:33:27 5C61B0 r [nagra-reader] ready for requests

    Also keine Clients konnten sich connecten.

    Die zugehörigen anderen Dateien:
    OSCAM.Config
    [global]
    logfile = /var/media/ftp/cs/oscam/oscam.log
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2000
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    netprio = 0
    clientdyndns = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    maxlogsize = 1000
    waitforcards = 1
    preferlocalcards = 1
    saveinithistory = 1
    readerrestartseconds = 5
    readerautoloadbalance = 0
    readerautoloadbalance_save = 0
    stealth = 1
    [monitor]
    port = 988
    nocrypt = 192.168.0.0-192.168.255.255
    aulow = 120
    hideclient_to = 30
    monlevel = 1
    appendchaninfo = 0
    [newcamd]
    #port = 34002@1830:003411;34003@09c4:000000;34004@0b00:000000
    #key = 0102030405060708091011121314
    #allowed = 0.0.0.0-255.255.255.255
    #keepalive = 0
    # Testzeile
    [cccam]
    port = yyyyy
    reshare = 0
    version = 2.1.1
    build = 2971

    [webif]
    httpport = 83
    httpcss = /var/tmp/flash/oscam/proflinux_debstyle_mitLogo
    httprefresh = 10
    httpallowed = 192.168.0.0-192.168.255.255
    httphideidleclients = 1
    httpreadonly = 0
    httpuser = admin
    httppwd = admin


    OSCAM.Servers

    [reader]
    label = hdplus
    enable = 1
    protocol = Smartreader
    #device = /dev/ttyUSB0
    device = 002:002
    device_out_endpoint = 0x82
    services =
    #smargopatch = 1
    caid = 1830
    rsakey = BFxxx...D5
    boxkey = A7....d
    etect = cd
    nagra_read = 1
    mhz = 357
    cardmhz = 368
    ident = 1830:000000,003411,008011
    group = 1
    emmcache = 1,3,2
    lb_weight = 100
    [reader]
    #label = mtv
    #Protocol = Smartreader
    #detect = CD
    #device = 002:003
    #device = /dev/ttyUSB2
    #group = 1
    #caid = 0B00
    #IDENT = 0B00:000000
    #emmcache = 1,3,2
    #mhz = 357
    #cardmhz = 357
    [reader]
    #Label = SKY_De
    #Protocol = Smartreader
    #smargopatch = 1
    #detect = CD
    #group = 1
    #device = 002:004
    #BoxID = 12345678
    #CAID = 09C4
    #IDENT = 09C4:000000
    #emmcache = 1,3,2
    #mhz = 357
    #cardmhz = 368

    OSCAM.Users

    [account]
    user = xxxx
    pwd = yyyyy
    description = blabla
    disabled = 0
    monlevel = 0
    au = 1
    caid = 1830,09C4,0B00
    uniq = 1
    group = 1
    monlevel = 4
    cccreshare = -1

    ....

    Jetzt bin ich auf dei Suche gegangen und habe dann irgendwann auch den Parameter waitingforcards in der oscam.config gefunden. Diesen habe umgestellt auf 0. Nach Beschreibung im Wiki "wait for local SCs on startup before opening network ports"

    Jetzt konnten sich Clients wieder connecten.

    Zu meiner Frage: Ich gehe mal davon aus, dass es sich bei SC um Services handelt. Habe leider keine Beschreibung gefunden, was SC bedeutet. Kann ich prüfen, was hier nicht richtig initialisert?
    Wie gesagt. Ich habe einige Updates von früheren Images bis zum gleichen Image durchgeführt (dort musste ich die Dateien nie anpassen). Ich habe auch config nicht geändert, bzw. einen kompletes Recovery gefahren und es hat auch mit der configuration waitingforcards = 1 funktioniert.
     
    #1

Diese Seite empfehlen