1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

TNK 0b01 hohe ECM-Zeiten und Timeout Problem

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von harra, 9. November 2013.

  1. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    Hey,

    Ich habe ein drei kleine Probleme, die meinen Share ein wenig unsauber machen.
    Zunächst das Equipment: TNK Karte (Caid: 0b01) in einem Smargo in der FritzBox.

    Erstes Problem: Ich habe ECM Zeiten von ca. 680ms, wenn gerade eine Person über die Karte schaut. Ist es normal? Oder sind die Zeiten zu hoch und wenn ja, wie kann man die senken?

    Zweites Problem: Wenn ich einen Sender öffne, der zwar auch den Caid 0b01 hat, aber von meiner Karte nicht geöffnet werden kann, dann wird einfach eine andere Karte, die ich in Hops habe, angefragt und es wird trotzdem auf dem Receiver als Hop 1 angezeigt. Kann man diesen Bug beheben?

    Drittes Problem: Es hängt mit dem Problem von zuvor zusammen. Wenn ich jetzt im WebIF schaue, dann sehe ich viele Timeouts. Wie kann ich diese verhindern?


    Configs:

    oscam.conf:
    [global]
    logfile = /var/media/ftp/uStor01/OScam.log
    cachedelay = 120
    nice = -1
    maxlogsize = 2480
    failbantime = 20
    failbancount = 10

    [cccam]
    port = ***
    nodeid = ***
    version = 2.3.0
    reshare = 1
    reshare_mode = 1
    ignorereshare = 1
    stealth = 1

    [monitor]
    port = 988
    aulow = 120
    monlevel = 4
    hideclient_to = 0
    appendchaninfo = 1

    [webif]
    httpport = 34001
    httpuser = ***
    httppwd = ***
    httpcss = /var/media/ftp/uStor01//cs/oscam//proflinux_ddcstyle.css
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    aulow = 120
    hideclient_to = 0
    appendchaninfo = 1

    oscam.server:
    [reader]
    label = tnk
    protocol = mouse
    device = /dev/ttyUSB0
    services = tnkpolsat
    caid = 0B01
    detect = cd
    mhz = 500
    cardmhz = 500
    group = 1
    emmcache = 1,3,2

    oscam.services:
    [tnkpolsat]
    caid = 0B01
    provid =
    srvid = 10DD,12C7,12C8,10D7,10D9,3DBB,332F,13F6,3DC5,3DC4,0005,13F6,332F,3DC5,0079,332D,3333,13FB

    oscam.user:
    [account]
    user = ***
    pwd = ***
    au = tnk
    betatunnel = 1833.FFFF:1702
    group = 1,2,3,4


    Viele Grüße
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Radagast
    Offline

    Radagast Elite User

    Registriert:
    11. Mai 2013
    Beiträge:
    1.628
    Zustimmungen:
    903
    Punkte für Erfolge:
    113
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Hi,

    zu den ECM Zeiten kann ich dir nichts sagen, da ich die Karte nicht habe und keine Erfahrungswerte damit habe.

    Wie sind denn die externen Karten bei dir eingebunden? Sollten diese per Newcamd oder per Camd3 eingeunden sein, so ist klar, warum keine weiteren Hops angezeigt werden. Das ist nur beim CCcam-Protokoll der Fall.

    Die Timeouts kommen von Anfragen auf die Karte, welche diese nicht beantworten kann.
    Du kannst zumindest deine Karte vor solchen Anfragen schützen indme du dir passende Services einrichtest. Dann erscheinen im Logfile zwar keine Timeouts mehr, aber es wird dann ein invalid ausgegeben. Es stehen dann zwar immernoch "Fehlermeldungen" im Logfile, aber es wird die Karte zumindest mal nicht mehr belastet.
    Was wird auf Seiten des Clients für eine Cam verwendet? Am besten konfigurierst du die Client Seite dem entsprechend was sie über den Server abfragen darf und auch kann.
     
    #2
    harra, Pilot und dodo83 gefällt das.
  4. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Okay danke schonmal :)

    Die Karten sind alle per CCCam eingebunden.

    Ich habe ja schon Services verwendet um meine Karte vor unnötigen Anfragen zu schützen, jedoch werden die Anfragen dann auf die externen Karten weitergeleitet.

    Ich habe jetzt mal eine neue Services errichtet und alle Sid´s die ich mit meiner Karte nicht öffnen kann, bei allen Usern gesperrt. Jetzt kommen auch wie oben von Radagast die Aussage invalid.
    Meine Clients verwenden überwiegend CCCam.

    Ich hoffe auf weitere Hilfe, wie ich es anders regeln kann :)
     
    #3
  5. Radagast
    Offline

    Radagast Elite User

    Registriert:
    11. Mai 2013
    Beiträge:
    1.628
    Zustimmungen:
    903
    Punkte für Erfolge:
    113
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Hi,

    was für eine Version von CCcam ist auf den Clients im Einsatz?
    Um es sauber zu lösen brauchst du bei den Clients eine CCcam.prio in welcher dann geregelt wird was abgefragt werden kann.
     
    #4
    harra gefällt das.
  6. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Es ist unterschiedlich, da ich ja nicht nur 2 Sharepartner habe, es ist sind überwiegend 2.1.4, 2.2.1, 2.3.0 im Einsatz ;)

    Ist es nicht möglich auf Seiten des Servers etwas zu ändern?
     
    #5
  7. Radagast
    Offline

    Radagast Elite User

    Registriert:
    11. Mai 2013
    Beiträge:
    1.628
    Zustimmungen:
    903
    Punkte für Erfolge:
    113
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Hi,

    auf Seiten des Servers kannst du es nur in soweit eindämmen, dass du ein invalid im Logfile stehen hast. Solange der Client die Anfrage stellt wird sie aber auch am Server ankommen und wird in irgendeiner Form auch abgearbeitet.
     
    #6
    harra gefällt das.
  8. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Welche Anfrage ist den "besser" für den Serverbetrieb? Invalid oder not found?
     
    #7
  9. fun7
    Offline

    fun7 Super Elite User Supporter

    Registriert:
    13. März 2013
    Beiträge:
    2.913
    Zustimmungen:
    1.805
    Punkte für Erfolge:
    113
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Invalid ;)
     
    #8
    harra und Pilot gefällt das.
  10. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Okay danke soweit :)

    Dann habe ich noch zwei Probleme:

    Einmal die o.g. ECM-Zeiten, ob diese etwas hoch oder doch i.O. sind?

    Dann zweitens noch das Problem, dass wenn ich z.B. einen Sender schaue auf meiner Dreambox und dieser auch von der Caid: 0b01 geöffnet wird, dann zeigt er mir dort beim CCCam den Hop 1 an, also als ob meine Karte den Sender öffnet, doch im WebIf merke ich, dass der Sender von einer externen Karte geöffnet wird. Kann man was auf Serverseite machen um damit der richtige Hop beim Clienten angezeigt wird? :)
     
    #9
  11. fun7
    Offline

    fun7 Super Elite User Supporter

    Registriert:
    13. März 2013
    Beiträge:
    2.913
    Zustimmungen:
    1.805
    Punkte für Erfolge:
    113
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Das ist normal für Conax Karten. Man kann noch etwas an der Clock drehen (MHz).

    Was bei deiner Config unangenehm auffällt ist die Verwendung vom Mouse Modus.

    Ich würde hier zum Smartreader Protokoll Raten.

    Cardmhz ist übrigens bei Conax IMMER = 357. Sobald du deinen Smargo im Smartreadermodus ansteuerst kannst du mit den mhz spielen, ich würde zunächst mal 600 ausprobieren, falls das stabil läuft kann man auch auf 800 hochgehen und testen wie sich die Zeiten verhalten.
     
    #10
    harra gefällt das.
  12. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Bei mir kommt immer dieser Fehler:

    2013/11/10 22:21:32 62A8F8 r tnk [smartreader] usb bulk write failed : ret = -7
     
    #11
  13. fun7
    Offline

    fun7 Super Elite User Supporter

    Registriert:
    13. März 2013
    Beiträge:
    2.913
    Zustimmungen:
    1.805
    Punkte für Erfolge:
    113
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Hub defekt / Stromversorgung unzureichend / Steckverbindung nicht in Ordnung
     
    #12
  14. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Hub hab ich keinen, der Smargo ist per USB Verlängerungskabel angebunden ;)
     
    #13
  15. fun7
    Offline

    fun7 Super Elite User Supporter

    Registriert:
    13. März 2013
    Beiträge:
    2.913
    Zustimmungen:
    1.805
    Punkte für Erfolge:
    113
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Ich habe 3 Dinge genannt...

    Bei dir tippe ich mal entweder auf ein minderwertiges Kabel oder unzureichende Stromversorgung.
     
    #14
    harra und Pilot gefällt das.
  16. harra
    Offline

    harra Freak

    Registriert:
    30. August 2010
    Beiträge:
    272
    Zustimmungen:
    40
    Punkte für Erfolge:
    28
    AW: TNK 0b01 hohe ECM-Zeiten und Timeout Problem

    Also, nun geht das Smartreader Protocol :) vielen Dank :)

    Das Problem war, dass ich vergessen hatte die Treiber in Freetz WebIf auszuschalten, also die FTDI Treiber.

    Jetzt kann ich mit den MHz ausprobieren :)
     
    #15

Diese Seite empfehlen