1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Tastatur Problem nach IPC SET

Dieses Thema im Forum "Archiv" wurde erstellt von reppo, 30. März 2011.

  1. reppo
    Offline

    reppo Stamm User

    Registriert:
    3. März 2008
    Beiträge:
    1.258
    Zustimmungen:
    701
    Punkte für Erfolge:
    113
    Beruf:
    Selbständig
    Ort:
    Alderaan
    So, nachdem ich IPC SET genutzt habe, komme ich weder per FTP auf meinen Server noch habe ich die gewohnte deutsche Tastatur in Putty...
    Wie kann ich das wieder reparieren?
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: Tastatur Problem nach IPC SET

    "ipc set" führt das script /var/emu/script/ipc-set.sh aus, was wiederum die Datei /var/emu/script/functions.sh läd und davon die function ' setrights '

    Und ' setrights ' sieht wie folgt aus:
    Code:
    setrights ()
    {
      #CCcam.cfg - Rechte und Besitzer
      chmod 755 /var/etc > /dev/null 2>&1
      chmod 755 $CCCFG > /dev/null 2>&1
      chown www-data:www-data $CCCFG > /dev/null 2>&1
      #EMU
      chmod 755 -R /var/emu > /dev/null 2>&1
      chmod 777 -R /var/emu/tmp > /dev/null 2>&1
      chown www-data:www-data -R /var/emu/tmp > /dev/null 2>&1
      #Changelog - Erstellen, Rechte, Besitzer
      [ ! -f $CCCHANGELOG ] && echo "" > $CCCHANGELOG > /dev/null 2>&1
      chmod 755 $CCCHANGELOG > /dev/null 2>&1
      chown www-data:www-data $CCCHANGELOG > /dev/null 2>&1
      #InfoPHP Tempdir und Rechte
      [ ! -d $INFOPHP_WORKPATH ] && mkdir -p $INFOPHP_WORKPATH > /dev/null 2>&1
      chmod 777 -R $INFOPHP_WORKPATH > /dev/null 2>&1
      chown www-data:www-data -R $INFOPHP_WORKPATH > /dev/null 2>&1
      chown www-data:www-data $INFOPHP_CONFIG > /dev/null 2>&1
    }
    dh da sind nur chmod und chown befehle drin ... kann also eigentlich nicht sein das dadurch andere Dienste wie ein FTP-Server beeinflusst werden oder sich die Tastatur verstellt...

    Bist du wirklich sicher das du sonst nix gemacht hast?
    IPC installiert zb garkein FTP-Server also hat es damit eigentlich auch nichts zu schaffen... Haste den mal überprüft ob der denn überhaupt läuft?



    /EDIT:

    Ansonsten um die Tastatur einzustellen kann man zB eins von folgendem nutzen:
    (ggf vorher: apt-get install console-data console-tools debconf)

    locale (listet die aktuellen einstellungen)
    loadkeys de-latin1-nodeadkeys
    dpkg-reconfigure console-common
    dpkg-reconfigure locales (de_DE, de_DE@Euro und ggf diverse de_DE.UTF-8)
    dpkg-reconfigure console-data (gesammte liste-> pc / qwertz / German / Standard / latin1 - no dead keys)
     
    Zuletzt bearbeitet: 30. März 2011
    #2
    reppo gefällt das.
  4. reppo
    Offline

    reppo Stamm User

    Registriert:
    3. März 2008
    Beiträge:
    1.258
    Zustimmungen:
    701
    Punkte für Erfolge:
    113
    Beruf:
    Selbständig
    Ort:
    Alderaan
    AW: Tastatur Problem nach IPC SET

    Mein ProFTPD lief immer einwandfrei, aber halt nach der IPC Set nicht mehr, ich muss jetzt mal schauen.
    Danke für die Erläuterung was das Script tut.

    Code:
     locale
    LANG=de_DE
    LC_CTYPE="de_DE"
    LC_NUMERIC="de_DE"
    LC_TIME="de_DE"
    LC_COLLATE="de_DE"
    LC_MONETARY="de_DE"
    LC_MESSAGES="de_DE"
    LC_PAPER="de_DE"
    LC_NAME="de_DE"
    LC_ADDRESS="de_DE"
    LC_TELEPHONE="de_DE"
    LC_MEASUREMENT="de_DE"
    LC_IDENTIFICATION="de_DE"
    LC_ALL=
    
    Und trotzdem englische Tastatur in Putty - ich will auch kein UTF-8 benutzen...

    Zu Proftpd:

    Code:
     proftpd
     - error: /var/log/proftpd is a world writeable directory
     - Fatal: SystemLog: you are attempting to log to a world writable directory on line 89 of '/etc/proftpd/proftpd.conf'
    
     
    Zuletzt bearbeitet: 30. März 2011
    #3
  5. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: Tastatur Problem nach IPC SET

    Naja wie gesagt, setrights verändert nur die IPC betreffenden Verzeichnisse und Dateirechte wie du oben in dem code auch nachvollziehen kannst

    Der proFTPD wird ganz woanders installiert und würde von "ipc set" weder gestopped noch verstellt werden o.ä. insofern kann das eigentlich nichts mit "ipc set" zu tun haben...


    Läuft der proftpd Dienst denn überhaupt? -> /etc/init.d/proftpd status
    (bzw was ist die Fehlermeldung wenn du versuchst dich zu verbinden?)


    Was ich aber gerade sehe - durch die .bashrc die IPC beiliegt wird für den Benutzer root ein Alias angelegt um die Tastaturbelegung bequemer zu ändern, durch die Eingabe von:

    tastatur1 (führt den Befehl " dpkg-reconfigure locales " aus)
    tastatur2 (führt den Befehl " dpkg-reconfigure console-data " aus)
    tastatur3 (führt den Befehl " dpkg-reconfigure console-common && dpkg-reconfigure console-tools " aus)
     
    #4
    reppo gefällt das.
  6. reppo
    Offline

    reppo Stamm User

    Registriert:
    3. März 2008
    Beiträge:
    1.258
    Zustimmungen:
    701
    Punkte für Erfolge:
    113
    Beruf:
    Selbständig
    Ort:
    Alderaan
    AW: Tastatur Problem nach IPC SET

    tastatur1
    tastatur2
    exit
    tastatur3

    habe ich schon probiert, aber hat nix geholfen - leider.

    Und ProFTPd kann ich nicht mehr starten... liegt wohl doch an den Rechten...

    Daher kommt der Scheiss, IPC SET war echt ne Scheiss IDEE...
     
    #5
  7. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: Tastatur Problem nach IPC SET

    aha!

    proftpd
    - error: /var/log/proftpd is a world writeable directory
    - Fatal: SystemLog: you are attempting to log to a world writable directory on line 89 of '/etc/proftpd/proftpd.conf'

    Sagt doch schon alles.... proftpd gefällt es nicht das /var/log für jeden zugänglich ist (genau deswegen verhasse ichs auch ohne plan alles auf chmod 777 zu setzen...)


    quatsch.... "ipc set" verändert aber trotzdem keine Rechte für /var/log/ sondern NUR /var/log/ipc/... (guck dir doch mal bitte obigen code an...)
    Deswegen, bist du dir wirklich sicher nichts anderes gemacht zu haben?


    probier ma: chmod 755 /var/log && /etc/init.d/proftpd restart ... oder: chmod 755 /var/log/proftpd/ && /etc/init.d/proftpd restart


    /EDIT: Soll ich mir mal die mühe machen die function ' setrights ' für dich auseinander zu nehmen und schritt für schritt zu analysieren was es macht? -- spätestens dann solltest du merken das 'ipc set' nichts an /var/log verändert - vorallem aber gewiss kein chmod 777 /var/log

    du musst also zwangsläufig irgendwas anderes gemacht haben (vllt irgendnen script?)



    PS: Wieso eigentlich proftpd? Dateien übertragen kanste auch mit WinSCP
     
    Zuletzt bearbeitet: 30. März 2011
    #6
    reppo gefällt das.
  8. reppo
    Offline

    reppo Stamm User

    Registriert:
    3. März 2008
    Beiträge:
    1.258
    Zustimmungen:
    701
    Punkte für Erfolge:
    113
    Beruf:
    Selbständig
    Ort:
    Alderaan
    AW: Tastatur Problem nach IPC SET

    @feissmaik,

    ich glaube dir ja, aber ich habe niemals 777 gesetzt, da bin ich mir sicher.

    Jetzt habe ich

    chmod 755 /var/log/proftpd

    gemacht und proftpd rennt wieder, also scheint das ipc set Skript 777 für alle /var/log/ Unterordner zu setzen...
    Anders kann ich mir das nicht erklären.

    Ok, schon mal vielen Dank, aber wie löse ich jetzt am besten mein Tastatur Problem...?

    Edith:

    Jetzt bin ich wieder per FTP drauf und IPC SET hat definitiv 777 für alle Unterverzeichnisse von /var/log gesetzt.
     
    #7
  9. reppo
    Offline

    reppo Stamm User

    Registriert:
    3. März 2008
    Beiträge:
    1.258
    Zustimmungen:
    701
    Punkte für Erfolge:
    113
    Beruf:
    Selbständig
    Ort:
    Alderaan
    AW: Tastatur Problem nach IPC SET

    Code:
    root@CCcam ~ > tastatur1
    Generating locales (this might take a while)...
      de_DE.ISO-8859-1... done
    Generation complete.
    root@CCcam ~ > tastatur2
    Looking for keymap to install:
    de-latin1-nodeadkeys
    root@CCcam ~ >
    
    Code:
    root@CCcam ~ > tastatur3
    Looking for keymap to install:
    de-latin1-nodeadkeys
    Setting console screen modes and fonts.
    cannot (un)set powersave mode
    root@CCcam ~ >
    
     
    #8
  10. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: Tastatur Problem nach IPC SET

    dann haste vllt doch irgendwas anderes noch gemacht, irgendnen script genutzt oder sowas?

    weil von alleine verstellt sich das nicht...


    prüf sonst mal die Verzeichnissrechte von /var/log und von /var/log/proftpd/ (ls -la oder mit IPC nur l)



    /EDIT: Jo und? Die 3 Befehle scheinen doch funktioniert zu haben?
     
    #9
    reppo gefällt das.
  11. reppo
    Offline

    reppo Stamm User

    Registriert:
    3. März 2008
    Beiträge:
    1.258
    Zustimmungen:
    701
    Punkte für Erfolge:
    113
    Beruf:
    Selbständig
    Ort:
    Alderaan
    AW: Tastatur Problem nach IPC SET

    Nochmal...

    Ich habe nix anderes als IPC SET gemacht und seitdem waren alle Unterordner von /var/log auf 777.
    Kannste ja mal selbst bei Dir testen. Jetzt ist /var/log/proftpd/ wieder auf 755 und alles ist ok.
    Bis auf die Tastatur, die kriege ich momentan noch nicht wieder umgestellt.

    Edith:

    Ich bin dumm, einfach nur dumm...
    Das Drecks-Windows 7 stand auf einmal auf englischer Tastatur...
    Sorry für's unnötige Belästigen... mei mei mei.
     
    Zuletzt bearbeitet: 30. März 2011
    #10
  12. feissmaik
    Offline

    feissmaik Elite User

    Registriert:
    21. November 2010
    Beiträge:
    1.666
    Zustimmungen:
    513
    Punkte für Erfolge:
    0
    Ort:
    FarFarAway
    AW: Tastatur Problem nach IPC SET

    ja ich hab das hier aufgrund deines Threads bereits 3x jetzt getestet um einen Bug in IPC aus zu schliesen (bzw um ihn dann zu beheben...)

    Ich kann das hier nur mit " ipc set " nicht nachvollziehen - vorallem aber weil in der function nur 2x chmod 777 auftaucht und das betrifft nicht /var/log ... wie aber auch jeder selber nachvollziehen kann


    ---

    Ich hab ne VM mit nem frischen Linux...

    wget ipc.pebkac.at/ipc/ipcsetup.sh
    bash ipcsetup.sh
    P
    apt-get install proftpd -y
    ipc set
    l /var/log/ | grep pro ->
    Code:
    root@ipc ~ > l /var/log/ | grep pro
    drwxr-xr-x  2 root root   4096 30. Mär 13:26 proftpd
    root@ipc ~ > 
    Code:
    root@ipc ~ > /etc/init.d/proftpd status
    ProFTPd is started in standalone mode, currently running.
    root@ipc ~ > /etc/init.d/proftpd restart
    Stopping ftp server: proftpd.
    Starting ftp server: proftpd.
    root@ipc ~ > 
     
    #11
    reppo gefällt das.
  13. reppo
    Offline

    reppo Stamm User

    Registriert:
    3. März 2008
    Beiträge:
    1.258
    Zustimmungen:
    701
    Punkte für Erfolge:
    113
    Beruf:
    Selbständig
    Ort:
    Alderaan
    AW: Tastatur Problem nach IPC SET

    Seltsam, sehr seltsam.

    Da ich faul bin, was Rechte ändern von der Konsole angeht, hätte ich eh WinSCP zum Rechte setzen genommen und das habe ich Ewigkeiten schon nicht mehr gestartet...

    Steht denn in deiner proftpd.conf auch drinnen, dass er nach /var/log/proftpd loggen soll?
     
    #12

Diese Seite empfehlen