1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Infos suche script für oscam installieren auf gen2vdr

Dieses Thema im Forum "CS VDR-SC" wurde erstellt von lefuet, 28. September 2012.

  1. lefuet
    Offline

    lefuet Meister

    Registriert:
    12. Dezember 2008
    Beiträge:
    801
    Zustimmungen:
    89
    Punkte für Erfolge:
    28
    Beruf:
    gibts
    Ort:
    in der zone
    oscam soll auf ein auf gen2 vdr system.
    Dabei ist oscam nur client.
    Benötigt man sc dann noch?
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. peje
    Offline

    peje Ist gelegentlich hier

    Registriert:
    1. Juli 2011
    Beiträge:
    69
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    AW: suche script für oscam installieren auf gen2vdr

    Nein du brauchst das plugin vdr-dvbapi (

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    ) und oscam-svn.
    Zum Beispiel gehst du nach /usr/local/src dann git clone

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    dann ins Verzeichnis vdr-plugin-dvbapi im Makefile vdr iclude dir und lib dir anpassen (/usr/include/vdr bei gentoo) (libdir /usr/lib/vdr/plugins bei gentoo).
    vdr mit plugin dvbapi starten.
    Oscam: siehe

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    da auf jeden fall dvpapi mitbauen und boxtype pc wählen
    cu Peje
     
    #2
    lefuet gefällt das.
  4. lefuet
    Offline

    lefuet Meister

    Registriert:
    12. Dezember 2008
    Beiträge:
    801
    Zustimmungen:
    89
    Punkte für Erfolge:
    28
    Beruf:
    gibts
    Ort:
    in der zone
    AW: suche script für oscam installieren auf gen2vdr

    Nein du brauchst das plugin vdr-dvbapi (

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    ) und oscam-svn.
    Zum Beispiel gehst du nach /usr/local/src dann git clone

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    so weit so gut.....................................

    dann ins Verzeichnis vdr-plugin-dvbapi im Makefile vdr iclude dir und lib dir anpassen (/usr/include/vdr bei gentoo) (libdir /usr/lib/vdr/plugins bei gentoo).

    1.im Makefile was umschreiben wenn ich dich richtig verstanden habe?
    Was wohin????

    2.vdr mit plugin dvbapi starten.
    wo stelle ich das dann ein?


    3.oscam wird ja vom streamboard automatisch eingebaut da fragt aber nix nach boxtype pc??????
     
    #3
  5. peje
    Offline

    peje Ist gelegentlich hier

    Registriert:
    1. Juli 2011
    Beiträge:
    69
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    AW: suche script für oscam installieren auf gen2vdr

    vdr-plugin-dvbapi verlangt im Makefile den vdr-include pfad, hab momentan kein gen2vdr installiert bei gentoo wäre er /usr/inlcude/vdr, das libdir wird gefragt bei gentoo /usr/lib/vdr/plugins.

    ### The directory environment:

    VDRDIR = /usr/include/vdr
    LIBDIR = /usr/lib/vdr/plugins
    TMPDIR = /tmp

    Nachher plugin bauen mit make.
    Die Liste der Plugins die geladen werden ist glaub ich in /etc/vdr/..
    Oscam würde ich selber runterladen und kompilieren - also wie beschrieben svn clonen in das oscam-svn wechseln und mit ./config.sh -g die optionen einstellen, nachher mit make simple bauen - das bin ist dann im Verzeichnis Distribution am besten nach /usr/local/bin/oscam kopieren.
    cu Peje

    Nachtrag hier noch ein ebuild für oscam:
    media-tv/oscam-9999.ebuild:

    # Copyright 1999-2012 Gentoo Foundation
    # Distributed under the terms of the GNU General Public License v2
    # $Header: $


    EAPI=4


    ESVN_REPO_URI="http://streamboard.tv/svn/oscam/trunk"


    inherit eutils subversion


    DESCRIPTION="OSCam is an Open Source Conditional Access Module software"
    HOMEPAGE="http://streamboard.gmc.to:8001/"
    SRC_URI=""


    LICENSE="GPL-2"
    SLOT="0"
    KEYWORDS="~amd64 ~x86"


    PROTOCOL="camd33 camd35 camd35_tcp newcamd cccam gbox radegast serial constcw pandora"
    for share in ${PROTOCOL}; do
    IUSE_PROTOCOL+=" protocol_${share}"
    done


    READER="nagra irdeto conax cryptoworks seca viaccess videoguard dre tongfang bulcrypt"
    for card in ${READER}; do
    IUSE_READER+=" reader_${card}"
    done


    IUSE="${IUSE_PROTOCOL} ${IUSE_READER}
    ac csp debug doc dvb gbox ipv6 irdeto lb lcd monitor pcsc +reader +ssl usb +www"


    REQUIRED_USE="
    protocol_camd35_tcp? ( protocol_camd35 )
    reader_nagra? ( reader )
    reader_irdeto? ( reader irdeto )
    reader_conax? ( reader )
    reader_cryptoworks? ( reader )
    reader_seca? ( reader )
    reader_viaccess? ( reader )
    reader_videoguard? ( reader )
    reader_dre? ( reader )
    reader_tongfang? ( reader )
    reader_bulcrypt? ( reader )
    "


    DEPEND="dev-util/cmake"
    RDEPEND="${DEPEND}
    dev-libs/openssl
    usb? ( dev-libs/libusb )
    pcsc? ( sys-apps/pcsc-lite )"


    RESTRICT="nomirror"


    S="${WORKDIR}/${PN}"


    src_defs() {
    myconf=""
    if use ac; then
    myconf="${myconf} CS_ANTICASC"
    fi
    if use lb; then
    myconf="${myconf} WITH_LB"
    fi
    if use monitor; then
    myconf="${myconf} MODULE_MONITOR"
    fi
    if use csp; then
    myconf="${myconf} CS_CACHEEX"
    fi
    if use debug; then
    myconf="${myconf} WITH_DEBUG"
    fi
    if use dvb; then
    myconf="${myconf} HAVE_DVBAPI"
    fi
    if use ipv6; then
    myconf="${myconf} IPV6SUPPORT"
    fi
    if use irdeto; then
    myconf="${myconf} IRDETO_GUESSING"
    fi
    if use lcd; then
    myconf="${myconf} LCDSUPPORT"
    fi
    if use ssl; then
    myconf="${myconf} WITH_SSL"
    fi
    if use www; then
    myconf="${myconf} WEBIF"
    fi
    if use protocol_camd33; then
    myconf="${myconf} MODULE_CAMD33"
    fi
    if use protocol_camd35; then
    myconf="${myconf} MODULE_CAMD35"
    fi
    if use protocol_camd35_tcp; then
    myconf="${myconf} MODULE_CAMD35_TCP"
    fi
    if use protocol_newcamd; then
    myconf="${myconf} MODULE_NEWCAMD"
    fi
    if use protocol_cccam; then
    myconf="${myconf} MODULE_CCCAM"
    fi
    if use protocol_gbox; then
    myconf="${myconf} MODULE_GBOX"
    fi
    if use protocol_radegast; then
    myconf="${myconf} MODULE_RADEGAST"
    fi
    if use protocol_serial; then
    myconf="${myconf} MODULE_SERIAL"
    fi
    if use protocol_constcw; then
    myconf="${myconf} MODULE_CONSTCW"
    fi
    if use protocol_pandora; then
    myconf="${myconf} MODULE_PANDORA"
    fi
    if use reader; then
    myconf="${myconf} WITH_CARDREADER"
    fi
    if use reader_nagra; then
    myconf="${myconf} READER_NAGRA"
    fi
    if use reader_irdeto; then
    myconf="${myconf} READER_IRDETO"
    fi
    if use reader_conax; then
    myconf="${myconf} READER_CONAX"
    fi
    if use reader_cryptoworks; then
    myconf="${myconf} READER_CRYPTOWORKS"
    fi
    if use reader_seca; then
    myconf="${myconf} READER_SECA"
    fi
    if use reader_viaccess; then
    myconf="${myconf} READER_VIACCESS"
    fi
    if use reader_videoguard; then
    myconf="${myconf} READER_VIDEOGUARD"
    fi
    if use reader_dre; then
    myconf="${myconf} READER_DRE"
    fi
    if use reader_tongfang; then
    myconf="${myconf} READER_TONGFANG"
    fi
    if use reader_bulcrypt; then
    myconf="${myconf} READER_BULCRYPT"
    fi


    export myconf
    }


    src_defs_2() {
    myconf_2=""
    if use usb; then
    myconf="${myconf_2} USE_LIBUSB=1"
    fi
    if use pcsc; then
    myconf="${myconf_2} USE_PCSC=1"
    fi
    export myconf_2
    }


    src_configure() {
    src_defs
    # Disable everything and enable set options
    ./config.sh -D all -E ${myconf}


    }


    src_compile() {
    emake ${myconf_2} CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
    }


    src_install() {
    cp Distribution/oscam-1.20-unstable_svn0-x86_64-pc-linux-gnu-ssl oscam || die "cp failed"
    dobin oscam || die "dobin failed"
    dodoc -r Distribution/doc/example/* || die "dodoc failed"


    if use doc; then
    doman Distribution/doc/man/* || die "doman failed"
    dodoc -r Distribution/doc/txt/* || die "dodoc failed"
    fi
    }


    pkg_postinst() {
    einfo "Please reffer to the wiki for assistance with the setup "
    einfo " located at

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    "
    }
     
    Zuletzt von einem Moderator bearbeitet: 8. Oktober 2012
    #4
  6. daxxa
    Offline

    daxxa Ist gelegentlich hier

    Registriert:
    1. Dezember 2010
    Beiträge:
    75
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    AW: suche script für oscam installieren auf gen2vdr

    hi

    meine güte macht ihr das alles Kompliziert

    ich habe seit Jahren unitymedia mit sc und oscam am laufen über ein Kartenleser der 5€ kostet

    ich werde meine Gebrauchsanweisung mal auf den neusten stand bringen und dann mal posten
     
    Zuletzt bearbeitet: 8. Oktober 2012
    #5
  7. lefuet
    Offline

    lefuet Meister

    Registriert:
    12. Dezember 2008
    Beiträge:
    801
    Zustimmungen:
    89
    Punkte für Erfolge:
    28
    Beruf:
    gibts
    Ort:
    in der zone
    AW: suche script für oscam installieren auf gen2vdr

    das wäre sehr nett
     
    #6
  8. peje
    Offline

    peje Ist gelegentlich hier

    Registriert:
    1. Juli 2011
    Beiträge:
    69
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    AW: suche script für oscam installieren auf gen2vdr

    Hallo es ist nicht kompliziert ohne vdr-sc auszukommen vdr-dvbapi bringt einige Vorteile mit sich zum Beispiel Umschaltzeiten von weniger als 1 Sekunde. Falls jemand diese Installation erklärt nur zu. Grüsse Peje
     
    #7
  9. daxxa
    Offline

    daxxa Ist gelegentlich hier

    Registriert:
    1. Dezember 2010
    Beiträge:
    75
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    AW: suche script für oscam installieren auf gen2vdr

    hi


    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #8
  10. peje
    Offline

    peje Ist gelegentlich hier

    Registriert:
    1. Juli 2011
    Beiträge:
    69
    Zustimmungen:
    9
    Punkte für Erfolge:
    8
    AW: suche script für oscam installieren auf gen2vdr

    Sorry daxxa, du willst offensichtlich nicht begreifen... Lefuet wollte das vdr-plugin-dvbapi mit Oscam per Script installieren also KEIN SC..
    cu Peje
     
    #9

Diese Seite empfehlen