1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ständiger reconnect vom Client löst hohe ECM Zeiten aus

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Fighttack, 4. April 2013.

  1. Fighttack
    Offline

    Fighttack Ist gelegentlich hier

    Registriert:
    26. April 2010
    Beiträge:
    52
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    Hallo zusammen,

    ich musste gestern feststellen, dass ich gestern während der Übertragung der Champions League Probleme hatte.
    Angemeldet waren 3 Clients (1 Dreambox = A, 1 Edision Argus Pingulux = B, 1 Edisioin Argus VIP mit Doppeltuner = C).
    Ab der zweiten Halbzeit traten bei Client B ständig "Mini-Freezer" (Bild nur kurz weg, keine 8 Sekunden) auf. Als ich nachher in LOG-Datei geschaut habe musste ich feststellen, dass Client C sich ständig versucht hat zu reconnecten. Dadurch enstanden beim Clienten B Zeiten von 1100 ms. In der ersten Halbzeit waren es normale Zeiten (~200 ms).

    Hat jemand hierfür eine Erklärung? Braucht man für die Lösung des Problems evtl. die Configs?

    Viele Grüße und Danke!
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Configs sind immer gut, aber auch die Info ob HS oder Inet-CS.

    Grüsse
    szonic
     
    #2
  4. Fighttack
    Offline

    Fighttack Ist gelegentlich hier

    Registriert:
    26. April 2010
    Beiträge:
    52
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    Die Configs kann ich nachher mal posten.
    Es handelt sich um Inet-CS.
    Funktioniert sonst immer alles super, der besagte Client (Client C) ist aber sehr , sehr selten online.

    Hier ist meine Oscam.config
    [global]
    logfile = /var/log/OScam.log
    cachedelay = 120
    nice = -1
    maxlogsize = 2480


    [cccam]
    port = 12000
    nodeid = 019DE0DF101914BA
    version = 2.1.3
    forward_origin_card = 1

    [monitor]
    port = 988
    aulow = 120
    monlevel = 4
    appendchaninfo = 1

    [webif]
    httpport = 83
    httpcss = /var/media/ftp/System/service/oscam/proflinux_ddcstyle.css
    httprefresh = 15
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    aulow = 120
    appendchaninfo = 1


    Oscam.user
    [account]
    user = cccam
    pwd = cccam
    caid = 09C4
    au = v13
    group = 1
    ident = 09C4:000000

    [account]
    user = xxx
    pwd = xxx
    caid = 09C4
    au = v13
    group = 1
    ident = 09C4:000000

    Oscam.server
    [reader]
    label = v13
    protocol = smartreader
    device = Serial:Reader XXXXX
    caid = 09C4
    boxid = 00009134
    ins7e11 = 15
    detect = cd
    mhz = 368
    cardmhz = 368
    group = 1
    emmcache = 1,3,2
    ndsversion = 2
     
    Zuletzt von einem Moderator bearbeitet: 4. April 2013
    #3
  5. Kermit
    Offline

    Kermit Guest

    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Hi,

    nimm in der oscam.conf mal forward_origin_card raus, den Abschnitt Monitor wirst du wahrscheinlich auch nicht benötigen. In der oscam.user setz bei jedem User zusätzlich keepalive =1 und die Einträge mit ident kannst du dir sparen.

    Grüße

    Kermit
     
    #4
  6. w33dburner
    Offline

    w33dburner Ist gelegentlich hier

    Registriert:
    16. April 2009
    Beiträge:
    34
    Zustimmungen:
    15
    Punkte für Erfolge:
    8
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Das Problem ist die "CCcam"(irgendeine uralt-mgcam) in der C-Box (Vip2, richtig?).
    Die kommuniziert nicht "ordentlich", sodaß alle ~15sekunden getrennt und erneut verbunden wird, was entsprechend Last auf deiner Büchse verursacht.

    Ich gehe mal davon aus, das es ein Router ist(wegen dem httpcss-path) und der beim Verbinden an seine Grenze kommt. Kannste ja mal testen ob die CPU am limit läuft, wenn der der Connect durchgeführt wird.
     
    #5
    Fighttack gefällt das.
  7. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Dann schmeisse noch AU beim Edision user raus, und setze emmcache in oscam.conf auf 1,1,2

    Grüsse
    szonic
     
    #6
    Fighttack und Pilot gefällt das.
  8. Fighttack
    Offline

    Fighttack Ist gelegentlich hier

    Registriert:
    26. April 2010
    Beiträge:
    52
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Vielen Dank ihr zwei, da bin ich mal gespannt, ob sich die Veränderungen positiv auswirken.

    Beim Receiver C handelt es sich tatsächlich um einen VIP2. Gibts da mittlerweile kein Firmwareupdate für die Box mit neuerem CAM? Oder heißt es, wenns weiterhin nicht läuft andere Box oder aus die Maus?
    Das ganze läuft tatsächlich auf einer Fritzbox. Wie kann ich denn da die CPU Auslastung sehen (z.b. beim connect von Clients?)?

    Viele Grüße!
     
    #7
  9. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Es gibt keine Frirmware mit neueren Cams.

    Was Du beachten mußt ist das der/ die Edision VIP keine komplizierten, Passwörter und User mag, und keine Sonderzeichen, so meine Erfahrung.

    Ansonsten rennen die mit Oscam als Server echt problemlos und stabil...wenn die Configs passen.

    3 Clienten sind aber kein Problem auf der FB.

    Was auch das sharing beeinflußt, wenn der Client parallel im Netz surft, etwas runterlädt und die Internetverbindung etwas schwachbrüstig ist.
    In der fritte kann man verbindungen priorisieren, das kann auch helfen und sollte bei Dir und dem Clienten mal geprüft werden.

    Grüsse
    szonic
     
    #8
    Fighttack gefällt das.
  10. Arenaworld
    Offline

    Arenaworld Ist gelegentlich hier

    Registriert:
    27. Dezember 2010
    Beiträge:
    98
    Zustimmungen:
    37
    Punkte für Erfolge:
    0
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Du solltest auf jeden Fall mal deine Config säubern Doppel Einträge haben da nicht zu suchen!
    Au solltest du nach Möglichkeit auch nicht so häufig frei geben a hast du so mehr Traffic b es werden deine Karten Daten mit übermittelt
    das willst du sicherlich nicht.
    Kermit hat dir ja schon empfohlen bei dem user keepalive = 1 zu setzen

     
    Zuletzt bearbeitet: 5. April 2013
    #9
    Fighttack gefällt das.
  11. cabal2k
    Offline

    cabal2k Guest

    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Das gleiche hatte ich auch mal.
    Ich vermutete aber, dass der VIP bei jedem Zap ein reconnect macht und durch den login die Inet Leitung mehr oder minder belastet.
    Durch ständiges zappen gabs dann massenhaft login Versuche die zudem noch scheiterten.
    Die Auslastung auf der Box kannst du z.B. durch den Telnet Befehl "top" überwachen.

    Ein Versuch ist auch noch der Parameter "receive Timeout" im cccam Konfig Menü.
    Als ich den hochgeschraub hab auf 3000ms waren wenigstens alle login Versuche erfolgreich und es lief.
     
    #10
  12. Fighttack
    Offline

    Fighttack Ist gelegentlich hier

    Registriert:
    26. April 2010
    Beiträge:
    52
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Ich werde nachher mal zu Hause noch den Ratschlag mit dem AU befolgen und schauen, ob die Zeiten besser werden. "Doof" ist natürlich, dass es schwer ist, das Phänomen zu reproduzieren, wenn man nicht selber im Besitz dieses Receivers ist und das Problem nicht ständig auftritt. Schade!
    Die ZAP-Theorie von cabal2k finde ich auch nicht so abwägig, aber dann auch sehr komisch umgesetzt von den Entwicklern des Receivers (wenns wirklich so ist).
     
    #11
  13. Arenaworld
    Offline

    Arenaworld Ist gelegentlich hier

    Registriert:
    27. Dezember 2010
    Beiträge:
    98
    Zustimmungen:
    37
    Punkte für Erfolge:
    0
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Ich hatte mal den Fall bei jemandem da war der Router von im defekt
    das DSL-Modem hatte Abbrüche mit der Verbindung und hat ständig reconnectet
    das kann man aber leicht raus finden wenn man sich den Router mal unter die Lupe nimmt.
     
    #12
  14. Fighttack
    Offline

    Fighttack Ist gelegentlich hier

    Registriert:
    26. April 2010
    Beiträge:
    52
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Hallo zusammen,

    folgende Rückmeldung kann ich geben:
    Der Client hat sich am Wochenende einmal verbunden und war auch relativ lange connected.
    Ich habe die Tipps befolgt (Keepalive = 1, AU nur bei einem User, den Monitor Eintrag rausgeschmissen, emmcache geändert). Hoffentlich klappts jetzt!

    Vielen Dank für die zahlreichen Hinweise und Tipps :)
     
    #13
    Pilot und szonic gefällt das.
  15. cabal2k
    Offline

    cabal2k Guest

    AW: Ständiger reconnect vom Client löst hohe ECM Zeiten aus

    Ich hab mal meinen VIP2 am Wochenende nochmal mit ILTV angeschlossen:

    Es geht ja um das Ticket: xxxxxoscam/ticket/1943

    In der Tat disconnected der VIP2 in neuen Oscam Versionen alle ca 20 sec. in älteren so alle 1-2 Minuten wenn kein verschlüsselter Sender geschaut wird.

    Wenn man in der OScam Konfig "Client Max Idle" wie im Ticket beschrieben auf 30 stellt gibt es KEINE disconnects mehr und das Problem ist gelöst. Getestet mit OSCAM #7865 über mehrer Stunden.
    Habs jetzt mit 'ner neueren nicht probiert, aber in der Timeline hab ich keine Änderungen an dem Parameter gefunden.

    EDIT:
    Und weil ich noch Urlaub hab und nix zu tun hab nochmal getestet mit 8599.
    Dort reichen die 30 Sekunden nicht, dort läufts einigermaßen stabil mit "Client Max Idle"=10 Sekunden.
    Höchstens mal so nach ner Stunde ein reconnect. Damit kann man leben.

    Ich habs noch zusammen mit ner Dreambox und CCcam getestet, der Parameter scheint mit 10 Sek. keinen Einfluß auf die anderen cccams zu haben.
    Die senden eh alle eine Erhaltungsmeldung.
     
    Zuletzt von einem Moderator bearbeitet: 10. April 2013
    #14

Diese Seite empfehlen