1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HowTo SRG V4 Card bleibt dunkel mit Debian Osacm Server

Dieses Thema im Forum "OScam Archiv" wurde erstellt von tracky, 21. Juli 2012.

  1. tracky
    Offline

    tracky Newbie

    Registriert:
    6. August 2011
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hallo ich nage schon länger an einem sehr hartnäckiges Problem mit minem Cardserver herum und habe mich heute Mittag entschlossen mich mit diesem Problem an das Bord zu wenden.
    Der Cardserver wird jetzt erst mal mit der SRG Karte getestet und wird später um die ORF Crypto-Karte erweitert, auch da wäre ich um die richtigen config Daten dankbar, doch zunächst soll erst mal die SRG Karten laufen.

    Daten Server:
    Igel Thin Client 564 Premium
    Debian x86 2,6,32-5-686
    Oscam: OSCAM 1.10rc-svn build #6089
    CardReader: Smartmouse Easymouse 2

    Daten Client:
    Edison Mini-IP Highspeed wird in cccam config benutzt.

    Mein Problem, alles sieht auf den ersten Blick Top aus, SRG (Original Karte) wird ohne Probleme erkannt und eingelesen.

    Oscam-Log:

    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Sat Jul 21 17:00:54 2012
    -------------------------------------------------------------------------------
    2012/07/21 17:00:54 B73BB8D0 s >> OSCam << cardserver started, version 1.10rc-svn, build #6089 (-pc-linux)
    2012/07/21 17:00:54 B73BB8D0 s version=1.10rc-svn, build #6089, system=-pc-linux, nice=-1
    2012/07/21 17:00:54 B73BB8D0 s client max. idle=120 sec, debug level=0
    2012/07/21 17:00:54 B73BB8D0 s max. logsize=1000 Kb, loghistorysize=4096 bytes
    2012/07/21 17:00:54 B73BB8D0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms
    2012/07/21 17:00:54 B73BB8D0 s services reloaded: 0 services freed, 5 services loaded, rejected 0
    2012/07/21 17:00:54 B73BB8D0 s userdb reloaded: 2 accounts loaded, 0 expired, 0 disabled
    2012/07/21 17:00:54 B73BB8D0 s signal handling initialized (type=sysv)
    2012/07/21 17:00:54 B73BB8D0 s 8 service-id's loaded in 0ms
    2012/07/21 17:00:54 B73BB8D0 s can't open file "/usr/local/etc/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2012/07/21 17:00:54 B73BB8D0 s can't open file "/usr/local/etc/oscam.provid" (err=2 No such file or directory), no provids's loaded
    2012/07/21 17:00:54 B73BB8D0 s can't open file "/usr/local/etc/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2012/07/21 17:00:54 B73BB8D0 s monitor: disabled
    2012/07/21 17:00:54 B73BB8D0 s camd33: disabled
    2012/07/21 17:00:54 B73BB8D0 s camd35: disabled
    2012/07/21 17:00:54 B73BB8D0 s cs378x: disabled
    2012/07/21 17:00:54 B73BB8D0 s newcamd: disabled
    2012/07/21 17:00:54 B73BB8D0 s cccam: initialized (fd=8, port=xxxxx, ip=xxx.xxx.x.xxxx, crypted)
    2012/07/21 17:00:54 B73BB8D0 s radegast: disabled
    2012/07/21 17:00:54 B73BB8D0 s http thread started
    2012/07/21 17:00:54 B73BB8D0 s creating thread for device /dev/ttyUSB1
    2012/07/21 17:00:54 B73BB8D0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/07/21 17:00:54 B73BB8D0 s waiting for local card init
    2012/07/21 17:00:54 B736DB70 h HTTP Server listening on port xxxxx
    2012/07/21 17:00:54 B7361B70 r reader thread started (thread=B7361B70, label=srgswiss, device=/dev/ttyUSB1, detect=cd, mhz=357, cardmhz=357)
    2012/07/21 17:00:57 B7361B70 r srgswiss card detected
    2012/07/21 17:01:01 B7361B70 r ATR: xx xx xx xx xx xx xx xx xx xx xx xx
    2012/07/21 17:01:04 B7361B70 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
    2012/07/21 17:01:05 B7361B70 r [viaccess-reader] using ecm #604 for long viaccess ecm
    2012/07/21 17:01:05 B7361B70 r type: Viaccess (standard atr), caid: 0500, serial: xxxxxxxxxxx
    2012/07/21 17:01:06 B7361B70 r providers: 4 (xxxxx0,xxxxx,xxxxxx,xxxxx)
    2012/07/21 17:01:06 B7361B70 r [viaccess-reader] ready for requests
    2012/07/21 17:01:06 B7361B70 r found cardsystem viaccess
    2012/07/21 17:01:06 B7361B70 r [viaccess-reader] card detected
    2012/07/21 17:01:06 B7361B70 r [viaccess-reader] serial: xxxxxxxxxxx
    2012/07/21 17:01:06 B7361B70 r provider: 1, id: xxxxx, name: ISSUER, sa: xxxxxxx geo: empty
    2012/07/21 17:01:07 B7361B70 r provider: 2, id: xxxxx, name: SRGSSR, sa: xxxxx, geo: FF FF FF FF
    2012/07/21 17:01:07 B7361B70 r class: 01, expiry date: 2012/07/09 - 2012/08/23
    2012/07/21 17:01:07 B7361B70 r class: 01, expiry date: 2012/06/04 - 2012/07/19
    2012/07/21 17:01:07 B7361B70 r class: 01, expiry date: 2012/04/30 - 2012/06/14
    2012/07/21 17:01:07 B7361B70 r class: 01, expiry date: 2012/03/26 - 2012/05/10
    2012/07/21 17:01:07 B7361B70 r class: 01, expiry date: 2012/02/20 - 2012/04/05
    2012/07/21 17:01:07 B7361B70 r class: 01, expiry date: 2012/01/26 - 2012/02/25
    2012/07/21 17:01:07 B7361B70 r class: 02, expiry date: 2012/01/26 - 2012/02/25
    2012/07/21 17:01:07 B7361B70 r class: 03, expiry date: 2012/01/26 - 2012/02/25
    2012/07/21 17:01:07 B7361B70 r class: 01, expiry date: 2012/01/16 - 2012/03/01
    2012/07/21 17:01:08 B7361B70 r provider: 3, id: xxxxxxx, name: Service2, sa: xxxxx, geo: FF FF FF FF
    2012/07/21 17:01:08 B7361B70 r provider: 4, id: xxxxxxx, name: Service3, sa: xxxxx, geo: FF FF FF FF
    2012/07/21 17:01:09 B73BB8D0 s init for all local cards done
    2012/07/21 17:01:09 B73BB8D0 s anti cascading disabled
    2012/07/21 17:01:12 B736DB70 h all debug_level=255
    2012/07/21 17:01:12 0 share-updater mode=initfast t=1s i=26
    2012/07/21 17:01:13 0 share-updater mode=initfast t=1s i=25
    2012/07/21 17:01:14 0 share-updater mode=initfast t=1s i=24
    2012/07/21 17:01:15 0 share-updater mode=initfast t=1s i=23
    2012/07/21 17:01:16 0 share-updater mode=initfast t=1s i=22
    2012/07/21 17:01:17 0 share-updater mode=initfast t=1s i=21
    2012/07/21 17:01:18 0 share-updater mode=initfast t=1s i=20
    2012/07/21 17:01:19 0 share-updater mode=initfast t=1s i=19
    2012/07/21 17:01:20 0 share-updater mode=initfast t=1s i=18
    2012/07/21 17:01:21 0 share-updater mode=initfast t=1s i=17
    Auch der Client verbindet sich mit cccam problemlos und steht anschließend auf Grün.
    Nach einem Restart der Client CCCam ist dann auf dem Bildschirm z.b bei SF1HD folgendes zu sehen:
    new cat [sat130 | tp12398 |service id 0385 |stream id 2134 |network id 013e
    new pmt [sat130 | tp12398 |service id 0385 |stream id 2134 |network id 013e

    Hier die Daten aus der Webmonitor: Oscan Log:
    2012/07/21 17:05:41 0 share-updater mode=initfast t=1s i=-242
    2012/07/21 17:05:42 0 share-updater mode=initfast t=1s i=-243
    2012/07/21 17:05:43 0 share-updater mode=initfast t=1s i=-244
    2012/07/21 17:05:44 0 share-updater mode=initfast t=1s i=-245
    2012/07/21 17:05:45 0 share-updater mode=initfast t=1s i=-246
    2012/07/21 17:05:45 B7349B70 c cccam: new connection from xxx.xxx.xx.xxx
    2012/07/21 17:05:45 B7349B70 c send ccc checksum
    2012/07/21 17:05:45 B7349B70 c receive ccc checksum
    2012/07/21 17:05:45 B7349B70 c ccc username received xxxx01
    2012/07/21 17:05:45 B7349B70 c ccc passwdhash received xxxx01
    2012/07/21 17:05:45 B7349B70 c 192.168.5.100: resolved ip=xxx.xxx.xx.xx
    2012/07/21 17:05:45 B7349B70 c encrypted cccam-client xxx.xxx.xx.xxx granted (xxxx01, au=auto (1 reader))
    2012/07/21 17:05:45 B7349B70 c ccc user authenticated xxxx01
    2012/07/21 17:05:45 B7349B70 c cccam: send ack:
    2012/07/21 17:05:45 B7349B70 xx xx xx xx xx 00 00 00 00 00 00 00 00 00 00 00
    2012/07/21 17:05:45 B7349B70 00 00 00 00
    2012/07/21 17:05:45 B7349B70 c cccam: cli data:
    2012/07/21 17:05:45 B7349B70 00 00 00 5D 68 61 6D 6D 30 31 00 00 00 00 00 00
    2012/07/21 17:05:45 B7349B70 00 00 00 00 00 00 00 00 0A 01 08 00 00 01 61 00
    2012/07/21 17:05:45 B7349B70 00 32 2E 30 2E 31 31 00 00 00 00 00 00 00 00 00
    2012/07/21 17:05:45 B7349B70 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    2012/07/21 17:05:45 B7349B70 00 32 38 39 32 00 00 00 00 00 00 00 00 00 00 00
    2012/07/21 17:05:45 B7349B70 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    2012/07/21 17:05:45 B7349B70 00
    2012/07/21 17:05:45 B7349B70 c cccam(s) xxxx01: client 'xxxxxx01' (0A010800000xxxxx) running v2.0.11 (2892)
    2012/07/21 17:05:45 B7349B70 c ccc send srv_data xxxxx01
    2012/07/21 17:05:45 B7349B70 c cccam: send server data
    2012/07/21 17:05:45 B7349B70 c cccam: auto build set for version: 2.1.4 build: 3191
    2012/07/21 17:05:45 B7349B70 c cccam(s) xxxxx01: version: 2.1.4, build: 3191 nodeid: 0A010800000xxxxxx
    2012/07/21 17:05:46 0 share-updater mode=initfast t=1s i=-247
    2012/07/21 17:05:47 B736DB70 h WebIf: Received stale header from xxx.xxxx.x.xxx
    2012/07/21 17:05:47 0 share-updater mode=initfast t=1s i=-248
    2012/07/21 17:05:47 B7349B70 c cccam(s) xxxxx01: 2.1.x compatibility mode
    2012/07/21 17:05:47 B7349B70 c ccc send cards xxxx01
    2012/07/21 17:05:47 B7349B70 c ccc connected and waiting for data xxxxx01
    2012/07/21 17:05:48 0 share-updater mode=initfast t=1s i=-249
    2012/07/21 17:05:49 0 share-updater mode=initfast t=1s i=-250
    2012/07/21 17:05:50 0 share-updater mode=initfast t=1s i=-251
    2012/07/21 17:05:51 0 share-updater mode=initfast t=1s i=-252

    Dann nach einiger Zeit:
    2012/07/21 17:08:05 0 share-updater mode=initfast t=1s i=-386
    2012/07/21 17:08:06 0 share-updater mode=initfast t=1s i=-387
    2012/07/21 17:08:07 0 share-updater mode=initfast t=1s i=-388
    2012/07/21 17:08:07 B7349B70 c ccc idle xxxxx01
    2012/07/21 17:08:07 B7349B70 c cccam: keepalive
    2012/07/21 17:08:07 B7349B70 c cccam(s) xxxxx01: parse_msg=6
    2012/07/21 17:08:07 B7349B70 c cccam: keepalive
    2012/07/21 17:08:07 B7349B70 c cccam(s) xxxxx01: parse_msg=6
    2012/07/21 17:08:08 0 share-updater mode=initfast t=1s i=-389
    2012/07/21 17:08:09 0 share-updater mode=initfast t=1s i=-390
    2012/07/21 17:08:10 0 share-updater mode=initfast t=1s i=-391
    2012/07/21 17:08:11 0 share-updater mode=initfast t=1s i=-392
    2012/07/21 17:08:12 0 share-updater mode=initfast t=1s i=-393
    2012/07/21 17:08:13 0 share-updater mode=initfast t=1s i=-394
    Das Blöde ist nur der Client bleibt dunkel, würde mich freuen wenn mir jemand im Bord helfen kann.
    Ach Ja sieht man unten habe das ganz auch schon mit der ganz aktuellen Version OSCAM 1.20-unstable_svn build #7190 versucht leider ebenfalls ohne Erfolg.

    Meine OSCam Config Data:

    oscam.Server:

    # oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn build #7190
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [reader]
    label = srgswiss
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB1
    services = srgswiss
    caid = 0500
    detect = cd
    mhz = 357
    cardmhz = 357
    ident =
    group = 1
    emmcache = 1,3,2
    lb_weight = 100

    Oscam.conf:

    # oscam.conf generated automatically by Streamboard OSCAM 1.10rc-svn build #6089
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [global]
    serverip = xxx.xxxx.x.xxx
    usrfile = /var/log/oscamuser.log
    logfile = /var/log/oscam.log
    cwlogdir = /Var/log/oscam/cw
    disableuserfile = 0
    failbantime = 300
    failbancount = 25
    cachedelay = 120
    nice = -1
    maxlogsize = 1000
    preferlocalcards = 1

    [monitor]
    hideclient_to = 15
    appendchaninfo = 0

    [cccam]
    port = xxxxxx
    reshare = 1
    forward_origin_card = 1
    ignorereshare = 0
    version = 2.1.4
    minimizecards = 0
    keepconnected = 1
    stealth = 1
    reshare_mode = 1
    updateinterval = 240
    #nodeid = xxxxxxx103014EA



    [webif]
    httpport = xxxxx
    httphelplang = de
    httpuser = xxxxxxxx
    httppwd = xxxxxxxxx
    httprefresh = 15
    httpallowed = 127.0.0.1,1.1.1.0-255.255.255.255

    oscam.user:


    # oscam.user generated automatically by Streamboard OSCAM 1.20-unstable_svn build #7190
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [account]
    user = xxxxx01
    pwd = xxxx
    description = xxxxxxxxxx
    group = 1
    hostname = xxx.xxx.x.xxx
    au = 1
    cccmaxhops = 2
    cccreshare = 1


    Wäre froh wenn mir jemand weiterhelfen kann.
     
    Zuletzt von einem Moderator bearbeitet: 22. Juli 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. T1x
    Offline

    T1x VIP

    Registriert:
    11. Juni 2010
    Beiträge:
    3.859
    Zustimmungen:
    2.719
    Punkte für Erfolge:
    113
    AW: SRG V4 Card bleibt dunkel mit Debian Osacm Server

    Hab das Thema verschoben.
    Setze bitte in Zukunft Spoiler für deine Configs!
     
    #2
  4. razorback
    Offline

    razorback Power Elite User

    Registriert:
    21. Mai 2008
    Beiträge:
    2.011
    Zustimmungen:
    1.306
    Punkte für Erfolge:
    113
    Beruf:
    IT
    Ort:
    Wien-Süd
    AW: SRG V4 Card bleibt dunkel mit Debian Osacm Server

    was leider fehlt sind die Log-Einträge wenn der Client einen SRG Sender anwählt.

    R
     
    #3

Diese Seite empfehlen