1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HowTo smargos werden an 7270 nicht erkannt

Dieses Thema im Forum "Fritzbox Talk" wurde erstellt von sweet17051983, 15. Juli 2012.

  1. sweet17051983
    Offline

    sweet17051983 Newbie

    Registriert:
    22. Februar 2009
    Beiträge:
    18
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Geschlecht:
    männlich
    Geräte im Netzwerk:
    Internet: Fritz-Box 6360 cable - Original-Software
    WLAN-Repeater & LAN-Bestandteil: Fritzbox 7270 mit freetz-devel-9182M
    Beide Geräte sind per LAN-Kabel verbunden, das Netzwerk funktioniert 1a
    An der 7270 hängt ein Aktiv-USB-Hub von D-Link, an dem stecken ein USB-Stick sowie 2 Smargos.

    Derzeitiger Karten-Server: Dream 8000 mit icvs & GP3 oscam 6773
    2 internen Karten:
    oberer Schacht SKY V13 Full-Abo
    unterer Schacht ORF-Karte cryptoworks(die gute alte)

    Clients:
    1 Dream 500 HD cccam
    1 Dream 800 cccam
    1 Dream 7025 cccam

    läuft soweit ohne Freezer, alles ist gut.:ja

    Nun habe ich vor, die Fritz 7270 mit 2 smargo+ (argolis, V 1.07) als Server zu Verwenden, da die Dream 8000
    im Urlaub vom Strom soll. Die smargos werden gefunden, aber wohl nicht als cardreader erkannt (so interpretiere ich das zumindest).
    Folgende configs:

    Freetz – Dienste
    dsld running
    ftpd running (inetd)
    multid running
    telnetd stopped
    crond stopped
    swap running
    webcfg running
    callmonitor stopped
    cifsmount stopped
    dropbear stopped
    inadyn-mt stopped
    inetd running
    openvpn stopped
    syslogd stopped
    vsftpd stopped
    wol stopped
    oscam running
    watchdog running
    usb2serial running

    Status-Informationen zur CS-Installation an der FRITZ!BOX:

    USB-Laufwerk an /var/media/ftp/uStor01 mit 'Stick-Installation Feature' eingebunden.
    Datei-System des Laufwerkes an: /var/media/ftp/uStor01 --> ext2

    Ein CHROOT-ROOTFS wurde an /var/media/ftp/uStor01 eingebunden.

    FTDI-Treiber -- > Treiber geladen
    PL2303-Treiber -- > Treiber nicht geladen

    PCSCD-TREIBER-TOOL --> nicht installiert

    # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn build #6012
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [global]
    serverip = 192.168.0.2
    logfile = /var/media/ftp/uStor01/OScam.log
    failbantime = 500
    failbancount = 3
    cachedelay = 120
    nice = -1
    maxlogsize = 2480
    preferlocalcards = 1
    saveinithistory = 1

    [monitor]
    port = 988
    aulow = 120
    hideclient_to = 15
    monlevel = 4
    appendchaninfo = 1

    [cccam]
    port = 12001
    reshare = 0
    version = 2.3.0.
    keepconnected = 0

    [webif]
    httpport = 83
    httphelplang = de
    httpcss = /var/media/ftp/uStor01/cs/oscam//style.css
    httprefresh = 10
    httpallowed = 192.168.0.0-192.168.255.255
    httphideidleclients = 1
    # oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn build #6012
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [reader]
    label = orf
    description = orf
    protocol = smartreader
    device = Serial:01234567
    device_out_endpoint = 0x82
    smargopatch = 1
    caid = 0D05
    boxid = 12345678
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 2
    emmcache = 1,3,15


    [reader]
    label = v13
    protocol = smartreader
    device = Serial:7654321
    device_out_endpoint = 0x82
    smargopatch = 1
    caid = 09C4
    boxid = 12345678
    detect = cd
    nagra_read = 1
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,3,2
    auprovid = 000001
    # oscam.user generated automatically by Streamboard OSCAM 1.20-unstable_svn build #6012
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [account]
    user = dm500
    pwd = dm500
    group = 1,2
    hostname = 192.168.0.37
    monlevel = 2

    logfile aus der Fritz:
    Stoppe OSCam Cardserver Dienst...
    USB2SERIAL-Treiber-Tool wird gestoppt.
    OSCam Cardserver wurde gestoppt.
    OSCam Cardserver-Dienst wird jetzt gestartet ...
    USB2SERIAL-Treiber-Tool wird nicht gestartet.
    Protokoll ist auf 'smartreader' eingestellt!
    USB-Serial Module werden geladen ...
    OSCam-Version: 1.20-unstable_svn Rev. 6012 gestartet.

    logfile aus dem oscam-webif der Fritz:
    2012/07/15 12:18:17 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build #6012 (mips-pc-linux)
    2012/07/15 12:18:17 0 s version=1.20-unstable_svn, build #6012, system=mips-pc-linux, nice=-1
    2012/07/15 12:18:17 0 s client max. idle=120 sec, debug level=0
    2012/07/15 12:18:17 0 s max. logsize=2480 Kb, loghistorysize=4096 bytes
    2012/07/15 12:18:17 0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms
    2012/07/15 12:18:17 0 s Couldn't allocate memory (errno=12 Cannot allocate memory)!
    2012/07/15 12:18:17 0 s Couldn't allocate memory (errno=12 Cannot allocate memory)!
    2012/07/15 12:18:17 0 s services reloaded: 0 services freed, 4 services loaded, rejected 0
    2012/07/15 12:18:17 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2012/07/15 12:18:17 0 s signal handling initialized (type=sysv)
    2012/07/15 12:18:17 0 s 116 service-id's loaded in 7ms
    2012/07/15 12:18:17 0 s 116 tier-id's loaded
    2012/07/15 12:18:17 0 s 3 provid's loaded
    2012/07/15 12:18:17 0 s 22 lengths for caid guessing loaded
    2012/07/15 12:18:17 0 s Starting listener 0
    2012/07/15 12:18:17 0 s monitor: initialized (fd=7, port=988, ip=192.168.0.2)
    2012/07/15 12:18:17 0 s Starting listener 0
    2012/07/15 12:18:17 0 s camd35: disabled
    2012/07/15 12:18:17 0 s Starting listener 0
    2012/07/15 12:18:17 0 s cs378x: disabled
    2012/07/15 12:18:17 0 s Starting listener 0
    2012/07/15 12:18:17 0 s newcamd: disabled
    2012/07/15 12:18:17 0 s Starting listener 0
    2012/07/15 12:18:17 0 s cccam: initialized (fd=8, port=12001, ip=192.168.0.2, crypted)
    2012/07/15 12:18:17 0 s Starting listener 0
    2012/07/15 12:18:17 0 s radegast: disabled
    2012/07/15 12:18:17 556EB8 h HTTP Server listening on port 83
    2012/07/15 12:18:17 0 s http thread started
    2012/07/15 12:18:17 0 s reader check thread started
    2012/07/15 12:18:17 0 s check thread started
    2012/07/15 12:18:17 0 s creating thread for device Serial:01234567
    2012/07/15 12:18:17 0 s creating thread for device Serial:7654321
    2012/07/15 12:18:17 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/07/15 12:18:17 0 s waiting for local card init
    2012/07/15 12:18:17 559CE8 r Using 0x82 as endpoint for smartreader hardware detection
    2012/07/15 12:18:17 559CE8 r Smartreader device Serial:7654321 not found
    2012/07/15 12:18:17 5585D0 r Using 0x82 as endpoint for smartreader hardware detection
    2012/07/15 12:18:17 559CE8 r Cannot open device: Serial:7654321
    2012/07/15 12:18:17 5585D0 r Found reader with serial 01234567 at 001:006
    2012/07/15 12:18:17 5585D0 r Smartreader : couldn't read config descriptor , assuming this is not a smartreader
    2012/07/15 12:18:17 5585D0 r Smartreader device Serial:01234567 not found
    2012/07/15 12:18:17 5585D0 r Cannot open device: Serial:01234567
    :emoticon-0179-headb
    Da komme ich jetzt nicht mehr weiter und hoffe auf Eure Hilfe. Was stimmt nicht in den Einstellungen ?
     
    Zuletzt von einem Moderator bearbeitet: 15. Juli 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. antinesi
    Offline

    antinesi Ist gelegentlich hier

    Registriert:
    11. November 2008
    Beiträge:
    70
    Zustimmungen:
    25
    Punkte für Erfolge:
    18
    AW: smargos werden an 7270 nicht erkannt

    meine beiden Smargo (1 x Max.,1 x Agro) FW1.5 werden auch über Smartreader und Serial angesprochen

    in meiner 7390 durfte ich keine FTDi oder PC2303 Treiber laden, weder noch, sonst waren die reader auch nicht da.
     
    #2
  4. sweet17051983
    Offline

    sweet17051983 Newbie

    Registriert:
    22. Februar 2009
    Beiträge:
    18
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Geschlecht:
    männlich
    AW: smargos werden an 7270 nicht erkannt

    einen der beiden findet er: 2012/07/15 12:18:17 5585D0 r Found reader with serial 01234567 at 001:006

    Edit: habe die Serial des 2. Smargo geändert, natürlich auch die oscam.server
    Jetzt werden beide erkannt, aber wohl nicht ausgelesen:
    2012/07/15 14:45:54 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build #6012 (mips-pc-linux)
    2012/07/15 14:45:54 0 s version=1.20-unstable_svn, build #6012, system=mips-pc-linux, nice=-1
    2012/07/15 14:45:54 0 s client max. idle=120 sec, debug level=0
    2012/07/15 14:45:54 0 s max. logsize=2480 Kb, loghistorysize=4096 bytes
    2012/07/15 14:45:54 0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms
    2012/07/15 14:45:54 0 s Couldn't allocate memory (errno=12 Cannot allocate memory)!
    2012/07/15 14:45:54 0 s Couldn't allocate memory (errno=12 Cannot allocate memory)!
    2012/07/15 14:45:54 0 s services reloaded: 0 services freed, 4 services loaded, rejected 0
    2012/07/15 14:45:54 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2012/07/15 14:45:54 0 s signal handling initialized (type=sysv)
    2012/07/15 14:45:54 0 s 116 service-id's loaded in 5ms
    2012/07/15 14:45:54 0 s 116 tier-id's loaded
    2012/07/15 14:45:54 0 s 3 provid's loaded
    2012/07/15 14:45:54 0 s 22 lengths for caid guessing loaded
    2012/07/15 14:45:54 0 s Starting listener 0
    2012/07/15 14:45:54 0 s monitor: initialized (fd=7, port=988, ip=192.168.0.2)
    2012/07/15 14:45:54 0 s Starting listener 0
    2012/07/15 14:45:54 0 s camd35: disabled
    2012/07/15 14:45:54 0 s Starting listener 0
    2012/07/15 14:45:54 0 s cs378x: disabled
    2012/07/15 14:45:54 0 s Starting listener 0
    2012/07/15 14:45:54 0 s newcamd: disabled
    2012/07/15 14:45:54 0 s Starting listener 0
    2012/07/15 14:45:54 0 s cccam: initialized (fd=8, port=12001, ip=192.168.0.2, crypted)
    2012/07/15 14:45:54 0 s Starting listener 0
    2012/07/15 14:45:54 0 s radegast: disabled
    2012/07/15 14:45:54 556EB8 h HTTP Server listening on port 83
    2012/07/15 14:45:54 0 s http thread started
    2012/07/15 14:45:54 0 s reader check thread started
    2012/07/15 14:45:54 0 s check thread started
    2012/07/15 14:45:54 0 s creating thread for device Serial:01234567
    2012/07/15 14:45:54 0 s creating thread for device Serial:22222222
    2012/07/15 14:45:54 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/07/15 14:45:54 0 s waiting for local card init
    2012/07/15 14:45:54 559CE8 r Using 0x82 as endpoint for smartreader hardware detection
    2012/07/15 14:45:54 559CE8 r Found reader with serial 22222222 at 001:012
    2012/07/15 14:45:54 559CE8 r Smartreader : couldn't read config descriptor , assuming this is not a smartreader
    2012/07/15 14:45:54 559CE8 r Smartreader device Serial:22222222 not found
    2012/07/15 14:45:54 5585D0 r Using 0x82 as endpoint for smartreader hardware detection
    2012/07/15 14:45:54 559CE8 r Cannot open device: Serial:22222222
    2012/07/15 14:45:54 5585D0 r Found reader with serial 01234567 at 001:009
    2012/07/15 14:45:54 5585D0 r Smartreader : couldn't read config descriptor , assuming this is not a smartreader
    2012/07/15 14:45:54 5585D0 r Smartreader device Serial:01234567 not found
    2012/07/15 14:45:54 5585D0 r Cannot open device: Serial:01234567
     
    Zuletzt von einem Moderator bearbeitet: 15. Juli 2012
    #3
  5. antinesi
    Offline

    antinesi Ist gelegentlich hier

    Registriert:
    11. November 2008
    Beiträge:
    70
    Zustimmungen:
    25
    Punkte für Erfolge:
    18
    AW: smargos werden an 7270 nicht erkannt

    ich hab bei den Smargos FW 1.05, ich nehme die Serial die der Smargo beim flashen bekommt.

    dann sieht mein Eintrag so aus:

    device = Serial:Reader C023ECE
     
    #4
  6. sweet17051983
    Offline

    sweet17051983 Newbie

    Registriert:
    22. Februar 2009
    Beiträge:
    18
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Geschlecht:
    männlich
    AW: smargos werden an 7270 nicht erkannt

    die Serial wird bei der Firmware 1.07 durch den user vergeben
     
    Zuletzt von einem Moderator bearbeitet: 15. Juli 2012
    #5
  7. antinesi
    Offline

    antinesi Ist gelegentlich hier

    Registriert:
    11. November 2008
    Beiträge:
    70
    Zustimmungen:
    25
    Punkte für Erfolge:
    18
    AW: smargos werden an 7270 nicht erkannt

    mir der 1.07 kam ich nie zurecht, deshalb hab ich die 1.05
     
    #6
  8. sweet17051983
    Offline

    sweet17051983 Newbie

    Registriert:
    22. Februar 2009
    Beiträge:
    18
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Geschlecht:
    männlich
    AW: smargos werden an 7270 nicht erkannt

    würde ich ja auch gerne ausprobieren. Habe auf meinem Rechner Win 7 64 und schon vieles ausprobiert (Win XP-Kompat., admin-Rechte, ...) Komme aber von 1.07 nicht mehr runter
     
    #7

Diese Seite empfehlen