1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem Smargo ein festen Port zuweisen bei oscam

Dieses Thema im Forum "CS Root & Vserver" wurde erstellt von baban76, 29. Mai 2012.

  1. baban76
    Offline

    baban76 Ist gelegentlich hier

    Registriert:
    26. Juli 2010
    Beiträge:
    78
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Hallo
    ich habe alle beitrage zum Tema gelesen

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    ich bnutze
    pc
    debian ipc 11.3
    cccam 2.1.4
    oscam 6921



    ich habe 3 smargo
    abo1,abo2,abo3
    mit cccam habe ich kein Problem es läuft wie es sein soll
    nach jede reboot bleibt abo1 mit smarog1 usw.
    aber bei oscam läuft nicht ich wie es sein soll
    habe versucht abo 1 und 3 mit cccam lesen und abo 2 mit oscam
    abo2 habe bei cccam deaktiviert und im oscam aktiviert,
    Device: /dev/abo2
    es läuft wunderbar bis ich pc reboote
    nachdem reboot kommt Error, karte wird nicht mehr erkannt.
    haber die beide smargo von cccam entfernt ,und habe nur smargo2 mit abo2 in oscam gehabt, und pc rebootet
    kommt auch Error karte wird nicht erkannt.
    komische weise mit cccam habe ich kein Problem .
    kann bitte jemand helfen was ich fasch mache , oder wo ran liegt es ?
    ich bedanke mich für jede Vorschlag
    mfg
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    Morgen,

    ich denke nicht das es an den Udevregeln liegt, die schauen eigentlich in Ordnung aus.

    poste mal deine Oscam-Configs in Spoiler!
     
    #2
  4. baban76
    Offline

    baban76 Ist gelegentlich hier

    Registriert:
    26. Juli 2010
    Beiträge:
    78
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    hallo
    hier ist oscam .cfg
    [global]
    logfile = stdout
    fallbacktimeout = 4900
    clientmaxidle = 200
    failbancount = 2
    unlockparental = 1
    nice = -1
    serialreadertimeout = 800
    suppresscmd08 = 1
    maxlogsize = 0
    waitforcards = 0
    saveinithistory = 1
    readerrestartseconds = 10
    cacheexwaittime = 10
    cacheexenablestats = 1
    lb_mode = 1
    lb_save = 100
    lb_nbest_readers = 5
    lb_nfb_readers = 3
    lb_max_ecmcount = 2000
    lb_reopen_seconds = 500
    lb_retrylimit = 2500
    lb_savepath = /tmp/.oscam/stat
    lb_reopen_mode = 1
    lb_auto_betatunnel = 0

    [monitor]
    port = xxxxxxxxxxx
    hideclient_to = 30
    monlevel = 4
    appendchaninfo = 1

    [newcamd]
    port = 10001@1702:000000
    key = 0102030405060708091011121314
    keepalive = 1
    mgclient = 1

    [cs357x]
    port = xxxxxx
    suppresscmd08 = 1

    [cccam]
    port = xxxxx
    reshare = 1
    version = 2.1.4
    minimizecards = 1
    stealth = 1
    nodeid = C981864C10381498
    reshare_mode = 1

    [webif]
    httpport = xxxxxxx
    httphelplang = de
    httpuser = xxxxx
    httppwd = xxxxxx
    httprefresh = 30
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
    httphideidleclients = 1
     
    #3
  5. aragorn
    Offline

    aragorn Guest

    die oscam.conf beinhaltet keine reader einstellungen also bitte die oscam.server posten
    und bitte auch den abschnitt bezüglich der reader aus der cccam.cfg posten sowie die fehlermeldung von oscam
     
    #4
  6. baban76
    Offline

    baban76 Ist gelegentlich hier

    Registriert:
    26. Juli 2010
    Beiträge:
    78
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    [reader]
    label = sky-de
    enable = 0
    protocol = smargo
    device = /dev/abo2
    services = sky select,skyde
    caid = 1702,1833
    boxkey = 1122334455667788
    ecmwhitelist = 1702:93
    detect = cd
    mhz = 961
    cardmhz = 600
    group = 11
    emmcache = 1,3,2
    lb_weight = 200
    auprovid = 001702


    Error
    0xb7300478 r1 sky-de ON OFF 127.0.0.1 0 smargo 0000:0000 no data 00:00:43 ERROR (no entitlements)No active entitlements found



    2012/05/29 14:27:12 A1F1CF0 c thread B6763B70 ended!
    2012/05/29 14:27:12 9ABF358 h restarting reader sky-de
    2012/05/29 14:27:12 9ABF358 h creating thread for device /dev/abo2
    2012/05/29 14:27:12 A2362C0 r smargo init
    2012/05/29 14:27:12 A2362C0 r reader sky-de initialized (device=/dev/abo2, detect=cd, mhz=961, cardmhz=600)
    2012/05/29 14:27:12 A2362C0 r sky-de card detected
     
    #5
  7. aragorn
    Offline

    aragorn Guest

    na daran sieht man schon mal das er den /dev port öffnen konnte du ihn also vorher in cccam auch auskommetiert hast (es kann nämlich immer nur eine cam exklusiv auf einen reader zugreifen)

    probier es doch mal bitte mit einem anderen device protokol zum beispiel "protocol = mouse" und kommentier auch mal bitte die krasse übertaktung aus (mhz = 961)
    leerzeichen in den services ist glaub ich auch ungültig.. solange die karte nicht läuft lässt du sowas bitte erst mal weg
     
    #6
  8. baban76
    Offline

    baban76 Ist gelegentlich hier

    Registriert:
    26. Juli 2010
    Beiträge:
    78
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    bekomme immer das gleiche fehle
    wenn ich smargo2 mit abo2 mit ccam starte und bende danach mit oscam verbite geht und hat kein problem
    dh. ich muss immer zuerst mit cccam starten alle 3 abo dan abo2 deaktvier und mit iscam aktveiren
     
    #7
  9. *Neptun*
    Offline

    *Neptun* Meister

    Registriert:
    16. März 2012
    Beiträge:
    759
    Zustimmungen:
    497
    Punkte für Erfolge:
    0
    Beruf:
    Rentner der Langeweile hat!!
    Ort:
    Über den Wolken!!
    Moin, ich denke mal das CCcam sich den Reader zuerst schnappt, das kann man ändern in dem man CCcamStartScript ne Pause einbaut das es später startet, aber weiss net mehr wo, lange her mit CCcam!!!
     
    #8
  10. aragorn
    Offline

    aragorn Guest

    in cccam musst du wie gesagt die SERIAL READER zeile auskommentieren oder ganz raus schmeissen. es kann immer nur ein programm auf das gerät zugreifen
     
    #9
  11. baban76
    Offline

    baban76 Ist gelegentlich hier

    Registriert:
    26. Juli 2010
    Beiträge:
    78
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    wie geschrieben wurde deaktviert es siht soaus :


    #SMARTCARD CLOCK FREQUENCY: /dev/skyabo 9610002
    #TRY ALL CHIDS : /dev/abo2
    #SMARTCARD SID REJECT: /dev/skyabo 5 { 000F,003b,0046,0096,0097,0098,0099,009A,009B,009C,0201,0159,0163,016D,0079,007A,132F,1330,32C9,32CA,32CB,32CC,32CD,32CE,32CF,32D0,32D1,32D2,32D3,32D4,33A7,3332,4E27,F1E0,33A5 }
    #SERIAL READER : /dev/abo2 smartreader+
     
    #10
  12. baban76
    Offline

    baban76 Ist gelegentlich hier

    Registriert:
    26. Juli 2010
    Beiträge:
    78
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    habe auch cccam aus geschaltet , nur oscam ist gelaufen und immer das gleiche problem
     
    #11
  13. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    versuch in Oscam nur mal das notwendigste bei der Readereinstellung!

    PHP:
    [reader]
    label                         sky-de
    protocol                      
    mouse
    device                        
    = /dev/abo2
    caid                          
    1702
    boxkey                        
    1122334455667788
    detect                        
    cd
    mhz                           
    600
    cardmhz                       
    600
    group                         
    11
    emmcache                      
    1,1,2
    auprovid                      
    1
     
    Zuletzt bearbeitet: 29. Mai 2012
    #12
  14. gooseman
    Offline

    gooseman Elite User

    Registriert:
    17. August 2009
    Beiträge:
    1.567
    Zustimmungen:
    751
    Punkte für Erfolge:
    113
    Ort:
    39°58'59.95"N,117°49'59.52"E
    Ich kann mir nicht vorstellen das dies mit dem protocol = smargo laufen wird.
    Mach mal bitte protocol = mouse
    oder du updatest deine Smargos mal auf die Firmware 1.5 und lässt die Smargos dann mit protocol = smartreader laufen und benötigst dann nicht mehr die udevRegeln, da du die dann mit der iSerial vom Smargo fest verlinken kannst.
     
    #13
  15. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    sorry das habe ich übersehen..hatte nur aus seinem Reader die nicht wichtigen Parameter gelöscht.
     
    #14
  16. baban76
    Offline

    baban76 Ist gelegentlich hier

    Registriert:
    26. Juli 2010
    Beiträge:
    78
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    hallo
    bezug zum update
    smargo haben Firmware 1.5
    sie haben serial Nr.: Reader C099E49
    protocol = smartreader
    devic = was soll ich her schreiben

    Udevadm info starts with the device specified by the devpath and then
    walks up the chain of parent devices. It prints for every device
    found, all possible attributes in the udev rules key format.
    A rule to match, can be composed by the attributes of the device
    and the attributes from one single parent device.

    looking at device '/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/ttyUSB0/tty/ttyUSB0':
    KERNEL=="ttyUSB0"
    SUBSYSTEM=="tty"
    DRIVER==""

    looking at parent device '/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/ttyUSB0':
    KERNELS=="ttyUSB0"
    SUBSYSTEMS=="usb-serial"
    DRIVERS=="ftdi_sio"
    ATTRS{latency_timer}=="1"
    ATTRS{port_number}=="0"

    looking at parent device '/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0':
    KERNELS=="2-1:1.0"
    SUBSYSTEMS=="usb"
    DRIVERS=="ftdi_sio"
    ATTRS{bInterfaceNumber}=="00"
    ATTRS{bAlternateSetting}==" 0"
    ATTRS{bNumEndpoints}=="02"
    ATTRS{bInterfaceClass}=="ff"
    ATTRS{bInterfaceSubClass}=="ff"
    ATTRS{bInterfaceProtocol}=="ff"
    ATTRS{supports_autosuspend}=="1"
    ATTRS{interface}=="USB smartcard server"

    looking at parent device '/devices/pci0000:00/0000:00:1d.0/usb2/2-1':
    KERNELS=="2-1"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{configuration}==""
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bmAttributes}=="a0"
    ATTRS{bMaxPower}=="100mA"
    ATTRS{urbnum}=="6838"
    ATTRS{idVendor}=="0403"
    ATTRS{idProduct}=="6001"
    ATTRS{bcdDevice}=="0400"
    ATTRS{bDeviceClass}=="00"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="00"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{bMaxPacketSize0}=="8"
    ATTRS{speed}=="12"
    ATTRS{busnum}=="2"
    ATTRS{devnum}=="2"
    ATTRS{devpath}=="1"
    ATTRS{version}==" 2.00"
    ATTRS{maxchild}=="0"
    ATTRS{quirks}=="0x0"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{authorized}=="1"
    ATTRS{serial}=="Reader C099E49"

    looking at parent device '/devices/pci0000:00/0000:00:1d.0/usb2':
    KERNELS=="usb2"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{configuration}==""
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bmAttributes}=="e0"
    ATTRS{bMaxPower}==" 0mA"
    ATTRS{urbnum}=="33"
    ATTRS{idVendor}=="1d6b"
    ATTRS{idProduct}=="0001"
    ATTRS{bcdDevice}=="0300"
    ATTRS{bDeviceClass}=="09"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="00"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{speed}=="12"
    ATTRS{busnum}=="2"
    ATTRS{devnum}=="1"
    ATTRS{devpath}=="0"
    ATTRS{version}==" 1.10"
    ATTRS{maxchild}=="2"
    ATTRS{quirks}=="0x0"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{authorized}=="1"
    ATTRS{manufacturer}=="Linux 3.0.0-17-generic uhci_hcd"
    ATTRS{product}=="UHCI Host Controller"
    ATTRS{serial}=="0000:00:1d.0"
    ATTRS{authorized_default}=="1"

    looking at parent device '/devices/pci0000:00/0000:00:1d.0':
    KERNELS=="0000:00:1d.0"
    SUBSYSTEMS=="pci"
    DRIVERS=="uhci_hcd"
    ATTRS{vendor}=="0x8086"
    ATTRS{device}=="0x27c8"
    ATTRS{subsystem_vendor}=="0x17aa"
    ATTRS{subsystem_device}=="0x3807"
    ATTRS{class}=="0x0c0300"
    ATTRS{irq}=="23"
    ATTRS{local_cpus}=="ff"
    ATTRS{local_cpulist}=="0-7"
    ATTRS{dma_mask_bits}=="32"
    ATTRS{consistent_dma_mask_bits}=="32"
    ATTRS{enable}=="1"
    ATTRS{broken_parity_status}=="0"
    ATTRS{msi_bus}==""

    looking at parent device '/devices/pci0000:00':
    KERNELS=="pci0000:00"
    SUBSYSTEMS==""
    DRIVERS==""
     
    #15

Diese Seite empfehlen