1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Seit OSCAM Update geht garnichts mehr

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von n00bie, 9. Januar 2014.

  1. n00bie
    Offline

    n00bie Ist gelegentlich hier

    Registriert:
    28. September 2012
    Beiträge:
    62
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    Hallo,

    kurze Vorgeschichte. Ich habe gestern meine Dreambox von OE1.6 auf OE2.0 upgegraded. Somit ist auch mein Oscam von der Version 8339 auf 9044 aktualisiert worden.
    Nun habe ich das Problem das Sky seit dem Update garnicht mehr geht, weder bei mir lokal über DVBAPI, noch bei den ganzen Clients die sich zu mir verbinden.
    Hat sich da wirklich soviel bei den Versionen verändert das die neue Oscam Version mit meinen "alten" Configs garnicht mehr geht?!
    Müheselig habe ich herausfinden können das wohl bei den Readern jetzt die Mhz und Cardmhz eintragen muss. Immerhin sehe ich jetzt die Entitlements und habe nicht mehr die Meldung "card system not supported"

    So sehen meine Configs aus und haben bis vor gestern einwanfrei funktioniert:

    oscam.conf
    [global]
    logfile = /var/log/oscam.log
    nice = -1
    maxlogsize = 3000
    preferlocalcards = 1
    dropdups = 1

    [cache]

    [cccam]
    port = 12345
    nodeid = 8DEA858810D01598
    version = 2.3.0
    reshare = 1
    stealth = 1

    [dvbapi]
    enabled = 1
    au = 1
    user = dvbapi
    boxtype = dreambox

    [webif]
    httpport = 1234
    httpuser = admin
    httppwd = xxxxxxx
    httpcss = /etc/tuxbox/config/pastel.css
    httptpl = /media/usb/piconWebif/
    httphelplang = de
    httprefresh = 10
    httphideidleclients = 1
    httpshowpicons = 1
    httpallowed = 0.0.0.0-192.168.255.255
    hideclient_to = 60

    oscam.server
    [reader]
    label = sky_sat
    protocol = internal
    device = /dev/sci0
    services = sat-sky-starter,sat-sky-welt-extra,sat-sky-welthd,sat-sky-film,sat-sky-filmhd,sat-sky-sportsd,sat-sky-sporthd,sat-sky-bundesligasd,sat-s
    caid = 1702,1833
    boxkey = 1122334455667788
    ecmwhitelist = 1702:93;1833:89
    detect = cd
    mhz = 2700
    cardmhz = -1
    group = 1
    emmcache = 1,1,2

    [reader]
    label = sky_kabel
    protocol = internal
    device = /dev/sci1
    services = kdg-sky-starter,kdg-sky-welthd,kdg-sky-film,kdg-sky-filmhd,kdg-sky-sportsd,kdg-sky-sporthd,kdg-sky-bundesligasd,kdg-sky-bundesligahd
    caid = 1722,1834
    boxkey = 1122334455667788
    detect = cd
    mhz = 2700
    cardmhz = -1
    group = 2
    emmcache = 1,3,2

    [reader]
    label = hdplus
    protocol = mouse
    device = /dev/ttyUSB0
    services = hdplus
    caid = 1843
    boxkey = boxkey
    rsakey = rsakey
    ecmwhitelist = 1843:89
    detect = cd
    mhz = 2700
    cardmhz = -1
    group = 3

    oscam.user
    [account]
    user = dvbapi
    caid = 1702,1833,1843
    uniq = 3
    au = 1
    betatunnel = 1833.FFFF:1702
    group = 1,2,3
    services = hdplus,sat-sky-starter,sat-sky-welt-extra,sat-sky-welthd,sat-sky-film,sat-sky-filmhd,sat-sky-sportsd,sat-sky-sporthd,sat-sky-bundesligas

    [account]
    user = blablablub
    pwd = blablablub
    caid = 1702,1833,1843
    betatunnel = 1833.FFFF:1702
    group = 1,3
    services = hdplus,sat-sky-starter,sat-sky-welt-extra,sat-sky-welthd,sat-sky-film,sat-sky-filmhd,sat-sky-sportsd,sat-sky-sporthd,sat-sky-bundesligas
    cccmaxhops = 0
    cccreshare = 0
     
    Zuletzt bearbeitet: 9. Januar 2014
    #1
  2. phantom

    Nervigen User Advertisement

  3. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.948
    Zustimmungen:
    5.872
    Punkte für Erfolge:
    113
    AW: Seit OSCAM Update geht garnichts mehr

    Hi,
    versuch es mal mit
    bei deinen Karten.
    Ich glaub da gab es mal wieder eine Änderung.

    Gruß
    janni1
     
    #2
  4. n00bie
    Offline

    n00bie Ist gelegentlich hier

    Registriert:
    28. September 2012
    Beiträge:
    62
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Seit OSCAM Update geht garnichts mehr

    hat leider nichts gebracht, das problem besteht weiterhin. Im Log sieht alles wunderbar aus, nur wird leider nichts hell :)
     
    #3
  5. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.948
    Zustimmungen:
    5.872
    Punkte für Erfolge:
    113
    AW: Seit OSCAM Update geht garnichts mehr

    Hi,
    sorry, diese Änderung tritt erst ab #9064/9099 in Kraft, denk daran wenn du Oscam wieder mal updatest.
    Könntest du denn mal einen Log-Auszug posten, wenn du auf einen abonierten Sender wechselst?

    Gruß
    janni1
     
    Zuletzt bearbeitet: 9. Januar 2014
    #4
  6. neoma
    Offline

    neoma Ist gelegentlich hier

    Registriert:
    3. Dezember 2013
    Beiträge:
    45
    Zustimmungen:
    2
    Punkte für Erfolge:
    8
    AW: Seit OSCAM Update geht garnichts mehr

    Was für eine Karte hast Du denn? Spiel mal in der oscam.server mit dem Eintrag ins7e11 rum, fang mal mit 11 an und erhöhe das sukzessive bis 15 ...
     
    #5
  7. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.948
    Zustimmungen:
    5.872
    Punkte für Erfolge:
    113
    AW: Seit OSCAM Update geht garnichts mehr

    Hi,
    dieser Parameter hat nur bei NDS-Karten eine Auswirkung und da hat der TE ja keine.
    Außerdem werden die Karten bei ihm ja erkannt
    Gruß
    janni1
     
    #6
  8. n00bie
    Offline

    n00bie Ist gelegentlich hier

    Registriert:
    28. September 2012
    Beiträge:
    62
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Seit OSCAM Update geht garnichts mehr

    Fehlerursache gefunden. Es liegt an diesem externen Reader
    [reader]
    label = hdplus
    protocol = mouse
    device = /dev/ttyUSB0
    services = hdplus
    caid = 1843
    boxkey = boxkey
    rsakey = rsakey
    ecmwhitelist = 1843:89
    detect = cd
    mhz = 2700
    cardmhz = -1
    group = 3

    Kommentiere ich diesen aus, funktioniert alles so wie es soll.

    Ist der Reader jedoch in der config aktiviert, bleibt oscam hängen

    Im log sieht es dann so aus, weiter kommt oscam nicht:
    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Thu Jan 9 10:14:52 2014
    -------------------------------------------------------------------------------
    2014/01/09 10:14:52 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r9044 (mipsel-oe-linux)
    2014/01/09 10:14:52 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 3236
    2014/01/09 10:14:52 0 s services reloaded: 0 services freed, 24 services loaded, rejected 0
    2014/01/09 10:14:52 0 s userdb reloaded: 11 accounts loaded, 0 expired, 0 disabled
    2014/01/09 10:14:52 0 s signal handling initialized
    2014/01/09 10:14:52 0 s 241 service-id's loaded in 6ms
    2014/01/09 10:14:52 0 s 35 tier-id's loaded
    2014/01/09 10:14:52 0 s cccam: initialized (fd=5, port=xxxxx)
    2014/01/09 10:14:52 0 s sky_sat [internal] creating thread for device /dev/sci0
    2014/01/09 10:14:52 78C4E8 r sky_sat [internal] Reader initialized (device=/dev/sci0, detect=cd, pll max=27.00 MHz, wanted cardmhz=-0.01 MHz
    2014/01/09 10:14:52 0 s sky_kabel [internal] creating thread for device /dev/sci1
    2014/01/09 10:14:52 0 s hdplus [mouse] creating thread for device /dev/ttyUSB0
    2014/01/09 10:14:52 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2014/01/09 10:14:52 0 s waiting for local card init
    2014/01/09 10:14:52 76C00468 r sky_kabel [internal] Reader initialized (device=/dev/sci1, detect=cd, pll max=27.00 MHz, wanted cardmhz=-0.01 MHz
    2014/01/09 10:14:52 78E5F0 h webif: decompressed 54551 bytes back into 156136 bytes
    2014/01/09 10:14:52 78E5F0 h HTTP Server running. ip=0.0.0.0 port=xxxx

    Trotz dem das dort "HTTP Server running. ip=0.0.0.0 port=xxxx" steht, läuft oscam und auch das webinterface nicht. Ich sehe oscam auch nicht in der "ps aux" Prozessliste
     
    #7
  9. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    AW: Seit OSCAM Update geht garnichts mehr

    hi,

    also für mich ist der Fehler hier bei deinem Reader!

    laut dem device ist es ja ein externer USB-Card-Reader oder?
    wie soll der mit den Einstellungen für die internen Reader laufen?

    lg, Laila
     
    #8
    janni1 gefällt das.
  10. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.948
    Zustimmungen:
    5.872
    Punkte für Erfolge:
    113
    AW: Seit OSCAM Update geht garnichts mehr

    Hi
    Hier müssen wieder die original-Werte rein, diese Einstellungen funktionieren nur im internen Reader der Dream.
    versuchs mal so:
    Gruß
    janni1
     
    #9
    n00bie und laila-no1 gefällt das.
  11. n00bie
    Offline

    n00bie Ist gelegentlich hier

    Registriert:
    28. September 2012
    Beiträge:
    62
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Seit OSCAM Update geht garnichts mehr

    Weltklasse!

    Ich hätte tatsächlich den externen Reader nicht mit den mhz 2700 und cardmhz -1 Werten befeuern dürfen.
    Zurückgesetzt auf mhz = 368 und cardmhz = 368 und schon läuft alles.

    Vielen Dank, Ihr seit die besten!
     
    #10
    laila-no1 und janni1 gefällt das.

Diese Seite empfehlen