1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk Reader werden nicht korrekt eingebunden

Dieses Thema im Forum "Fritzbox Talk" wurde erstellt von Martin860609, 5. Januar 2014.

  1. Martin860609
    Offline

    Martin860609 Ist gelegentlich hier

    Registriert:
    15. November 2013
    Beiträge:
    46
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Guten Morgen allesamt,
    ich klink mich einfach mal mit ein und hoffe ihr könnt mir Helfen.
    ich möchte gern Internet CS betreiben bin neu im Thema hab mich aber bis zu den einstellungen von Oscam vorgekämpft!
    Also ich habe eine Fritzbox 7170 hinter einer Fritzbox 7360sl, an der 7170 hängt ein Hama USB Hub an dem die Easymouse2 mit Sky Vollabo Karte V14 und natürlich auch der stick drin steckt!
    Meine Config.Dateien

    Oscam.Conf:
    [global]logfile = /var/tbmodlog/oscam.log
    nice = -1
    maxlogsize = 20
    usrfile = /var/log/oscamuser.log




    [cccam]
    port = 4000
    serverip = 255.255.255.255
    nodeid = 3C63FFDD10C71586
    version = 2.3.0
    reshare = -1


    [webif]
    httpport = 83
    httphelplang = de
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255


    Oscam.Server:
    [reader]label = skyv14
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 098C
    boxid = 12345678
    ins7e11 = 15
    detect = cd
    mhz = 500
    group = 1
    emmcache = 1,3,10


    Oscam.user:
    [account]user = user
    pwd = pwduser
    hostname = #ip der dreambox?
    caid = 098C
    uniq = 3
    au = 1
    group = 1
    cccmaxhops = 0
    cccreshare = 0


    Client ist eine DM 500 HD mit Newnigma2 Image auf dem cccam 2.3.0 drauf ist.
    in der cccam.cfg steht
    c:XXXX.selfost.eu 4000 user pwduser

    und im oscam webif unter status steht
    2014/01/05 10:22:19 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:22:19 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:23:16 0 share-updater mode=interval t=240s
    2014/01/05 10:23:19 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:23:19 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:24:20 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:24:20 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:25:20 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:25:20 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:26:20 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:26:20 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:27:16 0 share-updater mode=interval t=240s
    2014/01/05 10:27:21 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:27:21 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:28:21 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:28:21 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:29:21 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:29:21 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:30:21 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:30:21 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:31:16 0 share-updater mode=interval t=240s
    2014/01/05 10:31:22 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:31:22 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:32:22 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:32:22 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:33:22 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:33:22 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:34:23 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:34:23 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:35:16 0 share-updater mode=interval t=240s
    2014/01/05 10:35:23 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:35:23 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:36:23 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:36:23 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:37:24 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:37:24 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:38:24 4FA9D0 r skyv14 [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
    2014/01/05 10:38:24 4FA9D0 r skyv14 [mouse] Cannot open device: /dev/ttyUSB0
    2014/01/05 10:38:30 4FC6D8 h WebIf: Origin checked. Result: access from 192.168.178.21 => allowed

    ich hoffe ihr könnt mir Helfen das ich das Bild Hell bekomme
     
    Zuletzt bearbeitet: 5. Januar 2014
    #1
  2. phantom

    Nervigen User Advertisement

  3. Michi1965
    Offline

    Michi1965 Ist oft hier

    Registriert:
    16. Dezember 2013
    Beiträge:
    190
    Zustimmungen:
    73
    Punkte für Erfolge:
    28
    Beruf:
    Zerspanungsmechaniker
    Ort:
    Hagen, NRW
    AW: Reader werden nicht korrekt eingebunden

    Hast Du die FTDI-Treiber (unter USB2Serial) zusammen mit Oscam gestartet?

    Mache bitte Deine persönlichen Daten in den Spoilern unkenntlich!!
     
    #2
  4. Martin860609
    Offline

    Martin860609 Ist gelegentlich hier

    Registriert:
    15. November 2013
    Beiträge:
    46
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Reader werden nicht korrekt eingebunden

    Ja die laden mit!
     
    #3
  5. Michi1965
    Offline

    Michi1965 Ist oft hier

    Registriert:
    16. Dezember 2013
    Beiträge:
    190
    Zustimmungen:
    73
    Punkte für Erfolge:
    28
    Beruf:
    Zerspanungsmechaniker
    Ort:
    Hagen, NRW
    AW: Reader werden nicht korrekt eingebunden

    Starte den Telnet-Dienst unter Freetz. Logge Dich über die Windows-Console mit "telnet 192.168.178.xy (IP der Freetz-Box) ein. User root, PW freetz, sofern Du das nicht geändert hast. Dann den Befehl "ls -l /dev/ttyUSB*" Da solltest Du dann sehen, unter welcher USB-Adresse der Reader zu finden ist.
    Und wenn Du irgendetwas an Oscam verändert hast, musst Du eine 7170 komplett neu starten. Oscam alleine reicht in dem Fall nicht aus.

    Und noch ein Fehler, der aber erst zum tragen kommt, wenn der Reader bereits läuft: in der oscam.user unter "hostname = #ip der dreambox?" gehört die IP der Freetz!Box hin.
     
    #4
  6. Martin860609
    Offline

    Martin860609 Ist gelegentlich hier

    Registriert:
    15. November 2013
    Beiträge:
    46
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Reader werden nicht korrekt eingebunden

    Vielen dank für die Antwort werd es später gleichmal ausprobieren und mich dann wieder melden...erst mal verlangt sohnemann nach mir :)

    Gesendet von meinem GT-I9300 mit Tapatalk
     
    #5
  7. sierra9999
    Offline

    sierra9999 Meister

    Registriert:
    14. Dezember 2012
    Beiträge:
    789
    Zustimmungen:
    151
    Punkte für Erfolge:
    43
    AW: Reader werden nicht korrekt eingebunden

    Auf jeden Fall solltest Du den USB-Anschluß (bzw. die Easymouse) via S/N fest verlinken,
    siehe hier:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #6
  8. Knipser1
    Offline

    Knipser1 Hacker

    Registriert:
    25. Dezember 2010
    Beiträge:
    376
    Zustimmungen:
    44
    Punkte für Erfolge:
    28
    AW: Reader werden nicht korrekt eingebunden

    Hi,

    versuch auch erstmal ohne den Fast Mode, also so:

    oscam.server
    [reader]label = skyv14
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 098C
    boxid = 12345678
    #ins7e11 = 15
    detect = cd
    mhz = 500
    group = 1
    emmcache = 1,3,10
     
    #7
  9. Michi1965
    Offline

    Michi1965 Ist oft hier

    Registriert:
    16. Dezember 2013
    Beiträge:
    190
    Zustimmungen:
    73
    Punkte für Erfolge:
    28
    Beruf:
    Zerspanungsmechaniker
    Ort:
    Hagen, NRW
    AW: Reader werden nicht korrekt eingebunden

    @sierra9999,
    es gibt bei der 7170 kein udev_first. Und eine Easymouse kann man auch nicht per (Device = Serial Reader xyz) verlinken, das geht nur mit Smargos.
     
    #8
  10. sierra9999
    Offline

    sierra9999 Meister

    Registriert:
    14. Dezember 2012
    Beiträge:
    789
    Zustimmungen:
    151
    Punkte für Erfolge:
    43
    AW: Reader werden nicht korrekt eingebunden

    Stimmt - geht ja erst bei den neueren Boxen :emoticon-0133-wait:

    Aber verlinken kann man die Easymouse trotzdem.
    In der UDEV_FIRST die Einträge machen und dann im Reader:
    device = /dev/EasyMouseSKY (z.B.)
     
    #9
  11. Martin860609
    Offline

    Martin860609 Ist gelegentlich hier

    Registriert:
    15. November 2013
    Beiträge:
    46
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Reader werden nicht korrekt eingebunden

    Hallo Michi1965,
    hab jetzt Telnet gestartet und alles so eingegeben da kommt immer not found!?
    Ich möchte aber nochmal die Status seite vom webinterf. laden denn das was ich oben gepostet habe steht immer erst später da am anfang steht immer
    2014/01/05 19:01:31 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build r9146 (mipsel-linux-uclibc-libusb-pcsc)
    2014/01/05 19:01:31 0 s creating pidfile /tmp/.oscam/oscam.pid with pid 933
    2014/01/05 19:01:31 0 s services reloaded: 0 services freed, 5 services loaded, rejected 0
    2014/01/05 19:01:31 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2014/01/05 19:01:31 0 s signal handling initialized
    2014/01/05 19:01:31 0 s 181 service-id's loaded in 29ms
    2014/01/05 19:01:31 0 s cccam: initialized (fd=7, port=4000, ip=255.255.255.255)
    2014/01/05 19:01:31 0 s skyv14 [mouse] creating thread for device /dev/ttyUSB0
    2014/01/05 19:01:31 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2014/01/05 19:01:31 0 s waiting for local card init
    2014/01/05 19:01:31 4FCAD8 h webif: decompressed 55014 bytes back into 156708 bytes
    2014/01/05 19:01:31 4FCAD8 h HTTP Server running. ip=0.0.0.0 port=83
    2014/01/05 19:01:31 4FADD0 r skyv14 [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=500, cardmhz=357)
    2014/01/05 19:01:32 4FADD0 r skyv14 [mouse] card detected
    2014/01/05 19:01:32 4FADD0 r skyv14 [mouse] ATR: 07 FE 00 FC DF F8 67 FC FF F9 DB FC FF 1F FF FB FF C4 FF 9F A3 FF 00 BB F9 DB C0 FF FF DB
    2014/01/05 19:01:32 4FADD0 r skyv14 [mouse] ERROR: Could not read reader->convention
    2014/01/05 19:01:32 4FADD0 r skyv14 [mouse] Error activating card.
    2014/01/05 19:01:33 4FADD0 r skyv14 [mouse] ATR: 07 FE 00 FC DF F8 67 FC FF FD DB FC FF 1F FF FB FF C4 FF 9F A3 FF 00 BB F9 DB C0 FF FF DB
    2014/01/05 19:01:33 4FADD0 r skyv14 [mouse] ERROR: Could not read reader->convention
    2014/01/05 19:01:33 4FADD0 r skyv14 [mouse] Error activating card.
    2014/01/05 19:01:34 4FADD0 r skyv14 [mouse] ATR: 07 FE 00 FC DF F8 67 FC FF FD DB FC FF 1F FF FB FF C4 FF 9F A3 FF 00 BB F9 DB C0 FF FF DB
    2014/01/05 19:01:34 4FADD0 r skyv14 [mouse] ERROR: Could not read reader->convention
    2014/01/05 19:01:34 4FADD0 r skyv14 [mouse] Error activating card.
    2014/01/05 19:01:35 4FADD0 r skyv14 [mouse] THIS WAS A FAILED START ATTEMPT No 1 out of max alloted of 1
    2014/01/05 19:01:35 4FADD0 r skyv14 [mouse] card initializing error
    2014/01/05 19:01:35 0 s init for all local cards done
    2014/01/05 19:01:35 0 s anti cascading disabled
     
    #10
  12. sierra9999
    Offline

    sierra9999 Meister

    Registriert:
    14. Dezember 2012
    Beiträge:
    789
    Zustimmungen:
    151
    Punkte für Erfolge:
    43
    AW: Reader werden nicht korrekt eingebunden

    Irgendwas passt da mit Deinen IPs aber so gar nicht.
    Der Server hat die IP 0.0.0.0 ?!
    Beim cccam-Protokoll kannste die ip=255.255.255.255 weglassen...
     
    #11
  13. Martin860609
    Offline

    Martin860609 Ist gelegentlich hier

    Registriert:
    15. November 2013
    Beiträge:
    46
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Reader werden nicht korrekt eingebunden

    Also muss in die oscam.server noch mein dyndns mit rein?
     
    #12
  14. sierra9999
    Offline

    sierra9999 Meister

    Registriert:
    14. Dezember 2012
    Beiträge:
    789
    Zustimmungen:
    151
    Punkte für Erfolge:
    43
    AW: Reader werden nicht korrekt eingebunden

    Nein, das hat da gar nix zu suchen...

    Über welche IP greifst Du auf das WebIF zu ?
    Und bist Du Dir sicher, dass hinter /dev/ttyUSB0 die Easymouse hängt ?
     
    #13
  15. Michi1965
    Offline

    Michi1965 Ist oft hier

    Registriert:
    16. Dezember 2013
    Beiträge:
    190
    Zustimmungen:
    73
    Punkte für Erfolge:
    28
    Beruf:
    Zerspanungsmechaniker
    Ort:
    Hagen, NRW
    AW: Reader werden nicht korrekt eingebunden

    Der Reader wird doch jetzt erkannt, nur die Karte nicht. Kann aber auch nicht funktionieren, da Du mhz=500 im oscam.server stehen hast, aber die Easymouse gar keine 5Mhz unterstützt. Bitte ändern auf mhz=357. Einfügen: cardmhz=357 und vor das ins7e11 erstmal eine Raute schreiben.
    Die Schalter an der Easymouse: 3,3; mouse; 3,579. der 4. Schalter ist egal.
     
    #14
  16. Martin860609
    Offline

    Martin860609 Ist gelegentlich hier

    Registriert:
    15. November 2013
    Beiträge:
    46
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: Reader werden nicht korrekt eingebunden

    webIf:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    hab grad nochmal unter freetz-->Toolbox-->geräte manager-->easymouse. steckt wohl an 5 obwohl ich jetzt nicht so recht weiß ob es die 5 oder die 4 da stehen muss?
     
    #15

Diese Seite empfehlen