1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk Projekt:APC Back-UPS USV via USB einrichten u. aktivieren

Dieses Thema im Forum "Raspberry Pi" wurde erstellt von TaTuEe, 27. Dezember 2013.

  1. TaTuEe
    Offline

    TaTuEe Spezialist

    Registriert:
    10. Oktober 2012
    Beiträge:
    658
    Zustimmungen:
    503
    Punkte für Erfolge:
    93
    Hi,
    habe eine APC Back-UPS CS 500 USB USV. Auf meinem alten Igel funktioniert meine /etc/init.d/apcupsd Status Abfrage und ich erhalte folgende Auswertung:
    Code:
    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Fri Dec 13 22:45:01 2013 from yadi-pc.speedport.ip
    root@igel:~# [COLOR=#ff0000]/etc/init.d/apcupsd status[/COLOR]
    APC      : 001,045,1074
    DATE     : 2013-12-27 14:12:06 +0100
    HOSTNAME : igel
    VERSION  : 3.14.8 (16 January 2010) debian
    UPSNAME  : igel
    CABLE    : USB Cable
    MODEL    : Back-UPS CS 500
    UPSMODE  :
    STARTTIME: 2013-12-27 14:11:03 +0100
    SHARE    :
    STATUS   :[COLOR=#ff0000] ONLINE[/COLOR]
    LINEV    : 226.0 Volts
    LOADPCT  :   9.0 Percent Load Capacity
    BCHARGE  : 100.0 Percent
    TIMELEFT :  44.6 Minutes
    MBATTCHG : 10 Percent
    MINTIMEL : 5 Minutes
    MAXTIME  : 0 Seconds
    OUTPUTV  : 230.0 Volts
    SENSE    : Medium
    DWAKE    : 000 Seconds
    DSHUTD   : 180 Seconds
    LOTRANS  : 180.0 Volts
    HITRANS  : 266.0 Volts
    RETPCT   : 000.0 Percent
    ITEMP    : 29.2 C Internal
    ALARMDEL : Always
    BATTV    : 13.5 Volts
    LINEFREQ : 50.0 Hz
    LASTXFER : Automatic or explicit self test
    NUMXFERS : 0
    TONBATT  : 0 seconds
    CUMONBATT: 0 seconds
    XOFFBATT : N/A
    SELFTEST : NO
    STESTI   : None
    STATFLAG : 0x07000008 Status Flag
    SERIALNO : [COLOR=#ff0000]4B1233P31316[/COLOR]
    BATTDATE : 2012-08-15
    NOMOUTV  : 230 Volts
    NOMINV   : 230 Volts
    NOMBATTV :  12.0 Volts
    NOMPOWER : 300 Watts
    FIRMWARE : 808.q10 .I USB FW:q
    APCMODEL : Back-UPS CS 500
    END APC  : 2013-12-27 14:12:34 +0100
    root@igel:~#
    

    Und genau diese Statusanzeige im Spoiler wird mir in der Himbeere nicht mehr angezeigt. Es kommt zu eine Fehlermeldung:
    Code:
    root@kdmedia:~# [COLOR=#ff0000]apcaccess Status[/COLOR]
    [COLOR=#ff0000]Error contacting apcupsd [/COLOR]@[COLOR=#ff0000] localhost:3551[/COLOR]: [COLOR=#ff0000]Connection timed out[/COLOR]
    Das ist der NISPORT 3551 (Port mit verfügbarem UPS-Status) und dieser gehört zum NETSERVER (on # aktiviert den NIS-Server für Statusinformationen)

    Laut diversen Quellen soll folgende Config aktiviert werden, was ich auch umgesetzt habe.
    Code:
     
    Bei einer USB-Verbindung:
     UPSCABLE usb
     UPSTYPE usb
     DEVICE
     LockFile /var/lock
     UPSCLASS standalone
     UPSMODE disable
     NETSERVER on # aktiviert den NIS-Server für Statusinformationen
     NISPORT 3551 # Port mit verfügbarem UPS-Status
     BATTERYLEVEL 10 # Shutdown bei Ladezustand unter 10%
     nano /etc/default/apcupsd && /etc/init.d/apcupsd start && apcaccess
     Folgenden Eintrag setzen:
     ISCONFIGURED=yes
     

    Ein Logfile Auswertung bestätigt mir den corecten USB Anschluss an der Himbeere
    root@kdmedia:~# tail /var/log/messages
    Dec 23 13:16:18 kdmedia kernel: [ 32.188502] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
    Dec 23 13:16:18 kdmedia kernel: [ 32.707795] Adding 102396k swap on /var/swap. Priority:-1 extents:1 across:102396k SSFS
    Dec 26 11:47:39 kdmedia kernel: [253902.506681] usb 1-1.2: USB disconnect, device number 4
    Dec 26 11:47:47 kdmedia kernel: [253909.910483] usb 1-1.2: new low-speed USB device number 10 using dwc_otg
    Dec 26 11:47:47 kdmedia kernel: [253910.082712] usb 1-1.2: New USB device found,idVendor=051d, idProduct=0002
    Dec 26 11:47:47 kdmedia kernel: [253910.082748] usb 1-1.2: New USB device strings: Mfr=3, Product=1, SerialNumber=2
    Dec 26 11:47:47 kdmedia kernel: [253910.082766] usb 1-1.2: Product: Back-UPS CS 500 FW:808.q10 .I USB FW:q10
    Dec 26 11:47:47 kdmedia kernel: [253910.082782] usb 1-1.2: Manufacturer: American Power Conversion
    Dec 26 11:47:47 kdmedia kernel: [253910.082797] usb 1-1.2: SerialNumber: 4B1233P31316
    Dec 26 11:47:48 kdmedia kernel: [253910.615777] hid-generic 0003:051D:0002.0002:hiddev0,hidraw0: USB HID v1.10 Device [American Power Conversion Back-UPS CS 50 0 FW:808.q10 .I USB FW:q10 ] on usb-bcm2708_usb-1.2/input0
    root@kdmedia:~#

    Wenn ich auf der Himbeere den Test durchführe...sieht alles gut aus .... ich erhalte diverse positive Informationen.
    Code:
    2013-12-27 12:41:27 [COLOR=#ff0000]apctest 3.14.10[/COLOR] (13 September 2011) debian
    Checking configuration ...
    Attached to driver: usb
    sharenet.type = Network & ShareUPS Disabled
    cable.type = USB Cable
    mode.type = USB UPS Driver
    Setting up the port ...
    Doing prep_device() ...
    You are using a USB cable type, so I'm entering USB test mode
    Hello, this is the apcupsd Cable Test program.
    This part of apctest is for testing USB UPSes.
    
    Getting [COLOR=#ff0000]UPS capabilities...SUCCESS[/COLOR]
    
    
    Please select the function you want to perform.
    1)  Test kill UPS power
    2)  Perform self-test
    3)  Read last self-test result
    4)  View/Change battery date
    5)  View manufacturing date
    6)  View/Change alarm behavior
    7)  View/Change sensitivity
    8)  View/Change low transfer voltage
    9)  View/Change high transfer voltage
    10) Perform battery calibration
    11) Test alarm
    12) View/Change self-test interval
     Q) Quit
    Select function number:
    

    Ich vermute das hat irgendetwas mit dem NIS Server und dem Port und mit 127.0.0.1 zu tun, eventuell muss ich diesen unter meinem jetzigen Image erst noch installieren/aktivieren - Debian wheezy? Oder es gibt unter wheezy nicht mehr diese Status Auswertung...Ich weiß es nicht...habe kein Plan mehr.
     
    Zuletzt bearbeitet: 27. Dezember 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. TaTuEe
    Offline

    TaTuEe Spezialist

    Registriert:
    10. Oktober 2012
    Beiträge:
    658
    Zustimmungen:
    503
    Punkte für Erfolge:
    93
    AW: Projekt: Himbeere als Oscam Only mit APC Back-UPS CS 500 USB einrichten u. aktivi

    Ich habe gesehen das es für •wheezy (stable) (admin) eine V. 3.14.10-2 gibt, ich habe derzeit aktuell die
    Code:
    apc[COLOR=#ff0000]upsd 3.14.10 (13[/COLOR] September 2011) debian startup succeeded
    2013-12-27 20:33:37 +0100  apcserver: cannot bind port 3551. ERR=Cannot assign requested address
    2013-12-27 20:34:48 +0100  Communications with UPS restored.

    Unter folgendem Link gibt es die neuere Version

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    Und wie bekomme ich die jetzt runtergeladen bzw. welche Architektur hat den meine Himbeere? Und dann via Telnet installieren?

    Danke + Gruß
     
    #2
  4. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.424
    Zustimmungen:
    12.689
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Projekt:APC Back-UPS USV via USB einrichten u. aktivieren

    Dein Raspberry Pi hat die ARMEL Architektur.

    Das Paket kannst du so herunterladen:
    Code:
    wget http://ftp.de.debian.org/debian/pool/main/a/apcupsd/apcupsd_3.14.10-2_armel.deb
    Installiern dann mit:
    Code:
    dpkg -i apcupsd_3.14.10-2_armel.deb
     
    #3
  5. TaTuEe
    Offline

    TaTuEe Spezialist

    Registriert:
    10. Oktober 2012
    Beiträge:
    658
    Zustimmungen:
    503
    Punkte für Erfolge:
    93
    AW: Projekt:APC Back-UPS USV via USB einrichten u. aktivieren

    Hups ;-) ...gar nicht gesehen, Danke erst mal! Habe es gleich ausprobiert.

    Zuerst habe ich den Dienst gestoppt:
    Code:
    root@kdmedia:~# /etc/init.d/apcupsd stop
    Stopping UPS power management: apcupsd.

    Dann das Paket abgeholt:
    Code:
    root@kdmedia:~# wget http://ftp.de.debian.org/debian/pool/main/a/apcupsd/
    apcupsd_3.14.10-2_armel.deb
    --2014-01-03 20:12:26-- http://ftp.de.debian.org/debian/pool/main/a/apcupsd
    /apcupsd_3.14.10-2_armel.deb
    Auflösen des Hostnamen »ftp.de.debian.org (ftp.de.debian.org)
    «... 141.76.2.4
    Verbindungsaufbau zu ftp.de.debian.org
    (ftp.de.debian.org)|141.76.2.4|:80... verbunden.
    HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
    Länge: 304192 (297K) [application/x-debian-package]
    In »»apcupsd_3.14.10-2_armel.deb«« speichern.
    100%[===============================>] 304.192 1,13M/s 2014-01-03 20:12:27 (1,13 MB/s) - »»apcupsd_3.14.10-2_armel.deb«« 
    gespeichert [304192/304192]

    Dann das Paket installiert, dabei ist er auf einen Fehler gestoßen.
    Code:
    root@kdmedia:~# dpkg -i apcupsd_3.14.10-2_armel.deb
    dpkg: [COLOR=#ff0000]Fehler beim Bearbeiten von apcupsd_3.14.10-2_armel.deb (--install):
     Paket-Architektur (armel) passt nicht zum System (armhf)[/COLOR]
    Fehler traten auf beim Bearbeiten von:
     apcupsd_3.14.10-2_armel.deb
    root@kdmedia:~#

    Wenn ich das Richtig verstehe haben wir ein armhf System, was immer das auch bedeuten mag :read:
     
    #4
  6. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.424
    Zustimmungen:
    12.689
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Projekt:APC Back-UPS USV via USB einrichten u. aktivieren

    Dann ist es dieses Paket:
    Code:
    wget http://ftp.de.debian.org/debian/pool/main/a/apcupsd/apcupsd_3.14.10-2_armhf.deb
    und dann
    Code:
    dpkg -i apcupsd/apcupsd_3.14.10-2_armhf.deb
     
    #5
  7. TaTuEe
    Offline

    TaTuEe Spezialist

    Registriert:
    10. Oktober 2012
    Beiträge:
    658
    Zustimmungen:
    503
    Punkte für Erfolge:
    93
    AW: Projekt:APC Back-UPS USV via USB einrichten u. aktivieren

    ich muss wahrscheinlich erst ein Prozess beenden?
    Code:
    Code:
    root@kdmedia:~# [COLOR=#ff0000]/etc/init.d/apcupsd stop[/COLOR]
    Stopping UPS power management: apcupsd.
    
    root@kdmedia:~# wg[COLOR=#ff0000]et http://ftp.de.debian.org/debian/pool/main/a/apcupsd/apcupsd_3.14.10-2_armhf.deb[/COLOR]
    --2014-01-03 21:26:01--  http://ftp.de.debian.org/debian/pool/main/a/apcupsd/apcupsd_3.14.10-2_armhf.deb
    Auflösen des Hostnamen »ftp.de.debian.org (ftp.de.debian.org)«... 141.76.2.4
    Verbindungsaufbau zu ftp.de.debian.org (ftp.de.debian.org)|141.76.2.4|:80... verbunden.
    HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
    Länge: 287276 (281K) [application/x-debian-package]
    In »»apcupsd_3.14.10-2_armhf.deb«« speichern.
    100%[=====================================================================>] 287.276     1,17M/s   in 0,2s
    2014-01-03 21:26:01 (1,17 MB/s) - »»apcupsd_3.14.10-2_armhf.deb«« gespeichert [287276/287276]
    
    root@kdmedia:~# [COLOR=#ff0000]dpkg -i apcupsd/apcupsd_3.14.10-2_armhf.deb[/COLOR]
    dpkg:[COLOR=#ff0000] Fehler [/COLOR]beim Bearbeiten von apcupsd/apcupsd_3.14.10-2_armhf.deb (--install):
     Au[COLOR=#ff0000]f das Archiv kann nicht zugegriffen werden: [/COLOR]Datei oder Verzeichnis nicht gefunden
    Fehler traten auf beim Bearbeiten von:
     apcupsd/apcupsd_3.14.10-2_armhf.deb
    root@kdmedia:~# ps fax
     
    #6
  8. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.424
    Zustimmungen:
    12.689
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Projekt:APC Back-UPS USV via USB einrichten u. aktivieren

    ALds noch mal neu herunter. Und versuch erneut. Mit dem Packet kenn ich mich auch net aus,
    hab nur das passende für deine Architektur gesucht.
     
    #7
  9. TaTuEe
    Offline

    TaTuEe Spezialist

    Registriert:
    10. Oktober 2012
    Beiträge:
    658
    Zustimmungen:
    503
    Punkte für Erfolge:
    93
    AW: Projekt:APC Back-UPS USV via USB einrichten u. aktivieren

    Trotzdem Danke!, jetzt kenne ich das Prinzip und hab auch funktionierenden Code und kann an der Stelle weitermachen ... bin schon wieder ein Stückchen weiter ;-). Gruß
     
    #8
    al-x83 gefällt das.

Diese Seite empfehlen