1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Probleme mit freetz auf 7390

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von Frosch1482, 19. März 2012.

  1. Frosch1482
    Offline

    Frosch1482 Ist gelegentlich hier

    Registriert:
    1. Dezember 2010
    Beiträge:
    35
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    ich bekomme oscam nicht gestartet auf der 7390
    hab verschiedene versionen durchprobliert. Entweder:
    - Illegal instructions
    - Segmentation fault
    Schon komisch... Was könnte das sein... dachte immer die Meldungen sind wenn die CPU die falsche ist...

    FW der Fritzbox ist übrigends 84.05.06-freetz-devel-8794

    ist glaub ich im falschen Beitrag gelandet... Bitte verschieben falls notwendig.

    ein bisschen weiter bin ich noch gekommen: mit folgender version von oscam: oscam-stable-1.10-mips-freetz7390-webif-libusb (hier aus der DB) bekomme ich beim starten von OSCAM nun folgenden fehler:

    ------------------------------------------------------------------------------->> OSCam << cardserver started at Mon Mar 19 23:02:12 2012-------------------------------------------------------------------------------2012/03/19 23:02:12 400 s >> OSCam << cardserver started, version 1.10rc-svn, build #6089 (mips-pc-linux)2012/03/19 23:02:12 400 s version=1.10rc-svn, build #6089, system=mips-pc-linux, nice=-12012/03/19 23:02:12 400 s client max. idle=120 sec, debug level=02012/03/19 23:02:12 400 s max. logsize=50 Kb, loghistorysize=4096 bytes2012/03/19 23:02:12 400 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms2012/03/19 23:02:12 400 s services reloaded: 0 services freed, X services loaded, rejected 02012/03/19 23:02:12 400 s userdb reloaded: X accounts loaded, 0 expired, 0 disabled2012/03/19 23:02:12 400 s signal handling initialized (type=sysv)2012/03/19 23:02:12 400 s Couldn't allocate memory (errno=12 Cannot allocate memory)!2012/03/19 23:02:12 400 s cardserver down
     
    Zuletzt bearbeitet: 19. März 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. gompf
    Offline

    gompf Ist oft hier

    Registriert:
    18. August 2010
    Beiträge:
    195
    Zustimmungen:
    23
    Punkte für Erfolge:
    18
    Dieser Fehler (" Couldn't allocate memory (errno=12 Cannot allocate memory)") passiert ab einer bestimmten Freetz Version fuer 1.10 SVN (mit 7883 gehts noch, die hat aber andere Probleme).Ich bin da gerade am suchen warum. Mit 1.20 gibts diese Issue nicht, dafuer ist die aber in der Tat nicht stable und die Reader bleiben unter last haengen, was mit der 1.10 nicht passiert.

    /Gompf
     
    #2
  4. Frosch1482
    Offline

    Frosch1482 Ist gelegentlich hier

    Registriert:
    1. Dezember 2010
    Beiträge:
    35
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Lass mich wissen was du noch rausgefunden hast.

    Ich hab mitlerweile die Build 6090 laufen... und zwar war die beim 84.05.06freetz-devel-8336M mit dabei
     
    #3
  5. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.877
    Zustimmungen:
    6.210
    Punkte für Erfolge:
    113
    Nicht immer ist die neueste Version auch die beste.
    Haben schon mehrere hier berichtet, daß es mit einigen Versionen unterhalb der aktuellen besser geht.
    Die Devs von oscam können ja auch nicht jede Möglichkeit testen, unter der das zum Einsatz kommen könnte/ wird.
     
    #4
  6. gompf
    Offline

    gompf Ist oft hier

    Registriert:
    18. August 2010
    Beiträge:
    195
    Zustimmungen:
    23
    Punkte für Erfolge:
    18
    Ich habe es nun wieder am laufen , liegt an der Freetz configuration die sich geaendert hat, aber auch an der OSCAM Implementation.

    Da ich aber meine rocksolide 1.10 5983 nicht anlangen moechte habe ich es in Freetz von hinten gefixed (man kann es wie gesagt auch im OSCAM source anedern). Das ist aber major Arbeit, man muss uclibc config abaendern und die Toolchain selbst bauen, was auch immer wieder Probleme macht. Es laeuft jetzt wieder alles bei mir unter 05.20 und dem latest Freetz und meiner 1.10 R5983 stable. Jetzt habe ich aber noch die Issue das der smargo nach dem reset der box erstmal blockiert ist und abgesteckt werden muss, irgentwas greift da wohl darauf zu, werde mal sehen wie sich das verhindern laesst.

    Fuer Leute die es trotzdem versuchen wollen, das ganze haengt an der malloc() Funktion, die unterschiedlich implementiert ist. malloc(0) returniert einen validen pointer auf weis der Geier in der glibc, waeren uclibc einen nullpointer returniert wie man das auch erwarten sollte. Man kann uclibc auch in einem Modus builden der damit kompatibel ist und dann auch einen validen pointer retuniert, dann gehts. Die frage ist aber warum OSCAM malloc(0) macht ;)

    /Gompf

    Den Anhang 52703 betrachten
     
    Zuletzt bearbeitet: 28. März 2012
    #5

Diese Seite empfehlen