1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem: Oscam mit cccam

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von schmuhlhanf, 6. August 2011.

  1. schmuhlhanf
    Offline

    schmuhlhanf Newbie

    Registriert:
    6. Juni 2009
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Hallo,
    ich möchte allen hier im Forum danken für die tollen Beiträge.

    Leider habe ich aktuell ein Problem:

    Ich versuche mit einer V13 Karte z.B. Sky Sport1 HD hell zu bekommen. Habe gelesen, dass dies nur mit Oscam in Verbindung mit cccam funktioniert. Leider bekomme ich das nicht hin. cccam (2.1.2) funktioniert ohne Probleme.

    Habe folgende Hardware

    Smargo+
    Fritzbox 7170
    Opticum 9600

    Habe mal meine Config eingestellt:

    OSCAM.config
    [global]
    logfile = /var/media/ftp/uStor01/logs/cs/oscam/oscam.log
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 4900
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 20
    netprio = 0
    clientdyndns = 0
    resolvedelay = 15
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    maxlogsize = 10
    waitforcards = 0
    preferlocalcards = 0
    saveinithistory = 1
    readerrestartseconds = 5


    [monitor]
    port = 988
    nocrypt = 0.0.0.0-255.255.255.255
    aulow = 120
    hideclient_to = 60
    monlevel = 1
    appendchaninfo = 1

    [newcamd]
    port = 30000@09c4:000000
    key = 0102030405060708091011121314
    allowed = 0.0.0.0-255.255.255.255
    keepalive = 1
    mgclient = 0

    [cs357x]
    port = xxxx
    [webif]
    httpport = 16001
    httpuser =
    httppwd =
    httpcss = /var/media/ftp/uStor01/cs/oscam//bluestyle.css
    httprefresh = 10
    httpallowed = 192.168.0.0-255.255.255.255
    httphideidleclients = 0
    httpreadonly = 0

    [anticasc]
    enabled = 1
    numusers = 0
    sampletime = 2
    samples = 10
    penalty = 0
    aclogfile = ./oscam_ac.log
    denysamples = 8
    fakedelay = 1000

    OSCAM servers
    [reader]
    label = v13
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB0
    device_out_endpoint = 0x82
    services = sky
    smargopatch = 1
    caid = 09C4
    boxid = 12345678
    detect = cd
    nagra_read = 2
    mhz = 357
    cardmhz = 357
    ident =
    group = 1
    emmcache = 1,3,2
    lb_weight = 100
    deprecated = 1
    auprovid = 000001


    OSCAM services:
    [sky]

    caid=09c4,1702,1833
    srvid=000A,000B,002B,0029,0009,0014,0204,0008,0203 ,0019,002a,0010,0024,0017,0032,001d,001b,0022,001c ,0013,001a,000e,000d,000c,00a8,0206,0016,0018,0034 ,0015,003c,003d,0040,4461,4462,003f,003e,3393,0042 ,2EFE,700A,0044,07FF ,0043,6ff1,7009,3331,3395,0035,0083,007e,0082,0080 ,007f,0081,0084,007a,007b,007c,00fb,0105,010f,0119 ,0123,012d,0137,0141,014b,0015,0201,0159,0163,016d ,0046,0011,00dd,00de,00fd,014d,0143,0139,012f,0125 ,011b,0107,0111,016b,0175,00df,0106,0110,2011a,012 4,012e,0138,0142,014 c,0156,0160,00fc,000f,0075,0096,0097,0098,0099,009 A,009B,009C,0077

    OSCAM users
    [account]
    user = pass
    pwd = pass
    group = 1
    monlevel = 4
    au = 1
    services = sky
    caid = 09C4
    ident = 09c4:000000
    suppresscmd08 = 1


    cccam.cfg
    N: 127.0.0.1 51356 pass pass 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256
    N: 127.0.0.1 51357 pass pass 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256


    SERVER LISTEN PORT : 33359

    SOFTKEY FILE : /var/media/ftp/uStor01/cs/cccam/SoftCam.Key
    AUTOROLL FILE : /var/media/ftp/uStor01/cs/cccam/AutoRoll.Key
    STATIC CW FILE : /var/media/ftp/uStor01/cs/cccam/constant.cw
    CAID PRIO FILE : /var/media/ftp/uStor01/cs/cccam/CCcam.prio
    PROVIDERINFO FILE : /var/media/ftp/uStor01/cs/cccam/CCcam.providers
    CHANNELINFO FILE : /var/media/ftp/uStor01/cs/cccam/CCcam.channelinfo

    SERIAL READER: /dev/ttyUSB0 smartreader+

    WEBINFO USERNAME : cccam
    WEBINFO PASSWORD : cccam

    WEBINFO LISTEN PORT : 16001
    MINIMUM DOWNHOPS: 0

    DEBUG: yes
    SHOW TIMING: yes

    EXTRA EMM LEVEL : yes


    Hat vielleicht jemand ne Idee wo mein(e) Fehler liegen ?

    Vielen Dank für eure Antworten
     
    Zuletzt von einem Moderator bearbeitet: 7. August 2011
    #1
  2. phantom

    Nervigen User Advertisement

  3. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: Problem: Oscam mit cccam

    Nimm mal aus der reader raus:
    device_out_endpoint = 0x82
    services = sky
    auprovid = 000001
    nagra_read = 2

    Anticasc zum testen ausstellen - enable = 0

    In die Oscam.config mit rein:
    [cccam]
    port = Deiner Wahl
    version = Deiner Wahl
    keepconnected = 1
     
    #2
  4. schmuhlhanf
    Offline

    schmuhlhanf Newbie

    Registriert:
    6. Juni 2009
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Problem: Oscam mit cccam

    Danke für die schnelle Antwort.

    Es sieht jetzt etwas besser aus, denn eine Verbindung zum Opticum wird hergestellt. Leider wird aber die Karte nicht erkannt.

    Für weitere Ideen bin ich sehr dankbar.

    Nochmals danke
     
    #3
  5. MWTeddy10
    Offline

    MWTeddy10 Freak

    Registriert:
    18. September 2009
    Beiträge:
    239
    Zustimmungen:
    84
    Punkte für Erfolge:
    28
    AW: Problem: Oscam mit cccam

    Versuche mal folgender Readereinstellung:


    # Sky V13 Mode: autoswitch Kernel: normal T-mode: T=0 EGT: 0


    # # Sky V13 #
    [reader]
    label = sky
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB0
    services = skyhd,skybuli,skysport,skyextra,skyfilm,skywelt,skyselect,bluemovie
    boxid = 12345678
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,3,2
    lb_weight = 100
     
    #4
  6. schmuhlhanf
    Offline

    schmuhlhanf Newbie

    Registriert:
    6. Juni 2009
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Problem: Oscam mit cccam

    Danke, habe die Einstellungen versucht, leider wird die Karte nicht erkannt.

    Meine Einstellungen für die V13 Karte:

    Mode: Autoswitch
    Kernel: Dreambox
    T-mode: T=0
    EGT: 0

    Hat noch jemand eine Idee ?

    Danke
     
    #5
  7. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: Problem: Oscam mit cccam

    Welche Version ist der Smargo? V1.5 wäre zu empfehlen.
    Danach mal mit auto, normal, 0 ,0 probieren.
     
    #6
  8. schmuhlhanf
    Offline

    schmuhlhanf Newbie

    Registriert:
    6. Juni 2009
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Problem: Oscam mit cccam

    Hallo,

    Smargo hat schon die Version 1.5, leider komme ich da nicht weiter.

    Ist ech mühselig. :(
     
    #7
  9. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: Problem: Oscam mit cccam

    Karte verkehrt herum? Abgelaufen? Nach Änderungen an Oscam reboot?
    Stell mal die MHz und CardMHz auf 500.
     
    #8
  10. schmuhlhanf
    Offline

    schmuhlhanf Newbie

    Registriert:
    6. Juni 2009
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Problem: Oscam mit cccam

    Nein Karte ist richtig herum, denn wenn ich sie nur unter cccam betreibe dann läuft sie ja. Möchte allerdings Sport HD ebenfalls hell bekommen, der läuft aber nur bei eingesteckter Karte im Receiver.
     
    #9
  11. Skywalker
    Offline

    Skywalker VIP

    Registriert:
    18. April 2009
    Beiträge:
    6.137
    Zustimmungen:
    8.294
    Punkte für Erfolge:
    113
    Ort:
    Bayern
    AW: Problem: Oscam mit cccam

    Meines bescheidenen Wissens solltest du die Karte so in der oscam.config auslesen lassen (also mit roter Zeile zusätzlich), wenn ein Opticum als Client im Spiel ist.
    .....
    .......
    port = 30000@09c4:000000
    port = 30001@1833:000000
    key = 0102030405060708091011121314
    allowed = 0.0.0.0-255.255.255.255
    keepalive = 1
    mgclient = 0
    ....
    ......

    Das Camd Protokoll komplett weglassen
    ...
    ....
    #[cs357x]
    #port = xxxx
    ...
    ....

    Die oscam.user neu editieren
    ...
    .....
    [account]
    user = user
    pwd = pass
    group = 1
    monlevel = 4
    au = v13
    services = sky
    caid = 09C4
    ident = 09c4:000000

    [account]
    user = user1
    pwd = pass1
    group = 1
    monlevel = 4
    au = v13
    services = sky
    caid = 1833
    ident = 1833:000000

    Und in die CCcam.cfg zwei Nline schreiben (einmal für SD und einmal HD)
    ...
    ....
    N: 127.0.0.1 30000 user pass 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256
    N: 127.0.0.1 30001 user1 pass1 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256
    ....
    ......
     
    #10
    Pilot und mxer gefällt das.
  12. schmuhlhanf
    Offline

    schmuhlhanf Newbie

    Registriert:
    6. Juni 2009
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Problem: Oscam mit cccam

    Danke für die Hinweise.

    Leider kommt bei meinem Opticum nur "connection ok, 0 card"

    Keine Ahnung an was das liegt.
     
    #11
  13. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: Problem: Oscam mit cccam

    Schade, aber zu Opticum fällt mir nix ein.
    Versuche es mal mit der Board-Suche: opticum
    Da gibt es viele, ich weiß aber nicht, welcher es speziell sein soll.
     
    #12
  14. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.381
    Zustimmungen:
    23.798
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: Problem: Oscam mit cccam

    Hallo smulhanf,

    nimm das mal raus aus deiner cccam.cfg:
    SERIAL READER: /dev/ttyUSB0 smartreader+
    Und am USB Comport für cccam nimm den Haken raus.
    Grund cccam und oscam dürfen nicht gleichzeitig die Karte lesen. cccam darf die Karten Daten nur über die N-Lines bekommen.
    Nach dieser Änderung Fritzbox neu booten

    Mlg piloten
     
    #13
    mxer und Skywalker gefällt das.
  15. Skywalker
    Offline

    Skywalker VIP

    Registriert:
    18. April 2009
    Beiträge:
    6.137
    Zustimmungen:
    8.294
    Punkte für Erfolge:
    113
    Ort:
    Bayern
    AW: Problem: Oscam mit cccam

    Und,
    OSCam muss vor CCcam starten. Das heißt, du mußt OSCam automatisch starten lassen und CCcam manuell. Beide Einstellungen machst du im Freetz Image.

    OScam ---> Autostart

    CCcam ---> manuell
    Dann im WI Freetz klicken und dann rc.custom
    Jetzt diese Einträge

    sleep 20
    /bin/sh /mod/etc/init.d/rc.cccam start

    und auf Übernehmen. Dannach die FB rebooten
     
    #14
    hitschier, mxer und Pilot gefällt das.
  16. schmuhlhanf
    Offline

    schmuhlhanf Newbie

    Registriert:
    6. Juni 2009
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    AW: Problem: Oscam mit cccam

    Hallo, danke für die Beiträge. Leider ohne Erfolg. Es steht immer noch "connection ok, 0 card".

    Werde wohl auf Hd Live events verzichten müssen.
     
    #15

Diese Seite empfehlen