1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk Problem mit Putty

Dieses Thema im Forum "Debian" wurde erstellt von Wormser, 26. Februar 2013.

  1. Wormser
    Offline

    Wormser Ist gelegentlich hier

    Registriert:
    15. Dezember 2008
    Beiträge:
    65
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Ort:
    Bludenz
    Hallo,
    ich habe mir mit Putty einen Publickey eingerichtet auf meinem IPC-Server, aber jetzt komme ich mit Putty nicht mehr drauf, steigt sofort aus wenn ich bei Login etwas eingebe.
    Was kann ich machen das ich wieder von aussen auf meinen Server zugreifen kann?
    Bin um jede Hilfe dankbar.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. sumsi
    Offline

    sumsi VIP

    Registriert:
    13. Mai 2009
    Beiträge:
    5.393
    Zustimmungen:
    4.142
    Punkte für Erfolge:
    113
    AW: Problem mit Putty

    Schau mal die

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Sollte alles wieder gut laufen
     
    #2
    DocKugelfisch gefällt das.
  4. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Problem mit Putty

    Hast du den Publickey ist Putty eingebunden?

    Was gibt Putty als Meldung wenn du versuchst dich zu verbinden?
     
    #3
  5. Wormser
    Offline

    Wormser Ist gelegentlich hier

    Registriert:
    15. Dezember 2008
    Beiträge:
    65
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Ort:
    Bludenz
    AW: Problem mit Putty

    Ich weiss leider nicht welchen Mist ich gemacht habe. hatte probiert einen zugang über das Handy herzustellen, aber das ist wohl komplett fehlgeschlagen und mit Putty ist auch nichts mehr. habe nach dem PPK file gesucht finde ich natürlich auch nicht mehr, wie sollte es auch anders sein.

    Und bei Putty kommt als Fehler nach der Login eingabe " Disconnected: No supported authentication methods available (server send Publickey)"

    kann ich das SSH wieder auf dem Server löschen sodass ich da wieder rauskomme, oder was könnte ich noch machen das es wieder normal läuft, denn ich brauche das ja eigentlich nicht. war Blöd von mir.
     
    #4
  6. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Problem mit Putty

    Ja dazu musst du den Server am Bildschirm anschließen um dich über die normale Konsole anmelden zu können.

    Anschlißend bearbeitest du die sshd_config wie folgt:

    Code:
    # Package generated configuration file
    # See the sshd_config(5) manpage for details
    
    # What ports, IPs and protocols we listen for
    Port 22
    # Use these options to restrict which interfaces/protocols sshd will bind to
    #ListenAddress ::
    #ListenAddress 0.0.0.0
    Protocol 2
    # HostKeys for protocol version 2
    HostKey /etc/ssh/ssh_host_rsa_key
    HostKey /etc/ssh/ssh_host_dsa_key
    #Privilege Separation is turned on for security
    UsePrivilegeSeparation yes
    
    # Lifetime and size of ephemeral version 1 server key
    KeyRegenerationInterval 3600
    ServerKeyBits 768
    
    # Logging
    SyslogFacility AUTH
    LogLevel INFO
    
    # Authentication:
    LoginGraceTime 120
    PermitRootLogin yes
    StrictModes yes
    
    RSAAuthentication yes
    PubkeyAuthentication yes
    [COLOR=#ff0000]#AuthorizedKeysFile    %h/.ssh/authorized_keys[/COLOR]
    
    # Don't read the user's ~/.rhosts and ~/.shosts files
    IgnoreRhosts yes
    # For this to work you will also need host keys in /etc/ssh_known_hosts
    RhostsRSAAuthentication no
    # similar for protocol version 2
    HostbasedAuthentication no
    # Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
    #IgnoreUserKnownHosts yes
    
    # To enable empty passwords, change to yes (NOT RECOMMENDED)
    PermitEmptyPasswords no
    
    # Change to yes to enable challenge-response passwords (beware issues with
    # some PAM modules and threads)
    ChallengeResponseAuthentication no
    
    # Change to no to disable tunnelled clear text passwords
    [COLOR=#ff0000]PasswordAuthentication yes[/COLOR]
    
    # Kerberos options
    #KerberosAuthentication no
    #KerberosGetAFSToken no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    
    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes
    
    X11Forwarding yes
    X11DisplayOffset 10
    PrintMotd no
    PrintLastLog yes
    TCPKeepAlive yes
    #UseLogin no
    
    #MaxStartups 10:30:60
    #Banner /etc/issue.net
    
    # Allow client to pass locale environment variables
    AcceptEnv LANG LC_*
    
    Subsystem sftp /usr/lib/openssh/sftp-server
    
    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication and
    # PasswordAuthentication.  Depending on your PAM configuration,
    # PAM authentication via ChallengeResponseAuthentication may bypass
    # the setting of "PermitRootLogin without-password".
    # If you just want the PAM account and session checks to run without
    # PAM authentication, then enable this but set PasswordAuthentication
    # and ChallengeResponseAuthentication to 'no'.
    [COLOR=#ff0000]UsePAM yes[/COLOR]
    Dann noch SSH neustarten mit:

    Code:
    /etc/init.d/ssh restart
    Und schon solltest du über das Passwort wieder rein kommen.
     
    #5
    Wormser und sumsi gefällt das.
  7. Wormser
    Offline

    Wormser Ist gelegentlich hier

    Registriert:
    15. Dezember 2008
    Beiträge:
    65
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Ort:
    Bludenz
    AW: Problem mit Putty

    Hallo Meister85,es geht immer noch nicht, weiss nicht was los ist, aber vielleicht könnt ihr mir weiterhelfen, muss jetzt aber erst mal auf arbeit,
    kann heute abend oder morgen früh dann weiterprobieren.
     
    #6
  8. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Problem mit Putty

    Hast du dich über die "normale" Konsole verbunden? Änderungen soweit übernommen? SSH-Dienst neugestartet?
     
    #7
  9. Wormser
    Offline

    Wormser Ist gelegentlich hier

    Registriert:
    15. Dezember 2008
    Beiträge:
    65
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Ort:
    Bludenz
    AW: Problem mit Putty

    Habe mich über die normale und über die root verbunden, aber ich glaube ich habe mehr geändert als du markiert hattest. hatte es ausgedruckt und das rot geschriebene war dann auch schwarz , also alles soweit abgeändert was nicht gepasst hatte. das war denke ich ein grosser fehler. Habe dann den ssh Dienst mit dem Root-Zugang neu gestartet.

    Wäre es eine möglichkeit die datei hier hinein zustellen (ich weiss leider nicht ob da persönliche daten drinstehen)
    und einer von euch Spezialisten schaut mal drüber und sagt mir was ich ändern müsste, das es wieder geht?

    He Leute, kommt lasst mich nicht hängen, bitte helft mir doch. ich bin froh das ich soweit gekommen bin, ohne grosse Hilfe und jetzt will ich doch nur das es wieder sauber läuft.
    Ich habe halt nur sehr wenig Erfahrung mit Linux.
     
    Zuletzt bearbeitet: 28. Februar 2013
    #8

Diese Seite empfehlen