1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem mit Oscam und EMM AU

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von martines, 28. Mai 2013.

  1. martines
    Offline

    martines Newbie

    Registriert:
    4. Juli 2012
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Beruf:
    Ingenieur
    Ort:
    Bavaria
    Hallo Gemeinde,

    als erstes mal möchte ich mich herzlich bei allen Usern hier bedanken, eure Fragen und Themen haben mir bislang immer sehr geholfen.

    Nun zu meinem Problem. Ich besitze ein Raspberry Pi mit Smargo-Reader und einer V14 als Server (v8610), sowie 2 Kathrein UFS-913 als Clients (v7149)

    Ich bekomme es nicht hin dass ein Client (Account local) mir die EMMs als AU für die Karte übermittelt und diese dann weiterhin aktiviert.
    Als Protokoll habe ich das TCP gewählt weil UDP bei mir sehr oft Paketverlust hatte.

    Im Anhang sind die Configs

    Server oscam.conf
    [global]
    logfile = stdout;/var/log/oscam/oscam.log
    nice = -1
    maxlogsize = 10000
    usrfile = /var/log/oscam/oscamuser.log
    cwlogdir = /var/log/oscam/cw
    lb_save = 150

    [cs358x]
    port = 27550

    [webif]
    httpport = xxxx
    httpuser = xxxx
    httppwd = xxxx
    httphelplang = de
    httprefresh = 5
    httpallowed = 192.168.x.x-192.168.x.x

    Server oscam.server
    [reader]
    label = V14
    #enable = 1
    protocol = smartreader
    device = 001:006
    CAID = 098C
    services=SkyGermanyMitHDPlus
    boxid = xxxx
    detect = CD
    #mhz=500
    #cardmhz=357
    #mhz = 357
    #cardmhz = 357
    group = 4
    emmcache = 1,3,2
    ins7e11=15
    #ndsversion=2
    #cool_timeout_after_init = 25
    #cool_timeout_init = 150
    #blockemm-unknown = 1

    Server oscam.user
    [account]
    user = local
    pwd = xxx
    #enable = 1
    group = 4
    au = V14
    #betatunnel = 1833.FFFF:098C,1702.FFFF:098C
    caid = 098C
    #services = SkyGermany,HDplus
    #uniq = 3

    [account]
    user = kathreinKlingen
    pwd = xxx
    group = 4
    au = 1
    caid = 098C,1702,1833

    Client oscam.conf
    [global]
    Nice = -1
    ClientTimeout = 5
    FallbackTimeout=3
    ClientMaxIdle=120
    CacheDelay = 120
    BindWait = 5
    WaitForCards = 0
    PreferLocalCards = 1
    LogFile = stdout
    readerrestartseconds = 5
    maxlogsize = 200

    [monitor]
    serverip =
    nocrypt = 127.0.0.1
    aulow = 2
    hideclient_to = 15
    monlevel = 4
    appendchaninfo = 1

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = ufs913
    user = kathreinMartin
    pmt_mode = 0

    [webif]
    httpport = xxx
    httpuser = xxx
    httppwd = xxx
    httphelplang = de
    httprefresh = 5
    httpallowed = 192.168.x.x-192.168.x.x

    [monitor]
    nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255
    appendchaninfo = 1

    Client oscam.dvbapi
    # dvbapi configuration
    S: PTI0 pmt_PTI0.tmp
    S: PTI1 pmt_PTI1.tmp
    S: PTI2 pmt_PTI2.tmp
    S: PTI3 pmt_PTI3.tmp
    S: PTI4 pmt_PTI4.tmp

    P: 098C 1
    P: 0d05


    I: 0
    #I: 1843
    #I: 09C4

    Client oscam.server
    [reader]
    label = skyhd
    protocol = cs378x
    device = 192.168.1.250,27550
    user = local
    password = xxxx
    #services = SkyGermanyMitHDPlus,!ORFmitAustriaSat
    caid = 098C
    group = 1
    emmcache = 1,3,2

    [reader]
    label = orf
    protocol = camd35
    device = 127.0.0.1,30003
    user = av
    password = av
    services = ORFmitAustriaSat
    emmcache = 1,3,2
    #caid= 0D05
    #detect = cd
    group=2
    audisabled = 1

    Client oscam.user
    [account]
    user = kathreinMartin
    #pwd = xxxx
    #description = UFS913HDTV1 (Twin-Receiver)
    group = 1,2
    #hostname =
    uniq = 2
    au = skyhd
    #services = SkyGermanMitHDPlus,ORFmitAustriaSat
    #caid = 098C,0D05
    #caid = 1702,1830,1833
    #betatunnel = 1833.FFFF:1702
    #cccignorereshare = 0
    #cccstealth = 0
    keepalive = 1

    Falls gewünscht die globale
    oscam.services
    [SkyGermanyMitHDPlus]
    caid = 098C
    provid = 000000,000001,000002,000003
    srvid=0083,000A,000B,002B,006B,0029,006A,007A,007B ,007D,007E,007F,0009,0008 ,0017,0014,0015,0204,0021,0203,0023,4462,0075,007C ,0010 ,0025,0024,002A,0032,001B,001D,2EFE,4461,0026,0016 ,0034,0081,0072,0069,0035,006C,0084,79E0,0037 ,0077,3331,00A8,0011,00DD,00DE,00FD,014D,0143,0139 ,012F,0125,011B,0107,0111,016B,0175,0106,0110,011A ,0124,012E,0138,0142,014C,0156,0160,00FC,00DF,0070 ,000D,0076,000C,0082,000E,0071,003A,0039,7001 ,6FF1,0206,0018,0074,0022,006F,0019,001C,001A,0027 ,0038,0013,700A,07FF,006E,1519,151A,2E9A,5273,5274 ,EF10,EF11,EF14,EF15,EF74, EF75,EF76,EF77,157F,001E
    #Sender die gesehen werden können (alle außer Sky Select) 6FFF,
    #caid = 1702,1833,09C4,098C,1830,1843



    [ORFmitAustriaSat]
    caid = 0D05
    provid =
    srvid = 132F,1330,3332,32C9,32CA,32CB,32CC,32CD,32CE,32CF,32D0,32D1,32D2,32D3,32D4,4E27,0046,33A7,33A5,31FC,332D ,14B4,14B5,14B6,14B7,6FEE,6FEF,6FF0,6FF3,6FFF,07FA,31FA,003B

    Falls Logauszüge gewünscht werde ich diese natürlich nachliefern! :)

    Ich bedanke mich jetzt im Vorraus schon einmal für eure Mühe und Hilfe.
    Gerne dürft ihr mir Verbesserungsvorschläge zu meinen Configs geben, da ich recht neu bin und mir diese Configs zusammengesucht habe bis es "funktioniert"

    Viele Grüße

    martines

    EDIT:
    Der Beitrag "Update Funktion in Oscam zur Freischaltung einer Smartcard" ist sehr informativ aber da die Oscam Version meiner Kathrein (Aus dem Schlappohr Paket) kein CCCAM beherrscht steh ich am selben problem wie anfangs.
     
    Zuletzt bearbeitet: 28. Mai 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Problem mit Oscam und EMM AU

    Hi,

    im ersten Spoiler ist falsch
    Code:
    [cs358x]
    port                          = 27550
    
    richtig ist
    Code:
    [[COLOR=#ff0000]cs378x[/COLOR]]
    port                          = 27550
    
    Der Beitrag ist sicher auch auf das camd35 Protokoll übertragbar. Deine Einstellungen sollten so passen.
     
    #2
  4. martines
    Offline

    martines Newbie

    Registriert:
    4. Juli 2012
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Beruf:
    Ingenieur
    Ort:
    Bavaria
    Danke für die fixxe Korrekturhilfe! :)

    Leider ist das AU dennoch irgendwie nicht funktionsfähig.
    Ich habe bei meinem Reciever eben eine neue Oscam aufgespielt, um auf das CCCAM Protokoll zu wechseln, dort sollte es ja funktionieren.
    Mal sehen ob ich es morgen zum laufen bekomme
    Ich werde morgen Google bemühen antworten auf diesen Fehler zu finden, aber wenn es von euch schon jemand weiß kann er mir gerne entgegenkommen, Danke

    --------------------------------------------

    So die OSCAM version die ich als "neu" empfunden hatte, hatte probleme mit meiner Kathrein...

    nun habe ich OSCam mit CCCam zum laufen bekommen nur beim einschalten der Box habe ich das Problem, dass der 1. Sender nicht "hell" wird. Nach dem Umschalten wird es auf einmal "hell"

    LOG (sry für die Newline chars, ich log das via RS232 mit)
    18:16:44 6540D0 p 192.168.1.250: resolved ip=192.168.1.250<\r><\n>
    18:16:44 6540D0 p skyhd [cccam] connecting to 192.168.1.250:27500<\r><\n>
    18:16:44 655878 p camd35 proxy 127.0.0.1:30003<\r><\n>
    18:16:44 655878 p orf [camd35] proxy initialized, server 127.0.0.1:30003<\r><\n>
    18:16:44 6540D0 p skyhd [cccam] proxy initialized, server 192.168.1.250:27500<\r><\n>
    18:16:44 660338 c plain dvbapi-client granted (kathreinMartin, au=on (1 reader))<\r><\n>
    18:16:44 663130 h webif: decompressed 52462 bytes back into 151752 bytes<\r><\n>
    18:16:44 663130 h HTTP Server listening on port 8888<\r><\n>
    18:16:44 660338 c stapi: use alternative ioctls<\r><\n>
    18:16:44 660338 c dvbapi: PTI: PTI4 open 0<\r><\n>
    18:16:44 660338 c dvbapi: PTI: PTI3 open 1<\r><\n>
    18:16:44 660338 c dvbapi: PTI: PTI2 open 2<\r><\n>
    18:16:44 660338 c dvbapi: PTI: PTI1 open 3<\r><\n>
    18:16:44 660338 c dvbapi: PTI: PTI0 open 4<\r><\n>
    18:16:44 660338 c dvbapi: liboscam_stapi v.0.08a initialized<\r><\n>
    18:16:44 660338 c Detected /dev/stapi/stpti4_ioctl Api: 2<\r><\n>
    18:16:44 660338 c [ADD PID 0] CAID: 1702 ECM_PID: 176A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 1] CAID: 1722 ECM_PID: 166A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 2] CAID: 1833 ECM_PID: 186A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 3] CAID: 1834 ECM_PID: 1C6A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 4] CAID: 09C4 ECM_PID: 1B6A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 5] CAID: 09C7 ECM_PID: 1D6A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 6] CAID: 09AF ECM_PID: 1F6A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 7] CAID: 098C ECM_PID: 1A6A PROVID: 000000<\r><\n>
    18:16:44 660338 c [ADD PID 8] CAID: 1861 ECM_PID: 196A PROVID: 000000<\r><\n>
    18:16:44 660338 c Found 9 ECMpids and 4 STREAMpids in PMT<\r><\n>
    18:16:44 660338 c New program number: 00DD (1702:00DD unknown) [pmt_list_management 3]<\r><\n>
    18:16:44 660338 c ERROR: Can't decode channel<\r><\n>
    18:17:16 6540D0 p skyhd [cccam] disconnected: reason inactivity<\r><\n>
    18:19:38 660338 c Stopping demux for pmt file /tmp/pmt_PTI0.tmp<\r><\n>
    18:19:38 660338 c [ADD PID 0] CAID: 1702 ECM_PID: 178C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 1] CAID: 1722 ECM_PID: 168C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 2] CAID: 1833 ECM_PID: 188C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 3] CAID: 1834 ECM_PID: 1C8C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 4] CAID: 09C4 ECM_PID: 1B8C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 5] CAID: 09C7 ECM_PID: 1D8C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 6] CAID: 09AF ECM_PID: 1F8C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 7] CAID: 098C ECM_PID: 1A8C PROVID: 000000<\r><\n>
    18:19:38 660338 c [ADD PID 8] CAID: 1861 ECM_PID: 198C PROVID: 000000<\r><\n>
    18:19:38 660338 c Found 9 ECMpids and 4 STREAMpids in PMT<\r><\n>
    18:19:38 660338 c New program number: 00DE (1702:00DE unknown) [pmt_list_management 3]<\r><\n>
    18:19:38 6540D0 p skyhd [cccam] connecting to 192.168.1.250:27500<\r><\n>
    18:19:43 660338 c Start descrambling PID #7 (CAID: 098C) 1<\r><\n>
    18:19:43 660338 c kathreinMartin (098C&000000/0000/00DE/98:25C4C6AFB8DD8BACB46A8A0C6FD83B10): timeout (5006 ms) by skyhd - Sky Sport 2<\r><\n>
    18:19:43 660338 c kathreinMartin (098C&000000/0000/00DE/98:6E76F3F204E6D95732C8B9350653D37A): found (102 ms) by skyhd - Sky Sport 2<\r><\n>

    Meine Aktuellen Dateien im Client sind wie folgt:

    oscam.conf
    [global]
    Nice = -1
    ClientTimeout = 5
    FallbackTimeout=3
    ClientMaxIdle=120
    CacheDelay = 120
    BindWait = 5
    WaitForCards = 0
    PreferLocalCards = 1
    LogFile = stdout
    readerrestartseconds = 5
    maxlogsize = 200
    [monitor]
    serverip =
    nocrypt = 127.0.0.1
    aulow = 2
    hideclient_to = 15
    monlevel = 4
    appendchaninfo = 1

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = ufs913
    user = kathreinMartin
    pmt_mode = 0

    [webif]
    httpport = xxx
    httpuser = xxx
    httppwd = xxxx
    httphelplang = de
    httprefresh = 5
    httpallowed = 192.168.x.x-192.168.x.x

    [monitor]
    nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255
    appendchaninfo = 1

    oscam.server
    [reader]
    label = skyhd
    protocol = cccam
    device = 192.168.1.250,27500
    user = local
    password = xxxx
    #services = SkyGermanyMitHDPlus
    caid = 098C
    group = 1
    cccversion = 2.3.0
    cccmaxhops = 0
    blockemm-unknown = 1

    [reader]
    label = orf
    protocol = camd35
    device = 127.0.0.1,30003
    user = av
    password = av
    services = ORFmitAustriaSat
    emmcache = 1,3,2
    #caid= 0D05
    #detect = cd
    group=2
    audisabled = 1

    oscam.user
    [account]
    user = kathreinMartin
    group = 1,2
    uniq = 2
    au = skyhd
    keepalive = 1
    cccmaxhops = 2
    cccreshare = 1
    cccversion = 2.2.1
    caid = 098C
    ccckeepalive = 1

    oscam.dvbapi
    # dvbapi configuration
    S: PTI0 pmt_PTI0.tmp
    S: PTI1 pmt_PTI1.tmp
    S: PTI2 pmt_PTI2.tmp
    S: PTI3 pmt_PTI3.tmp
    S: PTI4 pmt_PTI4.tmp

    P: 098C 1
    P: 0d05


    I: 0

    Woran liegt es dass es beim Aufstarten des Clients so einen Fehler verursacht?

    Vielen Dank schonmal :)
     
    Zuletzt bearbeitet: 29. Mai 2013
    #3

Diese Seite empfehlen