1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk Problem mit Debian und IPC Oscam

Dieses Thema im Forum "CS Root & Vserver" wurde erstellt von Naomi01, 16. August 2012.

  1. Naomi01
    Offline

    Naomi01 Newbie

    Registriert:
    2. Juli 2012
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ich habe mir einen Linux Rechner aufgesetzt und IPC installiert nur will der Reader (Easymouse 2) nicht so richtig.

    Die Karte und der Easymouse 2 ist nicht Defekt da ich das ganze an einer Dreambox getestet habe und da funktioniert alles einwandfrei.

    Ich hab mir gedacht dann zieh ich alle Daten rüber und häng den Reader an nur es funktioniert trotzdem nicht

    Ich benutze eine V13 Karte

    Das ist die Fehlermeldung
    2012/08/15 20:50:36 0 s starting thread log_list_thread
    2012/08/15 20:50:36 0 s log_list_thread thread started
    2012/08/15 20:50:36 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build #6593 (i686-pc-linux)
    2012/08/15 20:50:36 0 s version=1.20-unstable_svn, build #6593, system=i686-pc-linux, nice=0
    2012/08/15 20:50:36 0 s client max. idle=120 sec, debug level=0
    2012/08/15 20:50:36 0 s max. logsize=2480 Kb, loghistorysize=4096 bytes
    2012/08/15 20:50:36 0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
    2012/08/15 20:50:36 0 s services reloaded: 0 services freed, 1 services loaded, rejected 0
    2012/08/15 20:50:36 0 s userdb reloaded: 2 accounts loaded, 0 expired, 0 disabled
    2012/08/15 20:50:36 0 s signal handling initialized (type=sysv)
    2012/08/15 20:50:36 0 s can't open file "/var/etc/oscam.srvid" (err=2 No such file or directory), no service-id's loaded
    2012/08/15 20:50:36 0 s can't open file "/var/etc/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2012/08/15 20:50:36 0 s can't open file "/var/etc/oscam.provid" (err=2 No such file or directory), no provids's loaded
    2012/08/15 20:50:36 0 s can't open file "/var/etc/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2012/08/15 20:50:36 0 s can't open whitelist file /var/etc/oscam.whitelist
    2012/08/15 20:50:36 0 s can't open cacheex-matcher file /var/etc/oscam.cacheex
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s monitor: disabled
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s camd35: disabled
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s cs378x: disabled
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s newcamd: initialized (fd=5, port=xxxxx, crypted)
    2012/08/15 20:50:36 0 s -> CAID: 1830 PROVID: 003411
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s cccam: initialized (fd=6, port=xxxxx, crypted)
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s pandora: disabled
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s csp: disabled
    2012/08/15 20:50:36 0 s Starting listener 0
    2012/08/15 20:50:36 0 s radegast: disabled
    2012/08/15 20:50:36 0 s starting thread http
    2012/08/15 20:50:36 0 s http thread started
    2012/08/15 20:50:36 0 s starting thread reader check
    2012/08/15 20:50:36 0 s reader check thread started
    2012/08/15 20:50:36 0 s starting thread check
    2012/08/15 20:50:36 8528610 h HTTP Server listening on port xxxxx
    2012/08/15 20:50:36 0 s check thread started
    2012/08/15 20:50:36 0 s creating thread for device /dev/ttyUSB0
    2012/08/15 20:50:36 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/08/15 20:50:36 0 s waiting for local card init
    2012/08/15 20:50:40 B72014E8 r reader v13 initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2012/08/15 20:50:40 B72014E8 r v13 card detected
    2012/08/15 20:50:45 B72014E8 r ATR: 01 01 00
    2012/08/15 20:50:45 B72014E8 r ERROR: Could not read reader->convention
    2012/08/15 20:50:45 B72014E8 r Error activating card.
    2012/08/15 20:50:54 B72014E8 r ATR: 01 02 6A 01
    2012/08/15 20:50:54 B72014E8 r ERROR: Could not read reader->convention
    2012/08/15 20:50:54 B72014E8 r Error activating card.
    2012/08/15 20:51:03 B72014E8 r ATR: 01 01 00
    2012/08/15 20:51:03 B72014E8 r ERROR: Could not read reader->convention
    2012/08/15 20:51:03 B72014E8 r Error activating card.
    2012/08/15 20:51:04 B72014E8 r card initializing error
    2012/08/15 20:51:04 0 s init for all local cards done
    2012/08/15 20:51:04 0 s anti cascading disabled
    2012/08/15 20:51:04 B7209490 c illegal username received
    2012/08/15 20:51:04 B720ACC8 c anonymous disconnected from ip
    2012/08/15 20:51:04 B7209490 c anonymous disconnected from ip
    2012/08/15 20:51:04 B720ACC8 c thread B7349B70 ended!
    2012/08/15 20:51:04 B7209490 c thread B7355B70 ended!
    2012/08/15 20:51:06 B720C500 c dyndns: resolved ip=xxxxxxxx
    2012/08/15 20:51:06 B720C500 c encrypted cccam-client ip granted (oscamV13, au=on (1 reader))

    2012/08/16 13:19:12 0 s waiting for local card init
    2012/08/16 13:19:12 B73011F0 r ERROR in IO_Serial_Read (errno=11 Resource temporarily unavailable)
    2012/08/16 13:19:12 B73011F0 r ERROR in IO_Serial_Read (errno=11 Resource temporarily unavailable)
    2012/08/16 13:19:13 B73011F0 r ERROR in IO_Serial_Read (errno=11 Resource temporarily unavailable)
    2012/08/16 13:19:13 B73011F0 r reader v13 initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2012/08/16 13:19:14 B73011F0 r v13 card detected
    2012/08/16 13:19:20 B73011F0 r ERROR in IO_Serial_Read (errno=11 Resource temporarily unavailable)
    2012/08/16 13:19:23 B73011F0 r ERROR in IO_Serial_Read (errno=11 Resource temporarily unavailable)
    2012/08/16 13:19:23 B73011F0 r ATR: ............................................
    2012/08/16 13:19:23 B73011F0 r ERROR: Could not read reader->convention
    2012/08/16 13:19:23 B73011F0 r Error activating card.

    oscam.conf

    [global]
    logfile = /tmp/oscam.log
    nice = -1

    [monitor]
    port = 988
    aulow = 120
    hideclient_to = 15
    monlevel = 4
    appendchaninfo = 1

    [newcamd]
    port = 34001@09C4:000000
    key = 0102030405060708091011121314
    keepalive = 1

    [cccam]
    port = meinport
    reshare = 0
    version = 2.1.4
    nodeid = 47CC8E97102814A4

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = dvbapi

    [webif]
    httpport = 1600
    httpuser = admin
    httppwd = oscam
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255

    oscam.user

    [account]
    user = oscamV13
    pwd = V13_4_oscam
    group = 1,2
    monlevel = 0
    services = skyde
    caid = 09C4
    keepalive = 1

    [account]
    user = client1
    pwd = client2
    group = 1
    hostname = meine Daten
    monlevel = 0
    au = v13
    caid = 09C4
    cccignorereshare = 0
    keepalive = 1

    [account]
    user = user1
    pwd = pass1
    group = 1
    monlevel = 2
    au = 1
    keepalive = 1

    oscam.server

    [reader]
    label = v13
    protocol = mouse
    device = /dev/ttyUSB0
    services = skyde
    caid = 09C4
    boxid = 12345678
    detect = cd
    mhz = 357
    cardmhz = 357
    ident = 09C4:000000
    group = 1
    emmcache = 1,3,2
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Online

    Kermit Guest

    AW: Problem mit Debian und IPC Oscam

    Hi,

    was ist das für eine System sprich was für eine CPU und was für einen Kernel hast du installiert?

    Grüße

    Kermit
     
    #2
  4. Naomi01
    Offline

    Naomi01 Newbie

    Registriert:
    2. Juli 2012
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Problem mit Debian und IPC Oscam

    Ich hab debian Netinstall genommen

    ist ein Nettop PC mit intel Atom D510 dual Core 1.66Ghz 2GB Ram 250GB HDD

    Kernel version 2.6.32.5
     
    #3
  5. Kermit
    Online

    Kermit Guest

    AW: Problem mit Debian und IPC Oscam

    Ich lasse dich mal in einen anderen Bereich verschieben. Evtl kann dir dort besser geholfen werden.
     
    #4
  6. Naomi01
    Offline

    Naomi01 Newbie

    Registriert:
    2. Juli 2012
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Problem mit Debian und IPC Oscam

    Ja Danke

    gibt es denn einen bestimmten Kernel den man braucht?
     
    #5
  7. aragorn
    Online

    aragorn Guest

    AW: Problem mit Debian und IPC Oscam

    Naomi01: erfahrungs mässig nutzen die meisten hier thin clients wie den Igel aber dort wird vom debian setup ein falscher kernel installiert. darauf bezog sich Kermit04´s anliegen.. aber das wird bei dir denk ich nicht der fall sein

    handelt es sich um eine easymouse2 also mit usb? nutzt du mehrere reader oder nur einen?
    steckt die karte auch wirklich richtig drin? hast du beim umstöpseln von der dream nur den reader raus gezogen oder auch die karte?
    hast du auch schon einen anderen usb port ausprobiert?
    auch schon im bios gewesen und "load optimal defaults" gemacht?

    poste mal bitte die ausgabe von "dmesg" in
    Code:
    
    was mich ein wenig irretiert ist das der ATR nicht vollständig und auch 2x anders ist. den letzten hast du leider unkenntlich gemacht das brauchst du aber nicht..
    
    
    wegen deinen configs: dir fehlt noch ein [account] für dvbapi.. allerdings wird dir [dvbapi] auf einem nettop pc nichts bringen das kann man nur für receiver nutzen.. und laut dem log versucht sich auch ein "illegal user" zu verbinden
     
    #6
  8. Naomi01
    Offline

    Naomi01 Newbie

    Registriert:
    2. Juli 2012
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Problem mit Debian und IPC Oscam

    Ja aber wie kann man einen falschen Kernel aufspielen das muss doch bei jeden Pc laufen oder nicht?

    Nein habe die Karte so gelassen auch wenn ich sie verändere geht nichts.

    Es werden 3 easymouse 2 in Einsatz kommen aber will mal eine ans laufen bringen.

    Das mit dem anonymous war ich selbst mit einen clienten da waren die daten nicht korrekt.

    Das Bios hab ich gleich am Anfang eingestellt.

    Code:
    4032504k
    [    7.548792] EXT3 FS on sda1, internal journal
    [    7.701356] loop: module loaded
    [    9.040711] fuse init (API version 7.13)
    [   11.789010] ATL1E 0000:01:00.0: irq 26 for MSI/MSI-X
    [   11.789165] ATL1E 0000:01:00.0: ATL1E: eth0 NIC Link is Up<1000 Mbps Full Dup                         lex>
    [   11.789487] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   11.789955] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [   16.088015] Bluetooth: Core ver 2.15
    [   16.088168] NET: Registered protocol family 31
    [   16.088174] Bluetooth: HCI device and connection manager initialized
    [   16.088181] Bluetooth: HCI socket layer initialized
    [   16.140342] Bluetooth: L2CAP ver 2.14
    [   16.140349] Bluetooth: L2CAP socket layer initialized
    [   16.156674] Bluetooth: RFCOMM TTY layer initialized
    [   16.156687] Bluetooth: RFCOMM socket layer initialized
    [   16.156692] Bluetooth: RFCOMM ver 1.11
    [   16.247473] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   16.247481] Bluetooth: BNEP filters: protocol multicast
    [   16.296758] Bridge firewalling registered
    [   16.422419] Bluetooth: SCO (Voice Link) ver 0.6
    [   16.422426] Bluetooth: SCO socket layer initialized
    [   17.344599] lp: driver loaded but no devices found
    [   17.572918] ppdev: user-space parallel port driver
    [   21.948008] eth0: no IPv6 routers present
    [   24.953560] usb 3-2: USB disconnect, address 2
    [   24.953566] usb 3-2.1: USB disconnect, address 3
    [   25.038469] usb 3-2.4: USB disconnect, address 4
    [   27.887438] CPU0 attaching NULL sched-domain.
    [   27.887451] CPU1 attaching NULL sched-domain.
    [   27.887457] CPU2 attaching NULL sched-domain.
    [   27.887464] CPU3 attaching NULL sched-domain.
    [   27.953660] CPU0 attaching sched-domain:
    [   27.953671]  domain 0: span 0,2 level SIBLING
    [   27.953679]   groups: group c280370c cpus 0 (cpu_power = 589) group c2a0370c                          cpus 2 (cpu_power = 589)
    [   27.953700]   domain 1: span 0,2 level MC
    [   27.953707]    groups: group c2803778 cpus 0,2 (cpu_power = 1178)
    [   27.953721]    domain 2: span 0-3 level CPU
    [   27.953727]     groups: group c28037e4 cpus 0,2 (cpu_power = 1178) group c290                         37e4 cpus 1,3 (cpu_power = 1178)
    [   27.953750] CPU1 attaching sched-domain:
    [   27.953756]  domain 0: span 1,3 level SIBLING
    [   27.953763]   groups: group c290370c cpus 1 (cpu_power = 589) group c2b0370c                          cpus 3 (cpu_power = 589)
    [   27.953781]   domain 1: span 1,3 level MC
    [   27.953787]    groups: group c2903778 cpus 1,3 (cpu_power = 1178)
    [   27.953801]    domain 2: span 0-3 level CPU
    [   27.953807]     groups: group c29037e4 cpus 1,3 (cpu_power = 1178) group c280                         37e4 cpus 0,2 (cpu_power = 1178)
    [   27.953827] CPU2 attaching sched-domain:
    [   27.953834]  domain 0: span 0,2 level SIBLING
    [   27.953841]   groups: group c2a0370c cpus 2 (cpu_power = 589) group c280370c                          cpus 0 (cpu_power = 589)
    [   27.953859]   domain 1: span 0,2 level MC
    [   27.953866]    groups: group c2803778 cpus 0,2 (cpu_power = 1178)
    [   27.953879]    domain 2: span 0-3 level CPU
    [   27.953885]     groups: group c28037e4 cpus 0,2 (cpu_power = 1178) group c290                         37e4 cpus 1,3 (cpu_power = 1178)
    [   27.953906] CPU3 attaching sched-domain:
    [   27.953912]  domain 0: span 1,3 level SIBLING
    [   27.953919]   groups: group c2b0370c cpus 3 (cpu_power = 589) group c290370c                          cpus 1 (cpu_power = 589)
    [   27.953937]   domain 1: span 1,3 level MC
    [   27.953943]    groups: group c2903778 cpus 1,3 (cpu_power = 1178)
    [   27.953956]    domain 2: span 0-3 level CPU
    [   27.953963]     groups: group c29037e4 cpus 1,3 (cpu_power = 1178) group c280                         37e4 cpus 0,2 (cpu_power = 1178)
    [   34.624048] usb 2-1: USB disconnect, address 2
    [  627.566032] [drm] Big FIFO is enabled
    [ 1791.436026] usb 3-1: new full speed USB device using uhci_hcd and address 5
    [ 1791.638995] usb 3-1: New USB device found, idVendor=0403, idProduct=6001
    [ 1791.639003] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 1791.639009] usb 3-1: Product: FT232R USB UART
    [ 1791.639014] usb 3-1: Manufacturer: FTDI
    [ 1791.639018] usb 3-1: SerialNumber: A400ZGZN
    [ 1791.639202] usb 3-1: configuration #1 chosen from 1 choice
    [ 1791.780071] usbcore: registered new interface driver usbserial
    [ 1791.780118] USB Serial support registered for generic
    [ 1791.780189] usbcore: registered new interface driver usbserial_generic
    [ 1791.780196] usbserial: USB Serial Driver core
    [ 1791.812029] USB Serial support registered for FTDI USB Serial Device
    [ 1791.812200] ftdi_sio 3-1:1.0: FTDI USB Serial Device converter detected
    [ 1791.812444] usb 3-1: Detected FT232RL
    [ 1791.812452] usb 3-1: Number of endpoints 2
    [ 1791.812459] usb 3-1: Endpoint 1 MaxPacketSize 64
    [ 1791.812466] usb 3-1: Endpoint 2 MaxPacketSize 64
    [ 1791.812472] usb 3-1: Setting MaxPacketSize 64
    [ 1791.814116] usb 3-1: FTDI USB Serial Device converter now attached to ttyUSB0
    [ 1791.814168] usbcore: registered new interface driver ftdi_sio
    [ 1791.814175] ftdi_sio: v1.5.0:USB FTDI Serial Converters Driver
    [ 1831.897301] [drm] Big FIFO is enabled
    [ 1831.897895] [drm] Big FIFO is enabled
    
     
    #7
  9. aragorn
    Online

    aragorn Guest

    AW: Problem mit Debian und IPC Oscam

    naja nicht jeder kernel harmuniert mit jeder hardware.. beim igel erkennt das debian setup den cpu falsch und installiert einen SMP kernel der aber für multi-core/cpu systeme gedacht ist.. ausserdem ist der 686 kernel für moderne hardware gedacht aber im igel ist ältere hardware verbaut also läuft es in der regel mit einem 486 kernel besser...

    bios einstellen und "load optimal defaults" ist ein unterschied ;)
    wirst du zum beispiel bluetooth überhaupt benutzen? sachen die du nicht brauchst wie auch seriel und parallel ports würde ich abschalten.. aber erst nachdem du "load optimal defaults" gemacht hast

    welche oscam build benutzt du eigentlich? precompiled (o version) oder selber kompiliert (o compile)?
    auch schon mit einer anderen probiert?
     
    #8
  10. Naomi01
    Offline

    Naomi01 Newbie

    Registriert:
    2. Juli 2012
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Problem mit Debian und IPC Oscam

    So hab es nun hinbekommen hab einfach noch 3mal Debian neu installiert und nun läuft es mal auf meinen 1. clienten nur ich hänge noch bei den anderen Clienten braucht man denn eigentlich die N Line oder gehts auch ohne?
     
    #9
  11. aragorn
    Online

    aragorn Guest

    AW: Problem mit Debian und IPC Oscam

    welche n lines? du hast hier bisher nichts von n lines erwähnt.. (meine glaskugel is defekt)
     
    #10
  12. Naomi01
    Offline

    Naomi01 Newbie

    Registriert:
    2. Juli 2012
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Problem mit Debian und IPC Oscam

    naja man braucht doch eine n line zum verbinden oder hab ich das in einer Anleitung falsch verstanden
     
    #11
  13. aragorn
    Online

    aragorn Guest

    AW: Problem mit Debian und IPC Oscam

    um was zu verbinden?
    bitte detailiertere posts
     
    #12
  14. Naomi01
    Offline

    Naomi01 Newbie

    Registriert:
    2. Juli 2012
    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: Problem mit Debian und IPC Oscam

    Sry für die späte Meldung

    Es hat funktioniert war nur ein Installationsfehler genau kann ich es aber nicht sagen wo der Fehler lag ich hab dann einfach nochmal alles neu gemacht.
     
    #13

Diese Seite empfehlen