1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

port forwarding will nicht

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von Hades2, 30. Juni 2010.

  1. Hades2
    Offline

    Hades2 Freak

    Registriert:
    1. Juni 2010
    Beiträge:
    226
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Hallo zusammen,

    bekomme leider langsam ne Krise. Hab mich schon totgesucht. Zwar hatten mehrere offensichtlich ähnliche Probleme, bei denen hat es dann aber wie von Geisterhand funktioniert. Bei mir nicht!

    Habe HD+Karte am Smargo an Fritzbox 7270v2 mit OSCAM. CS funktioniert lokal wunderbar. Einstellungen wie in der Anleitung von j___k

    Ich bekomm aber den Port 22117 nicht frei, obwohl ich das Video-Tutorial angesehen habe. Die Portweiterleitung habe ich in freetz gemacht. "Aktivieren"-Häkchen gemacht, Übernehmen geklickt, neugestartet. Der Vollständigkeit halber alle meine Freigaben:
    udp 0.0.0.0:5060 0.0.0.0:5060
    tcp 0.0.0.0:5500 192.168.178.111:5500 0 # UltraVNC
    tcp 0.0.0.0:22117 0.0.0.0:22117 0 # Oscam
    udp 0.0.0.0:22117 0.0.0.0:22117 0 # Oscam

    Bei canyouseeme kommt dennoch immer "connection refused".
    OSCAM läuft natürlich. Oscam-WebIF geht auch. Wie gesagt, lokal gehts (über port 22117). Allerdings sagt das Oscam-WebIF, wenn mein lokaler Receiver angeschlossen ist port 3072. Den freizugeben geht aber auch nicht. Auch eine weiterleitung von extern 85 zu intern 22117 geht nicht.

    Weiß jemand Rat?!

    Danke! Hades.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. mrwong
    Offline

    mrwong VIP

    Registriert:
    17. Januar 2009
    Beiträge:
    4.697
    Zustimmungen:
    2.306
    Punkte für Erfolge:
    113
    Ort:
    Frankenland
    AW: port forwarding will nicht

    versuchs doch mal mit der protfreigabe in fritz menü nicht freetz

    und poste erstmal deine oscam config damit man weiß welche port du überhaupt gewählt hast nicht das du noch dem internet dein webif oder sonstiges zur verfügung stellst !
     
    #2
  4. Hades2
    Offline

    Hades2 Freak

    Registriert:
    1. Juni 2010
    Beiträge:
    226
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: port forwarding will nicht

    Portfreigabe im fritz-menü geht nicht, weil man da ja keine Portfreigabe zur Fritzbox selbst machen kann.

    Die oscam.conf ist wie die hier:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    Hab ich einfach kopiert und nur die cccam- und newcamd-Bereiche rausgenommen, weil ich über camd35-Protokoll connecte.

    Wie gesagt: lokales cs funktioniert über port 22117. Ich kann nur keine Verbindung aus dem internet herstellen, weil ich den Port nicht aufbekomme.

    Gruß,

    Hades.
     
    #3
  5. mrwong
    Offline

    mrwong VIP

    Registriert:
    17. Januar 2009
    Beiträge:
    4.697
    Zustimmungen:
    2.306
    Punkte für Erfolge:
    113
    Ort:
    Frankenland
    AW: port forwarding will nicht

    also nimmst du den cs357

    gut dann passt dein port ja schonmal

    tcp 0.0.0.0:22117 0.0.0.0:22117 0 # Oscam
    udp 0.0.0.0:22117 0.0.0.0:22117 0 # Oscam

    ändere das mal in

    tcp 127.0.0.1:22117 127.0.0.1:22117 0 # Oscam
    udp 127.0.0.1:22117 127.0.0.1:22117 0 # Oscam


    normal müstest du auch in fritz menü an die fritz senden können ich bin nicht daheim deswegen kann ich kein screen machen

    aber du must im fritz menü in der freigabe anderen host wählen oder wie das heist dann kannst du dort ip eingeben an wen es gehen soll entweder trägst dann die 192.168.178.1 ein wenn dus so gelassen hast oder halt 127.0.0.1
     
    #4
    Hades2 gefällt das.
  6. Hades2
    Offline

    Hades2 Freak

    Registriert:
    1. Juni 2010
    Beiträge:
    226
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: port forwarding will nicht

    OK Danke. Werd das heute Abend mal ausprobieren.
     
    #5
  7. mrwong
    Offline

    mrwong VIP

    Registriert:
    17. Januar 2009
    Beiträge:
    4.697
    Zustimmungen:
    2.306
    Punkte für Erfolge:
    113
    Ort:
    Frankenland
    AW: port forwarding will nicht

    ja geb dann aber bitte bescheid obs geholfen hat das vielleicht jemand der das selbe problem hat das hier lesen kann ;) ich sage das vorallem bei neuen user denn die kommen bekommen geholfen und kommen dann nie wieder.
     
    #6
  8. Hades2
    Offline

    Hades2 Freak

    Registriert:
    1. Juni 2010
    Beiträge:
    226
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: port forwarding will nicht

    tcp 127.0.0.1:22117 127.0.0.1:22117 0 # Oscam
    udp 127.0.0.1:22117 127.0.0.1:22117 0 # Oscam

    geht leider nicht.

    Auch das
    tcp 0.0.0.0:22117 127.0.0.1:22117 0 # Oscam
    udp 0.0.0.0:22117 127.0.0.1:22117 0 # Oscam

    geht nicht.

    Auch das nicht:
    tcp 0.0.0.0:22117 192.168.178.1:22117 0 # Oscam
    udp 0.0.0.0:22117 192.168.178.1:22117 0 # Oscam


    Da kommt bei canyouseeme jedesmal sogar "no route ro host"
    also irgendwas muss es ja bewegt haben wegen des anderen Meldung bei canyouseeme.

    Noch Tips?

    Und: natürlich poste ich das Ergebnis wie ich es geschafft hab, sofern das jemals eintritt...
    mir gings ja genauso, dass ich die Probleme fand aber nich die Lösung.
     
    #7
  9. Mogelhieb
    Offline

    Mogelhieb Administrator Digital Eliteboard Team

    Registriert:
    29. November 2008
    Beiträge:
    12.055
    Zustimmungen:
    16.482
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Counselor
    Ort:
    Bayern
    AW: port forwarding will nicht

    Da steht ja nun jede Menge. Ich glaube, ich ahne woran es liegen könnte. Um sicher zu gehen, müsste ich tatsächlich noch mal Deine aktuellen, gerade verwendeten Konfigs sehen.
     
    #8
  10. mrwong
    Offline

    mrwong VIP

    Registriert:
    17. Januar 2009
    Beiträge:
    4.697
    Zustimmungen:
    2.306
    Punkte für Erfolge:
    113
    Ort:
    Frankenland
    AW: port forwarding will nicht

    naja gebe es doch mal im fitz menü ein ! und hast du nach den portfreigaben mal die box neugestartet ?

    so kannst du im fritz menü selbst an die fritz leiten ! bei port dein port rein und die ip deiner fritz

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #9
  11. Hades2
    Offline

    Hades2 Freak

    Registriert:
    1. Juni 2010
    Beiträge:
    226
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: port forwarding will nicht

    Das kenne ich schon. Habs aber vorsichtshalber nochmal ausprobiert (mit 192.168.178.1). Da kommt folgende Fehlermeldung:
    FEHLER: Die angegebene IP-Adresse wird von FRITZ!Box verwendet. Eine Portfreigabe auf diese IP-Adresse ist nicht zulässig.

    hier meine Configs:
    oscam.conf:
    [global]
    disablelog = 0
    disableuserfile = 0
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2000
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    netprio = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    logfile = /var/media/ftp/uStor01/logs/oscam.log
    maxlogsize = 100
    waitforcards = 1
    preferlocalcards = 1
    saveinithistory = 1

    [monitor]
    port = 988
    nocrypt = 192.168.0.0-192.168.255.255
    aulow = 120
    hideclient_to = 30
    monlevel = 1
    appendchaninfo = 0

    #[newcamd]
    #port = 34000@1830:003411
    #key = 0102030405060708091011121314
    #allowed = 0.0.0.0-255.255.255.255
    #keepalive = 0

    [cs357x]
    port = 22117
    suppresscmd08 = 1

    [webif]
    httpport = 83
    httpcss = /var/media/ftp/uStor01/cs/oscam//bluestyle.css
    httprefresh = 10
    httpallowed = 192.168.0.0-192.168.255.255
    httphideidleclients = 1
    httpreadonly = 0

    [anticasc]
    enabled = 0
    numusers = 0
    sampletime = 2
    samples = 10
    penalty = 0
    aclogfile = ./oscam_ac.log
    denysamples = 8
    fakedelay = 1000

    oscam.server:
    # oscam.server

    [reader]
    label = HDplus
    Protocol = mouse
    smargopatch = 1
    detect = CD
    device = /dev/ttyUSB0
    group = 1
    emmcache = 1,3,2
    n3_rsakey= ***
    n3_boxkey = *****
    CAID = 1830
    IDENT = 1830:000000,3411,8011

    #[reader]
    #label = sky
    #Protocol = mouse
    #detect = CD
    #device = /dev/ttyUSB0
    #boxid = 12345678
    #group = 1
    #emmcache = 1,3,2
    #CAID = 1702,1833,1834,09c4 #V13
    #CAID = 1702,1833,1830 #S02

    oscam.user:
    #oscam.user

    [account]
    user = ***********
    pwd = **********
    disabled = 0
    group = 1
    uniq = 0
    sleep = 0
    monlevel = 1
    au = Sky, HDplus
    #caid = 1830&FFFF
    keepalive = 0
    numusers = 0
    penalty = 0
    CAID = 09c4 , 1830 , 1702 , 1833
    betatunnel = 1833.FFFF:1702
     
    #10
  12. Mogelhieb
    Offline

    Mogelhieb Administrator Digital Eliteboard Team

    Registriert:
    29. November 2008
    Beiträge:
    12.055
    Zustimmungen:
    16.482
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Counselor
    Ort:
    Bayern
    AW: port forwarding will nicht

    Probiere mal das:

    Ab camd3.719
    # UDP Port(optional); Default - 20248
    UDP_PORT=20248

    Das ist notwendig, da die neuen camd3 ip und udp können. ohne den eintrag geht cs nicht.

    Also schreibe mal bei Dir:
    UDP_PORT=22117

    Den Port dann auch als UDP in der Freetz AVM- Firewall freigeben.
    Das andere Portforwarding Menü der Fritzbox ist gesperrt. Da kann man nix mehr verstellen bei den neueren Images.

    Warum es eigentlich Camd3 sein. Was gibts an Newcamd auszusetzen?
     
    #11
    Hades2 gefällt das.
  13. Hades2
    Offline

    Hades2 Freak

    Registriert:
    1. Juni 2010
    Beiträge:
    226
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: port forwarding will nicht

    werds gleich ausprobieren, aber damit kein Mißverständnis entsteht:
    - CS funktioniert bei mir lokal ohne Probleme, nur übers inet nicht
    - ich connecte von meinem UFS910 mit oscam über cs357 nicht mit camd3.
    (hab die gepinnte Anleitung von j___k befolgt und da stand halt, dass es mit oscam bessere Umschaltzeiten geben soll. und da es funzte hab ich mir keine Gedanken zu Alternativen gemacht. Auf meinem UFS hab ich auch nur camd3 und oscam.
    -ich möchte demnächst meine sky-Karte S02 mit dazu hängen. Die hat einzeln auch schon funktioniert.

    Gruß,

    Hades.

    UPDATE:
    Also bei canyouseeme kommt immer noch "connection refused"

    UPDATE:
    was bedeutet bei canyouseeme eigentlich "connection refused" im Gegensatz zu "no route to host".
    Ersteres kommt nämlich wenn ich den port freigebe, letzteres wenn nicht.
    Kann im Moment nicht testen, ob tatsächlich kein connect zu Receiver möglich ist. Hier wurde aber mehrfach erwähnt, dass man gar nicht weiterprobieren braucht, wenn man bei canyouseeme keinen offenen port sieht.
    noch Tips?
     
    Zuletzt bearbeitet: 1. Juli 2010
    #12
  14. Hades2
    Offline

    Hades2 Freak

    Registriert:
    1. Juni 2010
    Beiträge:
    226
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    AW: port forwarding will nicht

    Jetzt geht's
    lag scheinbar wirklich an dem UDP-Port.
    zwar kommt bei canyouseeme immer noch "connection refused" aber er verbindet trotzdem.

    Danke!!!!
     
    #13
    Mogelhieb gefällt das.

Diese Seite empfehlen