1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst override.conf - deaktivieren aller CAIDs?

Dieses Thema im Forum "CS VDR-SC" wurde erstellt von Wickie1, 26. April 2012.

  1. Wickie1
    Offline

    Wickie1 Ist oft hier

    Registriert:
    22. September 2011
    Beiträge:
    142
    Zustimmungen:
    18
    Punkte für Erfolge:
    18
    Guten Tag,

    ich hab ein Problem mit meinem sc-Plugin (denk ich jedenfalls).

    Konfiguration:
    Hardware: Zotac IONITX U-E (Motherboard) mit TeVii S470 (TV-Karte), Netz über W-Lan
    System: Gentoo mit vdr-1.7.25 (Backend) und XBMC (Frontend)

    Problem:
    Ich verbinde ich zu einem Cardsharing-Server, um Sky zu empfangen. Die Umschaltezeiten bei den Sky-Kanälen sind dabei unerträglich lang, bevor die Sender hell werden. Manchmal dauert das bis zu 2 min. Sky SD funktioniert aber soweit.

    Bei Sky HD kommt noch das Problem hinzu, dass der Puffer alle paar Sekunden leer läuft. Als Folge davon setzt das Bild alle 4-5, manchmal auch 10 Sekunden aus. Dann krieg ich die Meldung "XVDR-Verbindung verloren" -> "Verbindung wieder hergestellt.". Dann geht's wieder für ein paar Sekunden, bevor das Theater wieder losgeht. Ich hab bisher keine Ahnung, an welcher Stelle genau ich das Problem zu suchen hab. Freie FullHD-Sender (Servus TV) funktionieren ohne Aussetzer, Sky SD klappt ebenfalls.

    Cardsharing-Protokoll ist Newcamd.

    In der Logdatei find ich noch folgende Meldungen:
    Code:
    localhost vdr: [4965] [general.error] too many CAIDs. You should ignore some CAIDs.
    Kann man in der override.conf irgendwie alle CAIDs per default erst mal sperren und nur bestimmte CAIDs anschließend wieder freischalten?

    In der Readme steht dazu:
    Code:
    11 ; In general every entry has a validity range, specified by caid/source/freq or
           12 ; source/freq. The validity range is enclosed with {} brakets. Some specifiers
           13 ; may be obmited, but you cannot omit the ':' delimiters.
           14 ;
           15 ; format:
           16 ; {caid[-caid]:[src[-src]]:[freq[-freq]]}
           17 ; {src[-src]:[freq[-freq]]}
           18 ;
           19 ; examples:
           20 ; matches caid 1815-1830 on sat 19.2E. Freqency is empty, so match all.
           21 ; {1815-1830:S19.2E:}
           22 ; same, but only matches on one frequency
           23 ; {1815-1830:S19.2E:12973}
           24 ; matches a lot of NA sats, all frequencies
           25 ; {S61.5W-S148W:}
           26 ; matches a single caid on a single sat
           27 ; {1801:S28.5E:}
           28 ; matches a frequency range on a sat
           29 ; {S13W:10500-11674}
           30 ; matches a caid on everything
     31 ; {1234::}
    Leider krieg ich da immer nur einen Fehler, wenn ich versuche, da was einzustellen. Hat das jemand mal geschafft?
     
    Zuletzt bearbeitet: 27. April 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. tecfreak
    Offline

    tecfreak Hacker

    Registriert:
    13. September 2010
    Beiträge:
    418
    Zustimmungen:
    128
    Punkte für Erfolge:
    43
    Am besten wäre es, wenn du das Plugin einfach neu baust und vorher im Makefile die Variable "MAXCAID" auf 64 setzt.

    Wegen der Umschaltzeiten:

    1. Im Ordner /usr/lib/vdr/plugins
    alle sc-plugin-plugins verschieben/löschen bis auf
    libsc-cardclient-30.so & libsc-nagra-30.so

    2. in der override.conf für skyHD nen betatunnel aktivieren und caids priorisieren
    ecmprio:{S19.2E:}1702:1833
    tunnel:{1833:S19.2E:}1702:nagra-beta

    3. Im osd in den plugin-settings den ca-cache aktivieren.


    Gruß
    tec
     
    #2
  4. Wickie1
    Offline

    Wickie1 Ist oft hier

    Registriert:
    22. September 2011
    Beiträge:
    142
    Zustimmungen:
    18
    Punkte für Erfolge:
    18
    Wow, vielen Dank.

    Werd ich morgen oder am Wochenende mal ausgiebig testen und berichten. :emoticon-0167-beer:
     
    #3
  5. Wickie1
    Offline

    Wickie1 Ist oft hier

    Registriert:
    22. September 2011
    Beiträge:
    142
    Zustimmungen:
    18
    Punkte für Erfolge:
    18
    Noch mal herzlichen Dank. Funktioniert perfekt.

    Update:
    Den Tunnel konnte ich wieder rausnehmen, da mir der Cardsharing-Server auch die entsprechenden Ports für HD liefert. Das Entscheidende war der ecmprio-Eintrag.
     
    Zuletzt bearbeitet: 29. April 2012
    #4
  6. snIP3r
    Offline

    snIP3r Newbie

    Registriert:
    14. November 2011
    Beiträge:
    6
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    gleiches problem - leider bei mir nicht geloest

    hi zusammen!
    ich klinke mich hier mal ein, auch wenn der thread schon geloest ist. habe das gleiche problem mit den zu vielen caids nur bei mir brachte die erwaehnte loesung mit dem ecmprio nichts. vllt gibts ja noch ne andere moeglichkeit???
    hier mal meine config:
    basissystem: gentoo 3.2.12-gentoo mit 2x tt-budget s2-1600
    vdr version: 1.7.25 aus dem vdr-devel overlay
    vdr-sc: 0.9.3.20111122 aus dem vdr-devel overlay
    es funktioniert hier alles wie es soll, auch das sc plugin, nur die meldung wird im log angezeigt.

    fuer vorschlaege, wie ich das problem loesen koennte, waer ich dankbar.
    greets
    snIP3r
     
    #5
  7. tecfreak
    Offline

    tecfreak Hacker

    Registriert:
    13. September 2010
    Beiträge:
    418
    Zustimmungen:
    128
    Punkte für Erfolge:
    43
    Bau das plugin einfach neu.
     
    #6
  8. snIP3r
    Offline

    snIP3r Newbie

    Registriert:
    14. November 2011
    Beiträge:
    6
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    hmmm, hab ich zwar noch nie gemacht, n ebuild bzw. dessen quellen veraendert, aber ich kanns ja mal versuchen...
     
    #7
  9. Wickie1
    Offline

    Wickie1 Ist oft hier

    Registriert:
    22. September 2011
    Beiträge:
    142
    Zustimmungen:
    18
    Punkte für Erfolge:
    18
    Ich hab's auch versucht, MAXCAID in sämtliche Makefiles reinzuschreiben, die ich so gefunden hab - ebenso vorm Compilieren in die Konsole per export. Hat bei mir nichts gebracht. Trotzdem mal 'ne kleine Anleitung speziell für Gentoo. vdr-sc liegt bei mir im vdr-Overlay. Bei mir: /usr/portage/local/layman/vdr-devel/media-plugins/vdr-sc:

    1. Entpacken (Portage-Verzeichnis):
    Code:
    cd /usr/portage/local/layman/vdr-devel/media-plugins/vdr-sc
    ebuild vdr-sc-0.9.3.20111122.ebuild unpack
    2. Editieren (andere Konsole):
    Code:
    cd /var/tmp/portage/media-plugins/vdr-sc/......
    vim ....
    3. Bauen, installieren, mergen (Portage-Verzeichnis):
    Code:
    ebuild vdr-sc-0.9.3.20111122.ebuild compile
    ebuild vdr-sc-0.9.3.20111122.ebuild install
    ebuild vdr-sc-0.9.3.20111122.ebuild qmerge
    Anschließend kannst du die Daten in /var/tmp/portage löschen.

    Nochmal zu den MAXCAIDs:
    Du solltest dafür den Debug-Modus des sc-Plugins aktivieren.

    1. als vdr-Frontend Xineliboutput starten
    2. 9 Plugins
    3. 4 sc
    4. Meldungsprotokollierung
    5. Meldungen im Syslog: ja


    In /var/log/messages solltest du dann beim Start des vdr eine Message wie diese finden:
    Code:
    May  9 21:02:57 localhost vdr: [17182] [general.error] too many CAIDs. You should ignore some CAIDs.
    May  9 21:02:57 localhost vdr: [17182] [core.ci] card 0/0, slot 0 (v= 1) caids: 09c4 1833 1702 0d05 0d95 0100 098c 
    1817 0500 1837 1818 1819 1830 0624 0d03 0d70
    Alle CAIDs, die du nicht brauchst, schreibst du in die Ignore-Zeile der /etc/vdr/plugins/sc/override.conf:
    Code:
    ignore:{*}0603:0604:0608:0622:0624:0626:0628:0630:0648:0664:0666:0668:06c9:0919:091F:0929:093B:09CD:1722:1801:1802:
    1810:1813:1834:1836:183D:1843:1861:1880:09C7:090F:091F:09AC:09AF:098E:0B01:0BAA:0D00:0D22:4AE1:0d95:098c:09c0:d03:0d70:
    0d96:0e48:1811:1817:1837:1818:1819:01860:1863
    Ich hab's so ausführlich gepostet, weil ich mir auch jede Kleinigkeit einzeln erst mühsam zusammensuchen musste. Falls noch was unklar ist, frag noch mal nach. Viel Erfolg!
     
    #8
  10. snIP3r
    Offline

    snIP3r Newbie

    Registriert:
    14. November 2011
    Beiträge:
    6
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    also, es scheint, als haette die ignore zeile das problem geloest. jedenfalls sind seit dieser aenderung die meldungen im log weg.
     
    #9

Diese Seite empfehlen