1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSCam zeigt falsche CAID bei Austriasat/ORF

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von mutzel6, 19. November 2012.

  1. mutzel6
    Offline

    mutzel6 Ist gelegentlich hier

    Registriert:
    23. Mai 2009
    Beiträge:
    59
    Zustimmungen:
    10
    Punkte für Erfolge:
    8
    Beruf:
    IT
    Ort:
    Osten
    Hallo,

    ich habe einen Netgear 3500L Router als Cardserver mit 2 mal EasyMouse2 (Sky V13 09C4, weiße HD+ 1830).
    Dazu einige Clients mit unterschiedlichen Systemen (Opticum 9600, Edision Pingulux, DBox2 ...)
    Der CS-Betrieb über die Karten funktionierte einwandfrei und stabil.

    Nun wollte ich die ORF mit Keyfile und Camd3 ebenfalls über OSCam einbinden. Ich hab dazu einen Camd3-Reader eingetragen, den Camd3-Server konfiguriert und alles funktioniert soweit, dass sich OSCam mit Camd3 verbindet (Camd3 läuft auch).

    Wenn ein Client nun eine Anfrage nach ORF sendet, erscheint diese immer mit der CAID 09C4 im OSCam, nicht mit der richtigen CAID 0D05. Entschlüsselt wird so natürlich nix. Die Anfrage nach 09C4:32CA (z.B.) kommt genau so auch so bei Camd3 an:
    19.11.2012 17:22:59 camd3: CMD 00 -> 09C4:000000:32CA:0012 from 192.168.6.6 ( oscam )

    Ich hab in den Clienten schon eine oscam.dvbapi und eine cccam.prio verpasst, mit der CAID 0D05. Hilft nichts. Testweise habe ich im Pingulux (dort läuft ein OSCam-Client) ebenfalls den Camd3-Reader eingetragen und die Anfrage kommt dann vollkommen richtig direkt beim Camd3-Server raus und wird beantwortet:
    19.11.2012 17:40:57 camd3: CMD 00 -> 0D05:000004:32C9:0001 0.004s from 192.168.6.53 ( oscam ) decoded on emu

    So, nun ist entweder mein OSCam auf dem Server nicht richtig konfiguriert. Oder mein OSCam hat einen "Fehler".
    Ich habe OSCam selbst kompiliert, weil ich ein paar Besonderheiten brauche (Static, SSH, kein LibUSB usw.). Ein fertiges OSCam-Binary würde mir also nichts nützen - ich könnte das nur mal vorrübergehend testen, wenn's sein muss.

    Vielleicht kann mir aber jemand sofort aus dem Stehgreif sagen, wo das komische Verhalten herrührt. Meine Configs kann ich posten bei Bedarf. Ich hab für die lokalen Reader die CAID's 09C4 bzw. 1830 eingetragen und die Services aus der oscam.services (sky, hdplus), den Camd3-Reader hatte ich mit oder ohne CAID bzw. mit oder ohne Services probiert. Bleibt aber gleich. Evtl. liegt es aber an einem Eintrag in der oscam.conf in der cccam-Sektion?
    Muss dort forward_origin_card oder für reshare etwas eingetragen werden?

    Ach so, ich hatte OSCam auch mittlerweile mit allen verfügbaren Readern und Protokollen kompiliert. Meine oscam.version sieht jetzt so aus:

    Unix starttime: 1353351468
    Starttime: 19.11.2012 19:57:48
    Version: 1.20-unstable_mutzel6_svn Rev. 7895
    Max PID: unlimited

    Active modules:
    Web interface support: yes
    Touch interface support: no
    SSL support: yes
    DVB API support: no
    Anti-cascading support: yes
    Irdeto guessing: yes
    Debug mode: yes
    Monitor: yes
    Loadbalancing support: no
    LCD support: no
    LED support: no
    IPv6 support: no
    Cache exchange support: yes
    camd 3.3x: yes
    camd 3.5 UDP: yes
    camd 3.5 TCP: yes
    newcamd: yes
    CCcam: yes
    CCcam share: yes
    Pandora: yes
    gbox: yes
    radegast: yes
    serial: yes
    constant CW: yes
    Cardreader: yes
    Nagra: yes
    Irdeto: yes
    Conax: yes
    Cryptoworks: yes
    Seca: yes
    Viaccess: yes
    NDS Videoguard: yes
    DRE Crypt: yes
    TONGFANG: yes
    Bulcrypt: yes
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. MegaV0lt
    Offline

    MegaV0lt Hacker

    Registriert:
    24. April 2011
    Beiträge:
    352
    Zustimmungen:
    80
    Punkte für Erfolge:
    28
    Geschlecht:
    männlich
    Ort:
    Neuland
    AW: OSCam zeigt falsche CAID bei Austriasat/ORF

    So viel ich weiß, sind das verbogene Anfragen von diversen Recievern, die kein O CCCam haben. Naromalerweise kommen die mit der Zeit auch die richtigen Anfragen. Es liegt auf jeden Fall am Client!
     
    #2
  4. mutzel6
    Offline

    mutzel6 Ist gelegentlich hier

    Registriert:
    23. Mai 2009
    Beiträge:
    59
    Zustimmungen:
    10
    Punkte für Erfolge:
    8
    Beruf:
    IT
    Ort:
    Osten
    Dachte ich auch erst. Im Pingulux-OSCam hatte ich dann den Camd3-Reader direkt angegeben und sofort wurde ORF hell.
    Aber, hm, natürlich kann es dann noch am CCCam im Pingulux-OSCam liegen. Ja, könnte sein. Werde mal auf meinem OSCam-Server noch [cs357] eintragen und dorthin mit dem OSCam-Client connecten.
    Ich melde mich mit dem Ergebnis.

    Wenn ich zum OSCam-Server mit dem OSCam-Client mittels cs357x/Camd3-Reader connecte, wird die korrekte CAID angefordert.
    ... o.k., verwirrt mich zwar irgendwie, aber damit muss ich wohl leben.
     
    Zuletzt von einem Moderator bearbeitet: 21. November 2012
    #3

Diese Seite empfehlen