1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam verliert Cardreader

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von germankid, 22. Dezember 2013.

  1. germankid
    Offline

    germankid Ist gelegentlich hier

    Registriert:
    19. November 2011
    Beiträge:
    77
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    Moin Moin,

    ich habe folgendes Problem:
    Seitdem ich meinen Cardserver vor zwei Tagen in den Keller gepackt habe, verliert Oscam nach ein paar Stunden die Cardreader, welche über den aktiven USB Hub angeschlossen sind. Ich habe testweise vier Reader mal direkt angeschlossen und diese laufen problemlos weiter.

    Zur Hardware:
    - Fujitsu Siemens Futro S400
    - Aktiver 10 Port USB2 Hub
    - 7x Smartmouse 2
    - 1x Progbee
    - Debian Webserver (ohne GUI)
    - Oscam 1.20 r9136

    Fehlermeldung:

    2013/12/22 13:50:44 84AA5C0 r reader2_mtv [mouse] ERROR: IO_Serial_GetStatus: ioctl(TIOCMGET): Input/output error
    2013/12/22 13:50:44 84AA5C0 r reader2_mtv [mouse] Error getting card status.
    2013/12/22 13:50:44 84BBFA8 r reader3_orf [mouse] ERROR: IO_Serial_GetStatus: ioctl(TIOCMGET): Input/output error
    2013/12/22 13:50:44 84BBFA8 r reader3_orf [mouse] Error getting card status.

    Was ich bisher versucht habe:
    - neueste Oscam Version compiled
    - anderen, aktiven USB2 Hub angeschlossen
    - Debian Pakete und IPC aktualisiert

    Ich habe keine Ahnung, woran es liegt.
    Zuerst dachte ich an einen defekten Hub aber da der zweite auch nicht funktioniert....
    Die drei direkt angeschlossenen Smartmouse und der direkt angeschlossene Progbee (zieht den Strom über USB) funktionieren reibungslos....
    Man muss nicht einmal Oscam direkt neu starten...
    Startet man die einzelnen Reader neu, werden die Karten auch direkt wieder erkannt :emoticon-0127-lipss

    P.S.: Einen König Hub habe ich mir zur Vorsicht schon bestellt....
     
    Zuletzt bearbeitet: 23. Dezember 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. Tengri3108
    Offline

    Tengri3108 Meister

    Registriert:
    19. Juni 2011
    Beiträge:
    989
    Zustimmungen:
    235
    Punkte für Erfolge:
    43
    Beruf:
    Elektro Meister
    Ort:
    Nordsee Küste
    AW: Oscam verliert Cardreader

    Hi

    Hast du schon mal versucht die Reader fest zu verlinken geht ja über IPC ganz einfach.

    Gruß Ralf

    Eine Frage hab ich noch warum kauft ihr noch die smargos? Das ist doch nur noch teurer Schrott Apollo Reader und easymouse oder omnikey sind doch viel einfacher im Handling
     
    #2
  4. germankid
    Offline

    germankid Ist gelegentlich hier

    Registriert:
    19. November 2011
    Beiträge:
    77
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Oscam verliert Cardreader

    Hi,

    Die Reader sind fest verlinkt ;)
     
    #3
  5. Tengri3108
    Offline

    Tengri3108 Meister

    Registriert:
    19. Juni 2011
    Beiträge:
    989
    Zustimmungen:
    235
    Punkte für Erfolge:
    43
    Beruf:
    Elektro Meister
    Ort:
    Nordsee Küste
    AW: Oscam verliert Cardreader

    Hi

    Dann poste mal deine conf.

    Gruß Ralf
     
    #4
  6. germankid
    Offline

    germankid Ist gelegentlich hier

    Registriert:
    19. November 2011
    Beiträge:
    77
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Oscam verliert Cardreader

    oscam.server

    [reader]
    label = reader1_sky.de
    protocol = mouse
    device = /dev/reader1
    services = sky_de,sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,!srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 1702
    boxkey = 1122334455667788
    ecmwhitelist = 1702:93
    detect = cd
    mhz = 600
    cardmhz = 600
    ident = 1702:000000
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1

    [reader]
    label = reader2_mtv
    protocol = mouse
    device = /dev/reader2
    services = !sky_de,!sky_de_xtra_feeds,mtv,!hdplus,!orf_irdeto,!srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 0B00
    detect = cd
    mhz = 368
    cardmhz = 368
    ident = 0B00:000000
    group = 2
    emmcache = 1,1,2
    saveemm-unknown = 1
    saveemm-u = 1
    saveemm-s = 1
    saveemm-g = 1
    lb_weight = 500

    [reader]
    label = reader3_orf
    protocol = mouse
    device = /dev/reader3
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,orf_irdeto,!srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 0648
    boxkey =
    rsakey =
    force_irdeto = 1
    detect = cd
    mhz = 600
    cardmhz = 600
    ident = 0648:000000,000003,000002
    group = 3
    emmcache = 1,3,2
    saveemm-unknown = 1
    saveemm-u = 1
    saveemm-s = 1
    saveemm-g = 1
    deprecated = 1

    [reader]
    label = reader4_srf
    protocol = mouse
    device = /dev/reader4
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 0500
    detect = cd
    ident = 0500:023800
    group = 4
    emmcache = 1,3,2

    [reader]
    label = reader5_tivusat
    protocol = mouse
    device = /dev/reader5
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,!srg_2.6,tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 183D
    boxkey =
    rsakey =
    detect = cd
    ident = 183D:005411,000000
    group = 5
    emmcache = 1,3,2
    auprovid = 005411

    [reader]
    label = reader5_canaldigitaal
    description = CanalDigitaal
    enable = 0
    protocol = mouse
    device = /dev/reader5
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,!srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 0100
    ecmwhitelist = 0100@00006A:64
    detect = cd
    mhz = 600
    group = 5
    emmcache = 1,1,15
    blockemm-unknown = 1
    dropbadcws = 1
    auprovid = 00006A
    ratelimitecm = 4
    ratelimittime = 0
    srvidholdtime = 0

    [reader]
    label = reader6_sky.uk
    protocol = mouse
    device = /dev/reader6
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,!srg_2.6,!tivusat,!tntsat,sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    cacheex = 1
    caid = 0963
    boxid = 01234567
    detect = cd
    ident = 0963:000000
    group = 6
    emmcache = 1,3,2
    saveemm-unknown = 1
    saveemm-u = 1
    saveemm-s = 1
    saveemm-g = 1
    lb_weight = 101
    dropbadcws = 1

    [reader]
    label = reader7_tnk
    enable = 0
    protocol = mouse
    device = /dev/reader7
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,!srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 0B00
    detect = cd
    ident = 0B00:000000
    group = 7
    emmcache = 1,3,2
    saveemm-unknown = 1
    saveemm-u = 1
    saveemm-s = 1
    saveemm-g = 1

    [reader]
    label = reader8_tntsat
    protocol = mouse
    device = /dev/reader8
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,!srg_2.6,!tivusat,tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 0500
    detect = cd
    mhz = 600
    ident = 0500:030B00
    aeskeys =
    group = 8
    emmcache = 1,1,2
    blockemm-unknown = 1
    blockemm-u = 1
    blockemm-s = 1
    blockemm-g = 1

    [reader]
    label = reader9_progbee_hd+
    protocol = mouse
    device = /dev/ttyS0
    services = !sky_de,!sky_de_xtra_feeds,!mtv,hdplus,!orf_irdeto,!srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,!austriasat_emu,!austriasat_emu_mtv,!skylink
    caid = 1830
    boxkey =
    rsakey =
    detect = cd
    ident = 1830:000000,003411,008011
    group = 9
    emmcache = 1,3,2

    [reader]
    label = reader10_camd3emu
    protocol = camd35
    device = 127.0.0.1,20248
    user = oscam
    password = oscam
    services = !sky_de,!sky_de_xtra_feeds,!mtv,!hdplus,!orf_irdeto,!srg_2.6,!tivusat,!tntsat,!sky_uk_freesat,!tnk_bez_oplat,austriasat_emu,austriasat_emu_mtv,skylink
    caid = 0D05,0D03
    group = 10
    cccreshare = 2
    ccchop = 2

    Das sollte reichen, da es ja nur ein Problem mit den Readern gibt.
    Wie gesagt: Ich habe nur den Standort des Servers verändert.... An der Config wurde nichts geändert - die läuft seit Monaten tadellos (ausgenommen aktualisierte services)
     
    #5
  7. Tengri3108
    Offline

    Tengri3108 Meister

    Registriert:
    19. Juni 2011
    Beiträge:
    989
    Zustimmungen:
    235
    Punkte für Erfolge:
    43
    Beruf:
    Elektro Meister
    Ort:
    Nordsee Küste
    AW: Oscam verliert Cardreader

    Hi

    Ich würde nur mal zum testen dien Server an den alten Platz stellen und einen anderen USB Port nehmen für den Hub. Bei mir liefen die smargos nur mit smargopatch in den Server Einstellungen. Habe aber jetzt auf omni umgestellt läuft seit Wochen ohne Probleme .

    Gruß Ralf
     
    #6
  8. germankid
    Offline

    germankid Ist gelegentlich hier

    Registriert:
    19. November 2011
    Beiträge:
    77
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    AW: Oscam verliert Cardreader

    Hi Ralf,

    Smargos benutze ich gar nicht...
    Ich habe 8x den Easymouse 2 im Gehäuse und 1x den Progbee mit der weißen HD+ Karte...
    Den Server kann ich leider nicht an den alten Platz stellen, da ich gerade die ganze Etage durchrenoviere :)
    Das mit dem USB Port ist noch eine Möglichkeit.... Ich werde es gleich mal testen...
     
    #7
  9. Tengri3108
    Offline

    Tengri3108 Meister

    Registriert:
    19. Juni 2011
    Beiträge:
    989
    Zustimmungen:
    235
    Punkte für Erfolge:
    43
    Beruf:
    Elektro Meister
    Ort:
    Nordsee Küste
    AW: Oscam verliert Cardreader

    Hi

    Alles klar mein Fehler dachte du hast smargos mit der easymousev bist du gut aufgestellt das einzige was ich bei dir noch sehe sind deine Emm Einstellungen ich habe bei mir in den Server Einstellungen nur 1,1,2 stehen und ich arbeite nur mit positiven Services in den readern.

    Gruß Ralf
     
    #8
  10. germankid
    Offline

    germankid Ist gelegentlich hier

    Registriert:
    19. November 2011
    Beiträge:
    77
    Zustimmungen:
    8
    Punkte für Erfolge:
    0
    Ich werde mir die EMM Einstellungen mal anschauen...
    Erstmal muss ich die Reader zum laufen bringen :wacko1:

    Ich bin sogar schon am überlegen, ob ich Debian neu aufsetze....
    Die aktuelle Installation ist 1 Jahr alt....

    Merkwürdig...
    Ich habe den Futro heute komplett neu installiert und bisher läuft alles wie gewohnt....

    Damit sollte das Problem gelöst sein ;)
     
    Zuletzt von einem Moderator bearbeitet: 23. Dezember 2013
    #9

Diese Seite empfehlen