1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

oscam und 2x09c7

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Saufsoldat, 3. Juli 2013.

  1. Saufsoldat
    Offline

    Saufsoldat Newbie

    Registriert:
    20. November 2009
    Beiträge:
    29
    Zustimmungen:
    3
    Punkte für Erfolge:
    3
    Mahlzeit.

    Habe Oscam mit CCcam auf nem Debian Server laufen.Jetzt habe ich ein merkwürdiges Problem. habe 2x die 09c7 von KD.
    Sie sind exakt gleich konfiguriert. aber im oscam web if wird nur eine karte erkannt. Die andere wird mir kurz im Log angezeigt und dann kommt 'error activating card'
    Im KD receiver läuft die Karte einwandfrei, ist also aktiviert.

    Hier ein Auszug aus dem Log:
    2013/07/03 17:01:40 B75022E8 r KDHome2 [smargo] Reader initialized (device=/dev/ttyUSB4, detect=cd, mhz=500, cardmhz=357)
    2013/07/03 17:01:41 B75022E8 r KDHome2 [smargo] card detected
    2013/07/03 17:01:48 B75022E8 r KDHome2 [smargo] Error activating card.

    oscam.server
    [reader]
    Label = KDHome
    protocol = smargo
    device = /dev/ttyUSB1
    Group = 1
    EmmCache = 1,3,2
    boxid = 12345678
    ident = 09C7:000000
    caid = 09C7
    detect = cd
    mhz = 500
    cardmhz = 357
    cccversion = 2.1.4

    [reader]
    label = sky
    protocol = cccam
    device = 192.168.0.103,1450
    user = oscam
    password = oscamreader
    group = 2
    services = sky
    detect = none
    CAID = 1722,1834
    cccversion = 2.1.4
    cccbuild = 3165

    [reader]
    Label = KDHome2
    protocol = smargo
    device = /dev/ttyUSB4
    Group = 3
    EmmCache = 1,3,2
    boxid = 12345678
    ident = 09C7:000000
    caid = 09C7
    detect = cd
    mhz = 500
    cardmhz = 357


    Jemand ne Idee, wie es sein kann, dass die Karten genau gleich konfiguriert sind, die Gruppen richtig angepasst sind, aber trotzdem eine nicht erkannt wird?
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: oscam und 2x09c7

    Hi,

    sind die Smargos beide mit der gleichen Firmware? Ändere bitte auch das Protokoll in
    Code:
    protocol = mouse
    oder versuche das Smartreader Protocol.

    Grüße
    Bombadil
     
    #2
  4. leyla38
    Offline

    leyla38 Stamm User

    Registriert:
    3. Oktober 2008
    Beiträge:
    1.177
    Zustimmungen:
    505
    Punkte für Erfolge:
    113
    Beruf:
    CS
    Ort:
    Hinter dem Mond...
    AW: oscam und 2x09c7

    Hi bombadil,
    Die smargos werden mit dem protocol smartreader angesprochen und nicht mouse!

    Code:
    protocol                      = smartreader
    device                        = Serial:Reader [COLOR=#ffa07a]xxxxx[/COLOR]
    
    serial der reader xxx ergänzen...
     
    #3
  5. joopastron
    Offline

    joopastron Administrator Digital Eliteboard Team

    Registriert:
    3. März 2011
    Beiträge:
    19.334
    Zustimmungen:
    12.423
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Immer bei der Sache
    AW: oscam und 2x09c7

    Hi,

    es ist auch möglich mit mouse Protokoll !


    Sent from my iPhone using Tapatalk
     
    #4
  6. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: oscam und 2x09c7

    Hi,

    laut deiner im Post eingestellten oscam.server steht dort device = smargo. Hast du auf deinem System kein libusb zur Verfügung? Beim von dir eingestellten Protokoll smargo benutzt du das Smartreader Protokoll mit dem Nachteil, den Smargo nicht seriell ansprechen zu können.

    Denke dabei bitte mal über eine feste Verlinkung über UDEV nach.

    Grüße
    Bombadil
     
    #5
  7. leyla38
    Offline

    leyla38 Stamm User

    Registriert:
    3. Oktober 2008
    Beiträge:
    1.177
    Zustimmungen:
    505
    Punkte für Erfolge:
    113
    Beruf:
    CS
    Ort:
    Hinter dem Mond...
    AW: oscam und 2x09c7

    Das mouse Protokoll ist das Standardprotokoll über die guten alten ftdi Treiber. Die neuen Treiber unterstützen den Protokoll leider nicht.


    Sent from my iPhone using Tapatalk
     
    #6
  8. joopastron
    Offline

    joopastron Administrator Digital Eliteboard Team

    Registriert:
    3. März 2011
    Beiträge:
    19.334
    Zustimmungen:
    12.423
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Immer bei der Sache
    AW: oscam und 2x09c7

    Das mouse Protokoll ist das Standardprotokoll über die guten alten ftdi Treiber. Alle handelsüblichen Reader verwenden die ftdi Treiber oder können mit umgehen. Der Smargo verwendet auch ftdi, die Verwendung wird aber eigentlich nicht unbedingt empfohlen. Beim Smargo sollte man soweit es möglich ist immer auf das smartreader Protokoll setzen. Hier wird libusb statt ftdi verwendet. Dadurch erhält man bessere ECM-Zeiten und man kann den Smargo fest anhand der Serial identifizieren, damit er nach einem Neustart des Servers wieder gefunden wird. Das smargo Protokoll ist für Benutzer gedacht die an ihrem Server kein libusb zur Verfügung haben und trotzdem gern den smartreader Mode nutzen möchten (z.b. Dreambox). Nur dann hat man nicht mehr die Möglichkeit den Smargo an der Serial zu identifizieren. Es ist aber über den Umweg udev möglich die Smargos im mouse-mode und im smargo-mode fest zu verlinken. Dann werden auch hier die Reader nach dem Neustart des Gerätes direkt wieder gefunden.

    Quelle zebradem Wiki


    Sent from my iPhone using Tapatalk
     
    #7
    bombadil und Pilot gefällt das.
  9. Saufsoldat
    Offline

    Saufsoldat Newbie

    Registriert:
    20. November 2009
    Beiträge:
    29
    Zustimmungen:
    3
    Punkte für Erfolge:
    3
    AW: oscam und 2x09c7

    Es lag übrigens an der Smargo Firmware 1.7. Läuft mit nem anderen Smargo mit 1.5 und den Einstellungen oben super, hab die Karten nur noch in die selbe Gruppe gepackt.
    Hatte mal kurz ins smartreader protocoll gewechselt, aber da wirft oscam mir ne Fehlermeldung aus und startet nicht, habs wohl ohne smartreader protocol kompiliert. Aber wenn das dann noch besser laufen soll wäre das ja noch mal eine Feinschliff-Option für mich.

    Dankeschön.
     
    #8

Diese Seite empfehlen