1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam startet nicht (DM500C)

Dieses Thema im Forum "OScam Archiv" wurde erstellt von speerspider, 11. März 2011.

  1. speerspider
    Offline

    speerspider Ist gelegentlich hier

    Registriert:
    2. Oktober 2009
    Beiträge:
    82
    Zustimmungen:
    36
    Punkte für Erfolge:
    18
    Beruf:
    Selbstständig
    Hi an alle,

    ich habe folgendes Problem: Das Startscript "CCcam_2.2.1_oscam_1.00_cam.sh" Startet zwar CCcam, aber leider Oscam nicht. Wenn ich Oscam manuell starte, meldet die Konsole folgenden Fehler: "Cannot allocate memory".
    CCcam habe ich damals noch über das Blue-Panel installiert, OSCam habe ich nun per Hand nachinstalliert. Ich habe schon unzählige Versionen von Oscam durch, auch die 0.9er.
    Die DM500 hat sonst keine weitere spezielle Konfiguration erhalten. Eigentlich nur Firmware draufgespielt, Sendersuchlauf durchgeführt, Bouquets sortiert, CCcam über Blue-Panel installiert und Oscam manuell übertragen.

    Folgende Oscam-Konfigurationen habe ich vorgenommen:

    oscam_1.00 nach /var/bin/ kopiert und Rechte auf 755 gesetzt.
    oscam.conf, oscam.server, oscam.services und oscam.user nach /var/tuxbox/config/ kopiert und Rechte auf 644 gesetzt.

    [EDIT]
    Ich verwende aktuell folgende Oscam-Variante: "oscam-svn4800-powerpc-tuxbox" aus dem Paket "oscam-svn4800-light-Distribution"
    [/EDIT]

    Das Start-Script:
    Code:
    #!/bin/sh
    
    CAMNAME="CCcam 2.2.1/OSCam 1.00 "
    USERNAME=""
    ZAPTIME=6
    CAMID=6369
    DVBSET=0
    INFOFILE="ecm.info"
    INFOFILELINES=
    # end
    
    remove_tmp () {
      rm -rf /tmp/*.info* /tmp/*.tmp*
    }
    
    case "$1" in
      start)
      echo "[SCRIPT] $1: $CAMNAME"
      remove_tmp
      /var/bin/oscam_1.00 &
      sleep 15
      /var/bin/CCcam_2.2.1 &
      ;;
      stop)
      echo "[SCRIPT] $1: $CAMNAME"
      kill `pidof oscam_1.00 `
      killall oscam_1.00 CCcam_2.2.1 2>/dev/null
      sleep 2
      remove_tmp
      ;;
      *)
      $0 stop
      exit 0
      ;;
    esac
    
    exit 0
    

    oscam.conf
    Code:
     [global]
    pidfile = /var/run/oscam.pid
    usrfile = /var/log/oscamuser.log
    logfile = /var/log/oscam.log
    cwlogdir = /var/log/cw.log
    usrfileflag = 0
    clienttimeout = 7
    fallbacktimeout = 5
    clientmaxidle = 120
    cachedelay = 300
    bindwait = 120
    netprio = 0
    resolvedelay = 30
    unlockparental = 0
    nice = -5
    serialreadertimeout = 2500
    maxlogsize = 2048
    waitforcards = 1
    preferlocalcards = 0
    
    [webif]
    httpport = 1234
    httpuser = root
    httppwd = root
    httpcss =
    httptpl =
    httpscript =
    httprefresh = 5
    httpallowed = 192.168.0.0-192.168.255.255,127.0.0.1
    httphideidleclients =
    httpreadonly =
    
    [newcamd]
    port = 25834@1834:000000
    key = 0102030405060708091011121314
    keepalive = 100
     

    oscam.server
    Code:
      [reader]
    label = sky
    protocol = cccam
    device = 127.0.0.1,12000
    account = oscam,oscamreader
    group = 1
    services = sky
    detect = none
    CAID = 1722,1834
    cccversion = 2.1.4
    cccbuild = 3165 
      

    oscam.services
    Code:
      [skyhd-mapping]
    caid = 1834
    provid = 000000
    srvid = 0080,0081,0082,0083,0084,007e,007f
      

    oscam.user
    Code:
      [account]
    user = oscam
    pwd = oscamserver
    disabled = 0
    group = 1
    uniq = 0
    sleep = 0
    monlevel = 0
    services = skyhd-mapping
    caid = 1834
    Betatunnel = 1834.0081:1722,1834.0082:1722,1834.0083:1722,1834.0084:1722,1834.007e:1722,
    1834.007f:1722,1834.0080:1722
    ident = 1834:000000
    keepalive = 0
    numusers = 0
    penalty = 0
    
    [account]
    user = abcd
    pwd = abcd
    disabled = 0
    group = 1
    uniq = 0
    sleep = 0
    monlevel = 0
    services = skyhd-mapping
    caid = 1834
    Betatunnel = 1834.0081:1722,1834.0082:1722,1834.0083:1722,1834.0084:1722,1834.007e:1722,
    1834.007f:1722,1834.0080:1722
    ident = 1834:000000
    keepalive = 0
    numusers = 0
    penalty = 0
      

    cccam.cfg
    Code:
    N: 127.0.0.1 25834 oscam oscamserver 01 02 03 04 05 06 07 08 09 10 11 12 13 14
    F: oscam oscamreader 0 1 1 {1834:0:1}
    

    Habt ihr vielleicht eine Ahnung woran das liegen könnte?

    Gruß
    speerspider
     
    Zuletzt bearbeitet: 11. März 2011
    #1
  2. phantom

    Nervigen User Advertisement

  3. speerspider
    Offline

    speerspider Ist gelegentlich hier

    Registriert:
    2. Oktober 2009
    Beiträge:
    82
    Zustimmungen:
    36
    Punkte für Erfolge:
    18
    Beruf:
    Selbstständig
    AW: Oscam startet nicht (DM500C)

    Ich konnte den Fehler nun selbst beheben. Folgendes musste ich umstellen:
    - Die oscam_1.00-Rechte von 755 auf 777 ändern.
    - Die Einträge "cccbuild = 3191", "pidfile = /var/run/oscam.pid" und "resolvedelay = 30" auskommentieren.
    Dann kam nur noch ein "segmentation fault" Fehler, sodass ich von der 4800 Build auf das 4799 Build gewechselt bin und schon funktioniert das Starten.

    Bei der Fehlersuche geholfen hat mir der Quellcode von oscam und ein Build (4768), das ich zuvor noch nicht ausprobiert hatte.

    Gruß
    speerspider
     
    Zuletzt von einem Moderator bearbeitet: 11. März 2011
    #2

Diese Seite empfehlen