1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam.server und Oscam.user werden i Igel automatisch ergänzt

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Nozzy, 8. Januar 2013.

  1. Nozzy
    Offline

    Nozzy Ist gelegentlich hier

    Registriert:
    17. September 2008
    Beiträge:
    64
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Beruf:
    keine Zeir für
    Ort:
    Tja da sind viele Häuser
    Bin auf einen Igel als Server umgestiegen und habe diesen nach der Anleitung hier aus dem Board ans laufen bekommen. Als Smartreader habe ich eine Easymouse 2 USB mit einer S02 als Karte angeschlossen. Nun möchte ich meine configs von Grund auf neu aufsetzten aber mein Igel lässt mich nicht:-( Ursprünglich war meine oscam.server folgendermaßen
    [reader] label = sky description = enable = 1 protocol = mouse device = /dev/ttyUSB0 services = sky boxkey = 1122334455667788 caid = 1702,1833 detect = cd mhz = 600 cardmhz = 600 emmcache = 1,3,2 lb_weight = 300
    Und dieses ist plötzlich von alleine auf meinem Igel geschrieben worden
    [reader] label = sky description = enable = 1 protocol = mouse device = /dev/ttyUSB0 device_out_endpoint = 0x 0 key = password = pincode = none readnano = services = sky smargopatch = 0 showcls = 10 fallback = 0 logport = 0 caid = 1702,1833 boxid = fix9993 = 0 rsakey = force_irdeto = 0 boxkey = 1122334455667788 atr = ecmwhitelist = detect = cd nagra_read = 0 mhz = 600 cardmhz = 600 ident = chid = class = aeskeys = showcls = 10 group = 1 emmcache = 1,3,2 blockemm-unknown = 1 blockemm-u = 0 blockemm-s = 0 blockemm-g = 0 blockemm-bylen = lb_weight = 300 savenano = blocknano = ccchop = 2 deprecated = 0 audisabled = 0 auprovid = ndsversion = 0 ratelimitecm = 0 ratelimitseconds = 0
    Damit ich meine config testen kann, möchte ich endlich eine schlanke oscam.server anlegen. Ich bin sicher, daß unter Debian irgendwas eingestellt ist, was zu diesem automatischen Füllen der config führt. Nur leider finde ich den Knopf nicht :-( Vielleicht habt Ihr ja mal einen Tip für mich. Meine aktuell laufende Oscam Version auf dem Igel ist die 1.10rc-svn Rev. 6089 Habe auch schonmal auf die neueste Oscam upgedatet, aber leider mit dem gleichen Ergebnis. Vielen Dank Nozzy
     
    Zuletzt bearbeitet: 8. Januar 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.427
    Zustimmungen:
    12.694
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Oscam.server und Oscam.user werden i Igel automatisch ergänzt

    Du musst in der oscam.conf folgenden Parameter unter [webif] setzen:

     
    #2
    jensebub gefällt das.
  4. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: Oscam.server und Oscam.user werden i Igel automatisch ergänzt

    Hallo,
    die Option ist in der oscam.conf zu finden im Abschnitt [webif]
    Code:
    httpsavefullcfg               = 1
    hat weder mit deinem Server, noch mit IPC zu tun, ist ganz einfach oscam dran Schuld ;)

    Gruß
    jensebub

    /EDIT: al-x83 war schneller
     
    #3
    symbi und al-x83 gefällt das.
  5. Nozzy
    Offline

    Nozzy Ist gelegentlich hier

    Registriert:
    17. September 2008
    Beiträge:
    64
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Beruf:
    keine Zeir für
    Ort:
    Tja da sind viele Häuser
    AW: Oscam.server und Oscam.user werden i Igel automatisch ergänzt

    Vielen Dank für die schnellen Antworten!!

    Habe nun aus der 1 eine 0 gemacht.

    Muss ich nun alles nochmals manuell entfernen was leer in der config steht?

    [webif]
    httpport = xxxxx
    httphelplang = de
    httpuser = user
    httppwd = pw
    httpcert =
    httpcss =
    httpjscript =
    httptpl =
    httpscript =
    httprefresh = 15
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.255.255,172.16.0.0-172.31.255.255
    httpdyndns =
    httphideidleclients = 0
    httpreadonly = 0
    httpsavefullcfg = 0
     
    #4
  6. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.427
    Zustimmungen:
    12.694
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Oscam.server und Oscam.user werden i Igel automatisch ergänzt

    Einfach mal in's Webif von Oscam gehen, was änder und abspeichern. Schon sollte die Config deutlich übersichtlicher sein.
     
    #5
  7. Nozzy
    Offline

    Nozzy Ist gelegentlich hier

    Registriert:
    17. September 2008
    Beiträge:
    64
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Beruf:
    keine Zeir für
    Ort:
    Tja da sind viele Häuser
    Vielen Dank für die Hilfe.
    Habe die Änderungen so gemacht, aber direkt nach dem Speichern gibt es keine Veränderung der bereits geschriebenen Zeilen.
    Ich werde den Server gleich mal neu starten und berichten.
    Ich wäre ja schon zufrieden, wenn es sich nicht wieder von alleine aufbläht!

    Many THX

    Nozzy

    So habe Oscam neu getartet und es bleibt beim alten.
    Die leeren Felder bleiben erhalten.

    siehe hier.

    [global]
    serverip = 0.0.0.0
    usrfile =
    mailfile =
    logfile = /var/log/ipc/OScam.log
    cwlogdir =
    emmlogdir =
    disablelog = 1
    disableuserfile = 1
    disablemail = 1
    loghistorysize = 4096
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 5100
    clientmaxidle = 120
    failbantime = 0
    failbancount = 0
    cachedelay = 0
    bindwait = 120
    netprio = 0
    sleep = 0
    unlockparental = 0
    nice = -1
    serialreadertimeout = 5000
    suppresscmd08 = 0
    maxlogsize = 2480
    waitforcards = 1
    waitforcards_extra_delay = 500
    preferlocalcards = 1
    saveinithistory = 1
    readerrestartseconds = 5
    dropdups = 1
    lb_mode = 1
    lb_save = 0
    lb_nbest_readers = 5
    lb_nfb_readers = 1
    lb_min_ecmcount = 5
    lb_max_ecmcount = 500
    lb_reopen_seconds = 900
    lb_retrylimit = 800
    lb_retrylimits =
    lb_nbest_percaid =
    lb_noproviderforcaid =
    lb_savepath = /var/log/ipc/
    lb_stat_cleanup = 336
    lb_use_locking = 0
    lb_reopen_mode = 0
    lb_max_readers = 2
    lb_auto_betatunnel = 1
    resolvegethostbyname = 0

    Aber auch die Neugeschriebenen Teile der config sind unverändert, also auch nicht automatisch aufgefüllt worden.

    Ich denke ich muss manuell ran und alles mal wieder "schön" machen!

    Aber egal Hauptsache es funktioniert so.

    Vielen Dank nochmals für die Lösung

    Gruß

    Nozzy
     
    Zuletzt von einem Moderator bearbeitet: 8. Januar 2013
    #6

Diese Seite empfehlen