1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSCAM (Server) und OSCAM (Client) mit CCCAM Protokoll - EMM Konfiguration

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Maza17, 14. Oktober 2012.

  1. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    Das Problem wurde gelöst. Lösungsweg und Beispiel-Konfigurationen siehe Verlauf bzw. Antwort #4 unten!



    Hallo liebe Gemeinde,

    seit einigen Tagen schon quäle ich mich schon mit der EMM Problematik herum.

    Ich habe einen Igel Server auf dem Oscam läuft und eine GM Spark Reloaded, auf der ebenfalls OSCAM als Client läuft. Als Protokoll für das CS verwende ich CCCAM 2.1.4

    Ich schaffe es einfach nicht, EMM von der GM an meinen Server zu senden. Könnt ihr mir evtl. bei der Lösung des Problems behilflich sein?

    Hier der Inhalt der Config.-Dateien

    SERVER

    Oscam.conf
    # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn build #7050#

    [global]
    usrfile = /var/log/oscam/oscamuser.log
    logfile = /var/log/oscam.log
    cachedelay = 160
    nice = -1
    maxlogsize = 4069
    preferlocalcards = 1
    saveinithistory = 1

    [monitor]
    hideclient_to = 15
    appendchaninfo = 0

    [cccam]
    port = xxxxx
    reshare = 1
    version = 2.1.4
    nodeid = xxxxxxxxxxxxxxxxx


    [webif]
    httpport = xxxxx
    httphelplang = de
    httpuser = xxxxxxx
    httppwd = xxxxxxxx
    httprefresh = 15
    httpallowed = 127.0.0.1,1.1.1.0-255.255.255.255

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = dvbapi,dvbapi
    request_mode = 0

    Oscam.server
    # oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn build #7050# Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [reader]
    label = sky
    description = s
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 09C4
    boxid = 11223344
    boxkey = 1122334455667788
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,3,2
    saveemm-unknown = 1
    saveemm-u = 1
    saveemm-s = 1
    saveemm-g = 1
    auprovid = 0009C4

    Oscam.user
    [account]
    user = userA
    pwd = xxxxxxxxx
    group = 1
    cccmaxhops = 0
    keepalive = 1

    [account]
    user = dvbapi
    pwd = dvbapi
    description = mydvbapi
    group = 1
    au = sky
    caid = 09C4
    ident = 09C4:000000
    cccmaxhops = 0


    CLIENT

    Oscam.conf
    [global]
    nice = -1
    WaitForCards = 1
    saveinithistory = 1
    #lb_mode = 2
    #lb_save = 0
    #lb_nbest_readers = 1
    #lb_nfb_readers = 3
    #lb_min_ecmcount = 5
    #lb_reopen_seconds = 200

    logfile = stdout
    usrfile = /var/log/oscam/oscamuser.log
    cwlogdir = /var/log/oscam/cw
    disablelog = 1

    [monitor]
    hideclient_to = 15
    appendchaninfo = 0

    [dvbapi]
    enabled = 1
    au = 1
    user = dvbapi,dvbapi
    boxtype = dreambox

    Oscam.server
    [reader]
    label = sky
    protocol = cccam
    device = xxx.xxx.xxx.xxx,xxxxx
    user = userA
    password = xxxxxxx
    group = 1
    cccversion = 2.1.4
    audisabled = 1
    #au = 1
    cccmaxhop = 3
    caid = 09C4
    cccversion = 2.1.4
    emmcache = 1,3,2

    Oscam.user
    [account]
    user = dvbapi
    pwd = dvbapi
    description = mydvbapi
    group = 1
    monlevel = 0
    au = 1
    caid = 09C4
    ident = 09C4:000000
    cccmaxhops = 1

    Ich finde hier einfach den Wurm nicht. CS an sich funktioniert ohne weiteres. Nur eben AU nicht. Wurde in den wenigen Monaten die ich Sky bisher habe allerdings auch nur einmal schwarz. Habe die Karte dann in den Sky Receiver und habe einige Minuten gewartet, bis das Bild wieder hell war.

    Aber das ist eben mit unnötigen Aufwand verbunden. Ich hätte es, wenn schon CS, technisch vollständig und korrekt :)

    Ich hoffe ihr findet einige Minuten Zeit, um mir bei der Lösung meines Problems behilflich sein zu können.

    Besten Dank an euch.

    Grüße
    Maza
     
    Zuletzt bearbeitet: 14. Oktober 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. kabanett
    Offline

    kabanett Ist gelegentlich hier

    Registriert:
    24. April 2012
    Beiträge:
    95
    Zustimmungen:
    18
    Punkte für Erfolge:
    8
    AW: OSCAM (Server) und OSCAM (Client) mit CCCAM Protokoll - EMM Konfiguration

    auf dem server bei user mal AU = 1 eingetragen?
    beim client die server mal die # entfernt?


    lass beim client einfach oscam weg und trag in cccam ne c-line ein und fertsch!!!


    Gruß kabanett
     
    #2
  4. Kermit
    Online

    Kermit Guest

    AW: OSCAM (Server) und OSCAM (Client) mit CCCAM Protokoll - EMM Konfiguration

    Hi,

    entferne als erstes mal alle ident Einträge. Die werden in der Konstellation nicht benötigt.
    Der User auf dem Client, der zum dvbapi in der oscam.conf gehört hat kein pwd -> entfernen oder besser gesagt nur
    pwd =
    eintragen und nicht mehr.
    Allgemein empfiehlt es sich in der oscam.user nicht au = 1 zu verwenden sondern au = labeldesreaders in deinem Fall au= sky.
    In deiner oscam.server auf dem Client hast du audisabled = 1 eingetragen. Du wunderst dich warum keine EMMs durchkommen?
    emmcache macht bei einem Proxy rein gar keinen Sinn.
    In der oscam.conf auf deinem Client hast du im Abschnitt [dvbapi] user = dvbapi,dvbapi stehen. Das ist falsch -> user = dvbapi
    In der oscam.server auf dem Server nimm mal alles raus, was mit saveemm anfängt. Die V13 braucht eine boxid aber keinen boxkey.
    emmcache kannst du auf 1,1,2 einstellen, das reicht vollkommen aus auf dem Server.

    Grüße

    Kermit
     
    #3
  5. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: OSCAM (Server) und OSCAM (Client) mit CCCAM Protokoll - EMM Konfiguration

    Hallo und vielen Dank für eure Unterstützung.

    @kabanett : herzlichen Dank für deine Hilfe. Ich wollte den Ansatz des Einsatzes der der Cam auf der Spark Reloaded nicht verändern, weshalb ich mich gegen die C Line entschieden habe. Dennoch vielen Dank für deine Unterstützung.

    @Kermit : vielen vielen Dank! Es hat nach deiner Beschreibung/Anleitung bestens funktioniert. Es klappte bereits beim ersten Mal und läuft perfekt! Ich bin begeistert.


    Hier meine Konfiguration:

    Server

    oscam.conf
    [global]
    usrfile = /var/log/oscam/oscamuser.log
    logfile = /var/log/oscam.log
    cachedelay = 160
    nice = -1
    maxlogsize = 4069
    preferlocalcards = 1
    saveinithistory = 1

    [monitor]
    hideclient_to = 15
    appendchaninfo = 0

    [cccam]
    port = [Port wählen]
    reshare = 1
    version = 2.1.4
    nodeid = [Nodeid bestimmen]

    [webif]
    httpport = [Port wählen]
    httphelplang = de
    httpuser = [User Namen festlegen]
    httppwd = [Passwort festlegen]
    httprefresh = 15
    httpallowed = 127.0.0.1,1.1.1.0-255.255.255.255

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = dvbapi
    request_mode = 0

    oscam.server
    [reader]
    label = [reader label Name eingeben]
    description = s
    protocol = [bei einer Easymouse: mouse]
    device = [z.B. bei einer Igel mit Mouse: /dev/ttyUSB0]
    caid = 09C4
    boxid = 11223344
    detect = cd
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,1,2
    auprovid = 0009C4

    oscam.user
    [account]
    user = [User-Name]
    pwd = [User-Pass]
    group = 1
    cccmaxhops = 0
    keepalive = 1


    [account]
    user = dvbapi
    pwd =
    description = mydvbapi
    group = 1
    au = [reader label]
    caid = [z.B. 09C4 bei V13 Sat]
    cccmaxhops = 0

    Client

    oscam.conf
    [global]
    nice = -1
    WaitForCards = 1
    saveinithistory = 1
    logfile = stdout
    usrfile = /var/log/oscam/oscamuser.log
    cwlogdir = /var/log/oscam/cw
    disablelog = 1


    [monitor]
    hideclient_to = 15
    appendchaninfo = 0


    [dvbapi]
    enabled = 1
    au = 1
    user = dvbapi
    boxtype = dreambox

    [reader]
    label = [reader label des readers auf dem server]
    protocol = cccam
    device = [ip,port ; z.B. 192.168.1.2,12000]
    user = [User-Name auf Server]
    password = [User-Pass auf Server]
    group = 1
    au = 1
    cccmaxhop = 3
    caid = 09C4
    cccversion = 2.1.4

    oscam.user
    [account]
    user = dvbapi
    pwd =
    description = mydvbapi
    group = 1
    monlevel = 0
    au = [reader label]
    caid = 09C4
    cccmaxhops = 1

    Vielleicht hilft es ja dem einen oder anderen :)

    Vielen Dank euch allen.

    Grüße
    Maza
     
    #4
    shorty1409 und megadave74 gefällt das.

Diese Seite empfehlen