1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Maza17, 8. Juli 2013.

  1. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    Hallo liebe Community,

    ich setze derzeit ein Rasp. PI mit IPC und Oscam Build 8745 als Server ein.
    Ich habe eine V13 Karte, die über Easymouse an dem RPI verbunden ist.
    Versorgt werden zwei Clients im LAN.
    Unter anderem eine Spark Reloaded 990 (oscam).

    Die Spark soll zudem als EMM Versorger zur Verfügung stehen.

    Das Problem: der RPI erhält zwar EMM, allerdings nur Global EMM, die ich jedoch per Einstellung blocke. Unique oder Shared EMM kamen selbst nach 3000 ECMs keine an.
    Aufgrund eines Tipps (danke @hismastersvoice), habe ich über die SKY-Website nochmal eine Freischaltung der Karte vornehmen lassen. Dennoch sind keine anderen als Global EMM angekommen.

    Folgende Einstellungen habe ich vorgenommen:

    Server

    oscam.conf
    [global]
    logfile = /var/log/ipc/OScam.log
    unlockparental = 1
    nice = -10
    maxlogsize = 500
    waitforcards_extra_delay = 3000
    preferlocalcards = 1
    dropdups = 1
    saveinithistory = 1
    lb_mode = 1
    lb_save = 500
    lb_retrylimit = 1300
    lb_stat_cleanup = 6
    lb_reopen_mode = 1
    lb_savepath = /var/tmp/oscam.stat

    [cccam]
    port = 99999
    version = 2.2.1
    reshare = 1

    [webif]
    httpport = 99999
    httpuser = user
    httppwd = pass
    httphelplang = de
    httprefresh = 30
    httpallowed = 192.0.0.0-192.168.255.255
    appendchaninfo = 1

    oscam.user
    [account]
    user = user1
    pwd = pass1
    group = 1
    uniq = 3
    allowedprotocols = cccam
    caid = 09C4
    au = sky
    cccmaxhops = 1
    cccreshare = 1
    keepalive = 1

    oscam.server
    [reader]
    label = sky
    description = skysh
    protocol = mouse
    device = /dev/easym1 #UDEV ist über IPC eingerichtert
    caid = 09C4
    boxid = 12345678
    detect = CD
    mhz = 357
    cardmhz = 357
    group = 1
    emmcache = 1,3,2
    blockemm-unknown = 1
    blockemm-s = 1
    blockemm-g = 1
    saveemm-u = 1
    ins7e11 = 15
    ndsversion = 2

    Client

    oscam.conf
    [global]
    disablelog = 1
    disableuserfile = 1

    [dvbapi]
    enabled = 1
    au = 1
    user = dummyuser
    boxtype = dreambox

    oscam.user
    [account]
    user = dummyuser
    pwd = dummypassword
    group = 1
    au = 1

    oscam.server
    [reader]
    label = sky
    device = IP,Port
    protocol = cccam
    user = user1
    password = pass1
    emmcache = 1,3,2
    caid = 09C4
    group = 1
    cccversion = 2.1.4

    Kennt ihr das Problem bzw. erkennt ihr das Problem in meinen Konfigurationen? Habt ihr einen Tipp für mich, wie ich das mit den Unique EMM auf die Reihe bekomme?

    Ich wäre euch für eure Unterstützung sehr dankbar.

    Viele Grüße
    Maza
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.382
    Zustimmungen:
    23.798
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Hallo Maza,

    unique EMMs kommen sehr sehr selten.
    Schick dir über das Sky Portal selbst ein Freischaltsignal. Dann kommen unique EMMs.
    Stell auf sky Sport NewsHD. Nicht zappen. 30min sollten langen.

    Mlg pilten
     
    #2
    mxer, Maza17 und laila-no1 gefällt das.
  4. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    hi,

    ändere mal auf deinem Client von au = 1 auf au = Labelname

    auf der Clientseite bei der Dvbapisektion in der Oscam.conf.
    Code:
    [dvbapi]
    enabled = 1
    au      = sky
    user    = dummyuser
    boxtype = dreambox
    und im User Clientseitig auch dasselbe.

    Code:
    au      = sky
     
    Zuletzt bearbeitet: 8. Juli 2013
    #3
    Maza17 und Pilot gefällt das.
  5. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Hallo zusammen und vielen Dank für Eure Beiträge.

    @Piloten:
    das habe ich bereits versucht. Zwei mal sogar. Leider vergebens. Mittlerweile kann ich eine weitere Freischaltung nicht mehr anfordern. Muss wohl warten, bis ich es ein weiteres mal die EMM anfordern kann.

    @laila-no1:
    Danke für den Hinweis. Funktioniert jedoch nicht :/ es kommen jetzt nicht einmal mehr Global EMM an.

    Viele Grüße
    Maza
     
    #4
  6. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.884
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Unique EMM sind bei mir 2 written und 103 skipped.
    Laufzeit Server: 2 Tage und ~22 Stunden.
    Es kommen jede Menge, aber die sind selten nötig.

    Bischen Kosmetik :dance3:
    EMMCache = 1,1,2
    LB Cache auskippen und dann
    LB = 0
    Bei einer Karte macht ein laufender LB keinen Sinn.
     
    #5
    Maza17, laila-no1 und Pilot gefällt das.
  7. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Danke mxer für den Hinweis. Ich werde mich dann mal einige Tage gedulden und hoffen, dass es klappt.

    Die Konfiguration scheint ja soweit in Ordnung zu sein?!

    Hast du hierzu noch einige Infos für mich? Für was genau ist LP und wie leere ich den Cache?

    Viele Grüße
    Maza
     
    #6
  8. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.884
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    LB = LoadBalancer
    Regelt die Zugriffe bei 2 oder mehr Karten mit gleicher CAID.
    Lohnt also mit einer Karte nicht.

    Im Webif - Configuration - LoadBalancer aufmachen.
    Oben auf 0 stellen, gaaaaanz unten sind noch ein paar interessante Buttons.
    Dort alle drücken, wo "Clear" draufsteht.
    Oscam rebooten nicht vergessen.
     
    #7
    Maza17 und Pilot gefällt das.
  9. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.424
    Zustimmungen:
    12.689
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Verbinde den Client mal vie camd3.5 udp. Dann werden auch Unique EMMs geschrieben.
    Hatte via CCcam das selbe Problem. Kaum hatte ich auf camd umgestellt, schon waren die ersten EMMs da
     
    #8
  10. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    @mxer: besten Dank :good:

    @al-x83: geht das denn mit oscam und der spark reloaded? Ich verwende aktuell das Plugin oscam-1.10rc-svn-sh4-linux.

    Ich wüsste gar nicht wo ich da ansetzen und welche Einstellungen ich vornehmen sollte. Könntest du mir dabei behilflich sein?

    Viele Grüße und besten Dank für eure Antworten!
    Maza
     
    #9
  11. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    22.885
    Zustimmungen:
    16.190
    Punkte für Erfolge:
    113
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    in der oscam.conf am Server kommt das rein anstatt cccam oder du nimmst nur einen anderen port
    Code:
    [cs357x]
     port = 22200
    
    am Client den Reader so einrichten
    Code:
    [reader]
     label     = sky
     device    = IP,Port
     protocol  = camd35
     user      = user1
     password  = pass1
     caid      = 09C4
     group     = 1
    
     
    #10
    Maza17, Pilot, laila-no1 und 2 anderen gefällt das.
  12. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.424
    Zustimmungen:
    12.689
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Ich hab keine Spark relaoded, sondern einen "normalen" Pingulux, aber im Prinzip is es ja das selbe.
    Sollte so, wie von dodo83 beschrieben, funktionieren.
     
    #11
    Maza17 und Pilot gefällt das.
  13. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Hallo zusammen,

    vielen Dank, dass ihr euch weiterhin bemüht, mir zu helfen.

    @Dodo83

    Ich habe es mal versucht, wie von dir beschrieben. Hat leider nicht funktioniert. Das Bild bleibt
    schwarz. Das wird vermutlich daran liegen, dass das von mir verwendete Oscam Plugin wohl
    nur cccam unterstützt. Ich gehe wegen folgender Hinweise aus dem Oscam-Webinterface (Client)
    davon aus:

    Auszug aus dem Log:
    2013/07/09 13:24:29 29893208 s monitor: disabled
    2013/07/09 13:24:29 29893208 s camd33: disabled
    2013/07/09 13:24:29 29893208 s camd35: disabled
    2013/07/09 13:24:29 29893208 s cs378x: disabled

    Auszug aus oscam.version
    Unix starttime: 1373376269
    Starttime: 09.07.13 13:24:29
    Version: 1.10rc-svn Rev.
    Max PID: unlimited




    Active modules:
    Web interface support: yes
    SSL support: no
    DVB API support yes
    DVB API with STAPI support: no
    Anti-cascading support: yes
    ECM doublecheck: no
    Irdeto guessing: yes
    Debug mode: yes
    LED support: no
    Q-Box HD LED support: no
    Log history: yes
    Monitor: yes
    Loadbalancing support: yes
    LCD support: no
    camd 3.3x: yes
    camd 3.5 UDP: yes
    camd 3.5 TCP: yes
    newcamd: yes
    CCcam: yes

    Ich bin mir da zwar nicht sicher, aber kann es sein, dass nicht jedes Oscam-Plugin für Spark
    ad hoc camd35 unterstützt?

    @al-x83:
    Welches Plugin verwendest du denn, damit oscam zu oscam via camd35 läuft? Evtl. gibt es
    dieses Plugin ja auch für den Spark?

    Viele Grüße
    Maza
     
    #12
  14. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.424
    Zustimmungen:
    12.689
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    In dem Fall ist die Unterstützung aber drin.
    Die Oscam-Binaries funktionieren alle unter Spark.
    Die aktuellste, von mir kompilierte, findest du hier:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    Einfach die Endung .nfi entfernen, via FTP nach /root/plugin/var/bin kopieren und die REchte auf 755 setzen.

    Es währe auch noch interessant, was das Log ausspuckt.
     
    #13
    Maza17 und Pilot gefällt das.
  15. Maza17
    Offline

    Maza17 Ist oft hier

    Registriert:
    5. November 2009
    Beiträge:
    119
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    @al-x83:

    Höchst eigenartig. Da habe ich so oft in die oscam.version geschaut und könnte schwören, ein No gesehen zu haben :/ Strange.

    ABER: mit dem von dir bereitgestellten Plugin und den Tipps hier aus dem Thread konnte ich nun camd35 nun endlich zum Laufen bekommen.

    Bisher vielen Dank an euch alle!

    Leider gibt es noch ein "aber": AU funktioniert nun überhaupt nicht mehr. Es kommen keine EMMs mehr an, auch keine Global.

    Hier meine Config

    oscam.conf
    [global]
    logfile = /root/plugin/var/log/oscam/oscamuser.log

    [webif]
    httpport = PORT
    httpuser = admin1
    httppwd = passw1
    httphelplang = de
    httprefresh = 30
    httpallowed = 192.0.0.0-192.168.255.255

    [dvbapi]
    enabled = 1
    user = DVBAPI
    boxtype = dreambox

    oscam.user
    [account]
    user = DVBAPI
    pwd =
    group = 1
    au = 1

    oscam.server
    [reader]
    label = sky
    device = IP,PORT
    protocol = cs378x
    user = user1
    password = passw1
    emmcache = 1,3,2
    caid = 09C4
    group = 1
    emmcache = 1,1,2

    Hat da jemand ein Tipp für mich?

    Viele Grüße
    Maza
     
    #14
  16. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: OSCAM Server + OSCAM Client - Uniqe EMM werden nicht weitergeleitet

    Moin,

    versuch mal in der oscam.user den Label des Readers bei AU zu verwenden. Also
    Code:
    au = sky

    Grüße
    Bombadil
     
    #15
    Maza17 gefällt das.

Diese Seite empfehlen