1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSCam Server + Freetz Einrichtung

Dieses Thema im Forum "Fritzbox Archiv" wurde erstellt von ulf05, 10. November 2011.

  1. ulf05
    Offline

    ulf05 Guest

    Hallo!

    Also ich habe mich jetzt auch mal an das Thema freetz herangetraut... und bräuchte ein bissel Hiilfe. :emoticon-0144-nod:

    Ziel:
    - OSCam Server mit CCCam Protokoll auf freetzbox

    Material:
    - Fritzbox 7270 (dient als Wlan Router, Telefon und DSL Verbindung // Original Firmware)
    - Fritzbox 7141 (soll als OSCam Server dienen // freetz devel 7770)
    - USB Hub
    - USB Stick
    - 2x Smargo

    Aktueller Stand:
    - die Freetz ist an der original FB angeschlossen und ist auch per IP Eingabe erreichbar
    - alle Passwörter geändert

    Jetzt stehe ich aufen Schlauch, gehe ich ins Freetz IF kann ich dort alles anwählen und OSCAM Configs eingeben.

    Brauch ich jetzt den USB Stick mit den Dateien oder kann ich auch ohne Stick den Server aufziehen? Ich verstehe nicht so ganz warum ich nen Stick mit den Dateien aus der Database brauch...

    Ich hoffe, dass wurde nicht schon 1000000x beantwortet... :emoticon-0131-angel
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. giftstaub
    Offline

    giftstaub VIP

    Registriert:
    28. Januar 2010
    Beiträge:
    1.699
    Zustimmungen:
    1.656
    Punkte für Erfolge:
    113
    Ort:
    Ruhrpott
    #2
  4. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.382
    Zustimmungen:
    23.798
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: OSCam Server + Freetz Einrichtung

    Hallo ulf05,

    Stick wird gebraucht, weil der Speicher der Fritzbox zu klein ist für das freetz image. Ein Teil wird auf die Fritzbox geflasht. Der Rest ist auf dem Stick ausgelagert. Immer den Stickinhalt nehmen, der zum freetz dabei ist. Somst stimmen die Pfade nicht.
    Deine Entscheidung zu oscam allein mit cccam Protokoll ist absolut richtig. Läuft bei mir auch. Da du nicht geschrieben hast, welche Abo Karte du hast, such dir hier Config Beispiel aus, was du brauchst:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?




    Mlg piloten
     
    #3
  5. ulf05
    Offline

    ulf05 Guest

    AW: OSCam Server + Freetz Einrichtung

    Hey Danke für die schnelle Hilfe!

    @giftstaub: danke für die Videohinweise, das 2te hatte ich mir auch schon angeguckt... jetzt noch einmal gründlich ;) Das 1te Video brauche ich später wohl nochmal.
    @piloten: ahh jetzt kommt Licht ins dunkle, ich hätte es mir schon fast gedacht, aber ich war leicht verwirrt da das freetz-IF bereits verfügbar war mit allen Punkten...

    Nun gut, USB Stick ist eingebunden!
    Den Anhang 46149 betrachten
    Habe die lite Version ausgesucht, da ich eigentlich nicht viel brauche...


    Port Forwarding habe ich eingestellt, abweichend vom Video wie folgt:
    Den Anhang 46150 betrachten
    Irgendwo hatte ich gelesen, dass bei meiner Konstellation nur die Original Fritte nen Forwarding brauch auf die Freetz, ist das richtig??


    Ahhh jetzt sehe ich gerade auch nach dem Einbinden des Sticks viel mehr Infos unter OSCam Einstellungen! :)

    Leider will der Log bei mir nicht, Pfad habe ich in der Config angepasst, Rechte habe ich mit einem ftp programm geprüft, die sind auf 777 im Ordner logs:

    /var/media/ftp/uStor01/logs/oscam.logKommt trotzdem noch die Fehlermeldung...
    Hat jemand ne Idee?



    Werde heute Nachmittag weitermachen...


    Edit: Als Abo hd+ und Sky // weiße hd+ Karte; S02 Sky // Habe mir schon Configs angeguckt, und mich ein wenig mit OSCam vertraut gemacht, die Dokumentation darüber ist wirklich sehr gut, sei es Zebra oder das Wiki von OSCam, bin schwer beeindruckt
     
    #4
  6. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.382
    Zustimmungen:
    23.798
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: OSCam Server + Freetz Einrichtung

    @ulf05:Irgendwo hatte ich gelesen, dass bei meiner Konstellation nur die Original Fritte nen Forwarding brauch auf die Freetz, ist das richtig??
    Fast richtig. Wenn du 2 Fritzboxen hast-eine als Router und die Serverfritzbox als IP Clinte dahinter- Portweiterleitung zur Serverfritzbox wird in der ersten Fritzbox erledigt. Die der Router ist. Auch richtig, nicht forwading , sondern mit TCP.
    @ulf05:/var/media/ftp/uStor01/logs/oscam.logKommt trotzdem noch die Fehlermeldung...
    Rechte mal auf 0755 setzen.
    /var/media/ftp/uStor01/oscam.log-das ist mein Pfad
    Mlg piloten
     
    Zuletzt bearbeitet: 11. November 2011
    #5
    scorpi und (gelöschter Benutzer) gefällt das.
  7. ulf05
    Offline

    ulf05 Guest

    Problem Log gelöst: Hatte die "#" nicht gesehen... nu logged er auch :)

    Jetzt hänge ich bei der Smargo Konfiguration ein wenig fest. Auf was sollte ich die updaten? 1.3, 1.4 oder 1.5? Aus der Liste von Zebra werde ich nicht richtig schlau. Ist Aglois = Argolis? Kann ich eine HD01 mit Version 1.3 betreiben?

    Es sollten Originale sein, keine Rundungen sonder Ecken. Hinten die Aufschrift: SmartReader ht*p://www.argolis.de Danke

    Sooo, ich habe den Smargo auf Version 1.3 gelassen.

    Folgende Einstellungen unter Windows dem Smargo zugewiesen:
    Mode: Autoswitch
    Kernel: Dreambox
    T-Mode: T=0
    EGT: 0

    Es ist eine hd01 (weiß) karte. Folgenden Log bekomme ich unter OSCam:

    2011/11/12 9:23:46 400 s >> OSCam << cardserver started, version 1.10rc -DEB-Prof.Linux-, build #5990 (mipsel-router-linux-uclibc929)
    2011/11/12 9:23:46 400 s version=1.10rc -DEB-Prof.Linux-, build #5990, system=mipsel-router-linux, nice=-1
    2011/11/12 9:23:46 400 s client max. idle=120 sec, debug level=0
    2011/11/12 9:23:46 400 s max. logsize=2480 Kb, loghistorysize=4096 bytes
    2011/11/12 9:23:46 400 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms
    2011/11/12 9:23:47 400 s services reloaded: 0 services freed, 4 services loaded, rejected 0
    2011/11/12 9:23:47 400 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2011/11/12 9:23:47 400 s signal handling initialized (type=sysv)
    2011/11/12 9:23:48 400 s 11590 service-id's loaded in 1300ms
    2011/11/12 9:23:48 400 s WARNING: You risk high CPU load and high ECM times with more than 2000 service-id´s!
    2011/11/12 9:23:48 400 s HINT: --> use optimized lists from

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    2011/11/12 9:23:48 400 s 116 tier-id's loaded
    2011/11/12 9:23:48 400 s 3 provid's loaded
    2011/11/12 9:23:48 400 s 22 lengths for caid guessing loaded
    2011/11/12 9:23:48 400 s monitor: initialized (fd=8, port=988)
    2011/11/12 9:23:48 400 s camd33: disabled
    2011/11/12 9:23:48 400 s camd35: disabled
    2011/11/12 9:23:48 400 s cs378x: disabled
    2011/11/12 9:23:48 400 s newcamd: initialized (fd=9, port=34000, crypted)
    2011/11/12 9:23:48 400 s CAID: 1830
    2011/11/12 9:23:48 400 s provid #0: 003411
    2011/11/12 9:23:48 400 s radegast: disabled
    2011/11/12 9:23:48 400 s http thread started
    2011/11/12 9:23:48 400 s creating thread for device /dev/ttyUSB0
    2011/11/12 9:23:48 400 s loadbalancer: can't read from file /tmp/.oscam/stat
    2011/11/12 9:23:48 400 s waiting for local card init
    2011/11/12 9:23:48 C04 r reader thread started (thread= C04, label=hd+, device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2011/11/12 9:23:48 803 h HTTP Server listening on port 83
    2011/11/12 9:23:51 C04 r hd+ card detected
    2011/11/12 9:23:59 C04 r ATR: xxxxx
    2011/11/12 9:24:01 C04 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
    2011/11/12 9:24:04 C04 r detect native nagra card
    2011/11/12 9:24:18 C04 r card system not supported
    2011/11/12 9:24:18 C04 r Normal mode failed, reverting to Deprecated Mode
    2011/11/12 9:24:26 C04 r ATR: xxxxx
    2011/11/12 9:24:27 C04 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
    2011/11/12 9:24:30 C04 r detect native nagra card
    2011/11/12 9:24:45 C04 r card system not supported
    2011/11/12 9:24:45 C04 r card initializing error
    2011/11/12 9:24:46 400 s init for all local cards done
    2011/11/12 9:24:46 400 s anti cascading disabled

    OSCAM Server:


    [reader]
    label = HD+
    enable = 1
    protocol = mouse
    detect = CD
    device = /dev/ttyUSB0
    caid = 1830
    group = 1
    emmcache = 1,3,2
    rsakey = B**5 // ist eingegeben
    boxkey = A**C // ist eingegeben
    detect = cd
    mhz = 357
    cardmhz = 357

    Kann da jemand was zu sagen? Danke

    Edit: Grüne LED am Smargo leuchtet nicht sobald die Karte eingesteckt wird.
     
    Zuletzt von einem Moderator bearbeitet: 12. November 2011
    #6
  8. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: OSCam Server + Freetz Einrichtung

    Richtig: die LED geht aus, wenn die KArte drin ist, nur ab und zu flackert sie - bei Zugriff.
    In der oscam.server
    cardmhz = 368
    mhz = 368

    Denke daran: wenn Du Logs postest -> die serials durch xxxxx ersetzen :ja
     
    #7
  9. ulf05
    Offline

    ulf05 Guest

    AW: OSCam Server + Freetz Einrichtung

    Hallo!

    Die Serials sind die hinter ATR oder? Habe ich jetzt unkenntlich gemacht, sorry...

    Also folgende Einstellungen:

    [reader]
    label = HD+
    enable = 1
    protocol = mouse
    smargopatch = 1
    detect = CD
    device = /dev/ttyUSB0
    caid = 1830
    group = 1
    emmcache = 1,3,2
    rsakey = **
    boxkey = **
    mhz = 368
    cardmhz = 368

    Log:
    011/11/12 10:28:05 400 s >> OSCam << cardserver started, version 1.10rc -DEB-Prof.Linux-, build #5990 (mipsel-router-linux-uclibc929)
    2011/11/12 10:28:05 400 s version=1.10rc -DEB-Prof.Linux-, build #5990, system=mipsel-router-linux, nice=-1
    2011/11/12 10:28:05 400 s client max. idle=120 sec, debug level=0
    2011/11/12 10:28:05 400 s max. logsize=2480 Kb, loghistorysize=4096 bytes
    2011/11/12 10:28:05 400 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms
    2011/11/12 10:28:05 400 s services reloaded: 0 services freed, 4 services loaded, rejected 0
    2011/11/12 10:28:05 400 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2011/11/12 10:28:05 400 s signal handling initialized (type=sysv)
    2011/11/12 10:28:06 400 s 11590 service-id's loaded in 743ms
    2011/11/12 10:28:06 400 s WARNING: You risk high CPU load and high ECM times with more than 2000 service-id´s!
    2011/11/12 10:28:06 400 s HINT: --> use optimized lists from

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    2011/11/12 10:28:06 400 s 116 tier-id's loaded
    2011/11/12 10:28:06 400 s 3 provid's loaded
    2011/11/12 10:28:06 400 s 22 lengths for caid guessing loaded
    2011/11/12 10:28:06 400 s monitor: initialized (fd=8, port=988)
    2011/11/12 10:28:06 400 s camd33: disabled
    2011/11/12 10:28:06 400 s camd35: disabled
    2011/11/12 10:28:06 400 s cs378x: disabled
    2011/11/12 10:28:06 400 s newcamd: initialized (fd=9, port=34000, crypted)
    2011/11/12 10:28:06 400 s CAID: 1830
    2011/11/12 10:28:06 400 s provid #0: 003411
    2011/11/12 10:28:06 400 s radegast: disabled
    2011/11/12 10:28:06 400 s http thread started
    2011/11/12 10:28:06 400 s creating thread for device /dev/ttyUSB0
    2011/11/12 10:28:06 400 s loadbalancer: can't read from file /tmp/.oscam/stat
    2011/11/12 10:28:06 400 s waiting for local card init
    2011/11/12 10:28:06 803 h HTTP Server listening on port 83
    2011/11/12 10:28:06 C04 r reader thread started (thread= C04, label=hd+, device=/dev/ttyUSB0, detect=cd, mhz=368, cardmhz=368)
    2011/11/12 10:28:09 C04 r hd+ card detected
    2011/11/12 10:28:17 C04 r ATR: **
    2011/11/12 10:28:18 C04 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.68 Mhz
    2011/11/12 10:28:21 C04 r detect native nagra card
    2011/11/12 10:28:35 C04 r card system not supported
    2011/11/12 10:28:35 C04 r Normal mode failed, reverting to Deprecated Mode
    2011/11/12 10:28:43 C04 r ATR: **
    2011/11/12 10:28:44 C04 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.68 Mhz
    2011/11/12 10:28:47 C04 r detect native nagra card
    2011/11/12 10:29:02 C04 r card system not supported
    2011/11/12 10:29:02 C04 r card initializing error
    2011/11/12 10:29:03 400 s init for all local cards done
    2011/11/12 10:29:03 400 s anti cascading disabled
     
    #8
  10. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: OSCam Server + Freetz Einrichtung

    OK, den Smargo auf: auto, normal, 0, 0 stellen.
    Es gibt für die Argolis mittlerweile ein Update 1.07.
    Ob das aber was bringt, kann ich nicht sagen.
     
    #9
  11. ulf05
    Offline

    ulf05 Guest

    AW: OSCam Server + Freetz Einrichtung

    Einstellungen Smargo von Dreambox auf Normal:

    Log:

    2011/11/12 10:38:41 400 s >> OSCam << cardserver started, version 1.10rc -DEB-Prof.Linux-, build #5990 (mipsel-router-linux-uclibc929)
    2011/11/12 10:38:41 400 s version=1.10rc -DEB-Prof.Linux-, build #5990, system=mipsel-router-linux, nice=-1
    2011/11/12 10:38:41 400 s client max. idle=120 sec, debug level=0
    2011/11/12 10:38:41 400 s max. logsize=2480 Kb, loghistorysize=4096 bytes
    2011/11/12 10:38:41 400 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms
    2011/11/12 10:38:41 400 s services reloaded: 0 services freed, 4 services loaded, rejected 0
    2011/11/12 10:38:41 400 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2011/11/12 10:38:41 400 s signal handling initialized (type=sysv)
    2011/11/12 10:38:42 400 s 11590 service-id's loaded in 744ms
    2011/11/12 10:38:42 400 s WARNING: You risk high CPU load and high ECM times with more than 2000 service-id´s!
    2011/11/12 10:38:42 400 s HINT: --> use optimized lists from

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    2011/11/12 10:38:42 400 s 116 tier-id's loaded
    2011/11/12 10:38:42 400 s 3 provid's loaded
    2011/11/12 10:38:42 400 s 22 lengths for caid guessing loaded
    2011/11/12 10:38:42 400 s monitor: initialized (fd=8, port=988)
    2011/11/12 10:38:42 400 s camd33: disabled
    2011/11/12 10:38:42 400 s camd35: disabled
    2011/11/12 10:38:42 400 s cs378x: disabled
    2011/11/12 10:38:42 400 s newcamd: initialized (fd=9, port=34000, crypted)
    2011/11/12 10:38:42 400 s CAID: 1830
    2011/11/12 10:38:42 400 s provid #0: 003411
    2011/11/12 10:38:42 400 s radegast: disabled
    2011/11/12 10:38:42 400 s http thread started
    2011/11/12 10:38:42 400 s creating thread for device /dev/ttyUSB0
    2011/11/12 10:38:42 400 s loadbalancer: can't read from file /tmp/.oscam/stat
    2011/11/12 10:38:42 400 s waiting for local card init
    2011/11/12 10:38:42 803 h HTTP Server listening on port 83
    2011/11/12 10:38:42 C04 r reader thread started (thread= C04, label=hd+, device=/dev/ttyUSB0, detect=cd, mhz=368, cardmhz=368)
    2011/11/12 10:38:45 400 s init for all local cards done
    2011/11/12 10:38:45 400 s anti cascading disabled
    2011/11/12 10:39:19 C04 r hd+ card detected
    2011/11/12 10:39:25 C04 r ATR: xxxxxxxxxxxxxxxxx
    2011/11/12 10:39:27 C04 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.68 Mhz
    2011/11/12 10:39:30 C04 r detect native nagra card
    2011/11/12 10:39:44 C04 r card system not supported
    2011/11/12 10:39:44 C04 r Normal mode failed, reverting to Deprecated Mode
    2011/11/12 10:39:51 C04 r ATR: xxxxxxxxxxxxxxxxx
    2011/11/12 10:39:52 C04 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.68 Mhz
    2011/11/12 10:39:55 C04 r detect native nagra card
    2011/11/12 10:40:10 C04 r card system not supported
    2011/11/12 10:40:10 C04 r card initializing error
     
    Zuletzt von einem Moderator bearbeitet: 12. November 2011
    #10
  12. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: OSCam Server + Freetz Einrichtung

    Stimmen die RSA etc. ?
    Ich weiß, die werden ja nirgendwo gepostet.
    Aber nochmal überprüfen, wäre ja möglich.
    Ist die KArte schon in einem anderen Receiver hell gewesen?
     
    #11
  13. ulf05
    Offline

    ulf05 Guest

    AW: OSCam Server + Freetz Einrichtung

    Also rsa und box stimmen. von faceless...
    Die Karte lief gestern noch in einem black panther smart...

    Wenn ich den Smartreader rausziehe und wieder einstecke kriege ich folgende Meldungen:


    2011/11/12 11:05:54 C04 r ERROR Phoenix_GetStatus: ioctl error in card detection for hd+

    Ziemlich viele davon, ist das normal?
     
    Zuletzt von einem Moderator bearbeitet: 12. November 2011
    #12
  14. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: OSCam Server + Freetz Einrichtung

    Nach dem Ziehen des Smargos kommt diese Fehlermeldung - normal.
    Es hilft dann nur, oscam auf dem Server neu zu starten.
    Was hast Du denn unter oscam - Einrichtung als Treiber?
    Bei "USB-Comport" muß ein Haken dran sein, unten in der "USB-Smartmouse" keiner.
     
    #13
  15. ulf05
    Offline

    ulf05 Guest

    AW: OSCam Server + Freetz Einrichtung

    Ah Ok!
    Als Treiber habe ich:
    Haken bei USB Comport mit einem Treiber aktivieren
    FTDI_SiO bei Modul wählen

    Sonst überall kein Haken.

    Habe den Smargo auf usb01 gesetzt und umgesteckt, das Gleiche...
     
    #14
  16. mxer
    Offline

    mxer Moderator Digital Eliteboard Team

    Registriert:
    20. September 2008
    Beiträge:
    13.883
    Zustimmungen:
    6.212
    Punkte für Erfolge:
    113
    AW: OSCam Server + Freetz Einrichtung

    Mal die Fritte neu gebootet?
    Manchmal braucht Oscam eine Weile, ehe es mit dem Smargo zusammenarbeiten möchte.
    Wenn es aber dann einmal geklappt hat, ist es kein Problem mehr.
     
    #15

Diese Seite empfehlen