1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

oscam reshare aktivieren

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Rockerking, 23. April 2012.

  1. Rockerking
    Offline

    Rockerking Freak

    Registriert:
    13. Juni 2010
    Beiträge:
    289
    Zustimmungen:
    14
    Punkte für Erfolge:
    18
    hallo ich wollte mal fragen wie ich einem bestimmten user reshare erlaube?
    also was ich da einstellen muss?

    danke schonmal im vorraus
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Online

    Kermit Guest

    Hallo Rockerking,

    es gibt 3 Stellen an denen du Einstellungen hierfür vornehmen kannst/mußt.
    oscam.conf
    reshare

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    Parameter ist optional

    Reshare-Level

    0 = kein Resharing (default)
    1 = nur Reshare für Direct-Peer
    2 = Reshare für Direct-Peer und den nächsten Level
    x = Reshare für Direct-Peer und die nächsten x Level (x steht für die Zahl der Level)
    10 = (default)

    Beispiel

    reshare = 1 Reshare nur für Direct-Peer

    schlocke:

    reshare kann auf 3 verschiedene Arten definiert werden:
    - über oscam.server [reader] ("cccreshare")
    - über oscam.conf [cccam] ("reshare")
    - über oscam.user [account] ["cccreshare")
    Ein reshare Wert wird auf den kleinsten Wert aller Parameter gesetzt! Wenn der Wert < 0 ist, wird die Karte nicht reshared.

    Grüße

    Kermit
     
    #2
  4. zhcip
    Offline

    zhcip Newbie

    Registriert:
    6. Juli 2009
    Beiträge:
    3
    Zustimmungen:
    86
    Punkte für Erfolge:
    13
    AW: oscam reshare aktivieren

    Hallo,

    Möchte an diesem Punkt auch nochmals nachfragen..

    Ich habe eine Smartcard auf UBUNTU Server mit OScam für lokale user funktioniert es.
    Nun möchte ich meine Karte meinem Kumpel resharen. Sind diese Einstellungen richtig für die Version 1.20us_SVN8555

    oscam.conf
    [cccam]
    reshare = 1
    ignorereshare = 1
    reshare_mode = 0


    oscam.user reshare ON
    cccmaxhops = 2
    cccreshare = 1
    cccignorereshare = 0


    oscam.user reshare OFF
    cccmaxhops = 2
    cccreshare = 0
    cccignorereshare = 1


    Danke für die Hilfe.. :)

    ZHCIP
     
    Zuletzt von einem Moderator bearbeitet: 28. März 2013
    #3
  5. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: oscam reshare aktivieren

    Hi,

    in oscam.conf stell den Wert auf 0.
    Code:
    ignorereshare = 0
    in der oscam.user den Parameter
    Code:
    cccignorereshare = -1
    Die anderen Werte lassen.

    Gruß
    Bombadil
     
    #4
  6. remz
    Offline

    remz Stamm User

    Registriert:
    5. Januar 2009
    Beiträge:
    1.166
    Zustimmungen:
    537
    Punkte für Erfolge:
    113
    AW: oscam reshare aktivieren

    Wie vergibt man denn verschiedene reshare für seine Clients?

    Dazu mal folgendes Szenario:

    Man hat 2 Clients denen man zwar alle seine Karten aber kein reshare geben will, der eine setzt z.B. dafür eine Dreambox ein und der andere z.B. einen Igel-Server.
    Der mit dem Igel-Server muss ich ja 1 x reshare geben sonst bekommt er auf seinen Resi nix zu sehen.

    Jetzt hört man aber von verschiedene Seiten das es nicht gerne gesehen wird das man in der oscam.conf ignorereshare = 1 setzt da der reshare vom Partner damit umgangen werden kann.

    Setze ich in der oscam.conf ignorereshare = 0 und reshare = 1 gilt das ja global für alle.

    Wenn ich jetzt in der oscam.user den Clienten verschiedene reshare level geben will cccreshare = 0 bzw. cccreshare = 1 greift das nicht da diese Option nur beachtet wird wenn in der oscam.conf "ignorereshare" auf "1" steht.
     
    Zuletzt bearbeitet: 28. März 2013
    #5
    Epidemic2011 gefällt das.
  7. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    AW: oscam reshare aktivieren

    also ich habe in der Config reshare = 1!

    alles weitere regel ich in der Oscam.user im Account!

    @remz bist du dir sicher das das nicht greifen soll? also wenn ich z.b. testweise meinen zweiten Igel einbinde und in im User cccreshare = 0 stelle wird über diesesn Oscam-server nix hell! also funzt es so wie es soll!
     
    Zuletzt bearbeitet: 28. März 2013
    #6
    StefanPe und bombadil gefällt das.
  8. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: oscam reshare aktivieren

    Hi,

    in der oscam.conf mit dem Parameter
    Code:
    reshare = 1
    
    legst du fest, wieviel Reshare du maximal vergeben willst. Danach kannst du mit dem Parameter
    Code:
    cccreshare = 1|0
    
    jedem User es noch einmal extra vergeben, maximal dann bis 1 (oscam.conf).

    Mit
    Code:
    cccreshare = -1
    
    ubernimmt der User den Eintrag der oscam.conf.

    Der mit dem Igel bekommt die 1 (oder -1), der mit der Dream bekommt die 0.

    Gruß
    Bombadil
     
    #7
    Ass55, remz und laila-no1 gefällt das.
  9. remz
    Offline

    remz Stamm User

    Registriert:
    5. Januar 2009
    Beiträge:
    1.166
    Zustimmungen:
    537
    Punkte für Erfolge:
    113
    AW: oscam reshare aktivieren

    @bombadil
    Schon klar, mir ging aber eher um den ignorereshare-Parameter in der oscam.conf

    @laila-no1
    Was hast du denn auf den zweiten Igel in der oscam.conf stehen ignorereshare = 0 oder 1?

    Selber getestet habe ich es noch nicht aber bei ignorereshare = 0 in der oscam.conf dürfte das in der oscam.user cccreshare = x doch gar nicht greifen.

    Laut Wiki in der oscam.conf:

    0 = benutze die Reshare-Einstellungen des Servers (default)
    1 = benutze die Reshare-Einstellungen des Readers oder Users

    PS. Vielleicht habe ich auch einen Denkfehler, von welchen Server ist denn da die Rede, vom eigenen oder einen den ich bei mir einbinde?

    Das würde dann so manches klären da ja über oscam.conf, oscam.server oder oscam.user immer der kleinste Wert aller Parameter gesetzt wird.
    Wenn der Wert < 0 ist, wird die Karte nicht reshared.
     
    Zuletzt bearbeitet: 28. März 2013
    #8
  10. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    AW: oscam reshare aktivieren

    hier mal meine oscam.conf!

    Code:
    # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r8450
    # Read more: http://www.streamboard.tv/svn/oscam/trunk/Distribution/doc/txt/oscam.conf.txt
    
    [global]
    logfile                       = /var/log/ipc/OScam.log
    usrfileflag                   = 1
    clienttimeout                 = 4000
    fallbacktimeout               = 2700
    bindwait                      = 20
    unlockparental                = 1
    nice                          = -1
    maxlogsize                    = 2048
    preferlocalcards              = 1
    dropdups                      = 1
    usrfile                       = /var/log/ipc/OScam_user.log
    lb_mode                       = 1
    lb_save                       = 4550
    lb_max_ecmcount               = 2450
    lb_reopen_seconds             = 1000
    lb_retrylimit                 = 3000
    lb_stat_cleanup               = 2
    lb_savepath                   = /var/log/loadb.log
    failbantime                   = 30
    failbancount                  = 3
    
    [cccam]
    port                          = XXXXX
    nodeid                        = 74EE387F106714C4
    version                       = 2.3.0
    [B][COLOR=#ff0000]reshare                       = 1[/COLOR][/B]
    
    [webif]
    httpport                      = +57579
    httpuser                      = xxxxx
    httppwd                       = xxxx
    httpcss                       = /var/etc/DBR_Proflinux_DDCStyle.css
    httptpl                       = /var/picons/
    httphelplang                  = de
    httprefresh                   = 10
    httpshowpicons                = 1
    httpallowed                   = 127.0.0.1,192.168.0.0-192.168.255.255
    httpforcesslv3                = 1
    httpdyndns                    = xxxxxxxxxxxxxxx
    aulow                         = 120
    

    hier meine Oscam.user - hier steht jetzt nur ein normaler Client und ein Sharepartnerclient der 1 x Reshare bekommt drinn!

    Code:
    [B][COLOR=#ff0000]#normaler Client ohne Reshare![/COLOR][/B]
    [account]
    user                          = user
    pwd                           = pwd
    description                   = Reciever
    uniq                          = 3
    sleepsend                     = 255
    suppresscmd08                 = 1
    group                         = 1,2,3,4,5,6,7,8,9,10,12,13,14,15,16,17
    cccmaxhops                    = 1
    [B][COLOR=#ff0000]cccreshare                    = 0[/COLOR][/B]
    
    [B][COLOR=#ff0000]#Sharepartner mit 1 x Reshare![/COLOR][/B]
    [account]
    user                          = user
    pwd                           = pwd
    description                   = Reciever/Server
    uniq                          = 3
    sleepsend                     = 255
    suppresscmd08                 = 1
    group                         = 1,2,3,4,5,6,7,8,9,10,12,13,14,15,16,17
    cccmaxhops                    = 1
    [B][COLOR=#ff0000]cccreshare                    = 1[/COLOR][/B]
    

    ignorereshare = 0 habe ich in Verwendung!
    also bei mir funzt das so wie ich das haben will!
     
    #9
    _me22, nsane, remz und 2 anderen gefällt das.
  11. karli9
    Offline

    karli9 Freak

    Registriert:
    5. Februar 2009
    Beiträge:
    292
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    AW: oscam reshare aktivieren

    Hallo

    Ich möchte dieses Thema nochmals aufgreifen da ich bei mir auch auf der Suche nach einem Problem bin.

    Und zwar habe ich auf meiner DM8000 (Oscam als EMU) einen CCcam-Proxy (oscam.server) angebunden und dieser erlaubt mir ein Reshare. Dieser Reshare möchte ich meiner zweiten Box DM7020 weitergeben.

    oscam.conf (DM8000)

    oscam.server (DM8000)

    oscam.user (DM8000)

    Auf der DM8000 kommen die Daten wunderbar an.

    Auf der DM7020HD kommt leider nichts an und bleibt dunkel.

    oscam.server (DM7020)

    Kann mir hier vielleicht jemand helfen und sieht was ich falsch mache?

    Vielen herzlichen Dank

    Gruss
     
    #10
  12. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    22.932
    Zustimmungen:
    16.220
    Punkte für Erfolge:
    113
    AW: oscam reshare aktivieren

    und reshare wird auch angezeigt? geh mal im WebIF auf READERS und bei dem Proxy auf den Button SHOW ENTITLEMENTS, dort ist zu sehen ob du reshare hast, sollte mindestens eine 1 stehen

    oder probiers mal über das cccam protokol weiterleiten

    configs stimmen auf der zweiten box?
     
    #11
  13. karli9
    Offline

    karli9 Freak

    Registriert:
    5. Februar 2009
    Beiträge:
    292
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    AW: oscam reshare aktivieren

    Das wäre dann noch die oscam.conf von der DM7020 (also Client)


    Den Reshare prüfe ich noch, sobald der Server wieder online ist (ist im Moment offline), aber vielen Dank mal.

    Gruss
     
    Zuletzt von einem Moderator bearbeitet: 21. Juli 2013
    #12
  14. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    22.932
    Zustimmungen:
    16.220
    Punkte für Erfolge:
    113
    AW: oscam reshare aktivieren

    da fehlen noch zwei wichtige Sachen und zwar -.Server,-.user

    prüf erstmal aber den reshare
     
    #13
  15. karli9
    Offline

    karli9 Freak

    Registriert:
    5. Februar 2009
    Beiträge:
    292
    Zustimmungen:
    15
    Punkte für Erfolge:
    18
    AW: oscam reshare aktivieren

    Also ich habe den Reshare geprüft und der ist auf der DM8000 (Server) auf 1.

    Und das ist noch das Log wenn ich auf der DM7020HD (Client) auf einen Kanal gehe der eigentlich funktionieren sollte.


    Gruss
     
    #14
  16. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    22.932
    Zustimmungen:
    16.220
    Punkte für Erfolge:
    113
    AW: oscam reshare aktivieren

    wie vorher schon vorgeschlagen

    probiers mal über das cccam protokol
     
    #15

Diese Seite empfehlen