1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam Raspberry Pi HD+ card initializing error

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von dr.h8ball, 31. Juli 2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. dr.h8ball
    Offline

    dr.h8ball Ist oft hier

    Registriert:
    8. Juni 2011
    Beiträge:
    105
    Zustimmungen:
    7
    Punkte für Erfolge:
    0
    Ich habe Raspian auf meinem Pi laufen, und habe mir OSCam per SVN selbst kompiliert, BUILD 7197, soweit läuft alles ganz gut, der Reader wird erkannt (Smargo) die Karte ist aktiviert, webif funktioniert.

    Nur leider kommen bei meinen Clients, dann auch immer Fehlermeldungen von wegen


    2012/07/31 5:41:36 2B7484E8 c dvbapi: new program number: EF74 (SAT.1 HD)

    2012/07/31 5:41:36 2B7484E8 c dvbapi (1830&000000/EF74/92:FF40): invalid (13 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:36 2B7484E8 c dvbapi (1843&000000/EF74/89:35BB): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:36 2B7484E8 c dvbapi (098C&000000/EF74/59:DBDF): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:36 2B7484E8 c dvbapi: try pids again #1
    2012/07/31 5:41:37 2B7484E8 c dvbapi (1860&000000/EF74/8F:36F8): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:37 2B7484E8 c dvbapi (1830&000000/EF74/92:FF40): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:37 2B7484E8 c dvbapi (1843&000000/EF74/89:35BB): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:37 2B7484E8 c dvbapi (098C&000000/EF74/59:DBDF): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:37 2B7484E8 c dvbapi: try pids again #2
    2012/07/31 5:41:37 2B7484E8 c dvbapi (1860&000000/EF74/8F:36F8): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:38 2B7484E8 c dvbapi (1830&000000/EF74/92:FF40): invalid (13 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:38 2B7484E8 c dvbapi (1843&000000/EF74/89:35BB): invalid (13 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:38 2B7484E8 c dvbapi (098C&000000/EF74/59:DBDF): invalid (12 ms) (of 0 avail 0) (invalid SID)
    2012/07/31 5:41:38 2B7484E8 c dvbapi: try pids again #3
    2012/07/31 5:41:38 2B7484E8 c dvbapi: can't decode channel
    2012/07/31 5:41:38 2B7484E8 c dvbapi (1860&000000/EF74/8F:36F8): invalid (12 ms) (of 0 avail 0) (invalid SID)

    Und bei mir im WEBIF finde ich dann auch noch folgende Meldung

    [TABLE="class: status, width: 100%"]
    [TR="class: r"]
    [TD="class: statuscol1, bgcolor: #FFF3E7"]0x201da78 [/TD]
    [TD="class: statuscol2, bgcolor: #FFF3E7"]r[/TD]
    [TD="class: statuscol3, bgcolor: #FFF3E7"]1[/TD]
    [TD="class: statuscol4, bgcolor: #FFF3E7, align: left"]hd+[/TD]
    [TD="class: statuscol5, bgcolor: #FFF3E7"]

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [TD="class: statuscol6, bgcolor: #FFF3E7"]OFF[/TD]
    [TD="class: statuscol7, bgcolor: #FFF3E7"]127.0.0.1[/TD]
    [TD="class: statuscol8, bgcolor: #FFF3E7"]0[/TD]
    [TD="class: statuscol9, bgcolor: #FFF3E7, align: left"]mouse[/TD]
    [TD="class: statuscol10, bgcolor: #FFF3E7"][/TD]
    [TD="class: statuscol11, bgcolor: #FFF3E7"][/TD]
    [TD="class: statuscol12, bgcolor: #FFF3E7"]0000:0000[/TD]
    [TD="class: statuscol13, bgcolor: #FFF3E7, align: left"][/TD]
    [TD="class: statuscol14, bgcolor: #FFF3E7"]

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [TD="class: statuscol15, bgcolor: #FFF3E7"]00:02:03[/TD]
    [TD="class: statuscol16, bgcolor: #FFF3E7"]ERROR

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    [/TD]
    [/TR]
    [/TABLE]


    Wenn ich meinen OSCam nun starten will mit "oscam" , bekomme ich folgende Ausgabe in der Konsole.

    root@raspberrypi:~# oscam
    09:03:07 0 s starting thread log_list_thread
    09:03:07 0 s log_list_thread thread started
    09:03:07 0 s >> OSCam << cardserver started, version 1.20-unstable_svn, build #7197 (arm-linux-gnueabihf)
    2012/07/31 09:03:07 0 s version=1.20-unstable_svn, build #7197, system=arm-linux-gnueabihf, nice=-1

    2012/07/31 09:03:07 0 s client max. idle=120 sec, debug level=0, filter_sensitive=1
    2012/07/31 09:03:07 0 s max. logsize=10 Kb, loghistorysize=4096 bytes
    2012/07/31 09:03:07 0 s client timeout=7000 ms, fallback timeout=3000 ms, cache delay=120 ms
    2012/07/31 09:03:07 0 s Cannot open file "/usr/local/etc/oscam.services" (errno=2 No such file or directory)
    2012/07/31 09:03:07 0 s userdb reloaded: 2 accounts loaded, 0 expired, 0 disabled
    2012/07/31 09:03:07 0 s signal handling initialized (type=sysv)
    2012/07/31 09:03:07 0 s can't open file "/usr/local/etc/oscam.srvid" (err=2 No such file or directory), no service-id's loaded
    2012/07/31 09:03:07 0 s can't open file "/usr/local/etc/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2012/07/31 09:03:07 0 s can't open file "/usr/local/etc/oscam.provid" (err=2 No such file or directory), no provids's loaded
    2012/07/31 09:03:07 0 s can't open file "/usr/local/etc/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2012/07/31 09:03:07 0 s starting thread arm_led_thread
    2012/07/31 09:03:07 0 s arm_led_thread thread started
    2012/07/31 09:03:07 0 s can't open whitelist file /usr/local/etc/oscam.whitelist
    2012/07/31 09:03:07 0 s can't open cacheex-matcher file /usr/local/etc/oscam.cacheex
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s monitor: disabled
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s camd35: disabled
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s cs378x: disabled
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s newcamd: initialized (fd=4, port=34001, crypted)
    2012/07/31 09:03:07 0 s -> CAID: 1843 PROVID: 003411
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s cccam: initialized (fd=5, port=12000, crypted)
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s pandora: disabled
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s csp: disabled
    2012/07/31 09:03:07 0 s Starting listener 0
    2012/07/31 09:03:07 0 s radegast: disabled
    2012/07/31 09:03:07 0 s starting thread http
    2012/07/31 09:03:07 0 s http thread started
    2012/07/31 09:03:07 0 s starting thread reader check
    2012/07/31 09:03:07 0 s reader check thread started
    2012/07/31 09:03:07 0 s starting thread check
    2012/07/31 09:03:07 0 s check thread started
    2012/07/31 09:03:07 0 s hd+ [mouse] creating thread for device /dev/ttyUSB0
    2012/07/31 09:03:07 721A78 h HTTP Server listening on port 8888
    2012/07/31 09:03:07 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/07/31 09:03:07 0 s waiting for local card init
    2012/07/31 09:03:09 720228 r hd+ [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=368, cardmhz=368)
    2012/07/31 09:03:11 0 s init for all local cards done
    2012/07/31 09:03:11 0 s anti cascading disabled
    2012/07/31 09:03:11 728EC0 c client connected to 34001 port
    2012/07/31 09:03:12 728EC0 c encrypted newcamd:34001-client 10.8.0.1 granted (smargo1, au=auto (1 reader))
    2012/07/31 09:03:12 728EC0 c user smargo1 authenticated successfully (CCcam)
    2012/07/31 09:03:12 728EC0 c AU disabled for user smargo1
    09:32:34 201DA78 r hd+ [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=368, cardmhz=368)
    09:32:35 201DA78 r hd+ [mouse] card detected
    09:32:42 201DA78 r hd+ [mouse] ATR: 3F FF 95 00 FF 91 81 71 A0 47 00 44 4E 41 53 50 31 38 30 20 4D 65 72 30 30 30 28
    09:32:44 201DA78 r hd+ [mouse] Maximum frequency for this card is formally 5 Mhz, clocking it to 3.68 Mhz
    09:32:46 201DA78 r hd+ [mouse] detect native nagra card
    09:32:54 201DA78 r hd+ [mouse] card system not supported
    09:32:54 201DA78 r hd+ [mouse] Normal mode failed, reverting to Deprecated Mode
    09:33:01 201DA78 r hd+ [mouse] ATR: 3F FF 95 00 FF 91 81 71 A0 47 00 44 4E 41 53 50 31 38 30 20 4D 65 72 30 30 30 28
    09:33:02 201DA78 r hd+ [mouse] Maximum frequency for this card is formally 5 Mhz, clocking it to 3.68 Mhz
    09:33:04 201DA78 r hd+ [mouse] detect native nagra card
    09:33:13 201DA78 r hd+ [mouse] card system not supported
    09:33:13 201DA78 r hd+ [mouse] card initializing error

    Hier sind noch meine Configs

    oscam.conf

    [global]nice = -1
    clientTimeout = 7
    fallbackTimeout = 3
    clientMaxIdle = 120
    cacheDelay = 120
    bindWait = 20
    #ResolveDelay = 15
    waitForCards = 1
    preferLocalCards = 1
    logFile = stdout


    [newcamd]
    port = 34001@1843:003411
    key = 0102030405060708091011121314
    allowed = 10.8.0.0-10.8.0.255,10.9.0.0-10.9.0.255
    keepalive = 1


    [cccam]
    port = 12000
    reshare = 1
    version = 2.3.0
    stealth = 1
    nodeid = 39CDC010109E14B8

    oscam.server

    [reader]
    enable = 1
    label = hd+
    group = 1
    device = /dev/ttyUSB0
    protocol = mouse
    rsakey = BF...............................................................D5

    boxkey = A7............7C
    detect = cd
    mhz = 368
    cardmhz = 368
    emmcache = 1,3,2
    lb_weight = 100
    caid = 1843

    oscam.user

    [account]
    user = smargo1
    pwd = smargo1
    numusers = 1
    au = 1

    Ich hoffe jemand von euch kann mir helfen.
    Ich wünsche noch einen schönen Tag, vielen Dank schon mal

    Dr.H8Ball
     
    Zuletzt bearbeitet: 31. Juli 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. IDDQD
    Offline

    IDDQD Board Guru

    Registriert:
    6. Februar 2008
    Beiträge:
    1.416
    Zustimmungen:
    635
    Punkte für Erfolge:
    113
    Beruf:
    IT'ler
    Ort:
    Zone
    AW: Oscam Raspberry Pi HD+ card initializing error

    wie istn der smargo eingestellt? ist deine oscam mit "serial" reader kompiliert? da du ja einen smargo nutzt würde ich dir dazu raten, macht das ganze ein wenig einfacher.

    vorraussetzung dafür smargo mit firmware 1,4 oder 1,5

    dann einfach die seriennummer des smargos "auslesen"

    "lsusb -v |grep iSerial >smargo.txt"
    dann mit
    "cat smargo.txt" wird dir ausgegeben welche seriennummern deine USB devices haben,

    dann kannst du im oscam.server
    so tun:
    [reader]
    enable = 1
    label = hd+
    group = 1
    device = Serial: seriennummer
    protocol = smartreader
    rsakey = BF................................................ ...............D5

    boxkey = A7............7C
    detect = cd
    mhz = 368
    cardmhz = 368
    emmcache = 1,3,2
    lb_weight = 100
    caid = 1843
     
    #2
  4. dr.h8ball
    Offline

    dr.h8ball Ist oft hier

    Registriert:
    8. Juni 2011
    Beiträge:
    105
    Zustimmungen:
    7
    Punkte für Erfolge:
    0
    AW: Oscam Raspberry Pi HD+ card initializing error

    das liefert mir cat < smargo.txt

    iSerial 1 bcm2708_usb
    iSerial 0
    iSerial 0
    iSerial 0
     
    #3
  5. IDDQD
    Offline

    IDDQD Board Guru

    Registriert:
    6. Februar 2008
    Beiträge:
    1.416
    Zustimmungen:
    635
    Punkte für Erfolge:
    113
    Beruf:
    IT'ler
    Ort:
    Zone
    AW: Oscam Raspberry Pi HD+ card initializing error

    weisst du denn was für ne firmware auf dem smargo ist?
    welcher hersteller ist es denn?! was steht hinten auf dem smargo drauf?

    argolis oder maxdigital!?

    hier findest du die firmware für den smargo wenn er von argolis ist. kann sicher auch auf einen maxdigital geflasht werden übernehme aber keine garantie dafür

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #4
  6. dr.h8ball
    Offline

    dr.h8ball Ist oft hier

    Registriert:
    8. Juni 2011
    Beiträge:
    105
    Zustimmungen:
    7
    Punkte für Erfolge:
    0
    AW: Oscam Raspberry Pi HD+ card initializing error

    Ich habe den Argolis, und nein weiß ich nicht ich bekomme ihn nicht unter Windows 7 zum laufen, kann ich das nicht unter Linux machen?
     
    #5
  7. Kermit
    Offline

    Kermit Guest

    AW: Oscam Raspberry Pi HD+ card initializing error

    Hi,

    doppelt

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    hält nicht immer besser und deswegen ist hier zu.

    Grüße

    Kermit
     
    #6
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen