1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem Oscam only auf Debian

Dieses Thema im Forum "OScam Archiv" wurde erstellt von berny1983, 2. Januar 2012.

  1. berny1983
    Offline

    berny1983 Hacker

    Registriert:
    16. Mai 2009
    Beiträge:
    386
    Zustimmungen:
    145
    Punkte für Erfolge:
    43
    Beruf:
    Steuerzahler
    Ort:
    AT
    Ich wünsche allen erstmal ein gutes neues Jahr!

    Nun zu meinem Problem, ich habe mir jetzt einen S300 zugelegt! Probiere schon seit Tagen dieses Ding zum sharen zu bringen, leider ohne Erfolg! Da ich auf der Dream Oscam only fahre, was auch ohne Probleme läuft, dachte ich, ich könnte einfach die ganzen Configs so auf dem Debian eintragen! Dieses bringt aber auch nichts!

    Auf dem Debian sind auch 2 Smarmouse angeschlossen mit ner ORF ICE und ner TNK! Gelesen werden sie auch anscheinend nur erhellen tun sie nichts! Dementsprechend auch die eingetragenen Klienten! Muss man Oscam only auf einem Debian anders konfigurieren?

    Hoffe ich habe das Problem halbwegs verständlich geschrieben! :)


    Sent from my iPhone using Tapatalk
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Online

    Kermit Guest

    AW: Oscam only auf Debian

    Naja ohne Configd bzw. der Ausgabe des Logs wird es schwer dir zu helfen.
     
    #2
  4. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam only auf Debian

    Kann mich meinen Vorredner nur anschließen, ohne Configs und Log kann dir nicht weitergeholfen werden.

    ps. Hab dich mal nach Oscam verschoben, da es kein IPC spezifisches Problem ist....
     
    #3
  5. berny1983
    Offline

    berny1983 Hacker

    Registriert:
    16. Mai 2009
    Beiträge:
    386
    Zustimmungen:
    145
    Punkte für Erfolge:
    43
    Beruf:
    Steuerzahler
    Ort:
    AT
    AW: Oscam only auf Debian

    war mir natürliich auch nicht sicher ob ich mein problem nicht im oscam bereich posten soll, diesbezüglich danke fürs verschieben!

    hier mal meine configs:

    oscam.config

    Code:
    
    [cccam] 
    port = 12000 
    reshare = 2 
    version = 2.2.1 
    
    [webif] 
    httpport                      = *** 
    httpuser                      = ***
    httppwd                       = ***
    httprefresh                   = 7 
    httpallowed                   = 127.0.0.1,192.168.1.0-192.168.1.255 
    httphideidleclients           = 1 
    httpreadonly                  = 0 
    httpsavefullcfg               = 0  
    
    [dvbapi] enabled = 1 
    au = 1 
    boxtype = dreambox 
    user = localuser 
    pmt_mode = 0
    request_mode = 0 
    
    [global] 
    logfile                       = stdout 
    clienttimeout                 = 5000 
    fallbacktimeout               = 2500 
    clientmaxidle                 = 120 
    cachedelay                    = 120 
    bindwait                      = 120 
    nice                          = -1 
    serialreadertimeout           = 1500 
    maxlogsize                    = 10 
    waitforcards                  = 1 
    saveinithistory               = 1 
    
    
    oscam.server

    Code:
    [reader]
    label                         = ***
    enable                        = 1
    protocol                      = cccam
    device                        = ****
    user                          = ****
    password                      = ***
    inactivitytimeout             = 1
    reconnecttimeout              = 30
    group                         = 1
    lb_weight                     = 100
    cccversion                    = 2.2.1
    cccmaxhops                    = 3
    ccckeepalive                  = 1
    
    
    [reader]
    label                         = orf
    enable                        = 1
    protocol                      = mouse
    device                        = /dev/ttyUSB0
    services                      = orf
    caid                          = 0D95
    detect                        = cd
    mhz                           = 500
    cardmhz                       = 357
    group                         = 1
    emmcache                      = 1,3,2
    lb_weight                     = 100
    
    [reader]
    label                         = tnk
    enable                        = 1
    protocol                      = mouse
    device                        = /dev/ttyUSB1
    services                      = tnk
    caid                          = 0b00
    detect                        = cd
    mhz                           = 500
    cardmhz                       = 357
    group                         = 1
    emmcache                      = 1,3,2
    lb_weight                     = 100
    
    
    oscam.user

    Code:
    [account]
    user                          = DM800HD
    pwd                           = ***
    group                         = 1
    cccmaxhops                    = 3
    cccreshare                    = 1
    
    
    wie genau muss ich denn die mouses einstellen am reader selbst?
    ich habe es mal so für die orf karte und die tnk eingestellt:

    5v
    smartmouse
    3,579mhz
    6mhz
     
    #4
  6. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam only auf Debian

    lösch mal bitte folgendes aus der oscam.conf:

    Code:
    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = localuser
    pmt_mode = 0r
    request_mode = 0 
    
    und füge mal folgendes ein:

    Code:
    [cccam]
    port = 12000
    reshare = 1
    ignorereshare = 0
    version = 2.2.1
    updateinterval = 240
    minimizecards = 0
    keepconnected = 1
    stealth = 1
    reshare_mode = 0
    
    Die C-Line für deine Dreambox sollte dann so aussehen:

    C: ipvomdebian 12000 DM800HD ***

    Die roten Parameter musst du natürlich anpassen :emoticon-0105-wink:
     
    #5
    szonic gefällt das.
  7. berny1983
    Offline

    berny1983 Hacker

    Registriert:
    16. Mai 2009
    Beiträge:
    386
    Zustimmungen:
    145
    Punkte für Erfolge:
    43
    Beruf:
    Steuerzahler
    Ort:
    AT
    AW: Oscam only auf Debian

    dvpapi war ich mir nicht sicher ob ich es löschen musste, gesagt getan. fügte auch deine config ein, leider ohne erfolg! die c-line sieht e so aus auf der box:emoticon-0105-wink:
     
    #6
  8. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam only auf Debian

    Was heißt kein Erfolg? Poste mal dein Log.
     
    #7
  9. berny1983
    Offline

    berny1983 Hacker

    Registriert:
    16. Mai 2009
    Beiträge:
    386
    Zustimmungen:
    145
    Punkte für Erfolge:
    43
    Beruf:
    Steuerzahler
    Ort:
    AT
    AW: Oscam only auf Debian

    jier mal der log:

    Code:
    2012/01/02 11:03:29 2722 r05 ERROR: Could not read reader->convention  
    2012/01/02 11:03:29 2722 r05 Error activating card. 
    2012/01/02 11:03:33  2722 r05 ATR is malformed, it reports 14 historical bytes but there are only 12  
    2012/01/02 11:03:34 2722 r05 ATR: *******************
    2012/01/02 11:03:34 2722 r05 ERROR: Could not read  reader->convention 
    2012/01/02 11:03:34 2722 r05 Error activating card.  
    2012/01/02 11:03:35 2722 r05 card initializing error 
    2012/01/02 11:03:35  2716 s init for all local cards done 
    2012/01/02 11:03:35 2716 s anti  cascading disabled 
    2012/01/02 11:03:35 2716 s dvbapi: dvbapi disabled  
    2012/01/02 11:03:35 2716 s client(1) connect from 192.168.1.100 (pid=2724,  pipfd=15) 
    2012/01/02 11:03:35 2716 s client(2) connect from 192.168.1.100  (pid=2725, pipfd=16) 
    2012/01/02 11:03:35 2725 c02 account '' not found!  
    2012/01/02 11:03:35 2724 c01 account '' not found! 
    2012/01/02 11:03:35  2725 c02 cccam: 2773 failed errno: 0 (Success) 
    2012/01/02 11:03:35 2724 c01  cccam: 2773 failed errno: 0 (Success) 
    2012/01/02 11:03:35 2725 c02 anonymous  disconnected from 192.168.1.100 
    2012/01/02 11:03:35 2724 c01 anonymous  disconnected from 192.168.1.100 
    2012/01/02 11:03:43 2716 s client(1) connect  from 192.168.1.100 (pid=2748, pipfd=15) 
    2012/01/02 11:03:43 2748 c01  encrypted cccam-client 192.168.1.100 granted (DM800HD, au=0) 
    2012/01/02  11:03:43 2748 c01 cccam(s) DM800HD: client 'DM800HD' (E624B24D8E599EA8) running  v2.1.3 (3165) 
    2012/01/02 11:03:43 2748 c01 cccam(s) DM800HD: version: 2.1.1,  build: 2971 nodeid: E624B24D8E599EA8 
    2012/01/02 11:03:43 2748 c01 cccam(s)  DM800HD: reported 2 cards to client 
    2012/01/02 11:04:58 2748 c01 cccam(s)  DM800HD: reported 2 cards to client 
    2012/01/02 11:06:13 2748 c01 cccam(s)  DM800HD: reported 2 cards to client 
    2012/01/02 11:07:28 2748 c01 cccam(s)  DM800HD: reported 2 cards to client 
    2012/01/02 11:08:43 2748 c01 cccam(s)  DM800HD: reported 2 cards to client 
    
     
    #8
  10. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam only auf Debian

    Anscheinend wird die ATR falsch ausgelesen - warum auch immer....

    Versuch mal bitte eine andere Oscam Version. Außerdem würde ich mal die mhz für beide Reader löschen...

    Kannst du bei deinem Cardreader auf phoenix umstellen?
     
    #9
  11. berny1983
    Offline

    berny1983 Hacker

    Registriert:
    16. Mai 2009
    Beiträge:
    386
    Zustimmungen:
    145
    Punkte für Erfolge:
    43
    Beruf:
    Steuerzahler
    Ort:
    AT
    AW: Oscam only auf Debian

    habe jetzt mal beide mhz gelöscht und jetzt funktioniert die ice karte!tnk ist nach wie vor dunkel. im WI bei oscam steht bei beide karten aber "card ok" meine eingetragen clienten bleiben auch auf offline. im log steht "configuration error" ?
     
    #10
  12. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam only auf Debian

    Hast du den Port freigegeben? DynDns ist aktuell? Die TNK Karte kenne ich leider nicht....
     
    #11
  13. berny1983
    Offline

    berny1983 Hacker

    Registriert:
    16. Mai 2009
    Beiträge:
    386
    Zustimmungen:
    145
    Punkte für Erfolge:
    43
    Beruf:
    Steuerzahler
    Ort:
    AT
    12000er port ist schon freigegeben und die dyn-adresse ist auch aktuell! eigenartig dass ich keine verbindung zu meine klienten bekomme!


    Sent from my iPhone using Tapatalk
     
    #12
  14. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam only auf Debian

    Hast du die Clienten in der oscam.user angelegt?
     
    #13
  15. berny1983
    Offline

    berny1983 Hacker

    Registriert:
    16. Mai 2009
    Beiträge:
    386
    Zustimmungen:
    145
    Punkte für Erfolge:
    43
    Beruf:
    Steuerzahler
    Ort:
    AT
    die c-lines befinden sich in oscam.server und die f-lines im oscam.user

    habe es ja 1:1 kopiert von der dream auf den server! auf der dream funktioniert alles einwandfrei (außer tnk...noch nicht gestestet)


    Sent from my iPhone using Tapatalk

    kann das sein dass es vieleicht daran liegt, dass ich in der dream 12000er port bei cccam habe und beim debian auch den gleichen verwende auf oscam?


    Sent from my iPhone using Tapatalk
     
    Zuletzt von einem Moderator bearbeitet: 3. Januar 2012
    #14
  16. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Oscam only auf Debian

    Ja kann daran liegen, weil der Port ja dann doppelt belegt ist. Normalerweise sollte ne Fehlermeldung kommen...
     
    #15

Diese Seite empfehlen