1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

oscam mit cccam verbinden

Dieses Thema im Forum "Archiv" wurde erstellt von chrisclarke, 17. November 2011.

  1. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    Hallo ich habe ein kleines problem das mich verrückt macht.
    Ich habe einen futro s400 mit debia und ipc .
    Insatlliert ist cccam 2.1.3 / oscam
    bis jetzt hab ich es geschaft das oscam die schwarze hd + ausliest ( entilements werden angezeigt ) aber sie gibt die karte nicht an cccam weiter.
    Cccam liest die sky s02 auch perfekt aus aber ich bekomm die n linie nicht zum laufen .
    Ich bin nur über ipc mit dem server verbunden .

    Meine Daten:
    cfg
    N: 127.0.0.1 34002 cccam cccam 01 02 03 04 05 06 07 08 09 10 11 12 13 14

    oscam:

    oscam user : pass: cccam
    group: 1,2
    caid : 1843
    indent: 1843:000000,003411,008011
    au: hd+,hd+1

    oscam newcamd : port : 34002@1843:003411
    key: 0102030405060708091011121314

    Webinterface Config : Http allowed:127.0.0.1,192.168.1.0-192.168.1.255
    port : 83
    user: user
    pass: pass

    Ich hoffe es kann mir einer helfen denn ich habe schon den 1 tag gebrauch bis ich die schwarze hd+ zum laufen gebracht habe und jetzt funktioniert das mit der nline nicht.
    unter oscamwebif wird der user immer als offline angezeigt und im oscam log steht das beim neustart :

    >> OSCam << cardserver started, version 1.20-unstable_svn, build #5734 (i686-pc-linux)
    2011/11/17 13:52:07 9167418 s version=1.20-unstable_svn, build #5734, system=i686-pc-linux, nice=0
    2011/11/17 13:52:07 9167418 s client max. idle=120 sec, debug level=0
    2011/11/17 13:52:07 9167418 s max. logsize=1024 Kb, loghistorysize=4096 bytes
    2011/11/17 13:52:07 9167418 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=0 ms
    2011/11/17 13:52:07 9167418 s Cannot open file "/var/etc/oscam.services" (errno=2 No such file or directory)
    2011/11/17 13:52:07 9167418 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2011/11/17 13:52:07 9167418 s signal handling initialized (type=sysv)
    2011/11/17 13:52:07 9167418 s can't open file "/var/etc/oscam.srvid" (err=2 No such file or directory), no service-id's loaded
    2011/11/17 13:52:07 9167418 s can't open file "/var/etc/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2011/11/17 13:52:07 9167418 s can't open file "/var/etc/oscam.provid" (err=2 No such file or directory), no provids's loaded
    2011/11/17 13:52:07 9167418 s can't open file "/var/etc/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2011/11/17 13:52:07 9167418 s monitor: disabled
    2011/11/17 13:52:07 9167418 s camd33: disabled
    2011/11/17 13:52:07 9167418 s camd35: disabled
    2011/11/17 13:52:07 9167418 s cs378x: disabled
    2011/11/17 13:52:07 9167418 s newcamd: initialized (fd=5, port=34002, ip=127.0.0.1, crypted)
    2011/11/17 13:52:07 9167418 s -> CAID: 1843 PROVID: 003411
    2011/11/17 13:52:07 9167418 s radegast: disabled
    2011/11/17 13:52:07 9167418 s http thread started
    2011/11/17 13:52:07 9167418 s reader check thread started
    2011/11/17 13:52:07 9167418 s check thread started
    2011/11/17 13:52:07 9167418 s creating thread for device /dev/ttyUSB1
    2011/11/17 13:52:07 9167418 s creating thread for device /dev/ttyUSB2
    2011/11/17 13:52:07 9167418 s loadbalancer: can't read from file /tmp/.oscam/stat
    2011/11/17 13:52:07 9167418 s waiting for local card init
    2011/11/17 13:52:07 9172430 r ERROR opening device /dev/ttyUSB2
    2011/11/17 13:52:07 9172430 r Cannot open device: /dev/ttyUSB2
    2011/11/17 13:52:07 9173BC8 h HTTP Server listening on port 83
    2011/11/17 13:52:09 9170CC0 r reader hd+ initialized (device=/dev/ttyUSB1, detect=cd, mhz=357, cardmhz=357)
    2011/11/17 13:52:10 0 hd+ card detected
    2011/11/17 13:52:17 9170CC0 r ATR: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    2011/11/17 13:52:18 9170CC0 r Maximum frequency for this card is formally 5 Mhz, clocking it to 3.57 Mhz
    2011/11/17 13:52:19 9170CC0 r detect native nagra card
    2011/11/17 13:52:20 9170CC0 r [nagra-reader] type: NAGRA, caid: 1843, IRD ID: FF FF FF FF
    2011/11/17 13:52:20 9170CC0 r [nagra-reader] ProviderID: 00 00 34 11
    2011/11/17 13:52:20 9170CC0 r [nagra-reader] active to: 2012/01/04 11:59
     
    Zuletzt von einem Moderator bearbeitet: 17. November 2011
    #1
  2. phantom

    Nervigen User Advertisement

  3. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: oscam mit cccam verbinden

    Wenn das im oscam webif steht : 1 hd+ ON OFF 127.0.0.1 0 mouse 17.11.11 14:39:39 00:04:13 0000:0000 no data 00:04:13 CARDOK (1 entitlement

    Das ist doch die ip die in der nlinie stehen muss oder ?
     
    #2
  4. xetic
    Offline

    xetic Board Guru

    Registriert:
    24. November 2010
    Beiträge:
    1.372
    Zustimmungen:
    255
    Punkte für Erfolge:
    83
    AW: oscam mit cccam verbinden

    Du hast in der CCcam.cfg falschen User/PW eingetragen

    In der Oscam.user steht:
    oscam user : pass: cccam
    was eigentlich falsch ist ^^

    schau mal hier

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


     
    #3
  5. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: oscam mit cccam verbinden

    Habs jetzt so aber immer noch das gleiche .
    Hab mir denn link tread angeschaut und nachgebessert aber geht auch nicht.
     
    #4
  6. xetic
    Offline

    xetic Board Guru

    Registriert:
    24. November 2010
    Beiträge:
    1.372
    Zustimmungen:
    255
    Punkte für Erfolge:
    83
    AW: oscam mit cccam verbinden

    Du musst schauen, das die Angaben in der oscam.user (user und pw) gleich sind, wie die N-Line in der CCcam.cfg!
     
    #5
  7. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: oscam mit cccam verbinden

    ja ich weiss wenn ich beim oscamwebif einen neuen user anlege dann steht dort new user : dann schreib ich hier user rein , dann drücke ich ok , und dann kommt schon der password eintrag .
    Aber wenn ich mir dann denn user anschaue steht unter label : user stimmt das .
    Ich hab im webif keinen eintrag user : ?
     
    #6
  8. xetic
    Offline

    xetic Board Guru

    Registriert:
    24. November 2010
    Beiträge:
    1.372
    Zustimmungen:
    255
    Punkte für Erfolge:
    83
    AW: oscam mit cccam verbinden

    Warum machst du das über das WebIF ^^
    mach es direkt am IPC mit vi/vim oder über IPC Werkzeuge
    Befehl "o" und dann schau wie du weiter kommst zu oscam.user
    Ich glaube o user ^^
     
    #7
  9. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: oscam mit cccam verbinden

    Hier meine einstellungen direkt aus dem putty

    oscam.config

    Code:
    [global]
    serverip                      = 127.0.0.1
    logfile                       = /var/log/ipc/OScam.log
    nice                          = 0
    maxlogsize                    = 1024
    
    [monitor]
    hideclient_to                 = 15
    appendchaninfo                = 0
    
    [newcamd]
    port                          = 27000@1843:003411
    serverip                      = 127.0.0.1
    key                           = 0102030405060708091011121314
    allowed                       = 127.0.0.1,0.0.0.0-255.255.255.255
    mgclient                      = 1

    oscam.user

    Code:
    [account]
    user                          = user
    pwd                           = pwd
    group                         = 1
    au                            = 1
    caid                          = 1843
    betatunnel                    = 1833.FFFF:1702
    cccmaxhops                    = 0
    cccreshare                    = 0
    cccstealth                    = 0

    cccam.cfg


    N: 127.0.0.1 27000 user pwd 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256

    #####Allgemeine Einstellungen

    ALLOW TELNETINFO: yes # Ansonsten ist PORT 16000 offen
    TELENETINFO LISTEN PORT : 16000
    MINIMUM DOWNHOPS: 1 # Nur Karten annehmen die weitergegeben k�nnen
    DISABLE EMM : no # Ansonsten kommen keine Updates auf die Karten
    SHOW TIMING : yes # Antwortzeiten der Karten in Webansicht anzeigen

    PROVIDERINFO FILE : /var/keys/CCcam.providers
    CHANNELINFO FILE : /var/keys/CCcam.channelinfo

    SERVER LISTEN PORT : 12000
    WEBINFO LISTEN PORT : 16001

    WEBINFO USERNAME : cccam
    WEBINFO PASSWORD : cccam
     
    Zuletzt von einem Moderator bearbeitet: 18. November 2011
    #8
  10. xetic
    Offline

    xetic Board Guru

    Registriert:
    24. November 2010
    Beiträge:
    1.372
    Zustimmungen:
    255
    Punkte für Erfolge:
    83
    AW: oscam mit cccam verbinden

    Jetzt noch die oscam.reader...
     
    #9
  11. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: oscam mit cccam verbinden

    [reader]
    label = hd+
    description = 1
    protocol = mouse
    device = /dev/ttyUSB1
    smargopatch = 1
    showcls = 0
    caid = 1843
    rsakey =
    boxkey =
    detect = cd
    mhz = 357
    cardmhz = 357
    ident = 1843:003411,000000,008011
    group = 1
    emmcache = 1,3,2
     
    #10
  12. xetic
    Offline

    xetic Board Guru

    Registriert:
    24. November 2010
    Beiträge:
    1.372
    Zustimmungen:
    255
    Punkte für Erfolge:
    83
    AW: oscam mit cccam verbinden

    Ich denke in rsakey und boxkey steht das richtige drinne ^^
    ok, wenn das startup log von oscam so aussieht wie im ersten Post, dann ließt er die Karte richtig aus.

    Hast du nach den Änderung OScam und CCcam neugestartet?
    Wie sieht das Log von CCcam aus?

    Ich weis nicht ob 256 Trick bei der CCcam Version funktioniert oder die N-Line dadurch ungültig wird. Nimm es erstmal raus
     
    #11
  13. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: oscam mit cccam verbinden

    Hier der log von ccam aus dem putty :

    Nov 17 15:53:22 debian CCcam: local ecm <- card /dev/ttyUSB0 ok
    Nov 17 15:53:22 debian CCcam: client wohn1 ecm request for handler 0x64 0x1702(0 x0) sid 0x14 ok: 1 (took 0.7294 seconds)
    Nov 17 15:53:28 debian CCcam: ================================================== ====================
    Nov 17 15:53:28 debian CCcam: starting CCcam 2.1.3 compiled on Nov 14 2009@00:48 :18
    Nov 17 15:53:28 debian CCcam: ================================================== ====================
    Nov 17 15:53:28 debian CCcam: online using nodeId xxxxxxxxx
    Nov 17 15:53:28 debian CCcam: create 1 cam device(s)
    Nov 17 15:53:28 debian CCcam: /dev/ttyUSB0 configured clock frequency: 6000000 H z
    Nov 17 15:53:28 debian CCcam: calculated EGT: 0 us
    Nov 17 15:53:28 debian CCcam: irdeto card found
    Nov 17 15:53:31 debian CCcam: camkey challenge ok
    Nov 17 15:53:31 debian CCcam: card added to broker with caid 1702
    Nov 17 15:53:31 debian CCcam: added 0 keys from /var/keys/SoftCam.Key
    Nov 17 15:53:31 debian CCcam: added 0 keys from /var/keys/AutoRoll.Key
    Nov 17 15:53:31 debian CCcam: static cw not found or bad
    Nov 17 15:53:31 debian CCcam: parsed 0 entries from /var/etc/CCcam.prio
    Nov 17 15:53:31 debian CCcam: added 752 provider names from /var/keys/CCcam.prov iders
    Nov 17 15:53:31 debian CCcam: added 11471 channel names from /var/keys/CCcam.cha nnelinfo
    Nov 17 15:53:31 debian CCcam: server started on port 12000
    Nov 17 15:53:36 debian CCcam: login from 192.168.1.105
    Nov 17 15:53:36 debian CCcam: user schlaf login attempt from 192.168.1.105
    Nov 17 15:53:36 debian CCcam: client schlaf@217f0c640c64e7af, running CCcam 2.2. 1
    Nov 17 15:53:37 debian CCcam: login from 192.168.1.101
    Nov 17 15:53:37 debian CCcam: user wohn1 login attempt from 192.168.1.101
    Nov 17 15:53:37 debian CCcam: client wohn1@6308ed863700d7d0, running CCcam 2.2.1 Nov 17 15:53:50 debian CCcam: client schlaf ecm request for handler 0x66 0x1843( 0x0) sid 0xef15 ok: 0 (took 0.0648 seconds)^C

    root@debian ~ > c restart
    CCcam : restart
    CCcam : beendet
    CCcam : gestartet

    root@debian ~ > c log
    CCcam-Server: Log - Abbrechen mit [Strg]+[C] 17.11.2011 15:54

    ===============================================================================

    Nov 17 15:54:18 debian CCcam: configfile changed. Updating...
    Nov 17 15:54:31 debian CCcam: configfile changed. Updating...
    Nov 17 15:54:45 debian CCcam: ================================================== ====================
    Nov 17 15:54:45 debian CCcam: starting CCcam 2.1.3 compiled on Nov 14 2009@00:48 :18
    Nov 17 15:54:45 debian CCcam: ================================================== ====================
    Nov 17 15:54:45 debian CCcam: online using nodeId xxxxxxxxxx
    Nov 17 15:54:45 debian CCcam: create 1 cam device(s)
    Nov 17 15:54:46 debian CCcam: /dev/ttyUSB0 configured clock frequency: 60 z
    Nov 17 15:54:46 debian CCcam: calculated EGT: 0 us
    Nov 17 15:54:46 debian CCcam: irdeto card found
    Nov 17 15:54:49 debian CCcam: camkey challenge ok
    Nov 17 15:54:49 debian CCcam: card added to broker with caid 1702
    Nov 17 15:54:49 debian CCcam: added 0 keys from /var/keys/SoftCam.Key
    Nov 17 15:54:49 debian CCcam: added 0 keys from /var/keys/AutoRoll.Key
    Nov 17 15:54:49 debian CCcam: static cw not found or bad
    Nov 17 15:54:49 debian CCcam: parsed 0 entries from /var/etc/CCcam.prio
    Nov 17 15:54:49 debian CCcam: added 752 provider names from /var/keys/CCc iders
    Nov 17 15:54:49 debian CCcam: added 11471 channel names from /var/keys/CC nnelinfo
    Nov 17 15:54:49 debian CCcam: server started on port 12000
    Nov 17 15:54:52 debian CCcam: login from 192.168.1.105
    Nov 17 15:54:52 debian CCcam: user schlaf login attempt from 192.168.1.10
    Nov 17 15:54:52 debian CCcam: client schlaf@217f0c640c64e7af, running CCc 1
    Nov 17 15:54:52 debian CCcam: login from 192.168.1.101
    Nov 17 15:54:52 debian CCcam: user wohn1 login attempt from 192.168.1.101
    Nov 17 15:54:52 debian CCcam: client wohn1@6308ed863700d7d0, running CCca
     
    Zuletzt von einem Moderator bearbeitet: 18. November 2011
    #12
  14. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    AW: oscam mit cccam verbinden

    Hab eine linie zum schlaf zimmer wo hd + eingeschaltet ist .
    Aber im log seh ich jetzt kein versuch nach oscam zu berbinden oder ?

    Hab die 256 weck gemacht und nach jeder änderung einen neustart gemacht .
     
    Zuletzt bearbeitet: 17. November 2011
    #13
  15. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    AW: oscam mit cccam verbinden

    Das ist doch OK, Karte wird gelesen und übergeben!

    Schmeisse das mal aus dem User raus:
    betatunnel = 1833.FFFF:1702
    cccmaxhops = 0
    cccreshare = 0
    cccstealth = 0

    Dann machst Du noch eine F-Line in der cccam.cfg: F: user pass

    und auf dem Clienten wo Du schauen möchtest die C-Line dazu: c: ip 12000 user Pass

    Dann sollte es da helle werden.

    Grüsse
    szonic
     
    #14
  16. chrisclarke
    Offline

    chrisclarke Hacker

    Registriert:
    9. Februar 2010
    Beiträge:
    369
    Zustimmungen:
    13
    Punkte für Erfolge:
    0
    F line und c line hab ich schon fürs schlaf zimmer und dort habe ich auf einen hd+ sender geschalten aber wird trotzdem nicht hell. hey szonic bei mir ist das problem das oscam sich nicht zu cccam verbindet obwohl alle einstellungen passen müssten . Die sky karte wird von cccam gelesen und weitergegeben . Die hd + karte wir von oscam auch gelesen aber nicht weitergegeben . Im webif von oscam ist der user immer offline warum?
     
    Zuletzt von einem Moderator bearbeitet: 17. November 2011
    #15

Diese Seite empfehlen