1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Oscam hell, dann disconnect

Dieses Thema im Forum "OScam Archiv" wurde erstellt von floyd777, 7. März 2011.

  1. floyd777
    Offline

    floyd777 Newbie

    Registriert:
    22. Februar 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    Ich bin neu im Bereich CS und bin auf ein Problem gestoßen, bei dem ich nicht mehr weiter weiss. Vielleicht kann mir hier jemand weiterhelfen. Ich wäre EUch wirklich dankbar. Nach langem habe ich es geschafft den Oscam Server (3205) auf einer Fritz-Box mit einer ORF-ICE in einem Smargo (Maxdigital) zum laufen zu bringen (Protokoll: mouse). Mein Client (TF-7750 mit Enigma2) lauft mit Oscam Client (4736) und verbindet sich zum Server über das Protokoll camd35. Die Sender werden hell (ORF HD, ATV,....).

    Nun zum Problem: Sobald ich auf einen nicht verschlüsselten Sender wechsle, beendet der Server den entsprechenden Thread zum Client nach wenigen Minuten. Wenn ich dann am Receiver auf einen verschlüsselten Kanal (z.B. ORF1) zurückwechsle wird der nicht mehr hell. Neustart des Oscam-Client bringt nichts. Erst ein Neustart des Oscam-Servers macht den Kanal wieder hell.

    Anbei die Logs des Servers und Clients (192.168.178.21 ist der Client). Bug im Oscam oder mein Fehler? Keepalive ist sowohl am Server als auch am Client beim User ON. Im Webif sind Lines OK und die Karte auf CARDOK. Beim Client steht im Status immer Connected. Mit dem Parameter Supresscmd08 habe ich auch schon herumgespielt, hat aber nichts gebracht.



    Server (Oscam 3205)

    2011/03/06 18:38:00 8951 r02 user emmtype=shared, len=95, idx=4, cnt=1: written (105 ms) by orf
    2011/03/06 18:38:02 9214 c03 user (0D95&000004/132F/B8:331D): found (186 ms) by orf - ORF 1 HD [CW-ICE]
    2011/03/06 18:38:13 9214 c03 user (0D95&000004/132F/B8:954C): found (187 ms) by orf - ORF 1 HD [CW-ICE]
    2011/03/06 18:38:22 9214 c03 user (0D95&000004/132F/B8:8169): found (187 ms) by orf - ORF 1 HD [CW-ICE]
    2011/03/06 18:38:32 9214 c03 user (0D95&000004/132F/B8:0346): found (187 ms) by orf - ORF 1 HD [CW-ICE]
    2011/03/06 18:38:42 9214 c03 user (0D95&000004/132F/B8:4453): found (185 ms) by orf - ORF 1 HD [CW-ICE]
    2011/03/06 18:40:42 9214 c03 user disconnected from 192.168.178.21 2011/03/06 18:40:42 9214 c03 thread 3 ended!


    Client (oscam 4736)

    2011/03/06 18:36:56 2B77B4E8 c dvbapi: new program number: 132F (ORF1 HD)
    2011/03/06 18:36:56 2AF7B4E8 p 192.168.178.1: resolved ip=192.168.178.1
    2011/03/06 18:36:59 2B77B4E8 c dvbapi: Start descrambling PID #4 (CAID: 0D95) 1
    2011/03/06 18:36:59 2AF7B4E8 p cs357 CMD05 AU request for caid: 0D95 auprovid: 000004
    2011/03/06 18:36:59 2B77B4E8 c dvbapi (0D95&000004/132F/B8:63FC): cache2 (3297 ms) by cs357 (of 0 avail 0) - ORF 1 HD [CW-ICE]
    2011/03/06 18:38:32 2B77B4E8 c dvbapi (0D95&000004/132F/B8:0346): found (191 ms) by cs357 (of 0 avail 0) - ORF 1 HD [CW-ICE]
    2011/03/06 18:38:42 2B77B4E8 c dvbapi (0D95&000004/132F/B8:4453): found (189 ms) by cs357 (of 0 avail 0) - ORF 1 HD [CW-ICE]
    2011/03/06 18:38:53 2B77B4E8 c dvbapi: new program number: 43A3 (0000:43A3 unknown)
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. T1x
    Offline

    T1x VIP

    Registriert:
    11. Juni 2010
    Beiträge:
    3.859
    Zustimmungen:
    2.720
    Punkte für Erfolge:
    113
    AW: Oscam hell, dann disconnect

    Poste mal deine Configs bitte und prüfe das Oscam Log auf segfaults...
     
    #2
  4. floyd777
    Offline

    floyd777 Newbie

    Registriert:
    22. Februar 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: Oscam hell, dann disconnect

    Also segfaults habe ich in den Logs keine gefunden.

    Wenn am Client wieder auf einen verschlüsselten Kanal zurückwechsle kommt folgendes:
    2011/03/08 0:29:05 2B77B4E8 c dvbapi (0D95&000004/132F/B8:AC94): timeout (7081 ms) by cs357 (of 0 avail 0) - ORF 1 HD [CW-ICE]
    2011/03/08 0:29:05 2B77B4E8 c dvbapi (1702&000000/132F/93:BD15): rejected caid (129 ms) (of 0 avail 0) - 1702:132F unknown (invalid caid 1702)
    2011/03/08 0:29:06 2B77B4E8 c dvbapi (1833&000000/132F/89:7EFC): rejected caid (129 ms) (of 0 avail 0) - 1833:132F unknown (invalid caid 1833)
    2011/03/08 0:29:06 2B77B4E8 c dvbapi: try pids again #3
    2011/03/08 0:29:06 2B77B4E8 c dvbapi: can't decode channel

    Das sind meine Settings:

    SERVER BOX
    oscam.conf

    [global]
    Nice = -10
    ClientTimeout = 5
    #FallbackTimeout=3
    #ClientMaxIdle=120
    CacheDelay = 600
    BindWait = 5
    ResolveDelay = 15
    WaitForCards = 1
    PreferLocalCards = 1
    #LogFile = stdout
    saveinithistory = 1
    readerrestartseconds = 5
    LogFile = /var/log/oscam/oscam.log
    #usrfile = /var/keys/oscam_usr.log

    [monitor]
    nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255
    appendchaninfo = 1

    [newcamd]
    key = 0192837465019283746501928374
    port = 30000@0D95:000004

    [camd35]
    port = 10110

    [cs357x]
    Port = 34002

    [webif]
    httpport = 16002
    httpuser =
    httppwd =
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255

    oscam.server

    [reader]
    label = orf
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB0
    services = orf
    smargopatch = 1
    caid = 0D95
    detect = cd
    mhz = 357
    cardmhz = 357
    ident = 0D95:000004;0D95:000000;0D95:FFFFFF
    group = 1
    emmcache = 1,3,2
    ecmcache = 1
    lb_weight = 100

    oscam.user

    [account]
    user = user
    pwd = pass
    group = 1
    au = orf
    uniq=0
    #betatunnel = 1833.FFFF:1702
    ident = 0d95:000004;0d95:000000;0d95:FFFFFF
    caid= 0D95
    services = orf
    monlevel = 1

    CLIENT BOX

    oscam.conf

    [global]
    Nice = -1
    ClientTimeout = 7
    FallbackTimeout=3
    ClientMaxIdle=120
    CacheDelay = 120
    BindWait = 5
    ResolveDelay = 15
    WaitForCards = 1
    PreferLocalCards = 1
    #LogFile = stdout
    saveinithistory = 1
    readerrestartseconds = 5
    LogFile = /var/keys/oscam.log
    #usrfile = /var/keys/oscam_usr.log

    [monitor]
    nocrypt = 127.0.0.1,192.168.0.0-192.168.255.255
    appendchaninfo = 1
    httpport = 8888

    [webif]
    httpport = 8888
    httpuser =
    httppwd =
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dbox2
    user = dvbapi
    priority = 0D95:000004

    oscam.server

    [reader]
    label = cs357
    protocol = camd35
    device = 192.168.178.1,34002
    account = user,pass
    group = 1
    caid = 0D95
    fallback = 1

    oscam. user

    [account]
    user = dvbapi
    pwd = dvbapi
    group = 1
    au = 1
    uniq=0
    betatunnel = 1833.FFFF:1702
    caid = 0D95
     
    Zuletzt von einem Moderator bearbeitet: 8. März 2011
    #3
  5. T1x
    Offline

    T1x VIP

    Registriert:
    11. Juni 2010
    Beiträge:
    3.859
    Zustimmungen:
    2.720
    Punkte für Erfolge:
    113
    AW: Oscam hell, dann disconnect

    Moin,

    deine Reader scheinen auszusteigen. Du solltest evtl. mal die Oscam Version Serverseitig wechseln. Ich bin mir nicht 100%ig sicher...aber die Idents in beim ORF Reader brauchst du glaube ich nicht....ebenso wenig im Newcamd Abschnitt.
     
    #4
  6. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    AW: Oscam hell, dann disconnect

    Versuche mal den Eintrag in den accounts der oscam.user:

    keepalive = 1

    Grüsse
    szonic
     
    #5
  7. atomrofler
    Offline

    atomrofler Ist oft hier

    Registriert:
    30. Mai 2010
    Beiträge:
    109
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    Probier mal folgendes:

    echo 2 > /proc/cpu/alignment

    Ein ähnliches Probleme hatte ich auf meinem QNAP NAS.
     
    #6
  8. floyd777
    Offline

    floyd777 Newbie

    Registriert:
    22. Februar 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: Oscam hell, dann disconnect

    Hey, die Freude ist groß.!!

    Hab den Server auf 4800 angehoben und sonst nichts geändert und jetzt läufts ohne Probleme. Keepalive war aktiv.

    @T1X Vielen Dank!! Hatte die Hoffnung irgenwie schon aufgegeben.

    @atomrofler: jetzt hast du mich neugierig gemacht, hab seit kurzem ein TS-119P+ und hab mir auch schon überlegt Oscam dort laufen zu lassen. Wie hast du das hinbekommen?
     
    #7
  9. atomrofler
    Offline

    atomrofler Ist oft hier

    Registriert:
    30. Mai 2010
    Beiträge:
    109
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    Moin,

    man muss drauf achten, dass man oscam auf eine Partition packt, die nicht nach einem Reboot neu geladen wird. Ansonsten ist alles weg. Die NAS sind da etwas anders als ein normales Linux System. Bei mir liegt es in (mnt/HDA_ROOT/emu.

    Desweiteren muss, zumindest auf meinem TS210, eine Library runtergeladen eingebunden werden und der genannte Befehl abgesetzt werden. Das habe ich alles in ein Script verpackt. Siehe Anhang. Da sind auch noch ein paar Erklärungen drin.

    Grüße

     
    Zuletzt von einem Moderator bearbeitet: 9. März 2011
    #8
  10. floyd777
    Offline

    floyd777 Newbie

    Registriert:
    22. Februar 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: Oscam hell, dann disconnect

    Hi,

    Danke für das Skript. Oscam im Qnap wär natürlich nonPLUSultra.

    ftdi_sio ist bei mir vorhanden, Problem hab ich nur die libnxp.so zu bekommen, kannst du mir sagen, woher du die hast, bzw. mir deine zukommen lassen?

    Grüße
     
    #9
  11. atomrofler
    Offline

    atomrofler Ist oft hier

    Registriert:
    30. Mai 2010
    Beiträge:
    109
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    Hi,

    habe den Dateinamen einfach in google mit "download" reingeschmissen. Solltest du schnell finden.

    Grüße
     
    #10
  12. floyd777
    Offline

    floyd777 Newbie

    Registriert:
    22. Februar 2011
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    AW: Oscam hell, dann disconnect

    Ok, danke für Eure geschätzte Unterstützung.

    :emoticon-0157-sun:
     
    #11

Diese Seite empfehlen