1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSCAM DEBIAN Update

Dieses Thema im Forum "OScam Archiv" wurde erstellt von Babaya, 19. Februar 2010.

  1. Babaya
    Offline

    Babaya Ist gelegentlich hier

    Registriert:
    21. Dezember 2007
    Beiträge:
    40
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    Abend,

    kann mir jemand bitte erklären wie ich Oscam auf Debian updatete. Habe die Standard Version vom CCCAM Debian Thread installiert

    Möchte gerne eine Version mit Webinfo testen. Habe die Oscam datei nach

    USR/Bin kopiert rechte auf 775 gesetzt.

    Fehlermeldung: -bash: /usr/bin/oscam: cannot execute binary file
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. moench
    Offline

    moench Freak

    Registriert:
    22. Oktober 2009
    Beiträge:
    287
    Zustimmungen:
    45
    Punkte für Erfolge:
    28
    Beruf:
    EDV u. Telekommunikationstechniker
    AW: OSCAM DEBIAN Update

    wenn du das oscam installationsscript verwendet hast... dann liegt deine OSCAM datei im pfad... /var/emu/oscam und kann mit dem befehl "oscam start" gestartet werden...

    41. OSCam installieren (Setup). z.b für HD+
    OSCam ist NICHT Bestandteil dieses CCcam-Paketes. Aufgrund mehrer Anfragen hier ein kleines Setupscript.
    Siehe Anleitung

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #2
  4. Babaya
    Offline

    Babaya Ist gelegentlich hier

    Registriert:
    21. Dezember 2007
    Beiträge:
    40
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: OSCAM DEBIAN Update

    vielen dank für die prompte antwort.
    Habe die datei überschrieben im ordner "/var/emu/oscam"

    wenn ich in putty oscam start schreibe kommt die fehlermeldung

    /usr/bin/oscam: line 14: /var/emu/oscam/oscam: cannot execute binary file
     
    #3
  5. datamen
    Offline

    datamen Moderator

    Registriert:
    20. Dezember 2008
    Beiträge:
    6.497
    Zustimmungen:
    3.440
    Punkte für Erfolge:
    113
    Ort:
    hinter'm Router
    AW: OSCAM DEBIAN Update

    Rechte des oscam-binary auf 755 nicht 775 ;-)

    und es muss natürlich die x86 ... x64 version sein .... jenachdem .......
     
    #4
  6. Babaya
    Offline

    Babaya Ist gelegentlich hier

    Registriert:
    21. Dezember 2007
    Beiträge:
    40
    Zustimmungen:
    4
    Punkte für Erfolge:
    8
    AW: OSCAM DEBIAN Update

    hast du mal nen link für eine funktionierende Version mit Webinfo . Mein Server arbeitet mit nem Intel CPU. 32Bit
     
    #5
  7. datamen
    Offline

    datamen Moderator

    Registriert:
    20. Dezember 2008
    Beiträge:
    6.497
    Zustimmungen:
    3.440
    Punkte für Erfolge:
    113
    Ort:
    hinter'm Router
    AW: OSCAM DEBIAN Update

    versuch mal .......

    datei umbenennen so wie deine auf dem pc heisst.
     
    #6
    Babaya gefällt das.
  8. ultrasmd77
    Offline

    ultrasmd77 Ist gelegentlich hier

    Registriert:
    20. November 2009
    Beiträge:
    54
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: OSCAM DEBIAN Update

    @datamen

    Habe deine Version auch gerade mal probiert. Bei mir kommt jetzt folgende Fehlermeldung:
    Code:
    /var/emu/oscam/oscam: error while loading shared libraries: libpcsclite.so.1: cannot open shared object file: No such file or directory
    
    Kannst du damit was anfangen? Fehlen mir irgendwie ein paar Libarys?
     
    #7
  9. facefinity
    Offline

    facefinity Ist gelegentlich hier

    Registriert:
    24. September 2007
    Beiträge:
    71
    Zustimmungen:
    32
    Punkte für Erfolge:
    0
    AW: OSCAM DEBIAN Update

    Versuch mal das, steht übrigens alles hier im Board, 1Posting

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Für alle die Probleme mit der libcrypto haben:


    Einfach per per Telnet eingeben:
    apt-get install libssl-dev​

    Nach der Installations müssen die Links noch erstellt werden

    cd /usr/lib

    ln -s libcrypto.so.0.9.8 libcrypto.so.6
    ln -s libssl.so.0.9.8 libssl.so.6​
     
    #8
  10. ultrasmd77
    Offline

    ultrasmd77 Ist gelegentlich hier

    Registriert:
    20. November 2009
    Beiträge:
    54
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: OSCAM DEBIAN Update

    Ääähm, ich glaube die "libcrypto" ist vorhanden, jedenfalls sehe ich die. Im Gegensatz zur "libpcsclite.so.1", die fehlt mir scheinbar. oder wird die mit dadurch auch installiert?

    edit:
    Habs jetzt mal probiert, aber kein Erfolg. Habs dann irgendwie geschafft "libpcsclite" zu "installieren". Jetzt kommt aber folgende Meldung:

    Code:
    /var/emu/oscam/oscam: /lib/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by /var/emu/oscam/oscam)
     
    Zuletzt bearbeitet: 20. Februar 2010
    #9
  11. MertGenc
    Offline

    MertGenc Ist gelegentlich hier

    Registriert:
    26. März 2008
    Beiträge:
    89
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    AW: OSCAM DEBIAN Update

    das selbe problem habe ich auch diese fehler meldung... was müssten wir tun?
     
    #10
  12. andyuhu
    Offline

    andyuhu Ist gelegentlich hier

    Registriert:
    20. März 2009
    Beiträge:
    97
    Zustimmungen:
    32
    Punkte für Erfolge:
    18
    AW: OSCAM DEBIAN Update

    Habe leider auch das selbe Problem...
     
    #11
  13. andyuhu
    Offline

    andyuhu Ist gelegentlich hier

    Registriert:
    20. März 2009
    Beiträge:
    97
    Zustimmungen:
    32
    Punkte für Erfolge:
    18
    AW: OSCAM DEBIAN Update

    Das hab ich gefunden, dummerweise bekomme ich dann auch nur glibc-2.7-1
    Vom Risko ganz zu schweigen:


    mit
    Code:
    apt-get update
    apt-cache pkgnames glibc 
    den genauen Paketnamen herausfinden.

    dann mit
    Code:
    apt-get install -u <paketname> 
    das Update installieren.

    Da sollte dann gezeigt werden, welche anderen Pakete noch betroffen sind (werden 'ne ganze Menge sein).

    Vorsicht:
    Bei einem Update der glibc würde ich immer dazu raten, vorher ein komplettes Server-Backup zu machen, nicht über Plesk oder Confixx, sondern vom Hoster, damit wirklich alles gesichert ist.

    Die glibc ist (neben dem Kernel) sozusagen DAS zentrale Paket.
    Da die meisten Pakete dynamisch gegen die glibc gelinkt sind (inkl. Bash), kann ein fehlgeschlagenes Update das ganze System zerschiessen. Daher das Update nur ausführen, wenn kein Weg daran vorbeiführt.

    Beim geringsten Zweifel: Finger weg.



     
    #12
  14. mrnice00
    Offline

    mrnice00 Ist oft hier

    Registriert:
    5. März 2010
    Beiträge:
    101
    Zustimmungen:
    2
    Punkte für Erfolge:
    18
    AW: OSCAM DEBIAN Update

    Könnte jemand das installationsscript nocheinmal online stellen bitte ? Ist leider down
     
    #13
  15. andyuhu
    Offline

    andyuhu Ist gelegentlich hier

    Registriert:
    20. März 2009
    Beiträge:
    97
    Zustimmungen:
    32
    Punkte für Erfolge:
    18
    AW: OSCAM DEBIAN Update

    Das gibts so in der Form nicht mehr.
    siehe auch

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

     
    #14
  16. K@masutra
    Offline

    K@masutra Ist oft hier

    Registriert:
    15. November 2008
    Beiträge:
    134
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    AW: OSCAM DEBIAN Update

    So ich hab jetzt den ganzen tag dran gessen und hab es wirklich geschaft.Hier die neuste oscam mit webif und smartreader support
     
    #15
    nai22 gefällt das.

Diese Seite empfehlen