1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OScam CCcam auf Ubuntu Osiris problem

Dieses Thema im Forum "Archiv" wurde erstellt von surfbuster, 20. Oktober 2010.

  1. surfbuster
    Offline

    surfbuster Freak

    Registriert:
    24. März 2008
    Beiträge:
    226
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    Hallo, jetzt muss ich mich wohl doch mal an die experten wenden.

    hab auf einen futro S300 ubuntu und osiris aufgesetzt. hat auch super funktioniert. client an cccam 2.1.4 server connected und auch oscam oscam-1.00-svn3633 über newcamd protocol verbunden. siehe bilder im anhang. folgende hardware angeschlossen

    Code:
    7 port könig hub mit HD01 Karte
    ------------------------------
    smargo fw1.5 
    
    autoswitch
    normal
    0
    0 
    ------------------------------
    HD01 Karte bereits freigeschalten
    und funktioniert mit SCAM in Dreambox
    
    anbei poste ich mal den oscam log, config und ein paar bilder
    würd mich freuen wenn mir jemand sagen kann was ich verkehrt gemacht habe. momentan ist eine neuere oscam am laufen hab da auch schon mehrere versionen durchprobiert.

    oscam log
    Code:
    2010/10/20 18:27:16 B7FF88D0 s >> OSCam <<  cardserver started version 1.00-unstable_svn, build #3633 (i686-pc-linux)
    2010/10/20 18:27:16 B7FF88D0 s version=1.00-unstable_svn, build #3633, system=i686-pc-linux, nice=-1
    2010/10/20 18:27:16 B7FF88D0 s client max. idle=120 sec, debug level=0
    2010/10/20 18:27:16 B7FF88D0 s max. logsize=10 Kb
    2010/10/20 18:27:16 B7FF88D0 s client timeout=5000 ms, fallback timeout=2500 ms, cache delay=120 ms
    2010/10/20 18:27:16 B7FF88D0 s auth size=4788
    2010/10/20 18:27:16 B7FF88D0 s services reloaded: 0 services freed, 2 services loaded
    2010/10/20 18:27:16 B7FF88D0 s userdb reloaded: 0 accounts freed, 1 accounts loaded, 0 expired, 0 disabled
    2010/10/20 18:27:16 B7FF88D0 s signal handling initialized (type=sysv)
    2010/10/20 18:27:16 B7FF88D0 s 115 service-id's loaded
    2010/10/20 18:27:16 B7FF88D0 s 118 tier-id's loaded
    2010/10/20 18:27:16 B7FF88D0 s 3 provid's loaded
    2010/10/20 18:27:16 B7FF88D0 s 22 lengths for caid guessing loaded
    2010/10/20 18:27:17 B7FF88D0 s monitor: disabled
    2010/10/20 18:27:17 B7FF88D0 s camd33: disabled
    2010/10/20 18:27:17 B7FF88D0 s camd35: disabled
    2010/10/20 18:27:17 B7FF88D0 s cs378x: disabled
    2010/10/20 18:27:17 B7FF88D0 s newcamd: initialized (fd=5, port=34000, crypted)
    2010/10/20 18:27:17 B7FF88D0 s CAID: 1830
    2010/10/20 18:27:17 B7FF88D0 s provid #0: 003411
    2010/10/20 18:27:17 B7FF88D0 s cccam: disabled
    2010/10/20 18:27:17 B7FF88D0 s radegast: disabled
    2010/10/20 18:27:17 B7FF88D0 s http thread started
    2010/10/20 18:27:17 B7FF88D0 s creating thread for device Serial:Reader 916CB4F slot 0
    2010/10/20 18:27:17 B7FF88D0 s waiting for local card init
    2010/10/20 18:27:17 B7FBD280 r reader thread started (thread=B7FBD280, device=Serial:Reader 916CB4F, detect=cd, mhz=357, cardmhz=368)
    2010/10/20 18:27:17 B7FBD280 r Using 0x82 as endpoint for smartreader hardware detection
    2010/10/20 18:27:17 B7FC4280 h HTTP Server listening on port 10001
    2010/10/20 18:27:17 B7FBD280 r Found reader with serial Reader 916CB4F at 001:003
    2010/10/20 18:27:17 B7FBD280 r Found smartreader device Serial:Reader 916CB4F
    2010/10/20 18:27:17 B7FBD280 r card detected
    2010/10/20 18:27:20 B7FBD280 r ATR: 3F FF 95 00 FF 91 81 71 FE 47 00 44 4E 41 53 50 31 34 32 20 52 65 76 47 43 34 63 
    2010/10/20 18:27:20 B7FBD280 r Maximum frequency for this card is formally 5 Mhz, clocking it to 4.80 Mhz
    2010/10/20 18:27:21 B7FBD280 r detect native nagra card
    2010/10/20 18:27:22 B7FBD280 r -----------------------------------------
    2010/10/20 18:27:22 B7FBD280 r |id  |tier    |valid from  |valid to    |
    2010/10/20 18:27:22 B7FBD280 r +----+--------+------------+------------+
    2010/10/20 18:27:22 B7FBD280 r |8011|0064    |2010/10/16  |2011/10/17  |
    2010/10/20 18:27:23 B7FBD280 r |8011|0065    |1992/01/01  |1993/01/01  |
    2010/10/20 18:27:23 B7FBD280 r -----------------------------------------
    2010/10/20 18:27:23 B7FBD280 r found cardsystem
    2010/10/20 18:27:23 B7FBD280 r ROM:    D N A S P 1 4 2
    2010/10/20 18:27:23 B7FBD280 r REV:    R e v G C 4
    2010/10/20 18:27:23 B7FBD280 r SER:    xx xx xx xx 
    2010/10/20 18:27:23 B7FBD280 r CAID:   1830
    2010/10/20 18:27:23 B7FBD280 r Prv.ID: 00 00 34 11 (sysid)
    2010/10/20 18:27:23 B7FBD280 r Prv.ID: 00 00 00 00 
    2010/10/20 18:27:23 B7FBD280 r Prv.ID: 00 00 80 11 
    2010/10/20 18:27:23 B7FBD280 r [nagra-reader] ready for requests
    2010/10/20 18:27:23 B7FF88D0 s init for all local cards done
    2010/10/20 18:27:23 B7FF88D0 s anti cascading disabled
    2010/10/20 18:27:23 B75B6280 c client connected to 34000 port
    2010/10/20 18:27:24 B75B6280 c encrypted newcamd:34000-client 127.0.0.1 granted (hdplus, au(auto)=hdplus)
    2010/10/20 18:27:24 B75B6280 c user hdplus authenticated successfully (CCcam)
    2010/10/20 18:27:24 B75B6280 c AU enabled for user hdplus on reader hdplus
    
    oscam.conf
    Code:
    [global]
    logfile                       = stdout
    disablelog                    = 0
    disableuserfile               = 0
    usrfileflag                   = 0
    clienttimeout                 = 5
    fallbacktimeout               = 2500
    clientmaxidle                 = 120
    cachedelay                    = 120
    bindwait                      = 120
    netprio                       = 0
    clientdyndns                  = 0
    resolvedelay                  = 30
    unlockparental                = 0
    nice                          = -1
    serialreadertimeout           = 1500
    maxlogsize                    = 10
    waitforcards                  = 1
    preferlocalcards              = 0
    saveinithistory               = 0
    readerrestartseconds          = 5
    readerautoloadbalance         = 0
    readerautoloadbalance_save    = 0
    
    [newcamd]
    port                          = 34000@1830:003411
    key                           = 0102030405060708091011121314
    allowed                       = 
    keepalive                     = 1
    mgclient                      = 0
    
    [webif]
    httpport                      = 10001
    httprefresh                   = 15
    httpallowed                   = 127.0.0.1
    httphideidleclients           = 0
    httpreadonly                  = 0
    
    oscam.user
    Code:
    [account]
    user                          = hdplus
    pwd                           = hdplus
    disabled                      = 0
    expdate                       = 
    group                         = 1
    hostname                      = 
    uniq                          = 0
    sleep                         = 0
    monlevel                      = 1
    au                            = 1
    services                      = 
    caid                          = 1830           (hier auch probiert mit 1830&FFFF)
    betatunnel                    = 
    ident                         =                  (hier auch probiert mit 1830:003411)
    cccmaxhops                    = 10
    keepalive                     = 0
    numusers                      = 0
    penalty                       = 0
    
    oscam.server
    Code:
    [reader]
    label                         = hdplus
    enable                        = 1
    protocol                      = smartreader
    device                        = Serial:Reader 916CB4F
    services                      = 
    smargopatch                   = 1
    caid                          = 1830
    rsakey                        = xxxxxxxx
    boxkey                        = xxxxxxxx
    detect                        = cd
    #mhz                           = 368 
    cardmhz                       = 368
    ident                         = 1830:000000,003411,008011
    group                         = 1
    emmcache                      = 1,3,2
    ecmcache                      = 1
    lb_weight                     = 100
    
    cccam.cfg
    Code:
    N: 127.0.0.1 34000 hdplus hdplus 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256
    
    
    F: user pass 0 0 1 {0:0:1} 
    
    
    MINIMUM DOWNHOPS: 1
    DISABLE EMM : yes
    EXTRA EMM LEVEL : yes
    
    
    SERVER LISTEN PORT : 12000
    
    ALLOW WEBINFO: yes
    SHOW EXTENEDED CLIENT INFO : yes
    WEBINFO LISTEN PORT : 45000
    WEBINFO USERNAME : xxxxxxxx
    WEBINFO PASSWORD : xxxxxxxx
    
    Minimum Downhops: 1
    
    oscam webif ausgabe
    [​IMG]




    cccam clients
    [​IMG]




    cccam server connections
    [​IMG]
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.308
    Zustimmungen:
    9.407
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: OScam CCcam auf Ubuntu Osiris problem

    bei cccam 2.1.4 die 256 löschen !!!!

    N: 127.0.0.1 34000 hdplus hdplus 01 02 03 04 05 06 07 08 09 10 11 12 13 14 256


    bei cccam 2.1.4 wird die HD+ mit dem eintrag 256 am ende als hop 10
     
    #2
  4. surfbuster
    Offline

    surfbuster Freak

    Registriert:
    24. März 2008
    Beiträge:
    226
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    AW: OScam CCcam auf Ubuntu Osiris problem

    so, habs mal eben umgestellt und die 256 entfernt. server neustart aber immer noch alles so wie vorher. hab ich noch einen fehler irgend wo?

    was ich vielleicht auch noch sagen sollte,

    auf dem bild der oscam ausgabe wird bei der newcamd verbindung die CAID:SRVID so angezeigt: FFFE:FFFE

    das war bei meiner freetzbox vorher nicht so
     
    #3
  5. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.308
    Zustimmungen:
    9.407
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: OScam CCcam auf Ubuntu Osiris problem

    oscam server

    ident = 1830:003411

    also laut dem log wurde die karte richtig erkant und so wie ich es sehe in deine cccam info ist die karte auch drin.

    den eintrag hast du auch in cccam cfg. dopelt
    Minimum Downhops: 1
     
    #4
  6. surfbuster
    Offline

    surfbuster Freak

    Registriert:
    24. März 2008
    Beiträge:
    226
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    AW: OScam CCcam auf Ubuntu Osiris problem

    das hab ich nun auch mal abgeändert aber es geht leider immer noch nicht.
    hab 2 mal neu gestartet und die einstellungen noch einmal kontrolliert. noch ne idee?
     
    #5
  7. Beastmaster
    Offline

    Beastmaster Moderator Digital Eliteboard Team

    Registriert:
    9. Oktober 2008
    Beiträge:
    3.617
    Zustimmungen:
    12.203
    Punkte für Erfolge:
    113
    AW: OScam CCcam auf Ubuntu Osiris problem

    Jop das

    Code:
    ###########HD+############
    
    
    [reader]
    label = hd+
    enable = 1
    protocol = mouse
    detect = CD
    smargopatch = 1
    group = 1
    emmcache = 1,3,2
    caid = 1830
    device = /dev/ttyUSBx
    n3_rsakey   = 
    n3_boxkey   =
    
    
    
    
    
     
    Zuletzt bearbeitet: 20. Oktober 2010
    #6
  8. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.308
    Zustimmungen:
    9.407
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: OScam CCcam auf Ubuntu Osiris problem

    also ob du glaubst oder nicht , laut der fotos was du eingestelt hast , funktioniert die HD+ karte

    das einzige was nicht past ist der user

    in cccam steht xxxxxxx und in deine cccam cfg. user pass

    mach mal ein richtigen clienten in cccam so das er sich auch auf dem server verbindet
     
    #7
  9. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.308
    Zustimmungen:
    9.407
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: OScam CCcam auf Ubuntu Osiris problem

    @

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    er hat den smargo mit der serien nr eingebunden , das ist ok so , es mus nicht so ausehen wie du angibst

    und laut der fotos funktioniert die karte , das einziger was ich sehe ist noch der user in cccam cfg. , der ist auf den fotos anders als in cccam
     
    #8
  10. Beastmaster
    Offline

    Beastmaster Moderator Digital Eliteboard Team

    Registriert:
    9. Oktober 2008
    Beiträge:
    3.617
    Zustimmungen:
    12.203
    Punkte für Erfolge:
    113
    AW: OScam CCcam auf Ubuntu Osiris problem

    Jop laut seiner oscam.log funktioniert die karte
     
    #9
  11. surfbuster
    Offline

    surfbuster Freak

    Registriert:
    24. März 2008
    Beiträge:
    226
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    AW: OScam CCcam auf Ubuntu Osiris problem

    ja das ist eben das was mich auch stutzig macht. die user daten für den client stimmen überein. hab sie nur rausgenommen. die config habe ich sozusagen vom freezserver übernommen bzw angepasst. mit dem protocol = mouse habe ich ebenfalls schon probiert aber ohne erfolg. protocol smartreader mit seriennummer vergabe möchte ich auch beibehalten. von der sache her sollte es funktionieren aber das tut es nicht. werd jetzt mal die cccam 2.1.3 aufspielen und damit testen.
     
    #10
  12. surfbuster
    Offline

    surfbuster Freak

    Registriert:
    24. März 2008
    Beiträge:
    226
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    AW: OScam CCcam auf Ubuntu Osiris problem

    mit cccam 2.1.3 das gleiche problem. hm. so langsam gehen mir auch die ideen aus.:JC_hmmm:
     
    #11
  13. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.308
    Zustimmungen:
    9.407
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: OScam CCcam auf Ubuntu Osiris problem

    also wie du in ersten beitrag selbst sehen kanst , laut deinem oscam log funktioniert die HD+ karte !!

    das einziger problem könte noch bei cccam user ligen

    in deine fotos ist zu sehen das sich user xxxxxx anmeldet , aber in cccam cfg. steht F: user psas
     
    #12
  14. surfbuster
    Offline

    surfbuster Freak

    Registriert:
    24. März 2008
    Beiträge:
    226
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    AW: OScam CCcam auf Ubuntu Osiris problem

    ja das hatte ich nur so auskomentiert. lautet natürlich in cccam.cfg F: user pass und im cccam infoportal ist benutzer user angemeldet. sonst würde dieser client auch nicht verbunden sein. also scheidet das auch aus. glaube so langsam das ich ubuntu nochmal neu aufsetzen muss. wer weiss was da nicht stimmt
     
    #13
  15. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.308
    Zustimmungen:
    9.407
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: OScam CCcam auf Ubuntu Osiris problem

    gib mal deine linie per PN , ich teste mal ob das funktioniert

    am besten eine direkte N und eine C

    mach für beide linien ein port ofen in router
     
    #14
  16. czutok
    Offline

    czutok Best Member

    Registriert:
    17. März 2009
    Beiträge:
    24.308
    Zustimmungen:
    9.407
    Punkte für Erfolge:
    113
    Ort:
    Unter ne Brücke
    AW: OScam CCcam auf Ubuntu Osiris problem

    also als erstes ist dein port zu , den must du mit TCP an die ip adresse des servers in router frei machen

    also wie du sehen kanst funktioniert es wunderbar

    das einzige fehler ist nur dein CS port von der cccam , der mus ofen sein
     
    Zuletzt bearbeitet: 20. Oktober 2010
    #15

Diese Seite empfehlen