1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem OSCAM!! bitte um Hilfe...

Dieses Thema im Forum "OScam Archiv" wurde erstellt von hadizz, 26. Dezember 2011.

  1. hadizz
    Offline

    hadizz Freak

    Registriert:
    28. Dezember 2009
    Beiträge:
    225
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Ort:
    Mannheim
    Hallo zusammen...

    ich versuche seit Wochen OSVAM zum LAufen zu bringen und verzweifle langsam.

    also das habe ich bsiher:
    DM800 mit Newenigma2 v3.2 Image + CCCAM 2.2.1 + 1 Karte im internen Slot
    Jetzt will ich die 2. TNT mit Easymouse zum Laufen bringen mit OSCAM und natürlich auch die interne über OSCAM laufen lassen.

    Habe dazu die OSCAM v 1.00 per DCC in FTP usr/bin/ ..reinkopiert und die alte gelöscht.( dabei kann man ja keinen Fehler machen oder??
    Oscam starten tu ich über Bluepanel. Ich hatte dort oscam runtergeladen und wenn ich es starte, schriebt er mit auch "laufendes EMU OSCAM".
    Ist das so richtig? ABER: Wie kann ich überpürfen ob OSCAM wirklich läuft?
    ich komme auch nicht ins WIF ?

    Diese config habe ich:

    [global]
    logfile = /var/cache/oscam.log
    disableuserfile = 1
    clienttimeout = 15000
    fallbacktimeout = 4000
    clientmaxidle = 200
    cachedelay = 150
    bindwait = 20
    netprio = 0
    nice = -1
    serialreadertimeout = 3000
    maxlogsize = 20
    waitforcards = 1
    preferlocalcards = 1
    saveinithistory = 1

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = local
    pmt_mode = 0

    [webif]
    httpport = 16001
    httprefresh = 10
    httpallowed = 192.168.0.0-192.168.255.255

    [cccam]
    port = Portnummer
    reshare = 2
    ignoreshare = 0
    version = 2.2.1
    updateinterval = 300
    minimizecards = 0

    [reader]
    Label = hayat
    Protocol = internal
    Detect = cd
    Device = /dev/sci0
    EMMCache = 1,3,2
    Group = 1
    CAID = 0500
    ident = 0500:022e00

    [reader]
    label = tntsat
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 0500
    cardmhz = 357
    mhz = 357
    group = 2
    emmcache = 1,3,2
    lb_weight = 300
    aeskeys = xxxxxxxxxxx
    detect = CD

    [reader]
    label = name
    enable = 1
    protocol = cccam
    device = dyndns,12000
    user = name
    password = pass
    reconnecttimeout = 30
    group = 5
    cccversion = 2.1.0
    cccmaxhops = 2
    ccckeepalive = 0
    lb_weight = 100

    [account]
    User = local
    Group = 1,2
    AU = hayat

    [account]
    User = local
    Group = 1,2
    AU = hayat
    [account]

    [account]
    User = name
    Pwd = passw
    Group = 1,2
    Cccmaxhops = 2
    Cccreshare = 1
    Cccignorereshare = 1
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: OSCAM!! bitte um Hilfe...

    Hast du die CCcam mit Oscam ersetzt? Oder die Oscam binary unter /usr/bin gelegt.
    Wichtig die binary braucht mindestens die Rechte 755 !! Sonst startet nix.
    Und wenn du für das Oscam WebIf das den gleichen Port verwendest wie den für CCcam dürfen beide nicht gemeinsam laufen.
    Also für Oscam WebIF lieber einen anderen Port wählen z.B. 16002.
    Ein passendes Startscript muss unter /usr/script liegen.
    sollte aber bei NewNigma ja auch per OnlineUpdate möglich sein.
    Wenn Die Box auch noch zum TV schauen benutzt wird ist meiner Meninung immer och sinnvoll wegen den EMU Keys CCcam auf der Box mitlaufen zu lassen.
    Karten einlesen und sharen kannst ja mit Oscam machen.
     
    #2
  4. hadizz
    Offline

    hadizz Freak

    Registriert:
    28. Dezember 2009
    Beiträge:
    225
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Ort:
    Mannheim
    AW: OSCAM!! bitte um Hilfe...

    hallo skyrider.

    also folgendes zu deinen fragen:
    1. oscam binary liegt unter user/bin dort wo auch u.a. cccam 2.2.1 liegt
    2. startscript oscam liegt unter usr/script
    3. rechte sind auf 755

    meine fragen:
    wie kann ich beide scripts gemeinsam laufen lassen? ich kann doch über bp immer nur ein emu asuwählen zum startne?
    ich dachte oscam macht alles und ich brauche ccam nicht mehr!?..hmm

    wie kann ich prüfen ob oscam läuft? kann man dazu das startscript prüfen? wenn ja wie?

    danke & gruss
     
    #3
  5. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: OSCAM!! bitte um Hilfe...

    Also bei mir liegen unterschiedliche Startscripte unter /usr/script unter anderem auch eines welches Oscan und CCcam zusammen starten lässt bzw. nacheinander (steht dann auch so zur Auswahl im Menü OsCam/Cccam).
    Hatte das auch testweise mal so laufen. Erst mal nur Oscam dann Oscam/Cccam. Die Scripte kannst einfach mit einem Linux fähigem Editor öffnen und den inhalt anschauen. Im NewNigma sollte es diese Kombination auch im Online-Update geben. Und sollte auch im SoftCam Menü so auswählbar sein.
    Direkt testen ob Oscam läuft - über Telnet sollte das machbar sein weiss ich jetzt aber auch grade nicht auswendig.
    Wenn das WebIf nicht erreichbar ist das auf alle Fälle "verdächtig".
     
    #4
  6. hadizz
    Offline

    hadizz Freak

    Registriert:
    28. Dezember 2009
    Beiträge:
    225
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Ort:
    Mannheim
    AW: OSCAM!! bitte um Hilfe...

    ich hatte mir mal über online update cccam 2_1_4_and_OSCAM.emu installiert. das kann ich auch auswählen, sonst gab es keine anderen downloads.
    im script ordneer habe ich dazu auch das passende startscript.
    Wenn ich das laufen lassen sehe ich zwar an den sender das ccam läuft aber ich weiss nicht ob oscam läuft?

    hat noch jemand ideen?
     
    #5
  7. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: OSCAM!! bitte um Hilfe...

    Ist denn das WebInterface der Oscam dann erreichbar? Oder hast du vielleicht aus versehen eine OsCam Binary ohne Webinterface in /usr/bin kopiert?
     
    #6
  8. ernesto72
    Offline

    ernesto72 Freak

    Registriert:
    18. Juli 2010
    Beiträge:
    226
    Zustimmungen:
    48
    Punkte für Erfolge:
    28
    AW: OSCAM!! bitte um Hilfe...

    Verbinde dich mal mit Telnet zur Box (Kannst du auch mit DCC e2) und gib TOP ein, dann siehst du ob oscam läuft.
     
    #7
    Skyrider79 gefällt das.
  9. hadizz
    Offline

    hadizz Freak

    Registriert:
    28. Dezember 2009
    Beiträge:
    225
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Ort:
    Mannheim
    AW: OSCAM!! bitte um Hilfe...

    also ich habe diese version runtergeladen:

    OScam 1.10rc rev 6089-sh4-amino-webinf-dvb-libusb

    ist die korrekt?

    habe mal mit telnet getestet. das was da kommt sagt mir nicht viel. Was kann man da rauslsen oder wie?

    gruss
     
    #8
  10. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: OSCAM!! bitte um Hilfe...

    Ähhh du hast doch eine DM800? oder?
    Dann brauchst du eine Binary für mipsel und nicht für sh4 !!.
    Und du kannst ja einfach den Inhalt vom Telnet Fesnter rauskopieren und hier in einem Spoiler reinsetzen.
     
    #9
  11. kodiak
    Offline

    kodiak Hacker

    Registriert:
    6. Oktober 2008
    Beiträge:
    301
    Zustimmungen:
    34
    Punkte für Erfolge:
    28
    AW: OSCAM!! bitte um Hilfe...

    Hallo Leute
    Ich weiss nicht ob diese der richtige thred ist aber ich habe folgendes Problem:

    Ich habe eine DM800se und zwei Karten in interne Slot, eine ist SRG Swiss(oben) und eine Tring(unten).
    Weil Tring Karte nicht mit Cccam lauft habe ich bis jetzt mit cccam-newcs benutzt ich bin aber nicht zufrieden bin mit dieser Emu und will jetzt diese mit cccam 2.1.4/oscam laufen lassen.
    Ich habe Newnigma Image installiert und habe alles versucht um diese zwei Karten in Laufen zu bringen mit cccam 2.1.4/oscam, bringe aber leider SRG Karte nicht zum Laufen.
    Es funktioniert alles bis auf die SRG Karte…!
    Hie haben sie meine config Daten von oscam, kann jemand mich helfen!?Was habe ich falsch gemacht!?
    Oscam conf:
    [global]
    nice = -1
    logfile = /dev/null
    clienttimeout = 5000
    fallbacktimeout = 2500
    clientmaxidle = 120
    cachedelay = 120
    bindwait = 120
    resolvedelay = 30
    serialreadertimeout = 1500
    maxlogsize = 10
    waitforcards = 1
    preferlocalcards = 1
    saveinithistory = 1
    keepalive = 1

    [newcamd]
    key = 0102030405060708091011121314
    port = 34000@0500:023800;34001@0BAA:000000

    [webif]
    httpport = 16002
    httpuser = xxx
    httppwd = xxx
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255

    Oscam user:

    [reader]
    Label = SRG
    protocol = internal
    detect = CD
    device = /dev/sci0
    group = 1
    CAID = 0500
    ident = 0500:023800
    EMMCache = 1,3,2
    mhz = 357

    [reader]
    label = TRING
    Protocol = internal
    detect = CD
    device = /dev/sci1
    Group = 1
    EMMCache = 1,3,2
    CAID = 0BAA
    ident = 0BAA:000000

    Oscam user:

    [account]
    user = xxx
    pwd = xxx
    monlevel = 0
    uniq = 1
    group = 1
    au = TRING
    caid = 0BAA,
    ident = 0BAA:000000

    [account]
    user = xxx
    pwd = xxx
    monlevel = 0
    uniq = 1
    group = 1
    au = SRG
    caid = 0500
     
    #10
  12. hadizz
    Offline

    hadizz Freak

    Registriert:
    28. Dezember 2009
    Beiträge:
    225
    Zustimmungen:
    4
    Punkte für Erfolge:
    0
    Ort:
    Mannheim
    AW: OSCAM!! bitte um Hilfe...

    sorry, weiss nicht wie man das mit spoiler macht.

    kann mir jemand den richtigen downloadlink hier angeben, damit ich auch die richtige version von oscam für meine DM800 runterlade?
    ich komme ehrlich gesagt mit den vielen versiionen nicht klar. würde gern die v. 1.10 haben..

    danke
     
    #11
  13. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: OSCAM!! bitte um Hilfe...

    @haddizz
    Hier der Donwloadlink für die 1.10rc für Dreamboxen. Nicht durch den Dateinamen abschrecken lassen.
    Ist nur die Binary die musst du evtl. anpassen oder umbenennen je nachdem wie die jetzige heisst unter /usr/bin.

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    @kodiak
    ich würde mal jedem Reader eine eigene group geben.
    Was sagt denn OsCam beim einlesen der SRG Karte?
    Kommt ein Fehler? Log mal posten?
     
    #12
  14. kodiak
    Offline

    kodiak Hacker

    Registriert:
    6. Oktober 2008
    Beiträge:
    301
    Zustimmungen:
    34
    Punkte für Erfolge:
    28
    AW: OSCAM!! bitte um Hilfe...


    2011/12/27 13:19:48 5668E8 c thread 2F7FF4B0 ended!
    2011/12/27 13:19:53 55B118 c tring (0BAA&000000/0007/67:7E0F): found (93 ms) by tring
    2011/12/27 13:19:57 5668E8 c client connected to 34000 port
    2011/12/27 13:19:57 5668E8 c client(2F7FF4B0) duplicate user 'tring' from 127.0.0.1 (current 127.0.0.1) set to fake (uniq=1)
    2011/12/27 13:19:57 5668E8 c encrypted newcamd:34000-client 127.0.0.1 granted (tring, au=off)
    2011/12/27 13:19:57 5668E8 c user tring authenticated successfully (CCcam)
    2011/12/27 13:19:57 5668E8 c AU disabled for user tring
    2011/12/27 13:19:57 5668E8 c no valid CAID found in CAID for user 'tring'
    2011/12/27 13:19:58 5668E8 c WARNING: invalid client tcp_conn_close()
    2011/12/27 13:19:58 5668E8 c tring disconnected from 127.0.0.1
    2011/12/27 13:19:58 5668E8 c thread 2F7FF4B0 ended!
    2011/12/27 13:20:03 55B118 c tring (0BAA&000000/0007/67:F5DE): found (93 ms) by tring
    2011/12/27 13:20:09 5668E8 c client connected to 34000 port
    2011/12/27 13:20:09 5668E8 c client(2F7FF4B0) duplicate user 'tring' from 127.0.0.1 (current 127.0.0.1) set to fake (uniq=1)
    2011/12/27 13:20:09 5668E8 c encrypted newcamd:34000-client 127.0.0.1 granted (tring, au=off)
    2011/12/27 13:20:09 5668E8 c user tring authenticated successfully (CCcam)
    2011/12/27 13:20:09 5668E8 c AU disabled for user tring
    2011/12/27 13:20:09 5668E8 c no valid CAID found in CAID for user 'tring'
    2011/12/27 13:20:10 5668E8 c WARNING: invalid client tcp_conn_close()
    2011/12/27 13:20:10 5668E8 c tring disconnected from 127.0.0.1
    2011/12/27 13:20:10 5668E8 c thread 2F7FF4B0 ended!
    2011/12/27 13:20:13 55B118 c tring (0BAA&000000/0007/67:C071): found (94 ms) by tring


    Ich habe zwei N lines in ccam eingetragen,beides gleiche namen und password,mit newcs hat funk, ist das vileicht ein problem für oscam??
     
    #13
  15. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: OSCAM!! bitte um Hilfe...

    Nein das mit den mehreren N: Lines funktioniert - hatte ich auch schon laufen.
    Nimm mal aus der Oscam-user die Uniq = 1 Eintrag raus oder mache eine 0 rein. Das stört am anfang erstmal nur.
    Wenn Uniq gesetzt darf der User nur eine Verbindung aufbauen. Der User der in der N: Line in der Cccam.cfg drin steht
    muss eben auch in der Oscam-user existieren und bei mehrerern N: Lines mit gleichen User kein Uniq = 0 setzen.
     
    #14
  16. kodiak
    Offline

    kodiak Hacker

    Registriert:
    6. Oktober 2008
    Beiträge:
    301
    Zustimmungen:
    34
    Punkte für Erfolge:
    28
    AW: OSCAM!! bitte um Hilfe...

    Hab gemacht..jetz habe ich beide n Lines online aber srg funktioniert nicht...
    c tring_x (0500&023800/0385/2A:9C20): rejected user ident (121 ms) (0 of 0) (no card support 0500:023800)
    2011/12/27 13:36:16 5668E8 c tring_x (0500&040810/0385/30:16DB): rejected user ident (121 ms) (0 of 0) (no card support 0500:040810)
    2011/12/27 13:36:29 5668E8 c tring_x (0500&023800/0385/2A:9D20): rejected user ident (120 ms) (0 of 0) (no card support 0500:023800)
    2011/12/27 13:36:29 5668E8 c tring_x (0500&040810/0385/30:61DB): rejected user ident (121 ms) (0 of 0) (no card support 0500:040810)
    2011/12/27 13:36:36 5668E8 c tring_x (0500&023800/0385/2A:3232): rejected user ident (121 ms) (0 of 0) (no card support 0500:023800)
    2011/12/27 13:36:36 5668E8 c tring_x (0500&040810/0385/30:CF2D): rejected user ident (121 ms) (0 of 0) (no card support 0500:040810)
     
    #15

Diese Seite empfehlen