1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSCam auf Debian - Server - Probleme mit UM I12 - Karte

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von news6666, 9. April 2013.

  1. news6666
    Offline

    news6666 Ist gelegentlich hier

    Registriert:
    3. August 2011
    Beiträge:
    32
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Ich habe ein kleinen Debian-Server mit OScam und bekomme meine I12 Karte von UM nicht zum laufen.
    Verwenden tue ich einen Apollo USB-Cardreader CR 2.1, mit den Taktungen T1=3,68 , T2=10, T3=6.
    Der Jumper steht auf T3=6.

    Nachfolgend meine Reader-Config:
    [reader]
    label = i12
    description = I12reader
    enable = 1
    protocol = mouse
    device = /dev/ttyUSB0
    boxkey = 1122334455667788
    force_irdeto = 1
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,1,2
    Folgender Log-Output mit DEBUG-ALL:
    2013/04/09 12:13:11 6352D8 r um02 [pcsc] Reader initialized (device=0, detect=cd, mhz=368, cardmhz=368)
    2013/04/09 12:13:11 636B10 r um_i12 [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=600, cardmhz=600)
    ...
    2013/04/09 12:13:11 0 s um02 [pcsc] creating thread for device 0
    2013/04/09 12:13:11 0 s um_i12 [mouse] creating thread for device /dev/ttyUSB0
    ...
    2013/04/09 12:13:11 0 s waiting for local card init
    ...
    2013/04/09 12:13:11 6352D8 r um02 [pcsc] Reader initialized (device=0, detect=cd, mhz=368, cardmhz=368)
    2013/04/09 12:13:11 636B10 r um_i12 [mouse] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=600, cardmhz=600)
    2013/04/09 12:13:12 636B10 r um_i12 [mouse] card detected
    2013/04/09 12:13:12 6352D8 r um02 [pcsc] PCSC was opened with handle: 1347116687
    2013/04/09 12:13:12 6352D8 r um02 [pcsc] card detected
    ...
    2013/04/09 12:13:16 636B10 r um_i12 [mouse] Error activating card.
    2013/04/09 12:13:24 0 --- Skipped 2 duplicated log lines ---
    2013/04/09 12:13:24 636B10 r um_i12 [mouse] card initializing error
    2013/04/09 12:13:24 0 s init for all local cards done
    2013/04/09 12:13:24 0 s anti cascading disabled
    Also ich bekomme immer wieder "[mouse] Error activating card" und "[mouse] card initializing error".


    Bei der I12 handelt es sich ja um eine Irdeto-Karte, die man auch im Nagra-Modus betreiben könnte.
    Da ich so nicht weiterkam habe ich das mal probiert und die beiden Werte (Quelle: OSCam Config Editor):

    boxkey = 66xxxxxxxxxxxx7B
    rsakey = 8Axxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx11

    Dies führete mich leider auch nicht zum Ziel.

    Ich habe es mit der gleichen Konfiguration auch schon mit einer Easymouse2 Premium probiert,
    allerdings mit gleichem Ergebnis.

    Ich habe auch schon die Reader-Einstellungen aus folgendem Howto übernommen:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?


    Leider erfolglos.

    Eine Frage die ich mir auch gestellt hab: Wie rum muss die Karte eigentlich in den Reader?
    Bei Easymouse und Apollo war jeweils keine Dokumentation dabei.
    Es erscheint jedoch so, als wenn Chip nach Einschubrichtung-unten richtig sei.

    Die Karte ist nicht defekt, denn ich bekomme sie in einem internen Schacht einer Dreambox zum laufen.
    Dort konnte ich Sie auch aktivieren.

    Ich habe noch eine UM02 Karte in einem USB-Omnikey-Reader mit dem pcsc Protocol am laufen.
    Dies funktioniert einwandfrei.

    Ich verwende folgende Version von OSCam: OSCAM 1.20-unstable_svn build r8558

    lsusb liefert:
    Code:
     Bus 001 Device 004: ID aaaa:bbbb Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
    Bus 001 Device 005: ID cccc:dddd OmniKey AG CardMan 3121
    lsmod liefert:
    Code:
    ftdi_sio               33183  1
    usbserial              32890  3 ftdi_sio
    Folgendes habe ich noch in einem anderen Post gefunden:
    Unter oscam beim USB Comport den Haken setzen und auf FTDI_sio stellen.
    "[...] Unter oscam beim USB Comport den Haken setzen und auf FTDI_sio stellen. [...]"
    Allerdings weiss ich nicht wo genau ich diese Einstellung vornehmen kann.

    Dann hab ich noch was gelesen mit USB2SERIAL im Webif-Log, was mir aber auch erstmal nichts sagt.

    Was kann ich machen? Mir fällt nichts mehr ein, was ich noch probieren könnte. Kann ich den Reader notfalls irgendwie seriell ansprechen?
    Könnt Ihr mir weiterhelfen?
     
    Zuletzt von einem Moderator bearbeitet: 9. April 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. news6666
    Offline

    news6666 Ist gelegentlich hier

    Registriert:
    3. August 2011
    Beiträge:
    32
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: OSCam auf Debian - Server - Probleme mit UM I12 - Karte

    Hallo Jungs,

    ich habe nochmal ein bisschen experimentiert, jedoch bisher leider keinen Erfolg gehabt :-(.
    Ich hoffe jemand hat einen guten Tipp für mich, wie ich die I12 zum laufen bekomme.


    Hier mal ein bisschen Output von meinem System:

    pi@raspberrypi ~ $ lsusb
    Code:
    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
    Bus 001 Device 005: ID 076b:3021 OmniKey AG CardMan 3121
    
    pi@raspberrypi ~ $ sudo lsmod
    Code:
    Module                  Size  Used by
    snd_bcm2835            15846  1
    snd_pcm                77560  1 snd_bcm2835
    snd_seq                53329  0
    snd_timer              19998  2 snd_pcm,snd_seq
    snd_seq_device          6438  1 snd_seq
    snd                    58447  7 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
    snd_page_alloc          5145  1 snd_pcm
    ftdi_sio               33183  1
    usbserial              32890  3 ftdi_sio
    leds_gpio               2235  0
    led_class               3562  1 leds_gpio
    


    pi@raspberrypi ~ $ sudo lsusb -v | grep -i serial
    Code:
      iSerial                 0
      iSerial                 1 bcm2708_usb
      iSerial                 0
    Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
      idProduct          0x6001 FT232 USB-Serial (UART) IC
      iSerial                 3 CRWH3MX1
      iSerial                 0
    


    Hier habe ich mit verschiedenen Einstellungen experimentiert:

    --- Versuch 1 Protocol: smartreader ---
    [reader]
    ...
    protocol = smartreader
    device = Serial:CRWH3MX1
    force_irdeto = 1
    ...

    Webif Output:
    i12 [smartreader] Using 0x01/0x82 as endpoint for smartreader hardware detection
    i12 [smartreader] Cannot open device: Serial:CRWH3MX1

    Status des Reader im Webif:
    UNKNOWN (no entitlements)

    --- Versuch 2 Protocol: smartreader ---

    [reader]
    ...
    protocol = smartreader
    device = 001:004
    force_irdeto = 1
    ...

    Webif Output:
    i12 [smartreader] Using 0x01/0x82 as endpoint for smartreader hardware detection
    i12 [smartreader] Cannot open device: 001:004

    Status des Reader im Webif:
    UNKNOWN (no entitlements)

    --- Versuch 3 Protocol: mouse irdeto ---

    [reader]
    ...
    protocol = smartreader
    protocol = mouse
    device = /dev/ttyUSB0
    force_irdeto = 1
    ...

    Webif Output:
    i12 [mouse] Reader initialized (device=/dev/ttyUSB1, detect=cd, mhz=600, cardmhz=600)
    i12 [mouse] card detected
    i12 [mouse] Error activating card.
    i12 [mouse] card initializing error

    Status des Reader im Webif:
    ERROR (no entitlements)


    --- Versuch 4 Protocol: mouse nagra ---

    [reader]
    ...
    protocol = mouse
    device = /dev/ttyUSB0
    caid = 1722
    boxkey = 66xx7B
    rsakey = 8Axxxxxxxxxx11
    force_irdeto = 0
    ...

    Webif Output:
    2013/04/11 17:50:25 1BC6290 r i12 [mouse] Reader initialized (device=/dev/ttyUSB1, detect=cd, mhz=600, cardmhz=600)
    2013/04/11 17:50:26 1BC6290 r i12 [mouse] card detected
    2013/04/11 17:50:30 1BC6290 r i12 [mouse] Error activating card.
    2013/04/11 17:50:38 1BC6290 r i12 [mouse] card initializing error

    Status des Reader im Webif:
    ERROR (no entitlements)

    ---

    Der Apollo hat folgende Einstellungen:
    T3=6MHz, 5V, mehr kann man an den Gerät nicht einstellen.

    Die anderen Reader-Einstellungen sind wie im ersten Post.

    Bei jedem Versuch mit dem Protocol: smartreder erhalte ich "Cannot Open device".
    Habe ich die "Serial-Bezeichnung" richtig eingegeben?

    Bei jedem Versuch mit dem Protocol mouse bekomme ich:
    [mouse] Error activating card.
    [mouse] card initializing error


    Ich hoffe irgend jemand hat eine Idee, was bei mir schief läuft.
     
    Zuletzt von einem Moderator bearbeitet: 11. April 2013
    #2

Diese Seite empfehlen