1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem Oscam als CCcam Server,local machen probs

Dieses Thema im Forum "OScam Archiv" wurde erstellt von Lui2004, 6. Juni 2012.

  1. Lui2004
    Offline

    Lui2004 Spezialist

    Registriert:
    16. Februar 2008
    Beiträge:
    668
    Zustimmungen:
    46
    Punkte für Erfolge:
    28
    hi zusammen

    habe zur Zeit Oscam ( stets die aktuelle Version ) erfolgreich als CCcam-Server am Laufen,nur meine Lokalen Cards machen mir probleme, Oscam zu CCcam connecten kein problem aber wie
    bringe ich Oscam dazu meine Lokale zu nehmen und nicht die von meinen Peers ?

    Oscam.conf

    [global]
    serverip =
    usrfile =
    mailfile =
    logfile = /var/log/ipc/OScam.log
    cwlogdir =
    emmlogdir =
    disablelog = 0
    disableuserfile = 1
    disablemail = 1
    loghistorysize = 4096
    usrfileflag = 0
    clienttimeout = 5000
    fallbacktimeout = 2500
    clientmaxidle = 120
    failbantime = 360
    failbancount = 3
    cachedelay = 0
    bindwait = 120
    netprio = 0
    sleep = 0
    unlockparental = 0
    nice = -1
    serialreadertimeout = 1500
    suppresscmd08 = 0
    maxlogsize = 20
    waitforcards = 1
    waitforcards_extra_delay = 500
    preferlocalcards = 0
    saveinithistory = 1
    readerrestartseconds = 5
    dropdups = 0
    cacheexwaittime = 50
    cacheexenablestats = 1
    lb_mode = 1
    lb_save = 100
    lb_nbest_readers = 1
    lb_nfb_readers = 1
    lb_min_ecmcount = 5
    lb_max_ecmcount = 500
    lb_reopen_seconds = 900
    lb_retrylimit = 800
    lb_retrylimits =
    lb_nbest_percaid =
    lb_noproviderforcaid =
    lb_savepath = /var/log/stat
    lb_stat_cleanup = 336
    lb_reopen_mode = 0
    lb_max_readers = 0
    lb_auto_betatunnel = 1
    lb_auto_betatunnel_prefer_beta= 50
    ecmfmt =
    resolvegethostbyname = 0
    double_check = 0
    max_cache_time = 15
    max_cache_count = 1000

    [monitor]
    port = 0
    serverip = 0.0.0.0
    nocrypt = 127.0.0.1,192.168.2.0-192.168.2.255
    aulow = 30
    hideclient_to = 15
    monlevel = 4
    appendchaninfo = 1

    [newcamd]
    port = 30011@183D:005411
    serverip = 192.168.2.24
    key = 0102030405060708091011121314
    keepalive = 1
    mgclient = 0

    [cccam]
    port = xxxxx
    reshare = 10
    ignorereshare = 1
    forward_origin_card = 0
    version = 2.1.1
    updateinterval = 300
    minimizecards = 0
    keepconnected = 1
    stealth = 0
    nodeid = EFD0xxxxxxxxx14B0
    reshare_mode = 1

    [webif]
    httpport = 2010
    httphelplang = De
    httpcert =
    http_prepend_embedded_css = 0
    httpcss =
    httpjscript =
    httptpl = /var/picon/
    httpscript =
    httprefresh = 15
    httpallowed = 0.0.0.0-255.255.255.255
    httpdyndns =
    httphideidleclients = 0
    httpshowpicons = 1
    httpreadonly = 0
    httpsavefullcfg = 1
    Oscam.server
    so habe ich meine Server eingetrgen,hoffe das ist so ok ?

    [reader]
    label = Dyndns des Peers
    description =
    enable = 1
    protocol = cccam
    device = dyndns von peer,Port
    key =
    user = xxx
    password = xxx
    pincode = none
    services =
    inactivitytimeout = 1
    reconnecttimeout = 30
    fallback = 0
    cacheex = 0
    cacheex_maxhop = 0
    logport = 0
    group = 5
    emmcache = 0,1,0
    blockemm-unknown = 0
    blockemm-u = 0
    blockemm-s = 0
    blockemm-g = 0
    saveemm-unknown = 0
    saveemm-u = 0
    saveemm-s = 0
    saveemm-g = 0
    blockemm-bylen =
    lb_weight = 100
    cccversion = 2.1.2
    cccmaxhops = 3
    cccmindown = 1
    cccwantemu = 0
    ccckeepalive = 1
    cccreshare = -1
    cccreconnect = 12000
    audisabled = 0


    so habe ich meine Lokale Karte eingebunden,korrekt ??

    [reader]
    label = tivusat
    enable = 1
    protocol = newcamd
    device = 192.168.2.24,30011
    key = 0102030405060708091011121314
    user = ###
    password = ####
    pincode = none
    inactivitytimeout = 1
    reconnecttimeout = 30
    disableserverfilter = 0
    fallback = 0
    cacheex = 0
    cacheex_maxhop = 0
    logport = 0
    group = 1,5
    emmcache = 1,3,2
    blockemm-unknown = 0
    blockemm-u = 0
    blockemm-s = 0
    blockemm-g = 0
    saveemm-unknown = 0
    saveemm-u = 0
    saveemm-s = 0
    saveemm-g = 0
    lb_weight = 200
    ccchop = 0
    audisabled = 0
    Oscam.user
    so habe ich mein User eingetragen,korrekt so wie ich es vorgenommen habe ?

    [account]
    user = test
    pwd = test
    disabled = 0
    group = 5
    uniq = 0
    cacheex = 0
    cacheex_maxhop = 0
    sleep = 0
    monlevel = 4
    suppresscmd08 = 0
    cccmaxhops = 2
    cccreshare = 0
    cccignorereshare = -1
    cccstealth = -1
    sleepsend = 0
    failban = 0
    keepalive = 1
    numusers = -1
    penalty = -1


    und so habe ich meine lokale eingebunden:


    [account]
    user = tivusat
    pwd = password
    disabled = 0
    group = 1
    uniq = 0
    cacheex = 0
    cacheex_maxhop = 0
    sleep = 0
    monlevel = 4
    au = tivusat
    services = tivusat
    caid = 183D
    suppresscmd08 = 0
    cccmaxhops = 10
    cccreshare = -1
    cccignorereshare = -1
    cccstealth = -1
    sleepsend = 0
    failban = 0
    keepalive = 1
    numusers = -1
    penalty = -1

    habe ich in der config einen denkfehler ?

    hoffe ihr könnt mir helfen

    Danke schon mal
     
    Zuletzt von einem Moderator bearbeitet: 6. Juni 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Offline

    Kermit Guest

    Hallo Lui2004,

    setz mal in deiner oscam.conf den Parameter
    preferlocalcards = 1
    in der Sektion [global]. Damit werden deine lokalen Karten bevorzugt.
    Noch ein Tipp, wenn du in der oscam.conf in der Sektion [webif]
    httpsavefullcfg = 0
    setzt, so werden dir nur die Parameter angezeigt, die einen vom Default abweichenden Wert haben. Damit wird alles wesentlich übersichtlicher.

    Grüße

    Kermit
     
    #2
  4. Lui2004
    Offline

    Lui2004 Spezialist

    Registriert:
    16. Februar 2008
    Beiträge:
    668
    Zustimmungen:
    46
    Punkte für Erfolge:
    28
    hi kermit

    leider bringen die einstellungen auch nicht zum Erfolg.

    Auf meiner Tivusat karten kommen anfragen von meinen peers mit caid 604( Nova ) sollte doch eigentlich nicht der fall sein,da oscam.service gesetzt ist
    und über meine lokale wird trortdem nichts hell nur über peer

    werde nicht schlau daraus
     
    Zuletzt bearbeitet: 6. Juni 2012
    #3
  5. Kermit
    Offline

    Kermit Guest

    Hi,

    deine "lokale" Tivusat Karte ist für OScam nicht lokal, da sie per newcamd Protokoll eingebunden ist und nicht direkt von einem Reader wie Easymouse oder Smargo eingelesen wird.

    Grüße

    Kermit
     
    #4
  6. Lui2004
    Offline

    Lui2004 Spezialist

    Registriert:
    16. Februar 2008
    Beiträge:
    668
    Zustimmungen:
    46
    Punkte für Erfolge:
    28
    wie mache ich das sie als lokal verwendet wird ?
     
    #5
  7. Kermit
    Offline

    Kermit Guest

    Indem du sie direkt von OScam einlesen läßt und nicht von einem einem anderem Cam an OScam weiter sharst.
    Ansonsten hast du nur die Möglichkeit über lb_weight die Wertigkeit des Readers im Vergleich zu den anderen Readern zu erhöhen.

    Grüße

    Kermit
     
    #6
  8. Lui2004
    Offline

    Lui2004 Spezialist

    Registriert:
    16. Februar 2008
    Beiträge:
    668
    Zustimmungen:
    46
    Punkte für Erfolge:
    28
    Die karten werden direkt von Oscam eingelesen .

    Früher hat ich das so das oscam die karten ausgelesen hat und weiter per Nline an CCcam gegeben hat.

    Nun will ich nur oscam laufen lassen und meine Loakel werden nciht angesprochen

    hast du ein config beispiel für mich ?

    danke
     
    #7
  9. Kermit
    Offline

    Kermit Guest

    Hi,

    hast du schonmal diesen Bereich

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    gesehen?
    Da ich keine Ahnung habe und du auch keinerlei Informationen angibst wo denn dein OScam läuft (Dream oder Fritte) kann ich kein genaueres Bsp posten.

    Grüße

    Kermit
     
    #8
  10. Lui2004
    Offline

    Lui2004 Spezialist

    Registriert:
    16. Februar 2008
    Beiträge:
    668
    Zustimmungen:
    46
    Punkte für Erfolge:
    28
    Sorry

    System ist ein Debian Squeezy mit ipc 11.4

    folgenden teil erfolg habe ich jetzt habe die reader so jetzt drin und die karten sind im status mit OK nur wird nichts von der Lokal genommen

    [reader]
    label = tivusat
    protocol = mouse
    device = /dev/tivusat
    services = tivusat
    caid = 183D
    rsakey = A9......B5
    ecmwhitelist = 183D@005411:8C,B7
    detect = cd
    mhz = 800
    cardmhz = 368
    ident = 183D:000000,005411
    group = 1
    emmcache = 1,3,2
     
    #9
  11. Kermit
    Offline

    Kermit Guest

    Gibt es ein Logfile?
     
    #10
  12. Lui2004
    Offline

    Lui2004 Spezialist

    Registriert:
    16. Februar 2008
    Beiträge:
    668
    Zustimmungen:
    46
    Punkte für Erfolge:
    28
    Hab den fehler gefunden

    hatte vergessen dem reader mit der Lokalen karten die group von den proxies zu geben

    Danke dir kermit du hast mir diesen gedankensstos gegeben ;-)
     
    #11

Diese Seite empfehlen