1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

Dieses Thema im Forum "Andere Router Modelle Archiv" wurde erstellt von nappi, 8. Dezember 2012.

  1. nappi
    Offline

    nappi Meister

    Registriert:
    29. Juli 2010
    Beiträge:
    745
    Zustimmungen:
    186
    Punkte für Erfolge:
    43
    Homepage:
    hab mir mal openvpn installiert und alles klappt soweit nur das webif von oscam komme ich nicht rein,

    kann auf luci und auf den ssh zugang zugreifen mit der ip 192.168.1.1 aber oscam webif geht nicht.
    Da bekomme ich immer

    403forbidden
    Access denied

    obwohl ich in die oscam.conf schon die 127.0.01 eingetragen habe


    oscam.log

    2012/12/08 13:27:39 6CA998 h unauthorized access from 10.0.0.6 flag 1 <--- sollte die ip nicht 192.168.1.1 sein ? da ich ja über vpn connecte ?


    falls das wichtig sein sollte greife über android handy auf das vpn netzwerk drauf
     
    Zuletzt bearbeitet: 8. Dezember 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. derdigge
    Offline

    derdigge Super Elite User Supporter

    Registriert:
    2. September 2012
    Beiträge:
    2.546
    Zustimmungen:
    937
    Punkte für Erfolge:
    113
    Beruf:
    Florist
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    und wieder fehlt hintergrund wissen :)

    1. Schmeiss mal deine openvpn config raus.
    2. mal ein wenig hintergrund welcher host ist server client usw. von Welcher seite wird wie zugegriffen.
    3. tun oder tap device?
     
    #2
  4. nappi
    Offline

    nappi Meister

    Registriert:
    29. Juli 2010
    Beiträge:
    745
    Zustimmungen:
    186
    Punkte für Erfolge:
    43
    Homepage:
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    greife von handy mi inet verbindung ueber3g auf den router zu.

    host = router
    client = handy

    tun modus
     
    #3
  5. derdigge
    Offline

    derdigge Super Elite User Supporter

    Registriert:
    2. September 2012
    Beiträge:
    2.546
    Zustimmungen:
    937
    Punkte für Erfolge:
    113
    Beruf:
    Florist
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    ok, kappiert.
    Erstmal glückwunsch zu dieser sicheren Lösung! Sehr löblich :)!


    zeig mal deine oscam.conf bidde
     
    #4
  6. nappi
    Offline

    nappi Meister

    Registriert:
    29. Juli 2010
    Beiträge:
    745
    Zustimmungen:
    186
    Punkte für Erfolge:
    43
    Homepage:
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    heir mal die conf
    # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r7940
    # Read more:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    [global]
    logfile = stdout;/tmp/oscam.log
    cachedelay = 120
    unlockparental = 1
    nice = -1
    maxlogsize = 100
    waitforcards = 0
    preferlocalcards = 1
    block_same_ip = 0
    lb_mode = 1
    lb_reopen_mode = 1
    lb_auto_betatunnel = 0

    [cccam]
    port = XXXXXXX
    nodeid = D778B420108114E8
    version = 2.0.11
    reshare = 1

    [webif]
    httpport = 83
    httpuser = root
    httppwd = install
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.1.1-192.168.1.254
    aulow = 120
    appendchaninfo = 1

    Also so ich das verstanden habe läuft wenn openvpn aktiviert ist bei meinen handy der gesamte traffic über mein vpn.
    Das heisst keiner kann wenn ich in einem freien wlan bin meine verbindung abhören oder überhaupt sehen wohin ich grade verbinde. das selbe gilt auch für mobil netz.

    das ist doch so richtig ?


    EDIT: ohne den usb stick waere viele sachen gar nicht möglich da der speicher viel zu wenig ist !

    Bin erst wieder heute abend online, am system
     
    #5
  7. derdigge
    Offline

    derdigge Super Elite User Supporter

    Registriert:
    2. September 2012
    Beiträge:
    2.546
    Zustimmungen:
    937
    Punkte für Erfolge:
    113
    Beruf:
    Florist
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    Das ist fast richtig. Den kompletten ip traffic tunnelst du nun über vpn.
    Abei deine telefoniererei und sms geht weiterhin normal.

    Aus diesem Grund habe ich diese Möglichkeit geschaffen!


    [webif]
    httpport = 83
    httpuser = root
    httppwd = install
    httprefresh = 10
    httpallowed = 127.0.0.1,192.168.1.1-192.168.1.254,10.8.0.1-10.8.0.254
    aulow = 120
    appendchaninfo = 1

    damit gehts
     
    #6
    nappi gefällt das.
  8. nappi
    Offline

    nappi Meister

    Registriert:
    29. Juli 2010
    Beiträge:
    745
    Zustimmungen:
    186
    Punkte für Erfolge:
    43
    Homepage:
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    thx, werde heute abend testen
     
    #7
  9. Osprey
    Offline

    Osprey Moderator Digital Eliteboard Team

    Registriert:
    30. Dezember 2011
    Beiträge:
    8.796
    Zustimmungen:
    6.486
    Punkte für Erfolge:
    113
    Beruf:
    KFZ-Techniker
    Ort:
    Im wilden Süden
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    Hi,
    könnte jemand ein Howto schreiben mit Schritt für Schritt für die User denen es an Hintergrundwissen fehlt? Danke schonmal......ihr seit die Besten !
    LG
    Toni
     
    #8
  10. nappi
    Offline

    nappi Meister

    Registriert:
    29. Juli 2010
    Beiträge:
    745
    Zustimmungen:
    186
    Punkte für Erfolge:
    43
    Homepage:
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    hallo Osprey, es ist wirklich ganz einfach ! Ich empfehle dir wirklich gedit andere editoren machen nur ärger !
    hier quick und dirty:

    opkg update opkg install openvpn openvpn-easy-rsa

    dann musst du die vars datei editieren, gedit ist am besten
    cd /etc/easy-rsa vi vars

    Diese sachen musst du ändern in der vars datei

    export KEY_COUNTRY="US"
    export KEY_PROVINCE="CA"
    export KEY_CITY="SanFrancisco"
    export KEY_ORG="Fort-Funston"
    export KEY_EMAIL="me@myhost.mydomain"

    dann diese befehle in putty ausführen
    clean-all
    build-ca
    build-dh
    build-key-server server
    hier steht jimmy für deinen usernamen
    build-key Jimmy
    build-key-pkcs12 Jimmy

    dann mach das
    cd /etc/easy-rsa/keys
    cp ca.crt ca.key dh1024.pem server.crt server.key /etc/openvpn/

    danach die openvpn.conf bearbeiten (kannst aber auch so lassen)
    vi /etc/openvpn/openvpn.conf

    Dann die Firewall bearbeiten
    vi /etc/config/firewall


    config 'include'
    option 'path' '/etc/config/firewall.user'

    config 'rule'
    option 'target' 'ACCEPT'
    option 'name' 'VPN'
    option 'src' 'wan'
    option 'proto' 'udp'
    option 'dest_port' '1194'



    Dann die user firewall bearbeiten
    vi /etc/firewall.user
    iptables -t nat -A prerouting_wan -p udp --dport 1194 -j ACCEPT
    iptables -A input_wan -p udp --dport 1194 -j ACCEPT


    iptables -I INPUT -i tun+ -j ACCEPT
    iptables -I FORWARD -i tun+ -j ACCEPT
    iptables -I OUTPUT -o tun+ -j ACCEPT
    iptables -I FORWARD -o tun+ -j ACCEPT

    /etc/init.d/firewall restart
    /etc/init.d/openvpn start
    /etc/init.d/openvpn enable

    nun startet dein vpn automatisch !



    So hoffe das dies so richtig war, ist schon einige Tage her und habe mir leider nicht jeden schritt aufgeschrieben.
    Wenn alles gut rennt, dann bitte rückmeldung geben damit wir uns das hier speichern können
     
    Zuletzt bearbeitet: 13. Dezember 2012
    #9
    schetin und Osprey gefällt das.
  11. nappi
    Offline

    nappi Meister

    Registriert:
    29. Juli 2010
    Beiträge:
    745
    Zustimmungen:
    186
    Punkte für Erfolge:
    43
    Homepage:
    AW: Openwrt mit Openvpn auf oscam webif zugreifen klappt nicht

    Zum Android client,

    lade dir aus dem paystore openvpn runter und installier es, dann kopiere die ca und die key datei von deinen user auf dein handy und exportiere die beiden in openvpn,
     
    #10
    Osprey gefällt das.

Diese Seite empfehlen