1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OpenWRT Mac-Filter

Dieses Thema im Forum "Andere Router Modelle Archiv" wurde erstellt von bachmer, 8. Oktober 2013.

  1. bachmer
    Offline

    bachmer Newbie

    Registriert:
    7. Dezember 2008
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Hi, ich habe auf meinen WRD3600 OpenWRT installiert. Grundsätzlich läuft alles wie es soll, aber der MAC-Filter für W-LAN ignoriert meine Eingaben.
    Ich möchte nur bestimmte MAC-Adressen zulassen, aber es kann jedes Gerät, was den W-LAN-Schlüssel kennt ins W-LAN.

    Hier mal meine wireless-Datei:

    config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11ng'
    option macaddr '64:70:02:e7:b8:1d'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option country 'DE'
    option channel '3'
    option txpower '20'

    config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'xxxxxxxxxxxxxxxxxxxxxx'
    option encryption 'psk2'
    option key 'xxxxxxxxxxxxxxxxxxxxxxxxxxx'
    option network 'lan'
    list maclist '00:1F:1F:33:92:B9'
    list maclist '00:07:AE:A5:5V:89'
    option macfilter 'allow'

    config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option hwmode '11na'
    option macaddr '64:70:02:a2:e3:1e'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option disabled '1'

    config wifi-iface
    option device 'radio1'
    option mode 'ap'
    option ssid 'Open

    Kann mir vielleicht jemand sagen, wo der Fehler liegt?

    Ich hab es auch schon andersherum versucht. Also nur MAC-Adressen zulassen, die nicht gelistet sind. Auch das wird einfach ignoriert. Es hat den Anschein, als würde der MAC-Filter einfach übergangen. :(
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Osprey
    Online

    Osprey Moderator Digital Eliteboard Team

    Registriert:
    30. Dezember 2011
    Beiträge:
    8.817
    Zustimmungen:
    6.514
    Punkte für Erfolge:
    113
    Beruf:
    KFZ-Techniker
    Ort:
    Im wilden Süden
    AW: OpenWRT Mac-Filter

    Hi,
    habe es soeben bei mir probiert über das OpenWrt Interface und der Filter funktioniert.
    Mein Handy bekommt keine Verbindung wenn MAC nicht freigeschaltet ist.
    Gruß
     
    #2
  4. bachmer
    Offline

    bachmer Newbie

    Registriert:
    7. Dezember 2008
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: OpenWRT Mac-Filter

    Danke dir für die Hilfe!

    Kannst du mal bitte die wireless Datei vergleichen. Ist ja schon etwas eigenartig. Das Interface habe ich probiert, leider ohne Erfolg.
     
    Zuletzt von einem Moderator bearbeitet: 9. Oktober 2013
    #3
  5. Osprey
    Online

    Osprey Moderator Digital Eliteboard Team

    Registriert:
    30. Dezember 2011
    Beiträge:
    8.817
    Zustimmungen:
    6.514
    Punkte für Erfolge:
    113
    Beruf:
    KFZ-Techniker
    Ort:
    Im wilden Süden
    AW: OpenWRT Mac-Filter

    Ja klar schreibe ich später oder morgen. In welchem Pfad finde ich das? Bin nur immer über das Webif unterwegs.
    okey hab es gefunden in etc/config/wireless. Habe mal 3 Geräte zugelassen, alle anderen bekommen keine Verbindung.

    config wifi-device 'radio1'
    option type 'mac80211'
    option macaddr '64:x0:x2:xx:1x:x2'
    option hwmode '11ng'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'DSSS_CCK-40'
    option channel '3'
    option txpower '15'
    option country 'US'

    config wifi-iface
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid 'mein Router'
    option encryption 'psk2'
    option key 'mein passwort'
    option macfilter 'allow'
    list maclist '2x:xD:74:x0:Ex:x5'
    list maclist '00:xC:C3:x1:A4:xC'
    list maclist 'Ax:3C:xB:04:4x:07'
     
    Zuletzt bearbeitet: 9. Oktober 2013
    #4
  6. bachmer
    Offline

    bachmer Newbie

    Registriert:
    7. Dezember 2008
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    AW: OpenWRT Mac-Filter

    Ich danke dir. Ich habe jetzt alles probiert, nix zu machen, der Mac-Filter wird ignoriert. :(
     
    #5
  7. Osprey
    Online

    Osprey Moderator Digital Eliteboard Team

    Registriert:
    30. Dezember 2011
    Beiträge:
    8.817
    Zustimmungen:
    6.514
    Punkte für Erfolge:
    113
    Beruf:
    KFZ-Techniker
    Ort:
    Im wilden Süden
    AW: OpenWRT Mac-Filter

    Hi, du hast 2 wlan Schnittstellen. Radio0 und Radio1. Ist das so gewollt?
     
    #6
  8. bachmer
    Offline

    bachmer Newbie

    Registriert:
    7. Dezember 2008
    Beiträge:
    29
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Nein nicht wirklich. Ich schau mir das mal an. Danke für den Hinweis!

    Da ist alles Ok. Radio1 ist 2,4 GHz und Radio1 ist für 5 GHz.
     
    Zuletzt von einem Moderator bearbeitet: 16. Oktober 2013
    #7

Diese Seite empfehlen