1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Nutze ich die falschen Oscam Versionen ?

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Zig3un3r, 24. September 2013.

  1. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    Hallo Leute,

    Habe vor kurzem einen CCcam Client gegen Oscam Client getauscht. (Wegen HD02 EMM, da bis dato nicht per C-Line Emm geschrieben werden konnten )

    Kaum hatte ich die Umstellung fertig fand ich dieses in der der Database:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Hier der Link zur Anleitung:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Da CCcam noch auf der Clientbox komplett mit Config vorhanden ist dachte ich super und wollte die Oscam Verison auf dem W920 tauschen.

    Laut User Ammassida:

    [​IMG] AW: HD 02 (1843) macht AU nur mit Oscam Client nicht mit CCcam Client
    Habe vom Streamboard einen Patch bekommen der auf Rev 8821 (getestet von mir) und Rev 8844 (von Board Usern getestet) funktioniert.

    Nun klappt es das CCcam die EMM´s an Oscam übermitteln kann.

    Lieder möchte man das nicht in die Trunk mit integrieren da es ein Fehler von CCcam ist und nicht von Oscam.

    Dieser Patch ändert das EMM überprüfen so das auch unbekannte Provider ID´s für die 1843 übermittelt werden. Dies kommt weil CCcam dies ändern. Warum das CCcam macht weiß ich nicht aber so funktioniert es nun.

    Wenn ein Mod aus dem Forum so nett ist und mich per Skype kontaktiert um dann diesen Patch für andere publik zu machen wäre das echt nett da ich nur für 64bit Server kompilieren kann. (einfach eine PN an mich und ich schicke die Patch Datei)

    gruß

    amassidda

    gehen die beiden Oben genannten Verionen: Rev 8821 (getestet von mir) und Rev 8844 (von Board Usern getestet)

    SO ich nicht lange Überlegt und habe mir diese Versionen aus dem DEB Board gezogen:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    Rev 8844

    Leider Bekomme ich beim starten folgenden Fehler ( getestet per Telnet )

    segmentation fault

    Was bedeutet das ??

    Eingespielt wurde per WinScp manuell oder per TBflex ( immer der selbe Fehler )

    Zum testen habe ich noch nen paar andere Versionen getestet

    Immer wieder der Selbe Fehler ......

    Im Moment habe ich diese Version am Laufen

    v1.20-unstable_svn build r8282 (mipsel-linux-uclibc-ssl-libusb-pcsc)


    Weiss jemand Rat ?

    Gruss Zig
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.946
    Zustimmungen:
    5.865
    Punkte für Erfolge:
    113
    AW: Nutze ich die falschen Oscam Versionen ?

    Hi,
    ich glaube da hast du was falsch verstanden.
    Du mußt die Version 8821 oder 8844 mit diesem patch beim kompilieren patchen.
    Die normalen Versionen können das nach wie vor nicht.

    Gruß
    janni1
     
    #2
  4. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    AW: Nutze ich die falschen Oscam Versionen ?

    Hy Janni1,

    Hmm OK,

    Ich dachte ich kann eine vorhandene Oscam Version mit den oben beschriebenen Befehlen "bearbeiten"
    Dann bin ich wohl auf die Gnade eines Users angewiesen der das evtl. für mich mal
    kompilieren kann.
    Freiwillige gesucht :)
    Ich müsste mich wieder erst mit der Materie auseinander setzten.

    Danke fürs Aufklären

    Gruss Zig
     
    #3
  5. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.946
    Zustimmungen:
    5.865
    Punkte für Erfolge:
    113
    AW: Nutze ich die falschen Oscam Versionen ?

    Hi,
    ich kann es ja mal versuchen mit cross-compiling.
    Was ist das für ein Gerät (Fritzbox)?
    Was brauchst du alles?
    Am besten du kopierst mal die Einträge unter Files --> oscam.version im web-if von der jetzigen Version.

    Gruß
    janni1
     
    #4
  6. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    AW: Nutze ich die falschen Oscam Versionen ?

    hallo Janni1,

    Das wäre eine ganz feine Sache von dir :)

    Meine aktuelle Oscam Version

    Unix starttime: 1379980023
    Starttime: 24.09.2013 01:47:03
    Version: oscam-1.20-unstable_svn-r8282

    Web interface support: yes
    Touch interface support: yes
    SSL support: yes
    DVB API support: no
    Anti-cascading support: yes
    Irdeto guessing: yes
    Debug mode: yes
    Monitor: yes
    Loadbalancing support: yes
    LCD support: no
    LED support: no
    IPv6 support: no
    Cache exchange support: yes

    camd 3.3x: yes
    camd 3.5 UDP: yes
    camd 3.5 TCP: yes
    newcamd: yes
    CCcam: yes
    CCcam share: yes
    Pandora: yes
    ghttp: no
    gbox: yes
    radegast: yes
    serial: yes
    constant CW: yes

    Reader support: yes

    Nagra: yes
    Irdeto: yes
    Conax: yes
    Cryptoworks: yes
    Seca: yes
    Viaccess: yes
    NDS Videoguard: yes
    DRE Crypt: yes
    TONGFANG: yes
    Bulcrypt: yes
    Griffin: yes

    cardreader_phoenix: yes
    cardreader_internal_azbox: no
    cardreader_internal_coolapi: no
    cardreader_internal_sci: no
    cardreader_sc8in1: yes
    cardreader_mp35: yes
    cardreader_smargo: yes
    cardreader_pcsc: yes
    cardreader_smartreader: yes
    cardreader_db2com: no
    cardreader_stapi: no

    Ich habe als Server einen Gefreetzen Speedport W920V

    Gruss Zig

    Gruss Zig
     
    #5
  7. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.946
    Zustimmungen:
    5.865
    Punkte für Erfolge:
    113
    AW: Nutze ich die falschen Oscam Versionen ?

    Hi,
    der speedport ist zu einer 72xx gefritzt worden?

    Gruß
    janni1
     
    #6
  8. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    AW: Nutze ich die falschen Oscam Versionen ?

    Hy,

    bei dem Image was geflasht wurde steht Fritzbox 7570 mit dabei

    Gruss Zig
     
    #7
  9. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.946
    Zustimmungen:
    5.865
    Punkte für Erfolge:
    113
    AW: Nutze ich die falschen Oscam Versionen ?

    Hi,
    hier kannst ja mal testen
    File entfernt --- funktionierte nicht
    ist aber für eine fritz 73xx gebaut wurden. Keine Ahnung was ich sonst für einen toolchain für den speedport nehmen soll.
    Vieleicht gehts ja.

    Gruß
    janni1
     
    Zuletzt bearbeitet: 25. September 2013
    #8
    Zig3un3r gefällt das.
  10. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    AW: Nutze ich die falschen Oscam Versionen ?

    Dank dir,

    Ich glaube ich bräuchte eine Version für die 7270er reihe,

    Beim start kommt dieser Fehler:
    /var/media/ftp/usb/service/oscam/oscam: line 30: syntax error: unexpected word (expecting ")")

    Falls du noch lust haste kannste ja noch eine kompilieren :)

    Gruss & Danke
    Zig
     
    #9
  11. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.946
    Zustimmungen:
    5.865
    Punkte für Erfolge:
    113
    AW: Nutze ich die falschen Oscam Versionen ?

    Hi,
    so hier nochmal ein Versuch mit 72xx-er toolchain
    File entfernt --- funktionierte nicht
    Wenn das auch nicht geht, würd ich mal im Fritz-Bereich fragen.
    Da baut dir bestimmt mal ein Profi eine passende.

    Gruß
    janni1
     
    Zuletzt bearbeitet: 25. September 2013
    #10
    Zig3un3r gefällt das.
  12. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    AW: Nutze ich die falschen Oscam Versionen ?

    Danke nochmal für Probieren,

    Ich werde mal im Fritz bereich danach Fragen:

    Beim Starten kommt nun dieser Fehler -Leider :(
    /var/media/ftp/usb/service/oscam/oscam: can't load library 'libpcsclite.so.1

    Dennoch Danke für die Mühe !
    Gruss
     
    #11
  13. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.946
    Zustimmungen:
    5.865
    Punkte für Erfolge:
    113
    AW: Nutze ich die falschen Oscam Versionen ?

    Hi
    brauchst du denn unbedingt den pcsc-reader?
    ich hab den nur mit einkompiliert weil deine jetzige Version das auch hatte.

    Hier mal ohne pcsc
    File entfernt--- funktionierte nicht

    Gruß
    janni1
     
    Zuletzt bearbeitet: 25. September 2013
    #12
  14. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    AW: Nutze ich die falschen Oscam Versionen ?

    Hallo Nochmal

    Nein, ist halt in der jetzigen mit drin.

    meinst es liegt daran ?
    Ich trau mich dich schon gar nicht mehr zu fragen ob du noch eine Version ohne kompilierst *Duck*
    Gruss Zig
     
    #13
  15. janni1
    Offline

    janni1 Moderator Digital Eliteboard Team

    Registriert:
    3. Mai 2010
    Beiträge:
    4.946
    Zustimmungen:
    5.865
    Punkte für Erfolge:
    113
    AW: Nutze ich die falschen Oscam Versionen ?

    Hi,
    schau mal oben, hab editiert :DDD

    Gruß
    janni1
     
    #14
    Zig3un3r gefällt das.
  16. Zig3un3r
    Offline

    Zig3un3r Freak

    Registriert:
    21. September 2010
    Beiträge:
    207
    Zustimmungen:
    21
    Punkte für Erfolge:
    18
    Beruf:
    IT-Systemelektroniker
    AW: Nutze ich die falschen Oscam Versionen ?

    So, nun habe ich den oben genannten Fehler :(

    Segmentation fault - was auch immer das zu bedeuten hat :(

    Die Version wird nun richtig im Webif angezeigt, Rechte sind vergeben worden - nur starten will es nicht :)

    Für heute ist es erst einmal genug - Meine bessere Hälfte hält mir schon das Messer an die Kehle :)

    Danke nochmal

    Gruss Zig
     
    #15

Diese Seite empfehlen