1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

NewCS zu Newcamd. Es geht nicht !

Dieses Thema im Forum "CS Newcs" wurde erstellt von Gizeh, 19. März 2009.

  1. Gizeh
    Offline

    Gizeh Ist gelegentlich hier

    Registriert:
    7. Januar 2008
    Beiträge:
    37
    Zustimmungen:
    16
    Punkte für Erfolge:
    0
    Hallo Leute, es ist zum verzweifeln:

    Ich habe einen Linksys Nslu2 mit Smargo Cardreader. Auf der Nslu2 läuft NewCS. Der Client ist ein Octagon Receiver mit Newcamd 5.25. Die Karte ist eine PW S01.
    Hier das Log beim starten von NewCS:


    Code:
    # newcs.nslu2.usb -c /etc/newcs.usb.xml
    This is NewCS 1.65 - the New CardServer by the Butter-team..
    Compiled on Jan 19 2009 at 17:56:11
    Reading Config file from /etc/newcs.usb.xml
    TCP-log password is enabled, set to: NewCSpwd
    level: normal
    type: all
    output: console,file,tcp
    logger config: level 1 type 255 output 13
    Console log options: level 1 type 255
    log file: /tmp/newcs.logfile
    File log options: level 1 type 255
    TCP log options: level 1 type 255
    [ 23:34:38 ] [ Box detect ] Box type 1 (General Boxtype - PC compatible)
    [ 23:34:38 ] [ Config ] Irdeto EMM mode 0 SET on reader Smargo on USB1
    [ 23:34:38 ] [ Config ] Option <blockc0> for device 0 (Smargo on USB1) not present, defaulting to NO
    [ 23:34:38 ] [ Config ] Option <crypto-special> for device 0 (Smargo on USB1) not present, defaulting to NO
    [ 23:34:38 ] [ Config ] Option <PTShandshake> for device 0 (Smargo on USB1) not present, defaulting to NO
    [ 23:34:38 ] [ Config ] Option <Seca-PPV> for device 0 (Smargo on USB1) not present, defaulting to NO
    [ 23:34:38 ] [ Config ] /dev/ttyUSB0 ECM priority: round
    [ 23:34:38 ] [ Newcamd ] Server name : newcs
    [ 23:34:38 ] [ Newcamd ] Des key     : 0102030405060708091011121314
    [ 23:34:38 ] [ Config ] Option <spider> not present for User: dummy, defaulting to NO
    [ 23:34:38 ] [ Newcamd ] User 2: dummy, Pass: dummy, Host none, Port: 0, Au: Off, Spider allowed: No, Sidoverride: No, level: 0
    [ 23:34:38 ] [ httpd ] httpd-user: newcs, password: newcs, accesslevel: admin
    [ 23:34:38 ] [ EMM Cache ] Initialising dynamic Cache
    [ 23:34:38 ] [ ECM Cache ] Initialising dynamic Cache
    [ NewCS ] Process ID is: 509
    [ 23:34:38 ] [ Loader ] Starting Telnet on port 1001
    [ 23:34:38 ] [ Loader ] Started HTTP-server on port: 8080
    [ 23:34:38 ] [ Loader ] Reader type 2 on node /dev/ttyUSB0
    [ 23:34:38 ] [ Phoenix ] Opening device /dev/ttyUSB0
    [ 23:34:38 ] [ Phoenix ] Setting Parity to: NONE
    [ 23:34:38 ] [ Phoenix ] Setting 2 Stop bits on node /dev/ttyUSB0
    [ 23:34:38 ] [ Phoenix ] Setting Baud to standard 9600
    [ 23:34:39 ] [ Phoenix ] Normal RESET on node /dev/ttyUSB0
    [ 23:34:40 ] [ ATR ] T=14  1etu=174.60us  Guardtime:17etu  WWT:9600etu
    [ 23:34:40 ] [ ATR ] Historical bytes: I R D E T O   A C S [03] [83] [95] [00] [80]
    [ 23:34:40 ] [ Loader ] Init Irdeto card
    [ 23:34:40 ] [ Phoenix ] Setting Parity to: NONE
    [ 23:34:40 ] [ Phoenix ] Setting 2 Stop bits on node /dev/ttyUSB0
    [ 23:34:40 ] [ Phoenix ] Setting Baud to custom 5727
    [ 23:34:41 ] [ KeymaN ] Adding key 0000000071238c type 0 on Provider 000000 for caid 1702 ID=0
    [ 23:34:41 ] [ KeymaN ] Adding key 00000000ffffff type 1 on Provider 000000 for caid 1702 ID=0
    [ 23:34:41 ] [ KeymaN ] Adding key 00000000ffffff type 1 on Provider 000001 for caid 1702 ID=1
    [ 23:34:41 ] [ KeymaN ] Skipping duplicate irdeto
    [ 23:34:41 ] [ Loader ] Card 1702 on port /dev/ttyUSB0 ready
    [ 23:34:41 ] [ Loader ] Starting Newcamd Server on port 20028
    [ 23:34:41 ] [ Newcamd ] Newcamd thread Server started on port 20028
    newcamd: main loop
    [ 23:34:41 ] [ NewCS ] Ready to GO! :)
    #
    
    Für mich sieht das gut aus, oder täusch ich mich da.
    Und hier meine newcs.xml:

    Code:
    <?xml version="1.0"?>
    <!--
    The configfile are NOT case-sensitive, and shouldnt care about dos/unix cr/lf.
    -->
    
    <newCSconfig>
        <readers name="Smargo">
            <device>
                <name>Smargo on USB1</name>
                <type>phoenix</type>
                <mhz>358</mhz>
                <node>/dev/ttyUSB0</node>
                <parity>none</parity>
                <reset>normal</reset>
                <export>Yes</export>
                <enabled>Yes</enabled>
                <blocksa>No</blocksa>
                <blockua>No</blockua>
                <blockga>No</blockga>
                <blockC0>Yes</blockC0>
                <irdetomode>0</irdetomode>
                <carddetect>yes</carddetect>
                <newcamd_port>20028</newcamd_port>
                <priority>round</priority>
            </device>
        </readers>
        <cache>
                <emm>20</emm>
                <ecm>-1</ecm>
        </cache>
        <httpd>
            <server>
                <port>8080</port>
                <enabled>yes</enabled>
            </server>
            <user>
                <name>newcs</name>
                <password>newcs</password>
                <accesslevel>admin</accesslevel>
            </user>
        </httpd>
        <debug>
                <password>NewCSpwd</password>
                <mode>simple</mode>
                <level>normal</level>
                <type>all</type>
                <output>console,file,tcp</output>
                <logfile>/tmp/newcs.logfile</logfile>
                <tcp_port>1001</tcp_port>
                <tcp_options>normal,init</tcp_options>
        </debug>
        <newcamdserver>
                <enabled>Yes</enabled>
                <name>newcs</name>
                <deskey>01 02 03 04 05 06 07 08 09 10 11 12 13 14</deskey>
                <user>
                    <name>dummy</name>
                    <password>dummy</password>
                    <au>off</au>
                    <sidoverride>off</sidoverride>
                </user>
        </newcamdserver>
    </newCSconfig>
    
    Das Problem ist nun, dass beim Receiver nichts ankommt. Beim Einschalten von Newcamd wird auf Port 20028 gesucht, aber leider keine CAIDs gefunden. Bei einem Payserver funktionierts aber. Was mach ich blos falsch?

    Gruß Gizehs
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. Gizeh
    Offline

    Gizeh Ist gelegentlich hier

    Registriert:
    7. Januar 2008
    Beiträge:
    37
    Zustimmungen:
    16
    Punkte für Erfolge:
    0
    AW: NewCS zu Newcamd. Es geht nicht !

    Noch was vergessen:

    Hier das Log beim verbinden:

    Code:
    [ 23:55:07 ] [ Newcamd:20028 ] Connection from 192.168.1.70
    [ 23:55:07 ] [ Newcamd:20028 ] User dummy logged in, client: Generic
    [ 23:55:07 ] [ Newcamd:20028 ] User dummy logout
    [ 23:55:18 ] [ Newcamd:20028 ] Connection from 192.168.1.70
    [ 23:55:18 ] [ Newcamd:20028 ] User dummy logged in, client: Generic
    [ 23:55:18 ] [ Newcamd:20028 ] User dummy logout
    Im Receiver wird angezeigt:

    Code:
    Port 20028
    CAID 0000 not found
     
    #2
  4. Gizeh
    Offline

    Gizeh Ist gelegentlich hier

    Registriert:
    7. Januar 2008
    Beiträge:
    37
    Zustimmungen:
    16
    Punkte für Erfolge:
    0
    AW: NewCS zu Newcamd. Es geht nicht !

    Da mit niemand helfen kann, antworte ich mit mal selbst. Also, Newcs liest die S01 Karte falsch, zu erkennen am ATR. Entweder sind meine Einstellungen falsch (hab aber einiges durchprobiert), oder Newcs kann die Karte einfach nicht lesen. Kurzum, mit MPCS funktionierte es gleich im ersten Anlauf.

    Gruß Gizehs
     
    #3
  5. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: NewCS zu Newcamd. Es geht nicht !

    Dein Newcs log sieht ok aus. Um sicher zugehen, schau bitte in dein web Interface. Das kannst du aufrufen indem du auf den Server 127.0.0.1:8080 eingeben tust.

    Hier sollte erstmal unter reader dein Smargo stehen mit der Caid vom ABO.

    Dan lege über das Interface ein neuen User an. Aktiviere hier nur AU und Spider. Starte das newcs neu und versuche dich dann nochmal zu verbinden.
     
    #4
  6. Gizeh
    Offline

    Gizeh Ist gelegentlich hier

    Registriert:
    7. Januar 2008
    Beiträge:
    37
    Zustimmungen:
    16
    Punkte für Erfolge:
    0
    AW: NewCS zu Newcamd. Es geht nicht !

    Hallo Phantom,
    der Readerstatus im WebIf ist ok

    Status: Grün
    CAID: 1702
    Mhz: 358
    Resets: 0
    ECMs: 2
    NetECM: 0
    usw.

    Neuer User ABC angelegt und versucht zu connecten. Hier die Ausgabe (hab mal den Logmodus auf internal gesetzt)
    Code:
    [ 21:27:48 ] [ Newcamd ] new connection from 192.168.1.70 on socket 10
    [ 21:27:48 ] [ Newcamd:19543 ] Connection from 192.168.1.70
    [ 21:27:48 ] [ Newcamd:19543 ] User ABC logged in, client: Generic
    [ 21:27:48 ] [ Newcamd:19543 ] Command E3 from ABC len 3
    [ 21:27:48 ] [ Newcamd:19543 ] Sending Card Information to ABC:
    [ 21:27:48 ] [ Newcamd ] ProvID 0 Key 71238C on caid 1702 type 0
    [ 21:27:48 ] [ Newcamd ] ProvID 0 Key FFFFFF on caid 1702 type 1
    [ 21:27:48 ] [ Newcamd ] ProvID 1 Key FFFFFF on caid 1702 type 1
    [ 21:27:48 ] [ Newcamd ] Socket 10 hung up
    [ 21:27:48 ] [ Newcamd:19543 ] User ABC logout
    Beim Newcamd Client kommt die CAID 0x1a71 an, mit der er nichts anzufangen weiss. Warum geht es bei MPCS ohne Probleme? Bug in der Newcs.nslu2 Soft? Hab keinen Plan mehr.

    Gruß Gizehs
     
    #5
  7. phantom
    Offline

    phantom Administrator Digital Eliteboard Team

    Registriert:
    5. Juli 2007
    Beiträge:
    32.639
    Zustimmungen:
    17.921
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    AW: NewCS zu Newcamd. Es geht nicht !

    Nutze mal das Newcs 1.62. Damit hatte ich keine Probleme.
     
    #6
  8. Gizeh
    Offline

    Gizeh Ist gelegentlich hier

    Registriert:
    7. Januar 2008
    Beiträge:
    37
    Zustimmungen:
    16
    Punkte für Erfolge:
    0
    AW: NewCS zu Newcamd. Es geht nicht !

    Hallo,
    Newcs 1.62 versucht und leider keine Änderung. Nach einem Reset des Readers hat sich newcs sogar aufgehängt. Aber egal, nehm ich halt mpcs. Vielen Dank für deine Unterstützung.

    Gruß Gizeh
     
    #7
  9. IDDQD
    Offline

    IDDQD Board Guru

    Registriert:
    6. Februar 2008
    Beiträge:
    1.416
    Zustimmungen:
    635
    Punkte für Erfolge:
    113
    Beruf:
    IT'ler
    Ort:
    Zone
    AW: NewCS zu Newcamd. Es geht nicht !

    ich hatte das gleiche phänomen! aber mit ner mgcamd auf ner kathi ... mein problem waren die prio.list und replace.list! die weggelöscht und alles war in butter!
     
    #8

Diese Seite empfehlen