1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von Diebelsalt, 16. November 2012.

  1. Diebelsalt
    Offline

    Diebelsalt Ist oft hier

    Registriert:
    17. September 2008
    Beiträge:
    184
    Zustimmungen:
    64
    Punkte für Erfolge:
    28
    Hallo,

    ich habe eine Fritzbox 7141 auf der freetz (devel 9327) und die Oscam (svn 7903) laufen. An der Box hängt ein passiver USB-Hub (noname), in welchem wiederum zwei Kartenleser (Maxdata Smargo FW 1.5) stecken, einmal mit einer S02 und mit einer HD01 Karte. Meine Konfiguration läuft soweit zufriedenstellend, jedoch habe ich folgendes Problem: Wenn ich den Oscam Dienst neustarte, bekomme ich folgende Fehlermeldung von beiden Kartenlesern: usb bulk write failed : ret = -7. Das ist immer reproduzierbar. Lösen kann ich das Problem, indem ich die Fritte neustarte (z.B. Reboot über Webif) oder indem ich die Oscam stoppe, die Reader vom USB-Port abziehe, wieder einstecke und danach die Oscam wieder starte. Jetzt ist natürlich die Frage, wo das Problem ist. Ich greife über das smartreader Protokoll auf die Smargos zu (Fdti Treiber ist deaktiviert) siehe Konfiguration. Weis jemand woran das liegen könnte? Gerade um ein paar Optimierungen zu testen, wäre es schön, nicht immer die ganze Box neustarten zu müssen.

    Danke!

    Grüße

    hier nochmal das log im Fehlerfall:
    2012/11/16 10:43:10 0 s skyde [smartreader] creating thread for device Serial:Reader A111111
    2012/11/16 10:43:10 0 s hdplus [smartreader] creating thread for device Serial:Reader B222222
    2012/11/16 10:43:10 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/11/16 10:43:10 0 s waiting for local card init
    2012/11/16 10:43:10 5C2AC0 r skyde [smartreader] Using 0x82 as endpoint for smartreader hardware detection
    2012/11/16 10:43:10 5C2AC0 r Found reader with serial Reader A111111 at 001:003
    2012/11/16 10:43:10 5C2AC0 r Found smartreader device Serial:Reader A111111
    2012/11/16 10:43:10 5C42D0 r hdplus [smartreader] Using 0x82 as endpoint for smartreader hardware detection
    2012/11/16 10:43:10 5C42D0 r Found reader with serial Reader B222222 at 001:004
    2012/11/16 10:43:10 5C42D0 r Found smartreader device Serial:Reader B222222
    2012/11/16 10:43:10 5C2AC0 r skyde [smartreader] Reader initialized (device=Serial:Reader A111111, detect=cd, mhz=600, cardmhz=600)
    2012/11/16 10:43:10 5C42D0 r hdplus [smartreader] Reader initialized (device=Serial:Reader B222222 , detect=cd, mhz=369, cardmhz=369)
    2012/11/16 10:43:11 5C2AC0 r skyde [smartreader] card detected
    2012/11/16 10:43:11 5C42D0 r hdplus [smartreader] card detected
    2012/11/16 10:43:21 5C2AC0 r skyde [smartreader] usb bulk write failed : ret = -7
    2012/11/16 10:43:21 5C42D0 r hdplus [smartreader] usb bulk write failed : ret = -7


    oscam.conf
    [global]serverip = 192.168.1.2
    pidfile = /data/logs/oscam.pid
    logfile = /data/logs/oscam.log
    usrfile = /data/logs/oscamuser.log
    fallbacktimeout = 2000
    cachedelay = 120
    nice = -1
    maxlogsize = 2
    preferlocalcards = 1
    failbantime = 5
    clienttimeout = 7
    bindwait = 5
    WaitForCards = 1
    saveinithistory = 1


    [cccam]
    port = XXXXX
    version = 2.3.0
    reshare = 0
    forward_origin_card = 1
    ignorereshare = 0
    minimizecards = 0
    keepconnected = 1
    stealth = 0
    reshare_mode = 0
    updateinterval = 240


    [webif]
    httpport = 34002
    httpuser = XXXXX
    httppwd = XXXXX
    httphelplang = de
    httphideidleclients = 1
    httpallowed = 192.168.1.0-192.168.1.255


    [monitor]
    port = 988
    nocrypt = 192.168.1.0-192.168.1.255

    oscam.server
    [reader]
    label = skyde
    protocol = smartreader
    device = Serial:Reader A111111
    services = skyde
    caid = 1702,1833
    boxkey = 1122334455667788
    ecmwhitelist = 93
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,2,2
    blockemm-unknown = 1


    [reader]
    label = hdplus
    protocol = smartreader
    device = Serial:Reader B222222
    services = hdplus
    caid = 1830
    rsakey = B...5
    boxkey = A...C
    ecmwhitelist = 92
    detect = cd
    mhz = 369
    cardmhz = 369
    group = 2
    emmcache = 1,2,2
    blockemm-unknown = 1
    auprovid = 000001
     
    Zuletzt bearbeitet: 16. November 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Hi,

    versuch mal mit dem Eintrag

    Code:
    smargopatch = 1
    in beiden Readern

    Liebe Grüße
    Bombadil
     
    #2
    Pilot und meister85 gefällt das.
  4. Diebelsalt
    Offline

    Diebelsalt Ist oft hier

    Registriert:
    17. September 2008
    Beiträge:
    184
    Zustimmungen:
    64
    Punkte für Erfolge:
    28
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    huhu,

    danke für deine Antwort. Ich dachte bis jetzt, der bringt nur was beim mouse oder smargo Protokoll?

    Grüße

    Edit:

    Funktioniert leider auch nicht, gleiches Problem.
     
    Zuletzt bearbeitet: 16. November 2012
    #3
  5. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Hi,

    ob das wirklich die Lösung für dich ist, kann ich nicht sagen. Teste es erst mal mit dem Eintrag. Sonst versuche die Rader mit udev einzubinden

    Lieben Gruß
    Bombadil
     
    #4
  6. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Wenn du das Smartreader Protokoll nutzt, musst du natürlich auch die entsprechende LIBUSB Treiber haben, ansonsten wird es nichts.

    Am besten direkt eine OScam nehmen, wo die Libusb Treiber enthalten sind.

    Außerdem bitte folgendes korrigieren:

    [reader]
    label = skyde

    protocol = smartreader
    device = Serial:Reader A111111
    services = skyde
    caid = 1702,1833
    boxkey = 1122334455667788
    ecmwhitelist = 93
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,2,2
    blockemm-unknown = 1

    Du hattest die nebeneinander!
     
    #5
    Pilot gefällt das.
  7. Diebelsalt
    Offline

    Diebelsalt Ist oft hier

    Registriert:
    17. September 2008
    Beiträge:
    184
    Zustimmungen:
    64
    Punkte für Erfolge:
    28
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Hallo,

    das nebeneinander stehen war nur ein Kopierfehler, sorry.

    Ich nutze "Oscam 1.20-webinf-smartreader-rev 7903" aus dem streamboard. Ich vermute mal aufgrund der Namensgebung, dass der entsprechende USBTreiber dort enthalten ist. Und wie gesagt, nach einem Reboot der Box funzt alles wie gewünscht.

    Grüße
     
    #6
  8. Skyrider79
    Offline

    Skyrider79 Power Elite User

    Registriert:
    28. September 2011
    Beiträge:
    2.374
    Zustimmungen:
    881
    Punkte für Erfolge:
    113
    Beruf:
    Instandhaltungselektroniker
    Ort:
    Franken
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Ich glaube hier schon gelesen zu haben das dies ein Kernel Problem der 71..er Reihe ist mit dem Smartreader Protokoll.
    Lösung habe ich leider keine....
     
    #7
  9. meister85
    Offline

    meister85 VIP

    Registriert:
    21. September 2009
    Beiträge:
    7.927
    Zustimmungen:
    5.229
    Punkte für Erfolge:
    113
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Dann wird es vermute ich am passiven Hub liegen. Hast du einen aktiven Hub da, um es auszuprobieren?
     
    #8
  10. Diebelsalt
    Offline

    Diebelsalt Ist oft hier

    Registriert:
    17. September 2008
    Beiträge:
    184
    Zustimmungen:
    64
    Punkte für Erfolge:
    28
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Ich könnte mal das Netzteil an den Hub anschließen...

    Das kann ich aber erst heute Abend testen. Als ich noch alles mit der Cccam laufen hatte, gab es Probleme sobald das Netzteil dran war. Aber testen kann ich es.

    Wenn das so ist müsste ich mal das mouse Protokoll probieren.

    Danke!

    Grüße
     
    #9
  11. Diebelsalt
    Offline

    Diebelsalt Ist oft hier

    Registriert:
    17. September 2008
    Beiträge:
    184
    Zustimmungen:
    64
    Punkte für Erfolge:
    28
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    So...,

    bekomme das Mouse oder Smargo Protokoll noch nicht zum laufen (error activating card). Die eindeutige Zuordnung der Reader mit ftdi Treibern ist bei der 7141 (und auch 7170) in Ermangelung des udev Pakets nicht möglich. Ich vermute ja, dass es an den Einstellungen der Smargos liegt, das die beiden Protokolle nicht gehen.

    Aktuell sind meine Smargos (Maxdata FW 1.05) beide so eingestellt:
    Auto
    Normal
    1
    0

    Als ich die CCcam laufen hatte, waren beide Reader im Dreambox Kernel Mode. Aber mit fer EInstellung wollten die Reader das smartreader Protokoll nicht. Das werde ich heute Abend nochmal testen.


    Grüße

    P.S. Und Strom ranstecken werde ich auch nochmal...
     
    #10
  12. Pilot
    Offline

    Pilot MFC Digital Eliteboard Team

    Registriert:
    29. Mai 2008
    Beiträge:
    28.388
    Zustimmungen:
    23.804
    Punkte für Erfolge:
    113
    Beruf:
    Technologe
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Die Einstellung des Smargos ist falsch für eine Fritzbox 7170.
    Die verlangt das so:
    Auto
    Dreambox
    1
    0

    Hier nachzulesen:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Mlg piloten
     
    #11
    Diebelsalt, bombadil und Skyrider79 gefällt das.
  13. Diebelsalt
    Offline

    Diebelsalt Ist oft hier

    Registriert:
    17. September 2008
    Beiträge:
    184
    Zustimmungen:
    64
    Punkte für Erfolge:
    28
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Huhu,

    danke, die Übersicht habe ich schonmal gesehen. Leider ist das Sytem im Dreambox Kernel Mode nicht zum Laufen zu bekommen. Weder im mouse Protokoll (mit ftdi Treiber) noch mit smartreader Protokoll, egal ob mit smargopatch oder ohne. Immer kommt Error Activating Card als Fehlermeldung. Die einzige Einstellung wie es läuft ist Auto, Normal, 1, 0 im smartreader Protokoll mit dem beschriebenen Fehler.

    Wie gesagt vorher liefen beide Smargos mit Auto, Dream, 1, 0 mit der Cccam auf der Fritte.

    Grüße
     
    #12
  14. 4gx35
    Offline

    4gx35 VIP

    Registriert:
    18. Mai 2010
    Beiträge:
    16.776
    Zustimmungen:
    4.587
    Punkte für Erfolge:
    113
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    auf der Dream laufen alle #79xx versionen scheinbar nicht wirklich,
    nimm eine version ab 7884, aber keine 79xx
     
    #13
    Diebelsalt gefällt das.
  15. Diebelsalt
    Offline

    Diebelsalt Ist oft hier

    Registriert:
    17. September 2008
    Beiträge:
    184
    Zustimmungen:
    64
    Punkte für Erfolge:
    28
    AW: Nach Oscam Neustart Fehler beim Karten lesen -> nur Reboot hilft

    Huhu,

    ich habe jetzt alles durch. Habe auch die Oscam 1.20 7884 getestet. Ich habe gestern nochmal versucht die HD01 und die S02 im jeweiligen Smargo einzeln mit mouse oder smargo zum laufen zu bekommen. Ist nichts zu wollen. Endet immer mit Error Activating Card, egal ob der Kernel Mode auf Dream oder Normal eingestellt ist, mit oder ohne smargopatch. Ist im Prinzip aber auch nicht so schlimm, weil es ja im smartreader Protokoll funktioniert.

    Ich könnte das Ganze ja laufen lassen und ruhig sein. Das blöde ist, ich bin bei sowas leicht perfektionistisch veranlagt, dass heist es soll möglichst optimal laufen. Und dazu gehört raus zu finden, warum ich die Smargos reseten bzw. die Box rebooten muss, damit die Oscam die Karten erkennt.

    Grüße
     
    #14

Diese Seite empfehlen