1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von f1-tom, 26. März 2013.

  1. f1-tom
    Offline

    f1-tom Ist gelegentlich hier

    Registriert:
    9. Juni 2008
    Beiträge:
    63
    Zustimmungen:
    7
    Punkte für Erfolge:
    8
    Hallo

    Das wäre also mein erster Post im oscam Bereich. Wie sicher viele bin ich wegen einer neuen Karte fast ein wenig gezwungen das gewohnte Cccam zu verlassen und mich mit oscam zu beschäftigen.
    Ich habe seit ca. 2 Jahren eine Conaxkarte von meinem Kabelanbieter Quickline. Die lief immer problemlos mit CCcam und tut es auch in diesem Moment noch. Da es aber beim Umzug Schwierigkeiten gab die bestehende Karte in den Account eines bestehendes Internetabos an der neuen Adresse zu integrieren habe ich gratis eine neue Karte erhalten. Das ist zwar sehr freundlich von meinem Kabelanbieter, doch leider scheint die neue Karte eine neuere Generation zu sein. Cccam erkennt sie zwar, aber sie entschlüsselt nichts mehr. Mit Scam funktioniert die Karte problemlos. Es ist also kein Pairing usw. aktiv.
    Nur leider bin ich darauf angewiesen diese Karte an Cccam Clients weiter sharen zu können. Und da bleibt nach meinen Recherchen eigentlich nur oscam.
    Darum habe ich den heutigen Abend damit verbracht oscam auf einer DM800 einzurichten welche für Versuchszwecke als Server dienen soll. Das Ziel ist es die Karte an meine DM8000, welche in diesem Versuch als CCcam Client dient, zu sharen.

    Hier mal was bereits funktioniert:

    - Sharing von der DM800 (Newnigma 3.3.2) mit CCcam zur DM8000 (Newnigma 4.0 beta) welche als Cccam Client eingerichtet ist. (Natürlich mit der alten Karte welche mit CCcam noch funktioniert) Somit ist sichergestellt dass die Verbindung über das Netzwerk mit IP und Port funktioniert.

    Cccam config
    F-Line auf der DM800 -> F: QLTest 12345
    C-Line auf der DM8000 -> C: 192.168.178.43 12000 QLTest 12345

    -Dann habe ich oscam auf der DM800 online installiert. Weiter habe ich gemäss den verschiedenen Anleitungen hier die drei Files bearbeitet. (oscam.config / oscam.server / oscam. user) Auch wenn die Einstellungen sicherlich noch nicht alle korrekt sind hat die Karte lokal auf der DM800 sofort funktioniert.

    -Als die Karte lief versucht ich nun die Karte von oscam auf der DM800 zur C-Line auf der DM8000 zu sharen. Und da stehe ich irgendwie auf dem Schlauch. Habe alles so eingerichtet wie ich es verstanden habe um die gleiche C-Line welche ich vorher getestet hatte zu bedienen. Ich bekomme aber einfach keine Verbindung zum Server. Wahrscheinlich verstehe ich irgendwo etwas falsch oder habe irgendwo eine falsche Einstellung vorgenommen.

    Hier mal was ich bis jetzt gemacht habe:

    oscam.conf (Mit den Einstellungen fürs webif habe ich mich noch nicht befasst. Sollte aber doch keinen Einfluss aufs Sharing haben oder?)
    [global]

    LogFile = /tmp/oscam.log
    disableuserfile = 0
    ClientTimeout = 5
    FallbackTimeout = 2
    clientmaxidle = 60
    CacheDelay = 120
    bindwait = 20
    netprio = 0
    Nice = -1
    maxlogsize = 100
    PreferLocalCards = 1
    saveinithistory = 1

    [dvbapi]
    enabled = 1
    au = 1
    boxtype = dreambox
    user = QLTest
    pmt_mode = 0

    [webif]
    httpport = 8888
    httpuser = userif
    httppwd = passif
    httprefresh = 10
    #httpallowed = 192.168.178.39


    [cccam]
    port = 12000
    version = 2.2.1
    reshare = 1
    reshare_mode = 0
    ignorereshare = 0
    stealth = 0
    minimizecards = 0
    updateinterval = 10
    keepconnected = 1
    forward_origin_card = 0
    recv_timeout = 2000
    #nodeid =

    oscam.server
    [reader]
    label = Quickline
    enable = 1
    protocol = internal
    group = 1
    detect = CD
    device = /dev/sci0
    group = 1
    caid = 0b00
    emmcache = 1,3,2
    lb_weight = 100


    #cardmhz = 368
    #n3_rsakey =
    #n3_boxkey =

    oscam.user
    [account]
    User = QLTest
    Pwd = 12345
    Group = 1
    CAID = 0b00
    AU = 1
    uniq = 1

    Sieht jemand vielleicht gerade einen groben Schnitzer wieso ich keine Verbindung bekomme? Oder verstehe ich grundsätzlich etwas falsch? Müsste ich ich auf der DM800 Cccam & oscam installieren um von da aus an Cccam Clients sharen zu können? Bin für jede Hilfe dankbar! Jetzt gehts aber erst mal ab ins Bett, der Wecker klingelt schon bald wieder! :emoticon-0175-drunk
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. 4gx35
    Offline

    4gx35 Chef Mod

    Registriert:
    18. Mai 2010
    Beiträge:
    16.767
    Zustimmungen:
    4.583
    Punkte für Erfolge:
    113
    AW: Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

    sieht schon gut aus, aber es fehlt zum sharen ein weiterer user account,

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    , cccam wird auf dem server nicht benötigt
     
    #2
    f1-tom gefällt das.
  4. f1-tom
    Offline

    f1-tom Ist gelegentlich hier

    Registriert:
    9. Juni 2008
    Beiträge:
    63
    Zustimmungen:
    7
    Punkte für Erfolge:
    8
    AW: Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

    Super, vielen Dank für den Link! Den hatte ich noch nicht entdeckt! Werde das morgen Abend mal durchlesen!
     
    #3
  5. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

    Hi,

    du brauchst für jeden Client einen [account]-Eintrag in der oscam.user. Dabei dürfen nicht gleiche Usernamen vergeben werden.

    Mit dem vorhandenen account erhellst du dir auf der Serverbox (DM800) über die Schnittstelle dvbapi das Bild. In diesem account darf kein Passwort stehen. Den 2. User, den für die DM8000, legst du also zusätzlich an.
    [account]
    User = dm8000
    Pwd = 23456
    Group = 1
    AU = 0
    die dazugehörige C auf der 8000er Box sollte dann
    Code:
    C: 192.168.178.43 12000 dm8000 23456
    
    so aussehen.
    Au für deine Karte kannst du mit der Serverbox über dvbapi machen. Das sollte auch reichen.

    Im Grunde kann man sagen, daß dir der Umstieg auf oscam ganz gut gelungen ist. Herzlichen Glückwunsch.

    Lieben Gruß
    Bombadil
     
    #4
    f1-tom und laila-no1 gefällt das.
  6. f1-tom
    Offline

    f1-tom Ist gelegentlich hier

    Registriert:
    9. Juni 2008
    Beiträge:
    63
    Zustimmungen:
    7
    Punkte für Erfolge:
    8
    AW: Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

    Leute... vielen Dank! Das mit dem zweiten user war mein Überlegungsfehler! Habe immer gedacht der erste user wäre bereits für einen externen client. Aber jetzt begreife ich erst wie das läuft! Das ist wie wenn es bei Cccam ein separates File für die F-Lines geben würde und man auch für die Box in der die Karte steckt eine einrichten müsste und in ein zweites File die passende C-Line packen müsste. Habe das zwar immer gelesen und gesehen dass in den Beispielen ein zweiter user angelegt wurde aber ich habe es nicht verstanden wieso!
    Bin heute morgen nicht dazu gekommen alles im Link von 4gx35 durchzulesen. Aber ich habe einfach mal einen zweiten user angelegt und schon hat es funktioniert. So viel Zeit musste sein! :emoticon-0137-clapp
    Auf den ersten Blick scheint es schon ganz gut zu funktionieren. Nur beim schnellen zappen habe ich festgestellt dass die ersten 3-4 Sender sehr schnell hell werden und dann einer plötzlich ein paar Sekunden dunkel bleibt. Aber ist ja klar dass bei den ersten Versuchen noch nicht alles perfekt läuft. Vielleicht liegt es ja auch daran dass auf der Clientbox noch andere Conaxkarten per C-Line rein kommen. Dort habe ich neben dem Kabelsignal noch 5 Satpositionen drann. Bis auf diese Box werden alle anderen Clients nur einen DVB-C Tuner haben.
    Jetzt werde ich mal schauen dass ich all die verschiedenen Einstellungen verstehe und diese optimieren kann. Z.B. braucht es für die Conax Karte noch einen Jugendschutz PIN der irgendwo hinterlegt werden muss. Man will diesen ja nicht jedesmal eingeben müssen wenn man "per Zufall" auf einem geschützten Sender landet! :whistle2:
    Heute Abend werde ich leider nicht dazu kommen. Aber ab und zu ist es doch ganz spannend dass man sich wieder um etwas neues kümmern "muss"!

    Noch zum AU

    Voraussichtlich wird eine Box als Server dienen welche kein Kabelsignal hat und auch nicht zum Fernsehen benutzt wird. Also so etwas wie ein "stand alone Server". Funktioniert das dann trotzdem über dvbapi oder müsste es in diesem Fall dann doch über den user gemacht werden? Die EMM's können ja dann nur via Clients auf die Karte kommen.
     
    Zuletzt bearbeitet: 26. März 2013
    #5
  7. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

    Hi,

    versuche mal mit einer CCCam.prio, Reihenfolge dder Caids ist wichtig, die Abfrage zu steuern. Ich habe auch Mischbetrieb, Kabel, Sat auf meiner 8000er und auch Sat und Kabelkarten gemischt. Ich fahre damit ganz gut dort auch mit oscam only zu arbeiten und dort mit der oscam.dvbapi zu experimentieren. Diese Datei gegelt das bei Oscam wie die CCCam.prio bei CCcam.

    Wenn du eine Standalone box als Server betreibst kannst du von dort sharen. Dazu brauchst du dann nur deiner 8000er die Au Rechte geben. Die kann dann sowohl deine Kabel als auch Satkarten mit EMMs versorgen.

    Wegen des Jugendschutzpins gibt es für Seca und Viaaccess Karten den Parameter
    Code:
    unlockparental =1|0
    mit 1 schaltest du aus, mit 0 schaltest du ein.

    Gruß
    Bombadil
     
    #6
  8. f1-tom
    Offline

    f1-tom Ist gelegentlich hier

    Registriert:
    9. Juni 2008
    Beiträge:
    63
    Zustimmungen:
    7
    Punkte für Erfolge:
    8
    AW: Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

    Das wird das Problem sein. Wollte mich auch schon mal mit CCcam.prio befassen. Es hat aber auch ohne immer perfekt funktioniert. Und wie es dann so ist, man nimmt es sich immer nur vor und macht es dann doch nicht! :emoticon-0143-smirk Kann aber gut sein dass ich auf der DM8000 auch komplett auf oscam umstelle wenn ich das alles im Griff habe. Zuerst bastle ich aber jetzt mal an der DM800 herum.
    Dann müsste der Eintrag für die DM8000 also so aussehen:

    [account]
    User = dm8000
    Pwd = 23456
    Group = 1
    AU = 1
    Verstehe ich das richtig dass dann der Eintrag in der oscam.conf keine Rolle spielt da diese Einstellungen nur für den "Client der Box selber" zuständig ist? Oder muss dort AU grundsätzlich erlaubt sein damit die EMM's der Clients welche in oscam.user eingetragen sind zur Karte durch kommen?

    Wegen des Jugendschutz-PIN bin ich nicht sicher ob der Parameter für die Seca und Viaccess Karten das richtige ist. Funktioniert das auch für Conaxkarten? So weit ich weiss kann ich die PIN Abfrage für die Conax Karte nicht ausschalten. Bei Cccam hatte ich einfach den PIN eingetragen und die Sender wurden beim Client beim zappen ganz normal hell wie die normalen Sender ohne Jugendschutz-PIN. Dieser PIN müsste die Karte sicher auch von oscam irgendwie bekommen damit sie die Sender frei gibt. Aber eben, werde mich mal durchlesen müssen und dann kommen garantiert noch weitere Fragen!
     
    #7
  9. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Mein erster Abend mit oscam. Karte läuft, sharing klappt nicht...

    Hi,

    die dvbapi Sektion ind er iscam.conf auf dem Server brauchst du nur, wenn dieser Server auch sein eigener (DVBApi -)Client ist. Wenn du in diesem Fall dort auch nicht TV schauen willst, dann hast du für dvbapi auch keinen User definiert. Und somit kann dort auch nicht die Updatefunktion ausgelöst werden. Du kannst dir ja mal diesen Beitrag wegen der Updates durchlesen.

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Gruß
    Bombadil
     
    #8
    f1-tom gefällt das.

Diese Seite empfehlen