1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Locale Karten werden nicht richtig gelesen

Dieses Thema im Forum "Oscam Talk Archiv" wurde erstellt von q3a, 17. Juni 2013.

  1. q3a
    Offline

    q3a Ist oft hier

    Registriert:
    20. August 2009
    Beiträge:
    180
    Zustimmungen:
    24
    Punkte für Erfolge:
    18
    Hallo Leute,

    ich habe einen Igel Debian mit OScam. Da hängen drei Easymouse2 dran mit einer S02, einer HD02 und einer Huster Karte für Astra. Für die reader habe ich udev regeln angelegt. Das funktioniert soweit auch. Im WI werden die reader richtig erkannt. Aber scheinbar stimmt da irgendetwas noch nicht, weil die clients sich die Karten bei den anderen Servern holen und unter CAID:SRVID steht nur 0000:0000

    Ich habe mal bei einem CCcam Server geschaut was da ankommt. Da stehen zwei Karten drin. Die S02 und die HD02, die 1702 wurde auch an einen client weitergeleitet. Aber der Easymouse müsste doch bei einem Zugriff kurz blinken, dass tut er aber nicht.

    Jetzt ist die Frage wo das Problem ist und wie ich die karten richtig an die user weitergebe...

    reader
    [reader]
    label = Hustler
    description = Hustler
    protocol = mouse
    device = /dev/hustler
    caid = 0500
    detect = cd
    mhz = 369
    cardmhz = 368
    group = 1
    emmcache = 1,3,2

    [reader]
    label = hdplus
    protocol = mouse
    device = /dev/HD+
    services = hdplus
    rsakey = 8Axxxxxxxxxxx1B2F$
    boxkey = AxxxxxxxxxxC
    detect = cd
    mhz = 357
    cardmhz = 368
    group = 1
    emmcache = 1,3,2



    [reader]
    label = Sky
    description = Sky S02
    protocol = mouse
    device = /dev/SkyDE
    caid = 1702,1833
    boxkey = 1122334455667788
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 1
    emmcache = 1,3,2

    user
    [account]user = xxxxx
    pwd = xxxxx
    group = 1
    au = skyde
    caid = 1702,1833
    betatunnel = 1833.FFFF:1702
    F:1702
     
    Zuletzt bearbeitet: 17. Juni 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. laila-no1
    Offline

    laila-no1 Moderator Digital Eliteboard Team

    Registriert:
    20. Oktober 2011
    Beiträge:
    4.065
    Zustimmungen:
    3.280
    Punkte für Erfolge:
    113
    AW: Locale Karten werden nicht richtig gelesen

    hi,

    bitte noch die Oscam.conf posten?

    steht das rot markierte wirklich so im User oder ist hier bei copy&past ein Fehler passiert?

    ein aussagekräftiger Logfile wäre auch nicht schlecht ;)
     
    #2
    q3a gefällt das.
  4. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    22.854
    Zustimmungen:
    16.170
    Punkte für Erfolge:
    113
    AW: Locale Karten werden nicht richtig gelesen

    ich würde jedem reader eine eigene group zuweisen, nicht alle in einer, also reader 1 group =1, usw.
    [reader]
    label = Hustler
    description = Hustler
    protocol = mouse
    device = /dev/hustler
    caid = 0500
    detect = cd
    mhz = 369
    cardmhz = 368
    group = 1
    emmcache = 1,3,2

    [reader]
    label = hdplus
    protocol = mouse
    device = /dev/HD+
    services = hdplus
    rsakey = 8Axxxxxxxxxxx1B2F$
    boxkey = AxxxxxxxxxxC
    detect = cd
    mhz = 357
    cardmhz = 368
    group = 2
    emmcache = 1,3,2

    [reader]
    label = Sky
    description = Sky S02
    protocol = mouse
    device = /dev/SkyDE
    caid = 1702,1833
    boxkey = 1122334455667788
    detect = cd
    mhz = 600
    cardmhz = 600
    group = 3
    emmcache = 1,3,2

    dann dem usern auch die groups zuweisen, wieso ist bei dir AU = skyde, dein reader heisst doch Sky???caids brauchst du im oscam.user nicht zu definieren, die hast du schon im reader
    [account]
    user = xxxxx
    pwd = xxxxx
    group = 1,2,3
    au = Sky
    betatunnel = 1833.FFFF:1702
     
    #3
    q3a gefällt das.
  5. q3a
    Offline

    q3a Ist oft hier

    Registriert:
    20. August 2009
    Beiträge:
    180
    Zustimmungen:
    24
    Punkte für Erfolge:
    18
    Hier die oscam.conf
    [global]logfile = /var/log/oscam.log
    cachedelay = 120
    nice = -1
    maxlogsize = 4069
    preferlocalcards = 1
    saveinithistory = 1
    unlockparental = 1
    [cccam]
    port = xxxxxxx
    version = 2.3.0


    [webif]
    httpport = 1xxxxx
    httphelplang = de
    httpuser = xxxxx
    httppwd = xxxxx
    httprefresh = 15
    httpallowed = 127.0.0.1,1.1.1.0-255.255.255.255


    Ich bin gerade am Anfang und habe das gerade erst seit gestern am laufen. Bitte entschuldigt meine Fehler!

    2013/06/17 09:41:11 A145668 r hdplus [mouse] Reader initialized (device=/dev/HD+, detect=cd, mhz=357, cardmhz=368)
    2013/06/17 09:41:11 A1A1890 r Hustler [mouse] Reader initialized (device=/dev/hustler, detect=cd, mhz=369, cardmhz=368)
    2013/06/17 09:41:13 0 s init for all local cards done
    2013/06/17 09:41:13 0 s anti cascading disabled

    2013/06/17 09:43:08 A1A1890 r Hustler [mouse] cardreader_do_checkhealth: !reader_card_inserted
    2013/06/17 09:43:08 A1A1890 r Hustler [mouse] cardreader_do_checkhealth: reader->card_status = 4, ret = 0
    2013/06/17 09:43:08 A145668 r hdplus [mouse] cardreader_do_checkhealth: !reader_card_inserted
    2013/06/17 09:43:08 A145668 r hdplus [mouse] cardreader_do_checkhealth: reader->card_status = 4, ret = 0
    2013/06/17 09:43:08 A143A18 r Sky [mouse] cardreader_do_checkhealth: !reader_card_inserted
    2013/06/17 09:43:08 A143A18 r Sky [mouse] cardreader_do_checkhealth: reader->card_status = 4, ret = 0
    2013/06/17 09:43:09 A1A1890 r Hustler [mouse] cardreader_do_checkhealth: !reader_card_inserted
    2013/06/17 09:43:09 A1A1890 r Hustler [mouse] cardreader_do_checkhealth: reader->card_status = 4, ret = 0
    2013/06/17 09:43:09 A145668 r hdplus [mouse] cardreader_do_checkhealth: !reader_card_inserted
    2013/06/17 09:43:09 A145668 r hdplus [mouse] cardreader_do_checkhealth: reader->card_status = 4, ret = 0
    2013/06/17 09:43:09 A143A18 r Sky [mouse] cardreader_do_checkhealth: !reader_card_inserted
    2013/06/17 09:43:09 A143A18 r Sky [mouse] cardreader_do_checkhealth: reader->card_status = 4, ret = 0
    2013/06/17 09:43:09 A1AAB60 h all debug_level=0



    Sicherlich habe ich nur etwas vergessen. Im WI steht unter Status

    OFF (no entitlements)​
    Ich habe den Fehler gefunden!

    Es lag wahrscheinlich daran, dass ich mit copy&paste die Formatierung der 10-usbadapter.rules beeinträchtigt habe. Ich habe die "10-usbadapter.rules" nochmal neu angelegt und alles schön sauber eingetragen. Jetzt gehen schonmal die Sky und Hustler Karte.

    Bei der HD 02 bekomme ich aber ein Error. Vielleicht könnt ihr mir da nochmal einen Tip geben.
     
    Zuletzt bearbeitet: 17. Juni 2013
    #4
  6. dodo83
    Offline

    dodo83 Chef Mod Digital Eliteboard Team

    Registriert:
    3. Oktober 2008
    Beiträge:
    22.854
    Zustimmungen:
    16.170
    Punkte für Erfolge:
    113
    AW: Locale Karten werden nicht richtig gelesen

    wenn dein rsa und boxkey so anfängt
    dann ist das falsch

    richtig
     
    #5
    q3a und laila-no1 gefällt das.
  7. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Locale Karten werden nicht richtig gelesen

    Hi,

    das Log wäre recht hilfreich. Mein RSA Key sieht übrigens vorn und hinten anders aus.

    Code:
    rsakey                        = BF3#################################DD5
    
    Grüße
    Bombadil
     
    #6
    q3a gefällt das.
  8. q3a
    Offline

    q3a Ist oft hier

    Registriert:
    20. August 2009
    Beiträge:
    180
    Zustimmungen:
    24
    Punkte für Erfolge:
    18
    AW: Locale Karten werden nicht richtig gelesen

    Ok, ich hatte schon so eine Befürchtung, dass es am RSa Key liegen kann. Wo krieg ich denn den richtigen her?


    Danke!


    Hier nochmal das log:

    2013/06/17 15:20:26 978C668 r hdplus [mouse] ERROR: IO_Serial_GetStatus: ioctl(TIOCMGET): Input/output error
    2013/06/17 15:20:26 978C668 r hdplus [mouse] Error getting card status.
    2013/06/17 15:20:27 978C668 r hdplus [mouse] ERROR: IO_Serial_GetStatus: ioctl(TIOCMGET): Input/output error
    2013/06/17 15:20:27 978C668 r hdplus [mouse] Error getting card status.
     
    #7
  9. bombadil
    Offline

    bombadil MFC Digital Eliteboard Team

    Registriert:
    2. Oktober 2008
    Beiträge:
    11.816
    Zustimmungen:
    9.118
    Punkte für Erfolge:
    113
    Beruf:
    Kaufmann
    Ort:
    Mittelerde
    AW: Locale Karten werden nicht richtig gelesen

    Hi,

    für Rsa Key schau dir mal das Windows Programm an:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Das Log ist ein wenig knapp geraten, sagt aber nichts über einen falschen RSA sondern eher über ein Problem mit der Readereinstellung aus.

    Grüße
    Bombadil
     
    #8
    Pilot und q3a gefällt das.
  10. al-x83
    Offline

    al-x83 Super-Moderator Digital Eliteboard Team

    Registriert:
    10. Januar 2012
    Beiträge:
    13.421
    Zustimmungen:
    12.684
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    SysAdmin
    Ort:
    Paradise City
    AW: Locale Karten werden nicht richtig gelesen

    ERROR: IO_Serial_GetStatus: ioctl(TIOCMGET): Input/output error
    hat nichts mit den Keys zu tun, hatte ich auch schon, bei mir war das Usb-Kabel defekt.
     
    #9
    q3a, Pilot und bombadil gefällt das.
  11. q3a
    Offline

    q3a Ist oft hier

    Registriert:
    20. August 2009
    Beiträge:
    180
    Zustimmungen:
    24
    Punkte für Erfolge:
    18
    AW: Locale Karten werden nicht richtig gelesen

    So Leute, nun läufts!


    Die Lösung, Stecker ziehen und 10 Sekunden warten. Danach sind alle Karten da. Ein normaler reboot hat nicht ausgereicht.


    Danke an alle!



    ...mein erster voll funktionsfähiger Oscam Server, yes!
     
    #10

Diese Seite empfehlen