1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

HowTo LB "lb_mode=2" funktioniert nicht...?

Dieses Thema im Forum "OScam Archiv" wurde erstellt von hölli, 9. April 2012.

  1. hölli
    Offline

    hölli Ist oft hier

    Registriert:
    10. Dezember 2009
    Beiträge:
    136
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    Hallo alle,
    die einstellungen lb_mode=2 (oldest reader first) funktionieren nicht wie sie sollen. ich weiss nicht ob ich meine einstellungen falsch habe aber es werden alle reader gleichzeitig angefragt, nicht nur "der alteste reader". Hier meine configs:
    Code:
    oscam.conf
    >> OSCam <<  cardserver started, version 1.20-unstable_svn, build #6586 (i686-pc-linux)
    [global]
    logfile                       = /tmp/oscam.log
    fallbacktimeout               = 1000
    clientmaxidle                 = 600
    failbantime                   = 5
    bindwait                      = 10
    nice                          = -1
    serialreadertimeout           = 4
    maxlogsize                    = 100
    saveinithistory               = 1
    lb_mode                       = 2
    [newcamd]
    port                          = 4001@0D02:A0
    key                           = 0102030405060708091011121314
    
    Code:
    oscam.server
    [reader]
    label                         = upc1
    protocol                      = pcsc
    device                        = 1
    caid                          = 0D02
    detect                        = cd
    mhz                           = 357
    cardmhz                       = 357
    group                         = 1
    emmcache                      = 1,1,10
    .
    .
    .
    .
    .
    [reader]
    label                         = upc5
    protocol                      = pcsc
    device                        = 5
    caid                          = 0D02
    detect                        = cd
    mhz                           = 357
    cardmhz                       = 357
    group                         = 1
    emmcache                      = 1,1,10
    
    Code:
    oscam.log
     22:02:33 B5A43578 c test (0D02&0000A0/7858/84:9EA0): found (367 ms) by upc1 
     22:02:33 B5A44D98 c test (0D02&0000A0/7858/84:9EA0): cache2 (350 ms) by upc2 
     22:02:33 B5A888A8 c test (0D02&0000A0/7858/84:9EA0): cache2 (351 ms) by upc3
     22:02:33 B5A465B8 c test (0D02&0000A0/7858/84:9EA0): cache2 (353 ms) by upc4 
     22:02:33 B5A87088 c test (0D02&0000A0/7858/84:9EA0): cache2 (357 ms) by upc5 
     22:02:36 B5A87088 c test (0D02&0000A0/78B5/84:B8CD): found (355 ms) by upc1 
     22:02:37 B5A43578 c test (0D02&0000A0/78B5/84:B8CD): cache2 (361 ms) by upc2 
     22:02:37 B5A44D98 c test (0D02&0000A0/78B5/84:B8CD): cache2 (355 ms) by upc3
     22:02:37 B5A888A8 c test (0D02&0000A0/78B5/84:B8CD): cache2 (362 ms) by upc4 
     22:02:37 B5A465B8 c test (0D02&0000A0/78B5/84:B8CD): cache2 (359 ms) by upc5 
     22:02:39 B5A43578 c test (0D02&0000A0/78B5/84:BA38): found (361 ms) by upc1
     22:02:39 B5A888A8 c test (0D02&0000A0/78B5/84:BA38): cache2 (359 ms) by upc2 
     22:02:39 B5A87088 c test (0D02&0000A0/78B5/84:BA38): cache2 (350 ms) by upc3 
     22:02:39 B5A44D98 c test (0D02&0000A0/78B5/84:BA38): cache2 (353 ms) by upc4 
     22:02:39 B5A465B8 c test (0D02&0000A0/78B5/84:BA38): cache2 (355 ms) by upc5 
     22:02:40 B5A43578 c test (0D02&0000A0/77ED/84:8701): found (350 ms) by upc1
     22:02:40 B5A87088 c test (0D02&0000A0/77ED/84:8701): cache2 (348 ms) by upc2 
     22:02:40 B5A888A8 c test (0D02&0000A0/77ED/84:8701): cache2 (347 ms) by upc3 
     22:02:40 B5A44D98 c test (0D02&0000A0/77ED/84:8701): cache2 (345 ms) by upc4 
     22:02:40 B5A465B8 c test (0D02&0000A0/77ED/84:8701): cache2 (351 ms) by upc5 
    
    weiss hier bitte jemand was ich da falsch mache?
    danke
     
    Zuletzt von einem Moderator bearbeitet: 10. April 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. T1x
    Offline

    T1x VIP

    Registriert:
    11. Juni 2010
    Beiträge:
    3.859
    Zustimmungen:
    2.719
    Punkte für Erfolge:
    113
    Ist doch alles Ok wenn er den cache nimmt.
    Wo ist jetzt das Problem?
     
    #2
  4. hölli
    Offline

    hölli Ist oft hier

    Registriert:
    10. Dezember 2009
    Beiträge:
    136
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    problem ist dass alle reader angefragt werden, nicht nur der alteste, dafur ist doch "lb_mode=2" da, oder?
     
    #3
  5. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    Wie viele Clienten greifen denn in dem Moment zu?

    Wenn es mehrere sind macht Oscam alles richtig!

    Grüsse
    szonic
     
    #4
  6. hölli
    Offline

    hölli Ist oft hier

    Registriert:
    10. Dezember 2009
    Beiträge:
    136
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    was du in log siehst ist nur ein client...
     
    Zuletzt von einem Moderator bearbeitet: 10. April 2012
    #5
  7. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    Wenn nur ein Reader angefragt werden soll,
    dann muss der Eintrag lb_nbest_readers = 1 in oscam.conf rein.
     
    #6
    T1x gefällt das.
  8. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    Das ist nur zur Hälfte korrekt @hwmmc.
    Wenn der Parameter nicht geändert wird, ist er per default = 1.

    Ich verlasse mich jedoch nicht auf default, sondern setze was ich brauche in die Config, einen versuch ist es Wert!
     
    #7
    T1x und hwmmc gefällt das.
  9. hwmmc
    Offline

    hwmmc Elite Lord

    Registriert:
    14. August 2009
    Beiträge:
    5.503
    Zustimmungen:
    3.042
    Punkte für Erfolge:
    113
    Es ist mir völlig Rille, ob es Default so ist,
    wenn ich es so eintrage, kann ich mich auch darauf verlassen.
     
    #8
    T1x und szonic gefällt das.
  10. hölli
    Offline

    hölli Ist oft hier

    Registriert:
    10. Dezember 2009
    Beiträge:
    136
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    lb_nbest_readers = 1 hilft mir nichts, im log immer das selbe problem. Ich denke lb_mode=2 fukntioniert nicht.
     
    #9
  11. szonic
    Offline

    szonic MFC Digital Eliteboard Team

    Registriert:
    4. März 2009
    Beiträge:
    10.220
    Zustimmungen:
    8.445
    Punkte für Erfolge:
    113
    Dann wechsel doch mal auf eine Stable version die 1.10.
    Du nutzt eine 1.20 unstable, da kann schon mal das ein oder andere nicht korrekt funzen.

    Grüsse
    szonic
     
    #10
  12. hölli
    Offline

    hölli Ist oft hier

    Registriert:
    10. Dezember 2009
    Beiträge:
    136
    Zustimmungen:
    10
    Punkte für Erfolge:
    18
    habe auch stable version versucht, bringt nichts. kann es bitte jemand mal versuchen? an server seite genugt nut ein reader in oscam.server, an client seite an den server mit Newcamd verbinden, man kann 5 reader in oscam.server machen. da wird ihr sehen ob es das selbe ist.

    niemand...?
     
    Zuletzt von einem Moderator bearbeitet: 14. April 2012
    #11

Diese Seite empfehlen