1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem Kathrein 912 + Smargo einrichten, wie?!

Dieses Thema im Forum "Enigma2" wurde erstellt von daniel0319, 14. Februar 2012.

  1. daniel0319
    Offline

    daniel0319 Ist oft hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    147
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Hallo,

    ich hab mir einen Smargo Kartenleser für meine Kathrein 912 gekauft und wollt die Sky Karte (bekommen vor 3 Wochen, also sollte die neuste Karte sein) mit der Kathi betreiben. Jetzt meine Frage, wie richtge ich die Box und Oscam ein? Weil ich blicke da nicht ganz durch, man findet ihr und da mal ein tut aber irgend wie kommt man auf keinen wirklichen Nenner. Kann mir jemand dabei helfen, das wäre klasse! Danke schon mal.

    Image: AAF_E2_Summer_Image_UFS912_Serverupdate-Image_ufs912_UPDATEUSB
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. daniel0319
    Offline

    daniel0319 Ist oft hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    147
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    AW: Kathrein 912 + Smargo einrichten, wie?!

    will sich denn keiner mal erbarmen und mir helfen?!
     
    #2
  4. Kermit
    Online

    Kermit Guest

    AW: Kathrein 912 + Smargo einrichten, wie?!

    Hallo daniel0319,

    helfen wollen wir dir schon, aber etwas Eigeniniative dürfen wir von dir auch erwarten oder?
    Der globale Hilferuf bringt recht wenig.
    Was hast du bis jetzt gemacht, wo klemmt es oder was für Fehlermeldungen hast du?

    Grüße

    Kermit
     
    #3
  5. daniel0319
    Offline

    daniel0319 Ist oft hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    147
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    AW: Kathrein 912 + Smargo einrichten, wie?!

    Also eigeninitiative ist schon passiert, allerdings blick ich durch das ganze nicht so ganz durch...

    Hab die neuste oscam version auf der Box und den Smargo mit Karte (V13) eingesteckt. Dann hab ich im AAF Panel die entsprechenden einstellung gemacht, damit der Kartenleser erkannt wird. So und danahc hab ich versucht mal eine config datei zu finden. Dachte mir "oscam config für V13 Karte" könnte ja helfen, per FTP rein kopiert bzw. ersetzt... aber es blieb dunkel. Naja ich denke mal, dass man noch irgend was umstellen muss... aber da hängt es.
     
    #4
  6. Kermit
    Online

    Kermit Guest

    AW: Kathrein 912 + Smargo einrichten, wie?!

    Wie hast du denn den Smargo eingestellt?
    Wie sehen deine Konfigurations Dateien aus - am besten gespoilert posten?
    Hast du es geschafft OScam ein Logfile schreiben zu lassen? Wenn ja was steht da drinnen?

    Eine rudimentäre Konfig kannst du z.B. hier

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    finden. Falls du ein Logfile brauchst und das ist wohl im Moment bei dir erforderlich, mußt du das noch entsprechend anpassen.

    Bin mal gespannt, was jetzt kommt.

    Grüße

    Kermit
     
    #5
  7. daniel0319
    Offline

    daniel0319 Ist oft hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    147
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Hab die configs aus diesem

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    genommen. Erklär mir wie man eine Logfile schreiben lässt... Wie gesagt, ich nich wirklich Ahnung davon.
     
    #6
  8. Kermit
    Online

    Kermit Guest

    Hi,

    also wenn du die Konfig aus dem Thread hast, so steht dort oder besser gesagt stand dort in der oscam.conf eine Zeile:
    #LogFile = /var/keys/oscam.log

    In dieser Zeile entfernst du das # am Anfang der Zeile, speicherst die Datei ab, startest zur Sicherheit OScam neu und anschließend kannst du z.B. per ftp im Verzeichnis /var/keys/ dein Log runter kopieren. Die Datei nennt sich oscam.log.

    Auf meine Frage, wie du den Smargo eingestellt hast bist du leider nicht eingegangen!

    Grüße

    Kermit
     
    #7
  9. daniel0319
    Offline

    daniel0319 Ist oft hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    147
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Was meinst du mir einstellungen am Smargo? Hab am Smargo eigentlich noch nichts eingestellt, ich hab nur die einstellungen im AAF-Panel gemacht (ftdi und pl2303 auf "ja" stellen) nach diesem

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    .

    hier die Logfile
    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Thu Mar 1 18:41:25 2012
    -------------------------------------------------------------------------------
    2012/03/01 18:41:25 0 s >> OSCam << cardserver started, version 1.20-compiled_by_Speedy1, build #6201 (sh4-linux)
    2012/03/01 18:41:25 0 s version=1.20-compiled_by_Speedy1, build #6201, system=sh4-linux-, nice=-1
    2012/03/01 18:41:25 0 s client max. idle=120 sec, debug level=0
    2012/03/01 18:41:25 0 s max. logsize=10 Kb, loghistorysize=4096 bytes
    2012/03/01 18:41:25 0 s client timeout=7000 ms, fallback timeout=3000 ms, cache delay=100 ms
    2012/03/01 18:41:25 0 s services reloaded: 0 services freed, 1 services loaded, rejected 0
    2012/03/01 18:41:25 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2012/03/01 18:41:25 0 s signal handling initialized (type=sysv)
    2012/03/01 18:41:25 0 s 110 service-id's loaded in 2ms
    2012/03/01 18:41:25 0 s can't open file "/var/keys/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2012/03/01 18:41:25 0 s 912 provid's loaded
    2012/03/01 18:41:25 0 s can't open file "/var/keys/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2012/03/01 18:41:25 0 s can't open whitelist file /var/keys/oscam.whitelist
    2012/03/01 18:41:25 0 s Starting listener 0
    2012/03/01 18:41:25 0 s monitor: disabled
    2012/03/01 18:41:25 0 s Starting listener 0
    2012/03/01 18:41:25 0 s camd35: disabled
    2012/03/01 18:41:25 0 s Starting listener 0
    2012/03/01 18:41:25 0 s newcamd: disabled
    2012/03/01 18:41:25 0 s Starting listener 0
    2012/03/01 18:41:25 0 s csp: disabled
    2012/03/01 18:41:25 0 s starting thread http
    2012/03/01 18:41:25 0 s http thread started
    2012/03/01 18:41:25 0 s starting thread reader check
    2012/03/01 18:41:25 0 s reader check thread started
    2012/03/01 18:41:25 0 s starting thread check
    2012/03/01 18:41:25 0 s check thread started
    2012/03/01 18:41:25 0 s creating thread for device /dev/ttyUSB0
    2012/03/01 18:41:25 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/03/01 18:41:25 0 s waiting for local card init
    2012/03/01 18:41:25 561640 h HTTP Server listening on port 8888
    2012/03/01 18:41:25 55FCE8 r ERROR opening device /dev/ttyUSB0
    2012/03/01 18:41:25 55FCE8 r Cannot open device: /dev/ttyUSB0
    2012/03/01 18:41:46 561640 h Restart requested by WebIF from 192.168.100.13
    2012/03/01 18:41:46 561640 h restart oscam requested
    2012/03/01 18:41:46 561640 h HTTP Server: Shutdown requested.
    2012/03/01 18:42:25 55FCE8 r ERROR opening device /dev/ttyUSB0
    2012/03/01 18:42:25 55FCE8 r Cannot open device: /dev/ttyUSB0
     
    #8
  10. Kermit
    Online

    Kermit Guest

    Hilfe - ich mag nicht mehr!

    Der Smargo kann oder besser gesagt er muß per Software für die jeweilige Karte konfiguriert werden!
    Nein ich kau dir jetzt nicht vor wie das geht und was du einstellen mußt - jetzt mußt du halt mal die Boardsuche verwenden oder dich in diesem Board etwas einlesen.
    Das ist das, was ich z.B. mit
    meinte. Ein einfaches copy&paste reicht halt einfach nicht aus.

    Grüße

    Kermit
     
    #9
  11. daniel0319
    Offline

    daniel0319 Ist oft hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    147
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Wenn man eine gute Anleitung findet, ist alles gut...

    Also Smargo Fremdlink entfernt by scorpi eingestellt... allerdings schaut es laut telnet so aus:

    AAF-ufs912:~# mknod /dev.static/ttyUSB0 c 188 0
    mknod: /dev.static/ttyUSB0: File exists

    AAF-ufs912:~# ls -al /dev/ttyUSB0
    crw-r--r-- 1 root root 188, 0 Jan 1 1970 /dev/ttyUSB0

    AAF-ufs912:~# lsmod | grep usbserial
    usbserial 13068 4 pl2303,ftdi_sio

    AAF-ufs912:~# cat /proc/bus/usb/devices
    cat: can't open '/proc/bus/usb/devices': No such file or directory

    AAF-ufs912:~#

    oscam log schaut nun so aus:

    -------------------------------------------------------------------------------
    >> OSCam << cardserver log switched at Fri Mar 2 01:09:18 2012
    -------------------------------------------------------------------------------
    2012/03/02 01:09:17 561220 r Cannot open device: /dev/ttyUSB0
    2012/03/02 01:09:18 0 >> OSCam << cardserver log switched, version 1.20-compiled_by_Speedy1, build #6201 (sh4-linux)
    2012/03/02 01:09:18 0 version=1.20-compiled_by_Speedy1, build #6201, system=sh4-linux-, nice=-1
    2012/03/02 01:09:18 0 client max. idle=120 sec, debug level=1
    2012/03/02 01:09:18 0 max. logsize=10 Kb, loghistorysize=4096 bytes
    2012/03/02 01:09:18 0 client timeout=7000 ms, fallback timeout=3000 ms, cache delay=100 ms
    2012/03/02 01:10:18 561220 r ERROR opening device /dev/ttyUSB0
    2012/03/02 01:10:18 561220 r Cannot open device: /dev/ttyUSB0

    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Sat Dec 12 20:00:12 1970
    -------------------------------------------------------------------------------
    1970/12/12 20:00:12 0 s >> OSCam << cardserver started, version 1.20-compiled_by_Speedy1, build #6201 (sh4-linux)
    1970/12/12 20:00:12 0 s version=1.20-compiled_by_Speedy1, build #6201, system=sh4-linux-, nice=-1
    1970/12/12 20:00:12 0 s client max. idle=120 sec, debug level=0
    1970/12/12 20:00:12 0 s max. logsize=10 Kb, loghistorysize=4096 bytes
    1970/12/12 20:00:12 0 s client timeout=7000 ms, fallback timeout=3000 ms, cache delay=100 ms
    1970/12/12 20:00:12 0 s The current system time is smaller than the build date (Jan 6 2012). Waiting up to 60 seconds for time to correct
    2012/03/02 01:12:13 0 s services reloaded: 0 services freed, 1 services loaded, rejected 0
    2012/03/02 01:12:13 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2012/03/02 01:12:13 0 s signal handling initialized (type=sysv)
    2012/03/02 01:12:13 0 s 110 service-id's loaded in 14ms
    2012/03/02 01:12:13 0 s can't open file "/var/keys/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2012/03/02 01:12:14 0 s 912 provid's loaded
    2012/03/02 01:12:14 0 s can't open file "/var/keys/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2012/03/02 01:12:14 0 s can't open whitelist file /var/keys/oscam.whitelist
    2012/03/02 01:12:14 0 s Starting listener 0
    2012/03/02 01:12:14 0 s monitor: disabled
    2012/03/02 01:12:14 0 s Starting listener 0
    2012/03/02 01:12:14 0 s camd35: disabled
    2012/03/02 01:12:14 0 s Starting listener 0
    2012/03/02 01:12:14 0 s newcamd: disabled
    2012/03/02 01:12:14 0 s Starting listener 0
    2012/03/02 01:12:14 0 s csp: disabled
    2012/03/02 01:12:14 0 s starting thread http
    2012/03/02 01:12:14 0 s http thread started
    2012/03/02 01:12:14 0 s starting thread reader check
    2012/03/02 01:12:14 0 s reader check thread started
    2012/03/02 01:12:14 0 s starting thread check
    2012/03/02 01:12:14 55FA48 h HTTP Server listening on port 8888
    2012/03/02 01:12:14 0 s check thread started
    2012/03/02 01:12:14 0 s creating thread for device /dev/ttyUSB0
    2012/03/02 01:12:14 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/03/02 01:12:14 0 s waiting for local card init
    2012/03/02 01:12:16 5612A8 r reader readerextern1 initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2012/03/02 01:12:16 0 s init for all local cards done
    2012/03/02 01:12:17 563528 c plain dvbapi-client granted (dvbapi, au=on (1 reader))
    2012/03/02 01:12:17 563528 c dvbapi: reread priority file oscam.dvbapi
    2012/03/02 01:12:17 563528 c dvbapi: 52 entries read from oscam.dvbapi
    2012/03/02 01:12:19 563528 c dvbapi: new program number: 445D (0000:445D unknown)
    2012/03/02 01:17:48 55FA48 h Restart requested by WebIF from 192.168.100.13
    2012/03/02 01:17:48 55FA48 h restart oscam requested
    2012/03/02 01:17:49 55FA48 h HTTP Server: Shutdown requested.

    -------------------------------------------------------------------------------
    >> OSCam << cardserver started at Fri Mar 2 01:17:52 2012
    -------------------------------------------------------------------------------
    2012/03/02 01:17:52 0 s starting thread log_list_thread
    2012/03/02 01:17:52 0 s log_list_thread thread started
    2012/03/02 01:17:52 0 s >> OSCam << cardserver started, version 1.20-compiled_by_Speedy1, build #6201 (sh4-linux)
    2012/03/02 01:17:52 0 s version=1.20-compiled_by_Speedy1, build #6201, system=sh4-linux-, nice=-1
    2012/03/02 01:17:52 0 s client max. idle=120 sec, debug level=0
    2012/03/02 01:17:52 0 s max. logsize=10 Kb, loghistorysize=4096 bytes
    2012/03/02 01:17:52 0 s client timeout=7000 ms, fallback timeout=3000 ms, cache delay=100 ms
    2012/03/02 01:17:52 0 s services reloaded: 0 services freed, 1 services loaded, rejected 0
    2012/03/02 01:17:52 0 s userdb reloaded: 1 accounts loaded, 0 expired, 0 disabled
    2012/03/02 01:17:52 0 s signal handling initialized (type=sysv)
    2012/03/02 01:17:52 0 s 110 service-id's loaded in 6ms
    2012/03/02 01:17:52 0 s can't open file "/var/keys/oscam.tiers" (err=2 No such file or directory), no tier-id's loaded
    2012/03/02 01:17:52 0 s 912 provid's loaded
    2012/03/02 01:17:52 0 s can't open file "/var/keys/oscam.ird" (errno=2 No such file or directory) irdeto guessing not loaded
    2012/03/02 01:17:52 0 s can't open whitelist file /var/keys/oscam.whitelist
    2012/03/02 01:17:52 0 s Starting listener 0
    2012/03/02 01:17:52 0 s monitor: disabled
    2012/03/02 01:17:52 0 s Starting listener 0
    2012/03/02 01:17:52 0 s camd35: disabled
    2012/03/02 01:17:52 0 s Starting listener 0
    2012/03/02 01:17:52 0 s newcamd: disabled
    2012/03/02 01:17:52 0 s Starting listener 0
    2012/03/02 01:17:52 0 s csp: disabled
    2012/03/02 01:17:52 0 s starting thread http
    2012/03/02 01:17:52 0 s http thread started
    2012/03/02 01:17:52 0 s starting thread reader check
    2012/03/02 01:17:52 0 s reader check thread started
    2012/03/02 01:17:52 0 s starting thread check
    2012/03/02 01:17:52 0 s check thread started
    2012/03/02 01:17:52 0 s creating thread for device /dev/ttyUSB0
    2012/03/02 01:17:52 0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2012/03/02 01:17:52 0 s waiting for local card init
    2012/03/02 01:17:52 561048 h HTTP Server listening on port 8888
    2012/03/02 01:17:54 55F7A8 r reader readerextern1 initialized (device=/dev/ttyUSB0, detect=cd, mhz=357, cardmhz=357)
    2012/03/02 01:17:55 0 s init for all local cards done
    2012/03/02 01:17:55 5635C8 c plain dvbapi-client granted (dvbapi, au=on (1 reader))
    2012/03/02 01:17:55 5635C8 c dvbapi: reread priority file oscam.dvbapi
    2012/03/02 01:17:55 5635C8 c dvbapi: 52 entries read from oscam.dvbapi
    2012/03/02 01:17:57 5635C8 c dvbapi: new program number: 445D (0000:445D unknown)
     
    Zuletzt von einem Moderator bearbeitet: 2. März 2012
    #10
  12. Kermit
    Online

    Kermit Guest

    Hallo daniel0319,

    du hast die Boardregeln gelesen und verstanden [ ]
    Legende:
    [ ] Bedingung nicht erfüllt
    [X] Bedingung erfüllt

    Ich werde mich nicht im AAF anmelden um zu sehen, was dort geschrieben steht.

    Um den Smargo richtig einzustellen auf deine Karte hilft dir evtl. folgender Link

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    weiter.

    Wenn du dich per telnet an der Kathie anmeldest, was sagt denn ein lsusb ?
    Dein Smargo hängt nicht als /dev/ttyUSB0 im System!
    Wenn er als USB0 im System wäre, so würde die passende Ausgabe von
    Code:
    ls -la /dev/ttyUSB0
    
    so aussehen:
    Code:
    root@IPC:~# ls -la /dev/ttyUSB0
    crw-rw---- 1 root [COLOR=#ff0000]dialout [/COLOR]188, 0  2. Mär 05:48 /dev/ttyUSB0
    
    Erst wenn du den richtigen Port für den Smargo hast, dieser für die Karte richtig eingestellt ist kann die Karte auch von OScam angesprochen werden. Vorher bringt das dich nicht weiter.

    Grüße

    Kermit
     
    Zuletzt von einem Moderator bearbeitet: 2. März 2012
    #11
  13. scorpi
    Offline

    scorpi Elite Lord Supporter

    Registriert:
    1. Januar 2010
    Beiträge:
    6.210
    Zustimmungen:
    6.514
    Punkte für Erfolge:
    113
    Hab es mal in den Kathy e2-Bereich verschoben. Unter Programmer hat es ja nun nicht viel zu suchen gehabt. Ferner gibt es hier ja auch einen Oscam-Bereich.
    Evtl. findest du da ja die nötige Hilfe. Aber ich glaube schon, dass duie Jungs hier im Kathy-Bereich helfen können.
     
    #12
  14. daniel0319
    Offline

    daniel0319 Ist oft hier

    Registriert:
    8. Dezember 2009
    Beiträge:
    147
    Zustimmungen:
    4
    Punkte für Erfolge:
    18
    Also ich hab jetzt als im Forum gelesen und ausprobiert, aber es steht weiter hin das bei mir:

    Code:
    AAF-ufs912:~# ls -al /dev/ttyUSB0
    crw-r--r--    1 root     root      188,   0 Jan  1  1970 /dev/ttyUSB0
    Komme nicht weiter...
     
    #13
  15. Skywalker
    Offline

    Skywalker VIP

    Registriert:
    18. April 2009
    Beiträge:
    6.137
    Zustimmungen:
    8.294
    Punkte für Erfolge:
    113
    Ort:
    Bayern
    1. Smargo folgend setten:
    Mode: Fixed
    MHz: 3,69
    Kernel: normal
    T-Mode: T=0
    EGT: 0

    2. ftdi_SIO Treiber im E2 aktivieren

    3. Wie sehen überhaupt deine Configs aus???? Um weiteren Support zu bekommen, solltest du diese erst mal hier posten. Und nicht vergessen, Spoiler dabei nutzen
     
    #14

Diese Seite empfehlen