1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem IPC Web IF nach update nicht mehr erreichbar

Dieses Thema im Forum "IPC" wurde erstellt von $carface, 23. April 2012.

  1. $carface
    Offline

    $carface Guest

    Moin moin,
    Ich habe gestern abend auf meinem Igel mit IPC 11.3, apt -get upgrade durchgeführt. Da kam dann etwas von apache2, ob ich diesen updaten möchte oder net. Ich hab ihn upgedatet und nun
    kann ich net mehr des WebIF vom IPC aufrufen. Der Server rennt aber und ist auch über putty erreichbar.
    Kann mir einer sagen, ob ich des upgrade iwie rückgängig machen kann, buw. wie kann ich des wieder richten?
    Danke


    Sent from my iPhone using Tapatalk
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. joopastron
    Online

    joopastron Administrator Digital Eliteboard Team

    Registriert:
    3. März 2011
    Beiträge:
    19.334
    Zustimmungen:
    12.422
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Immer bei der Sache
    Der Port wird sich geändert haben
    von Apache.
    Schau mal bitte hier:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Sent from my iPhone using Tapatalk
     
    Zuletzt bearbeitet: 23. April 2012
    #2
    1 Person gefällt das.
  4. $carface
    Offline

    $carface Guest

    Hab Dank mein Bester. Is alles wida in Butter. Danke an alle die hier so supi mithelfen.
    Gruß


    Sent from my iPhone using Tapatalk
     
    #3
  5. joopastron
    Online

    joopastron Administrator Digital Eliteboard Team

    Registriert:
    3. März 2011
    Beiträge:
    19.334
    Zustimmungen:
    12.422
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Immer bei der Sache
    Was war der Fehler ? Port geändert gewesen nach dem
    Update ?


    Sent from my iPhone using Tapatalk
     
    #4
  6. $carface
    Offline

    $carface Guest

    In /etc/apache2/sites-enabled/000-default den Port wieder angepasst und läuft.
    Danke nochmal für die schnelle Hilfe
    Gruß


    Sent from my iPhone using Tapatalk
     
    #5
  7. aragorn
    Offline

    aragorn Guest

    wieso hast du überhaupt den virtualhost port geändert?
    in einem lan hinter dem router ist das unnötig. über welchen port der webserver aus dem internet zu erreichen ist stellst du doch eigentlich sowieso im router ein, auf welchen er dann zeigt ist egal (von port 12345 an port 80)
     
    #6
  8. -angelus-
    Offline

    -angelus- Newbie

    Registriert:
    16. Januar 2012
    Beiträge:
    11
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Bei mir lädt er nachdem Update immer nur eine "Download"-Datei herunter ... Weder im Chrome, noch FF, noch IE zeigen die Seite an. Port wurde wieder angepasst ....

    Wie kann ich das wieder ändern?
     
    #7
  9. -angelus-
    Offline

    -angelus- Newbie

    Registriert:
    16. Januar 2012
    Beiträge:
    11
    Zustimmungen:
    1
    Punkte für Erfolge:
    3
    Bei mir lädt er leider immer eine "Download"-Datei herunter ... Auch nach der Portänderungen ändert sich da nix ... wie kann ich das webif wieder herstellen?!

    Danke schonmal! :)
     
    #8
  10. $carface
    Offline

    $carface Guest

    Ich hab mir des iwann mal angeeignet, Standartgeschichten generell zu ändern. Hat aber nichts mit dem Zugriff aus dem Netz zu tun, der läuft über VPN Tunnel. Habe nur den port für CS offen.
    Gruß


    Sent from my iPhone using Tapatalk
     
    #9
  11. aragorn
    Offline

    aragorn Guest

    dann versteh ich das erst recht nicht :)
     
    Zuletzt von einem Moderator bearbeitet: 23. April 2012
    #10
  12. $carface
    Offline

    $carface Guest

    Habe den Port wieder auf 80 eingestellt, da es unnütz ist, den zu ändern. Nun habe ich festgestellt, das ich ohne Logindaten immer direkt im IPC WebIF lande?!? Vorher musste ich immer meinen User und Pass eintragen.



    Sent from my iPhone using Tapatalk
     
    #11
  13. einsmann
    Offline

    einsmann Moderator Digital Eliteboard Team

    Registriert:
    7. Februar 2009
    Beiträge:
    1.213
    Zustimmungen:
    462
    Punkte für Erfolge:
    83
    Aha!
    Dann sind hier alle Diskusionen im Board zum Thema Sicherheit und Lineklau etc auch unnütz ?

    Dann noch viel Spaß mit deinem offenen IPC

    regards
     
    #12
  14. aragorn
    Offline

    aragorn Guest

    hast du dies mal wirklich nur die /etc/apache2/sites-enabled/000-default datei bearbeitet oder hast du noch mehr gemacht?
    das dürfte dann eigentlich nicht sein. ändern ihn mal zurück und prüf das. hintergrund ist das in dem /var/www/ipc/ eine .htaccess datei angelegt wird die diesen schutz aktiviert, das funktioniert aber nur wenn "AllowOverride All" in der apache regel drin steht aber nicht vergessen apache2 neu zu starten
    ansonsten über "i cfg" neu setzen.


    einsmann: teilweise ja. wenn es sich um einen homeserver handelt und man den port 80 für den apache2 nicht als weiter leitung im router einrichtet ist das quatsch den VirtualHost port zu ändern da dieser aus dem internet doch gar nicht erreichbar ist also wozu überhaupt ändern?
     
    #13
  15. $carface
    Offline

    $carface Guest

    @ einsmann
    Was hast Du denn für ein Problem? Les mal den ganzen Beitrag, bevor Du sowas vom Stapel lässt. Kannst ja mal versuchen, bei mir reinzukommen. LOL
    Ist net böse gemeint, aber dein Ton...

    @ aragon
    In /etc/apache2/ports.conf habe ich den Port auch wieder auf 80 gesetzt. In der i cfg ist der Eintrag für .htaccess drin. Da habe ich nichts verändert.

    Edit:
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    Order allow,deny
    allow from all
    </Directory>
    In der Spalte war des AllowOverride auf none, warum auch immer. Habs geändert und den Apachen restartet und nun ist alles wieder wie es soll.
    Danke nochmal für die Hilfe Jungs.
    Grüsse


    Sent from my iPhone using Tapatalk
     
    Zuletzt von einem Moderator bearbeitet: 24. April 2012
    #14

Diese Seite empfehlen