1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

IPC Verständnissproblem und Fragen.

Dieses Thema im Forum "Archiv" wurde erstellt von dirkusg, 30. Oktober 2011.

  1. dirkusg
    Offline

    dirkusg Ist gelegentlich hier

    Registriert:
    22. November 2009
    Beiträge:
    45
    Zustimmungen:
    5
    Punkte für Erfolge:
    8
    Hallo, seit einer Woche setze ich mich mit dem Thema Cardsharing auseinender und irgendiwe finde ich nicht alle Antworten auf meine speziellen Fragen.
    Bzw Blicke da teilweise nicht durch.
    Folgendes: Hardware 386 PC mit Debian 6 und IPC 11.3
    2 x Smargo mit S02 und HD01 Karten.

    1. Was ich nicht rausgefunden bzw durchblicke. Welche Cams/Cam für meine Karten?

    2. IPC läuft und CCcam (2.1.2) startet. Oscam( 1.10 rcstable) startet nicht. Oscam Log endet einfach ohne Fehler:

    2011/10/30 12:32:54 B74618D0 s loadbalancer: can't read from file /tmp/.oscam/stat
    2011/10/30 12:32:54 B74618D0 s waiting for local card init
    2011/10/30 12:32:54 B7407B70 r reader thread started (thread=B7407B70, label=hdplus, device=Serial:Reader E42DE31 # HD+, detect=cd, mhz=369, cardmhz=368)
    2011/10/30 12:32:54 B7407B70 r Using 0x82 as endpoint for smartreader hardware detection
    2011/10/30 12:32:54 B6C06B70 r reader thread started (thread=B6C06B70, label=skyde, device=Serial:Reader 551307A # SKY, detect=cd, mhz=600, cardmhz=600)
    2011/10/30 12:32:54 B7413B70 h HTTP Server listening on port 16002
    2011/10/30 12:32:54 B7407B70 r Smartreader device Serial:Reader E42DE31 # HD+ not found
    2011/10/30 12:32:54 B6C06B70 r Using 0x82 as endpoint for smartreader hardware detection
    2011/10/30 12:32:54 B6C06B70 r Smartreader device Serial:Reader 551307A # SKY not found
    2011/10/30 12:32:54 B7407B70 r hdplus card detected

    Was ich zb am Log nicht verstehe: Erst starten beide Reader threads, dann kommt eine Fehlermeldung, und dann wird eine Karte erkannt. (Im Moment steckt die S02 im Receiver)

    Aber vorher möchte ich erst mal klären welche Cams ich dazu brauch. Vieleicht brauche ich oscam ja nicht.

    3. Desweiteren erstellt Cccam kein Log. Ob da was erkannt wid oder nicht steht auch in den Sternen.

    Wenn es irgendwo ein Howto gibt für meine Problem würde mir das schon mal reichen.

    Danke im vorraus.
     
    Zuletzt bearbeitet: 30. Oktober 2011
    #1
  2. phantom

    Nervigen User Advertisement

  3. Mogelhieb
    Offline

    Mogelhieb Administrator Digital Eliteboard Team

    Registriert:
    29. November 2008
    Beiträge:
    12.055
    Zustimmungen:
    16.482
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    Counselor
    Ort:
    Bayern
    AW: IPC Verständnissproblem und Fragen.

    Bei Dir schaut es so aus, als ob sich CCcam die beiden Kartenleser greift und OScam danach vergeblich versucht sie einzubinden.
    An Deiner Stelle würde ich nur OScam verwenden. Das erfordert zwar anfangs etwas Konfigurationsarbeit, dafür läuft es dann aber sauber durch. Wegen der HD+ Karte musst Du ohnehin OScam verwenden. Deswegen würde sich das anbieten. Wir haben im OScam Bereich sehr gute Beispielkonfigurationen für Deine Smartcards.

    Ich würde CCcam komplett deaktivieren bzw. erst mal die Readereinträge in der cccam.cfg raus # rauten.
    Dann die aktuellste OScam Version compilen. Dazu logst Du Dich mit Putty auf Deinen Server als root ein und tippst im IPC
    PHP:
    o compile
    Eine Internetanbindung ist erforderlich!

    Anschließend bearbeitest Du Deine OScam Konfigurationsdateien nach den Vorgaben der

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    .
     
    #2
  4. dirkusg
    Offline

    dirkusg Ist gelegentlich hier

    Registriert:
    22. November 2009
    Beiträge:
    45
    Zustimmungen:
    5
    Punkte für Erfolge:
    8
    AW: IPC Verständnissproblem und Fragen.

    Hallo
    erst mal Danke für die schnelle Antwort.
    Ok, ich erst mal die Autostartfunktion aus der rc.local rausgenommen und die überwachung der CCcam aus cron.
    Und dann erst mal einen reboot. Jetzt compile .
    Und oscam startet. Gut dann such ich mir mal ne passende config und melde mich dann noch mal.

    Gruß

    Hab verschieden configs ausprobiert. Aber oscam findet den cardreader zum verrecken nicht.

    Smargo einstellung geändert, oscam.server geändert. 100 Varianten. Nix geht.
    Cardreader wird nicht geöffnet.
    2011/10/30 23:20:19 B7466B70 r ERROR opening device Serial:Reader E42DE31 # HD+
    2011/10/30 23:20:19 B7466B70 r Cannot open device: Serial:Reader E42DE31 # HD+

    2011/10/30 23:27:33 B7555B70 r ERROR opening device /dev/ttyUSB0 # HD+
    2011/10/30 23:27:33 B7555B70 r Cannot open device: /dev/ttyUSB0 # HD+

    anderen Hub benutz. Auch nix.
    Protokolle geändert, oscam Version geändert. Nix geht.
    Verd....... noch eins.

    lsusb findet den Reader, smargolist findet ihn, Smargo einstellungen ändern via Linux geht.
    Nur Oscam schafft das nicht.
    Meine letzte Idee. Der USB Port vom PC ist USB 1.1 kann das Probleme machen?
    Die Smargos sollen das eigentlich können.
     
    Zuletzt bearbeitet: 30. Oktober 2011
    #3

Diese Seite empfehlen