1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Problem IPC liest keine Karte mehr vom Smargo

Dieses Thema im Forum "IPC" wurde erstellt von mrboom11, 8. April 2012.

  1. mrboom11
    Offline

    mrboom11 Ist gelegentlich hier

    Registriert:
    22. Juli 2011
    Beiträge:
    60
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    Hallo

    Ich habe gestern meinen Server das neue debian-6.0.4-i386-netinst installiert und nun mag er meine beiden Smargo´s leider nicht mehr.

    Er erkennt einfach keine Karte mehr im Smargo.Ich habe das Debian auch schon mehrmals neu installiert um zu schauen,ob sich bei der
    Installation ein Fehler eingeschlichen hat.

    Leider ohne erfolg.

    Meine cccam.cfg schaut so aus.

    #Lokale Karten - (Smargo Reader)
    SERIAL READER : /dev/ttyUSB0 smartreader+
    SERIAL READER : /dev/ttyUSB1 smartreader+
    SERIAL READER : /dev/ttyUSB2 smartreader+
    SERIAL READER : /dev/ttyUSB3 smartreader+
    #SMARTCARD CLOCK FREQUENCY: /dev/ttyUSB3 8000000


    Smargolist zeigt mir das an.

    Looking for smartreader with an out endpoint = 0x82 :
    bus 004, device 002 : 0403:6001 Smartreader (Device=004:002 EndPoint=0x82 insert in oscam.server 'Device = Serial:Reader E67E676')
    bus 004, device 003 : 0403:6001 Smartreader (Device=004:003 EndPoint=0x82 insert in oscam.server 'Device = Serial:Reader 5EED05E')


    Und dmesg | grep ttyUSB,gibt das aus

    [ 3.430938] ftdi_sio ttyUSB0: Unable to read latency timer: -32
    [ 3.431093] usb 4-1: FTDI USB Serial Device converter now attached to ttyUSB0
    [ 3.432113] ftdi_sio ttyUSB1: Unable to read latency timer: -32
    [ 3.432389] usb 4-4: FTDI USB Serial Device converter now attached to ttyUSB1
    [ 3.722679] ftdi_sio ttyUSB1: FTDI USB Serial Device converter now disconnected from ttyUSB1
    [ 3.730551] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0


    Kann mir vieleicht einer sagen wo der Fehler liegt?.

    Vielen Dank.


    PS

    Ich benutze cccam und nicht OScam

    Mein System Daten


    • Chipsatz: AMD Hudson D1
      CPU: AMD E-350 (Dual-Core)
      Grafik: HD 6310 (DirectX 11)
    • RAM: 2x DDR3 (1.066 MHz)
      max. 8 GB
    • Steckplätze:
      1x PCIe x16
    • Interne Anschlüsse:
      2x SATA 2
      4x USB 2.0
      1x 4-Pin Lüfter
    • Externe Anschlüsse:
      1x HDMI
      1x DVI-D
      1x VGA
      4x USB 2.0
      1x Gigabit LAN (1.000 / 100 / 10; Realtek 8111E)
      3x Audio (5.1)
      1x PS/2 Tastatur / Maus
    • Stromversorgung:
      1x 24-Pin ATX
      1x 4-Pin ATX12V

    Kann geschlossen werden,habe das Problem lösen können

    Danke
     
    Zuletzt bearbeitet: 8. April 2012
    #1
  2. phantom

    Nervigen User Advertisement

  3. **BadBoy**
    Offline

    **BadBoy** Spezialist

    Registriert:
    1. Juni 2011
    Beiträge:
    595
    Zustimmungen:
    849
    Punkte für Erfolge:
    0
    Beruf:
    Elektriker
    Ort:
    bei meiner kleinen Familie
    Versuch mal im IPC einen USB Reset... das hat bei mir gefunzt.
     
    #2
    mrboom11 gefällt das.
  4. aragorn
    Offline

    aragorn Guest

    "ipc usbreset" läd auch nur die usb treiber module neu:
    Code:
    modprobe -r ehci_hcd
    sleep 3
    modprobe ehci_hcd
    mit ipc ansich hat das problem aber nicht viel zu tun. ipc ist nur eine ansammlung an scripten aber hat keinen einfluss ob reader funktionieren, karten gelesen werden oder emus stabil laufen

    interessant zu wissen wären nicht die specs der hardware von der hersteller seite sondern vielmehr welches linux mit welchem kernel sowie welchen reader mit welcher firmware und guck auch mal ins bios ob es da irgendwelche energiespar funktionen gibt die du gegebenenfals mal ausschalten kannst
     
    #3
  5. Matlock
    Offline

    Matlock MFC Digital Eliteboard Team

    Registriert:
    18. Februar 2009
    Beiträge:
    16.593
    Zustimmungen:
    9.798
    Punkte für Erfolge:
    113
    Beruf:
    Schubkarren Beifahrer
    Ort:
    Atlanta
    Leute, Leute, Leute!!

    Post ein mal ganz zu Ende lesen!!!

     
    #4
    **BadBoy** und mrboom11 gefällt das.
  6. mrboom11
    Offline

    mrboom11 Ist gelegentlich hier

    Registriert:
    22. Juli 2011
    Beiträge:
    60
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    ^^

    Das Problem lag einfach nur an der Linux Version.

    Ich habe mir diese Version gesaugt (firmware-6.0.4-i386-netinst),ein paar Treiber dazu und schon war das Problem gelöst.

    Danke trotzdem für die Hilfe.
     
    #5
  7. aragorn
    Offline

    aragorn Guest

    da stand aber zum einen nicht woran es nun gelegen hat und zum anderen wäre es für alle anderen die diesen thread hier lesen wichtig zu wissen worauf es tatsächlich an kommt
    firmware-6.0.4-i386-netinst? du meinst denk ich eher debian-6.0.4-i386-netinst oder nicht? das sagt aber nichts darüber aus was für treiber oder was für ein kernel

    aber nun ja das problem wurde ja gelöst also darf man hier nix mehr posten
     
    #6
  8. mrboom11
    Offline

    mrboom11 Ist gelegentlich hier

    Registriert:
    22. Juli 2011
    Beiträge:
    60
    Zustimmungen:
    3
    Punkte für Erfolge:
    8
    Das Linux Image stammt von

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    ,es ist die 2.6.32-5-686 #1 SMP Mon Mar 26 05:20:33 UTC 2012 i686 GNU/Linux.

    Ich habe das mit uname -r ausgelesen.

    Dazu die

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    mit auf dem USB STick kopiert im Ordner treiber.

    Und schon war mein Problem gelöst.

    Dieser Text,stand noch mit auf der

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    .

    Falls Hardware auf Ihrem System das Laden von Firmware mit dem Gerätetreiber erfordert, können Sie eines der

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    benutzen oder ein inoffizielles Image herunterladen, welches diese nicht-freie Firmware enthält. Anleitungen zur Verwendung der Tarball-Archive und allgemeine Informationen über das Laden der Firmware während der Installation finden Sie in der Installationsanleitung (siehe Dokumentation unten).

    Netzinstallations-Images (typischerweise 175–240 MB), nicht-freie CD-Images mit Firmare


    Und schon lief alles so wie es soll.

     
    Zuletzt bearbeitet: 9. April 2012
    #7
    1 Person gefällt das.
  9. jäger25
    Offline

    jäger25 Ist gelegentlich hier

    Registriert:
    31. Juli 2009
    Beiträge:
    95
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    ITSE
    hi musstest du den IPC neu aufsetzen?

    Ich habe auch exaxt das gleiche Problem, kann ich den Treiber ohne neuinstallation integrieren?
     
    Zuletzt von einem Moderator bearbeitet: 17. April 2012
    #8
  10. aragorn
    Offline

    aragorn Guest

    wenn du dein system neu installierst musst du ipc auch neu installieren. ansonsten eigentlich nicht da ipc damit nichts zu tun hat
    aber in dem firmware.zip beziehungsweise firmware.tar.gz sind die gleichen pakete enthalten wie sie auch über apt zur verfügung stehen
    Code:
    > tar xfz firmware.tar.gz
    > ls firmware-*
    firmware-atheros_0.28+squeeze1_all.deb     firmware-ipw2x00_0.28+squeeze1_all.deb        firmware-netxen_0.28+squeeze1_all.deb
    firmware-bnx2_0.28+squeeze1_all.deb        firmware-ivtv_0.28+squeeze1_all.deb           firmware-qlogic_0.28+squeeze1_all.deb
    firmware-bnx2x_0.28+squeeze1_all.deb       firmware-iwlwifi_0.28+squeeze1_all.deb        firmware-ralink_0.28+squeeze1_all.deb
    firmware-brcm80211_0.28+squeeze1_all.deb   firmware-linux-free_2.6.32-41_all.deb         firmware-realtek_0.28+squeeze1_all.deb
    firmware-intelwimax_0.28+squeeze1_all.deb  firmware-linux-nonfree_0.28+squeeze1_all.deb
    Code:
    > apt-cache search firmware | grep "^firmware-*"
    firmware-atheros - Binary firmware for Atheros wireless cards
    firmware-bnx2 - Binary firmware for Broadcom NetXtremeII
    firmware-bnx2x - Binary firmware for Broadcom NetXtreme II 10Gb
    firmware-brcm80211 - Binary firmware for Broadcom 802.11 wireless cards
    firmware-intelwimax - Binary firmware for Intel WiMAX Connection
    firmware-ipw2x00 - Binary firmware for Intel Pro Wireless 2100, 2200 and 2915
    firmware-ivtv - Binary firmware for iTVC15-family MPEG codecs (ivtv and pvrusb2 drivers)
    firmware-iwlwifi - Binary firmware for Intel Wireless 3945, 4965 and 5000-series cards
    firmware-linux-nonfree - Binary firmware for various drivers in the Linux kernel
    firmware-linux - Binary firmware for various drivers in the Linux kernel (meta-package)
    firmware-netxen - Binary firmware for QLogic Intelligent Ethernet (3000 and 3100 Series)
    firmware-qlogic - Binary firmware for QLogic IBA7220, QLA1xxx, ISP2xxx and SP2x2
    firmware-ralink - Binary firmware for Ralink wireless cards
    firmware-realtek - Binary firmware for Realtek wired and wireless network adapters
    firmware-linux-free - Binary firmware for various drivers in the Linux kernel
    firmware-libertas - Binary firmware for Marvell Libertas 8xxx wireless cards
    firmware-myricom - Binary firmware for Myri-10G Ethernet adapters
    ich vermute das hierbei "firmware-linux", "firmware-linux-free"oder "firmware-linux-nonfree" das problem lösen würde. also kannst du diese auch nachträglich über apt-get installieren:
    apt-get update
    apt-get install firmware-linux
     
    #9
  11. jäger25
    Offline

    jäger25 Ist gelegentlich hier

    Registriert:
    31. Juli 2009
    Beiträge:
    95
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    ITSE
    leider geht es nicht.
    root@CCCServer ~ > apt-get update
    OK

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze Release.gpg
    Ign

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/main Translation-de
    Ign

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/main Translation-en
    Ign

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeenze Release.gpg
    OK

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze Release
    OK

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/updates Release.gpg
    Ign

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/updates/main Translation-de
    Ign

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/updates/main Translation-en
    Ign

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeenze Release
    OK

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/updates Release
    Fehl

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeenze/main Sources
    404 Not Found
    OK

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/main i386 Packages
    OK

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/updates/main Sources
    OK

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    squeeze/updates/main i386 Packages
    W: Fehlschlag beim Holen von

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    404 Not Found

    E: Einige Indexdateien konnten nicht heruntergeladen werden, sie wurden ignoriert oder alte an ihrer Stelle benutzt.
    root@CCCServer ~ > apt-get install firmware-linux
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Statusinformationen werden eingelesen... Fertig
    Paket firmware-linux ist nicht verfügbar, wird aber von einem anderen Paket
    referenziert. Das kann heiÃen, dass das Paket fehlt, dass es abgelöst
    wurde oder nur aus einer anderen Quelle verfügbar ist.

    E: Paket »firmware-linux« hat keinen Installationskandidaten
    root@CCCServer ~ >
     
    #10
  12. aragorn
    Offline

    aragorn Guest

    achte mal auf die fehlermeldungen. er konnte apt-get update nicht beenden weil es da bereits ein problem gab
    zeig mal dein inhalt von /etc/apt/sources.list aber bitte in
    Code:
    
    edit: die non-free firmware´s kann man erst laden wenn man "non-free" in /etc/apt/sources.list hinzugefügt hat und vorher natürlich "apt-get update"
    [spoiler][code]## squeeze
    deb http://ftp.de.debian.org/debian/ squeeze main contrib [B]non-free[/B]
    deb-src http://ftp.de.debian.org/debian/ squeeze main contrib [B]non-free[/B]
    Code:
    ## lenny
    deb http://ftp.de.debian.org/debian-archive/debian/ lenny main contrib [B]non-free[/B]
    deb-src http://ftp.de.debian.org/debian-archive/debian/ lenny main contrib [B]non-free[/B]
    [/spoiler]
     
    Zuletzt von einem Moderator bearbeitet: 24. Mai 2012
    #11
  13. Champ
    Offline

    Champ Freak

    Registriert:
    1. November 2008
    Beiträge:
    246
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: IPC liest keine Karte mehr vom Smargo

    So habe leider genau das gleiche Problem. Hab debian Netinstall 6.05 nach Anleitung von hier installiert.
    Hab mir ein Intel Atom Board D420KP geholt und weder seriell noch usb Reader werden erkannt.
    Auf meinem Alix mit damaligen deabian 6.03 hat alles funktioniert.
    Habe nur Easymouse Cardreader und wie gesagt beim Alix alles wunderbar und jetzt beim Intel Board mit Deabian 6.05 nix.

    Leider habe ich nicht genau verstanden wie ich das lösen kann. Habe genau die selbe Fehlermeldung
    FTDI USB Serial Device converter now disconnected from ttyUSB0


    Für Hilfe wäre ich echt dankbar.
    Achja mit welchem Befehl kann ich überprüfen ob ein serieller oder ein USB Reader korrekt erkannt worden sind?


    Edit. So nach Tip eines anderen Forums das Paket brltty zu deinstallieren kommt die Fehlermeldung nicht mehr.
    NAch Eingabe von ls /dev | grep USB erscheint USB0 das soll ja ok sein.


    So habe eine Firecrypt Karte zum Testen da (meine 2. Sky Karte ist bei den ganzen Tests irgendwie geschrottet worden und kommt Morgen neu).
    Die Firecrypt Karte wird in der Dreambox erkannt und wenn ich aufs Webinterface des Cccam gehe sehe ich die Karte unter Entitlements.
    Was nur komich ist das ich die Karte nicht im Webinterface des Ccam vom IPC PC sehe.
    Hier mal die Config des Cccam


    F: test test 2 0 0 { 0:0:1 }




    SERVER LISTEN PORT : 12000
    ALLOW WEBINFO: yes
    SHOW EXTENEDED CLIENT INFO : yes
    WEBINFO USERNAME : root
    WEBINFO PASSWORD : xxxxx
    WEBINFO LISTEN PORT : 16001
    SHOW TIMING : yes
    DEBUG : no
    DISABLE EMM : no
    EXTRA EMM LEVEL : yes
    CAID PRIO FILE : /var/keys/CCcam.prio
    PROVIDERINFO FILE : /var/keys/CCcam.providers
    CHANNELINFO FILE : /var/keys/CCcam.channelinfo
    MINIMUM DOWNHOPS: 1




    SERIAL READER : /dev/ttyUSB00
    #SMARTCARD CLOCK FREQUENCY: /dev/ttyUSB0 6000000
    B: /dev/ttyUSB0 00
    TRY ALL CHIDS : /dev/ttyUSB0


    So weiss jetzt einer warum ich die KArte nicht sehe.
    Möchte gerne vor Morgen klären ob alles funktioniert bevor ich meine Sky KArte wieder in den Cardreader stecke (will sie nicht nochmal fritten).
    Für Hilfe wäre ich echt dankbar.

    Achja wiso tauchen die Probleme erst mit dem neuen Debian Netinstall auf , frühere Versionen liefen ohne Schwierigkeiten.


    MFG Champ
     
    Zuletzt bearbeitet: 12. Juni 2012
    #12
  14. aragorn
    Offline

    aragorn Guest

    AW: IPC liest keine Karte mehr vom Smargo

    vorab: ipc hat damit nichts zu tun. ipc besteht aus ein paar shell scripten und einem webinterface was dir den umgang mit cs erleichtert aber hat keinen einfluss darauf ob ein reader erkannt wird oder wie stabil cccam/oscam usw laufen..

    über den befehl "dmesg"


    hast du mal geguckt wofür das programm überhaupt dar ist?
    ich kann mir nur schwer vorstellen das du der einzige bist der dieses paket deinstallieren muss beziehungsweise normalerweise ist das auch gar nicht installiert also musst du es aus irgend welchen gründen selber installiert haben..
    habe hier noch nie etwas darüber gelesen das jemand für card sharing das paket "brltty" deinstallieren musste..

    sowas passiert eigentlich auch nicht es sei denn man weiss nicht was man da eigentlich macht oder zu krass übertaktet..

    was sagt denn das log dazu? damit die karte erkannt wird muss natürlich erst mal der reader erkannt worden sein ("dmesg" oder "lsusb -v|grep iSerial"). dann musst du ihn passend in cccam einbinden und die karte richtig erkannt werden (grep CCcam /var/log/syslog)

    wieso machst du das? sowas ist sehr gefährlich und belastet deine karte mehr als unnötig!

    so kann das auch nicht gehen. da ist eine 0 zu viel. es gibt nur ttyUSB0, ttyUSB1 usw aber kein ttyUSB00

    standard mässig werden keine emms geblockt also brauchst du hier nicht "00" einstellen. wenn dann stell da ein das GA geblockt wird um deine karte zu entlasten aber ansonsten kannst du die zeile weg lassen/auskommentieren

    ist ebenfals unnötig da es die karte viel zu sehr belastet.
    die karte meldet der cam welche chid´s freigeschaltet sind. die chid´s sind kwasi die pakete die du auf der karte freigeschaltet hast mit ihrer gültigkeits dauer. bei den sky karten wäre das zum beispiel "sky welt" oder "sky bundesliga" die dann für 3 monate gültig sind. das würde dann in den entitlements stehen welche chid´s auf die karte geschaltet sind also brauch man nicht wild "alle die es gibt" aber deine karte gar nicht kennt durch probieren..


    wie gesagt kommt sowas sehr sehr selten vor. eigentlich nur bei unsachgemässe handhabung
    gewöhn dir einfach an nichts ein zu stellen dessen auswirkungen du nicht kennst wie zum beispiel "try all chids" oder auch die mhz anzugeben. der reader findet in 99,9% der fälle selber herraus mit wieviel mhz die karte betrieben werden kann. übertakten kann immer dazu führen die karte zu zerstören oder zu beschädigen..
    aber normalerweise stellt man an der easymouse (hardware) auch per dipschalter ein mit wieviel mhz sie betrieben wird dann ist eigentlich egal was du bei der software einstellst
     
    #13
  15. Champ
    Offline

    Champ Freak

    Registriert:
    1. November 2008
    Beiträge:
    246
    Zustimmungen:
    8
    Punkte für Erfolge:
    18
    AW: IPC liest keine Karte mehr vom Smargo

    OK dank dir ich werde mal versuchen auf deine Antworten etwas zu schreiben

    über den befehl "dmesg"

    Was muss dann da stehen wenn ein serieller oder USB Reader korrekt erkannt werden

    hast du mal geguckt wofür das programm überhaupt dar ist?

    ich installier definitiv nur Debian Netinstall 6.05 nach Anleitung von hier. Ich installiere brltty nicht nochmal extra.
    Nach googeln fand ich dann die Lösung wegen der Fehlermeldung.

    so kann das auch nicht gehen. da ist eine 0 zu viel. es gibt nur ttyUSB0, ttyUSB1 usw aber kein ttyUSB00
    habe ich falsch auskopiert habe natürlich nur 1x die 0

    was sagt denn das log dazu? damit die karte erkannt wird muss natürlich erst mal der reader erkannt worden sein ("dmesg" oder "lsusb -v|grep iSerial"). dann musst du ihn passend in cccam einbinden und die karte richtig erkannt werden (grep CCcam /var/log/syslog)
    werde ich gleich mal checken

    EXTRA EMM LEVEL : yes B: /dev/ttyUSB0 00 TRY ALL CHIDS : /dev/ttyUSB0
    dank dir , werde ich ändern

    aber normalerweise stellt man an der easymouse (hardware) auch per dipschalter ein mit wieviel mhz sie betrieben wird dann ist eigentlich egal was du bei der software einstellst

    Hab immer 6MHZ bzw 3,xx (HD+)


    sowas passiert eigentlich auch nicht es sei denn man weiss nicht was man da eigentlich macht oder zu krass übertaktet..

    Ich habe definitiv nicht übertaktet , nur KArte sehr oft rein und raus

    So ich teste mal diene Vorschläge und melde mich gleich nochmal.

    Edit so USB0 ist ok da wird auch eine Serial Nummer angezeigt (nur Firecrypt Karte wird nicht im Webinterface unter Entitlement angezeigt.

    So wie stelle ich fest ob mein seriel Reader erkannt wird , hab das gefühl der wird nicht erkannt.


    MFG Champ
     
    #14
  16. aragorn
    Offline

    aragorn Guest

    AW: IPC liest keine Karte mehr vom Smargo

    poste doch einfach mal deine "dmesg"

    wenn ich debian netinstall installiere installiert sich aber kein "brltty"..

    "oft die karte rein raus" macht sie auch nicht kaputt aber vielleicht warst du dabei unaufmerksam oder "grob" und hast den chip beschädigt keine ahnung...
     
    #15

Diese Seite empfehlen