1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Talk IPC-Installation bricht ab

Dieses Thema im Forum "IPC" wurde erstellt von ironsky, 14. März 2013.

  1. ironsky
    Offline

    ironsky Ist oft hier

    Registriert:
    20. Februar 2013
    Beiträge:
    124
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    Hi! Habe auf meinen IGEL 4210 LX gerade Debian Squeeze installiert und versuche nun IPC zu installieren. Habe mir IPC von ipc.pebkac.at/ipc/ipcsetup.sh geholt und die Installation gestartet. Diese bricht wie folgt ab:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?

    Die Datei webif.db ist definitiv _nicht_ vorhanden. Könnt Ihr mir sagen, was hier schief läuft? Gruß!
     
    Zuletzt bearbeitet: 15. März 2013
    #1
  2. phantom

    Nervigen User Advertisement

  3. Kermit
    Online

    Kermit Guest

    AW: IPC-Installation bricht ab

    Hi,

    da ist im Vorfeld schon etwas schief gelaufen als die erforderlichen Pakete installiert werden sollten.
    Kam vorher keine andere Fehlermeldung?

    Grüße

    Kermit
     
    #2
  4. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: IPC-Installation bricht ab

    Hallo,
    es schaut so aus, als ob bei der installation die sqlite install abgebrochen wurde, oder nicht richtig abgeschlossen wurde.

    Code:
    apt-get update && apt-get install sqlite3 php5-sqlite
    und danach den IPC-Befehl i sqlite ausführen. Danach sollte es wieder funktionieren.

    Bitte auf Fehlermeldungen achten!

    Gruß
    jensebub
     
    #3
    Hiwituner, laila-no1 und al-x83 gefällt das.
  5. ironsky
    Offline

    ironsky Ist oft hier

    Registriert:
    20. Februar 2013
    Beiträge:
    124
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: IPC-Installation bricht ab

    Hat funktioniert. Allerdings habe ich noch einen Fehler, der aber übersprungen wird: "/var/emu/script/ipc-cams.sh: Zeile 46: dialog: Kommando nicht gefunden". Bin nun in der IPC-Konfiguration. Kann man dort alles erst einmal so lassen? Habe nur username und pw geändert bisher.
     
    Zuletzt bearbeitet: 15. März 2013
    #4
  6. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: IPC-Installation bricht ab

    Bis auf den HTTPUSER und HTTPPASS brauch man erstmal nichts eintragen oder ändern.


    Die Fehlermeldung ist nicht normal. Aber vielleicht gibt ja ein Blick in das syslog ein Hinweis auf den Fehler. Findet man dann im IPC-Webif unter logs.
    Sind denn die Funktionen soweit vorhanden?


    Gruß
    jensebub
     
    #5
    ironsky gefällt das.
  7. Kermit
    Online

    Kermit Guest

    AW: IPC-Installation bricht ab

    Hi,

    da wird wohl noch das Paket fehlen
    Code:
    apt-get install dialog
    Grüße

    Kermit
     
    #6
  8. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: IPC-Installation bricht ab

    Schon eigenartig,.... die Pakete hätten alle bei der ipcsetup.sh installiert werden sollen.

    Gruß
    jensebub
     
    #7
    ironsky gefällt das.
  9. Kermit
    Online

    Kermit Guest

    AW: IPC-Installation bricht ab

    Hi,

    richtig, deswegen hab ich ja schon geschrieben gehabt
    Es werden mit ziemlicher Sicherheit noch weitere Pakete fehlen.

    Grüße

    Kermit
     
    #8
  10. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: IPC-Installation bricht ab

    Alle Pakete wären:
    Code:
    apt-get install openssh-server locales console-tools console-data console-common rsyslog nfs-common portmap apache2 libapache2-mod-php5 php5 php5-cli php5-common php5-cgi php5-sqlite php5-curl tofrodos htop ncftp libpcsclite1 sudo ntpdate dialog libusb-dev sqlite3 coreutils tar gzip nano less lm-sensors locate sendEmail libnet-ssleay-perl libio-socket-ssl-perl
    Ein großteil wird wahrscheinlich schon funktionieren und installiert sein, sonst wäre er nicht so weit, aber so haben wir die Pakete komplett ;)

    Gruß
    jensebub
     
    #9
  11. ironsky
    Offline

    ironsky Ist oft hier

    Registriert:
    20. Februar 2013
    Beiträge:
    124
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: IPC-Installation bricht ab

    Ich habe nun ein etwas größeres Problem. Nachdem IPC ja installiert war, aber 'dialog' fehlte, habe ich nach der IPC-Installation noch 'dialog' installiert und danach versucht, IPC einfach über das alte zu installieren (was vermutlich unnötig war). Nachdem ich mir also die ipcsetup.sh neu geladen und ausgeführt hatte, wollte er eine tar.gz herunterladen (hat er vorher irgendwie nicht gemacht - oder so schnell, dass ich es nicht gesehen habe). Jedenfalls ist der Download der tar.gz eingefroren und ich habe abgebrochen (STRG+C). Dann habe ich noch mal die ipcsetup.sh gestartet und das endete im Error beim Entpacken (vorher gibt es auch schon die Meldung "Einige Pakete konnten nicht installiert werden."):

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Dann habe ich den Anfängerfehler gemacht und versucht diverse ipc-Ordner zu löschen, in der Hoffnung, es würde was ändern. Fehlanzeige. Selber Error.

    Bevor ich nun Debian neu aufsetze: Habt Ihr eine Idee, wie ich das System wieder sauber und IPC frisch installiert bekomme?
     
    #10
  12. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: IPC-Installation bricht ab

    Nur Übung macht den Meister,....
    Dein System ist wahrscheinlich so quer, das ne neuinstallation des OS wohl die beste Variante ist. Und wahrscheinlich schneller :emoticon-0105-wink:
     
    #11
  13. ironsky
    Offline

    ironsky Ist oft hier

    Registriert:
    20. Februar 2013
    Beiträge:
    124
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: IPC-Installation bricht ab

    Yo, so sieht's aus. Werde es neu aufsetzen und mich wieder melden.
     
    #12
    jensebub gefällt das.
  14. ironsky
    Offline

    ironsky Ist oft hier

    Registriert:
    20. Februar 2013
    Beiträge:
    124
    Zustimmungen:
    3
    Punkte für Erfolge:
    0
    AW: IPC-Installation bricht ab

    Hatte extreme Probleme Squeeze mit Spiegelservern zu installieren - ging einfach nicht, egal welchen ich gewählt habe. Die Installation brach immer nach 3/4 Fortschritt ab (ohne konkrete Fehlermeldung - es gab lediglich den Hinweis, dass die Installation fehlgeschlagen ist).

    Habe die aktuelle Squeeze nun ohne grafische Oberfläche automatisch installieren lassen und nach erfolgreicher Installation erst einmal apt-get update und apt-get upgrade gemacht. Da hat er nicht so viel geladen. Dann habe ich noch apt-get install dialog und apt-get install sqlite3 gemacht. Danach habe ich mir die ipcsetup.sh von ipc.pebkac.at/ipc/ipcsetup.sh geholt und gestartet. Dieses mal hat er viel mehr geladen bei der Installation und auch die Tastatur musste ich festlegen (habe mich für pc/german/latin1 entschieden), bis es dann hieß "Jetzt geht es los!".

    Dann hat sich folgendes Fenster geöffnet:

    [​IMG]

    Habe alle 5 Optionen auf ON gestellt und fortgesetzt. Nun hat sich die ipc.cfg geöffnet, welche unter /var/emu/conf/ipc liegt. Dort habe ich nur den HTTPUSER und das HTTPPASS geändert und das Ganze gespeichert. 'i info' zeigt mir, dass alle 5 Cams (cccam, oscam, newcs, camd3, sbox) up sind, die Addons 'tmp2ram.sh' und logmini.sh' installiert sind. 'i scan localhost' gibt an, dass die Ports 22, 25, 80, 8080, 9080, 12000, 16001, 16002 offen sind.

    Das ganze rennt jetzt auf Debian Squeeze 2.6.32-5-686 (empfohlen wurde mir eigtl. Kernel 486). Ist das nun soweit alles okay?
     
    Zuletzt bearbeitet: 15. März 2013
    #13
  15. jensebub
    Offline

    jensebub Stamm User

    Registriert:
    8. Mai 2010
    Beiträge:
    1.059
    Zustimmungen:
    1.717
    Punkte für Erfolge:
    113
    Geschlecht:
    männlich
    Beruf:
    hab ich
    Ort:
    abvomweltlichen
    AW: IPC-Installation bricht ab

    Hallo,
    das hört sich ja schon besser an, als letzte mal,...
    ein erneutes selektieren der cams kannst du über den Befehl i cams machen.

    Wie man den Kernel auf einen 486er wechselt, steht hier:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Und nähere Infos bekommst du sicherlich hier:

    Dieser Link ist nur für Mitglieder!!! Jetzt kostenlos Registrieren ?



    Gruß
    jensebub

    P.S. lösche mal deinen Browser-cache, dann könnte es auch wieder mit dem board hier klappen ;)
     
    #14

Diese Seite empfehlen