1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gelöst IGEL OmniKey Udev Probleme

Dieses Thema im Forum "ThinClients" wurde erstellt von t0x1cal, 23. Oktober 2013.

  1. t0x1cal
    Offline

    t0x1cal Newbie

    Registriert:
    10. August 2009
    Beiträge:
    18
    Zustimmungen:
    3
    Punkte für Erfolge:
    3
    Hallo zusammen

    ich versuche seit 3 Tagen meinen internen Cardreader aus meinem Igel ans laufen zu bekommen, aber irgenwie will UDEV den nicht einbinden.
    Vielleicht hat ja von euch einer ne Idee was ich falsch mache.

    Hier mal ein par Infos:

    Hardware:
    [TABLE="class: tablemain, width: 451"]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"]Prozessoren[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]VIA C7 Processor 1500MHz[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG]PCI Geräte[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG](5x) Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]Host bridge: VIA Technologies, Inc. PT890 Host Bridge[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG](4x) USB controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]USB controller: VIA Technologies, Inc. USB 2.0[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South][/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II][/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro][/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG]IDE Geräte[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG]SCSI Geräte[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG]USB Geräte[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]Linux Foundation 2.0 root hub[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG](4x) Linux Foundation 1.1 root hub[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]Transcend Information, Inc. 2GB/4GB Flash Drive[/TD]
    [/TR]
    [TR="class: even, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]Logitech, Inc. LX710 Cordless Desktop Laser[/TD]
    [/TR]
    [TR="class: odd, bgcolor: #C0C0C0"]
    [TD="colspan: 2"][​IMG][​IMG]OmniKey AG CardMan 3121[/TD]
    [/TR]
    [/TABLE]

    Cardreader:
    Bus 005 Device 002: ID 076b:3021 OmniKey AG CardMan 3121pcsc_scan:Reader 0: OMNIKEY CardMan (076B:3021) 3021 00 00
    Card state: Card removed,

    Soweit so gut, PCSC ist installiert und auch der Treiber (ifdokccid_linux_i686-4.0.5) pcsc_scan erkennt auch Reader und Karte wenn ich sie einlege.
    pcsc_scan

    PC/SC device scannerV 1.4.20 (c) 2001-2011, Ludovic Rousseau <ludovic.rousseau@free.fr>
    Compiled with PC/SC lite version: 1.8.3
    Using reader plug'n play mechanism
    Scanning present readers...
    0: OMNIKEY CardMan (076B:3021) 3021 00 00


    Wed Oct 23 09:02:59 2013
    Reader 0: OMNIKEY CardMan (076B:3021) 3021 00 00
    Card state: Card removed,

    pcscd -dfa
    00000000 pcscdaemon.c:233:main() pcscd set to foreground with debug send to stdout00000434 debuglog.c:298:DebugLogSetCategory() Debug options: APDU
    00000375 configfile.l:245:DBGetReaderListDir() Parsing conf directory: /etc/reader.conf.d
    00000409 configfile.l:257:DBGetReaderListDir() Skipping non regular file: ..
    00000200 configfile.l:257:DBGetReaderListDir() Skipping non regular file: .
    00000205 configfile.l:298:DBGetReaderList() Parsing conf file: /etc/reader.conf.d/libccidtwin
    00000425 pcscdaemon.c:518:main() pcsc-lite 1.8.4 daemon ready.
    00006974 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0001, path: /dev/bus/usb/002/001
    00001020 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0001, path: /dev/bus/usb/002/001
    00000844 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x046D, PID: 0xC517, path: /dev/bus/usb/002/002
    00000883 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x046D, PID: 0xC517, path: /dev/bus/usb/002/002
    00001000 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x046D, PID: 0xC517, path: /dev/bus/usb/002/002
    00000910 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0001, path: /dev/bus/usb/003/001
    00000918 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0001, path: /dev/bus/usb/004/001
    00000922 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0001, path: /dev/bus/usb/005/001
    00000850 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0001, path: /dev/bus/usb/005/001
    00000760 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x076B, PID: 0x3021, path: /dev/bus/usb/005/002
    00000511 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x076B, PID: 0x3021, path: /dev/bus/usb/005/002
    00000236 hotplug_libudev.c:311:HPAddDevice() Adding USB device: OMNIKEY CardMan (076B:3021) 3021
    00000368 readerfactory.c:941:RFInitializeReader() Attempting startup of OMNIKEY CardMan (076B:3021) 3021 00 00 using /usr/lib/pcsc/drivers/ifdokccid_linux_i686-4.0.5.bu
    00001340 readerfactory.c:831:RFBindFunctions() Loading IFD Handler 3.0
    HID HID Global OMNIKEY CCID driver x86 v4.0.5
    00380080 readerfactory.c:299:RFAddReader() Using the reader polling thread
    00002543 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0002, path: /dev/bus/usb/001/001
    00000867 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1D6B, PID: 0x0002, path: /dev/bus/usb/001/001
    00000982 hotplug_libudev.c:260:get_driver() Looking for a driver for VID: 0x1307, PID: 0x0165, path: /dev/bus/usb/001/002
    00000555 readerfactory.c:1267:RFWaitForReaderInit() Waiting init for reader: OMNIKEY CardMan (076B:3021) 3021 00 00


    Das Problem ist, das ich sowol mit als auch ohne eigener Udev Regel keine Einbindung des Reader in /dev bekomme.

    /etc/udev/rules.d/99_omnikey.rules
    /etc/udev/rules.d/99_omnikey.rules
    SUBSYSTEM=="usb", ATTRS{idVendor}=="0x076B", ATTRS{idProduct}=="0x3021", ACTION=="add" RUN+="ok_pcscd_hotplug.sh" SYMLINK+="HD+"

    Das Problem ist UDEV erstellt einfach keinen Device in /dev mit dem namen HD+, und ohne meine Regel erstellt UDEV auch nichts.
    So kann ich natürlich auch keinen Reader in OSCam adden oder?
    Würde mich freuen wenn jemand ne Idee hat.
     
    #1
  2. phantom

    Nervigen User Advertisement

  3. lullu08
    Offline

    lullu08 Elite Lord

    Registriert:
    31. Mai 2010
    Beiträge:
    4.349
    Zustimmungen:
    1.277
    Punkte für Erfolge:
    113
    AW: IGEL OmniKey Udev Probleme

    du nutzt pcsc
    diverse = 0 (der zweite Reader würde eine 1 bekommen usw.) Siehe auch OScam Anleitung.
    das ist alles
     
    #2
    Pilot, al-x83 und t0x1cal gefällt das.
  4. t0x1cal
    Offline

    t0x1cal Newbie

    Registriert:
    10. August 2009
    Beiträge:
    18
    Zustimmungen:
    3
    Punkte für Erfolge:
    3
    AW: IGEL OmniKey Udev Probleme

    Vielen Dank das muss ich wohl mehrfach überlesen haben! :confused:

    Jetzt läuft es!


    Gesendet von meinem GT-N7100 mit Tapatalk 2
     
    #3
  5. Tengri3108
    Offline

    Tengri3108 Meister

    Registriert:
    19. Juni 2011
    Beiträge:
    985
    Zustimmungen:
    233
    Punkte für Erfolge:
    43
    Beruf:
    Elektro Meister
    Ort:
    Nordsee Küste
    AW: IGEL OmniKey Udev Probleme

    Hi

    Ich Hänge mich hier mal ran welche Karten kann der 3121 Auslesen? Habe darüber irgendwie nichts gefunden weil sie preislich ja sehr attraktiv sind.

    Gruß Ralf
     
    #4
  6. fun7
    Offline

    fun7 Super Elite User Supporter

    Registriert:
    13. März 2013
    Beiträge:
    2.913
    Zustimmungen:
    1.805
    Punkte für Erfolge:
    113
    AW: IGEL OmniKey Udev Probleme

    T0 und T1 Protokoll. T14 geht nicht.
     
    #5
  7. Tengri3108
    Offline

    Tengri3108 Meister

    Registriert:
    19. Juni 2011
    Beiträge:
    985
    Zustimmungen:
    233
    Punkte für Erfolge:
    43
    Beruf:
    Elektro Meister
    Ort:
    Nordsee Küste
    AW: IGEL OmniKey Udev Probleme

    Hi

    Will zwar nicht sagen das ich blöd bin aber für welche Karten stehen deine Angaben .

    Gruß Ralf
     
    #6
  8. t0x1cal
    Offline

    t0x1cal Newbie

    Registriert:
    10. August 2009
    Beiträge:
    18
    Zustimmungen:
    3
    Punkte für Erfolge:
    3
    AW: IGEL OmniKey Udev Probleme

    Hab hd01 und v13 ohne Probleme laufen! Mit aktueller oscam

    Gesendet von meinem GT-N7100 mit Tapatalk 2
     
    #7
    Tengri3108 gefällt das.
  9. fun7
    Offline

    fun7 Super Elite User Supporter

    Registriert:
    13. März 2013
    Beiträge:
    2.913
    Zustimmungen:
    1.805
    Punkte für Erfolge:
    113
    AW: IGEL OmniKey Udev Probleme

    Videoguard, natives Nagra (keine getunnelten Karten), Viaccess, DGCrypt, Conax, Cryptoworks (kein ICE).
     
    #8
    Tengri3108 gefällt das.
  10. Tengri3108
    Offline

    Tengri3108 Meister

    Registriert:
    19. Juni 2011
    Beiträge:
    985
    Zustimmungen:
    233
    Punkte für Erfolge:
    43
    Beruf:
    Elektro Meister
    Ort:
    Nordsee Küste
    AW: IGEL OmniKey Udev Probleme

    Hi

    Dann brauche ich nur das device anpassen dann läuft es da es der dritte bei mir ist also device = 2.


    Gruß Ralf
     
    #9

Diese Seite empfehlen